[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / www / htdig

File: [cvs.NetBSD.org] / pkgsrc / www / htdig / Makefile (download)

Revision 1.32, Sat Mar 4 21:30:58 2006 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
Changes since 1.31: +2 -2 lines

Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

# $NetBSD: Makefile,v 1.32 2006/03/04 21:30:58 jlam Exp $

DISTNAME=	htdig-3.1.6
PKGREVISION=	3
CATEGORIES=	www databases
MASTER_SITES=	http://www.htdig.org/files/ \
		ftp://ftp.htdig.org/ \
		${MASTER_SITE_SOURCEFORGE:=files/} \
		${MASTER_SITE_SOURCEFORGE:=pub/sourceforge/htdig/} \
		http://htdig.europeanservers.net/files/ \
		http://www.it.htdig.org/files/ \
		ftp://www.it.htdig.org/pub/htdig/ \
		http://www.opdenbrouw.nl/htdig/maindocs/files/
EXTRACT_SUFX=	.tar.gz

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://htdig.sourceforge.net/
COMMENT=	WWW indexing and searching system

USE_LANGUAGES=	c c++

GNU_CONFIGURE=	yes
CONFIGURE_ARGS+= --with-cgi-bin-dir=${PREFIX}/libexec/cgi-bin \
		--with-common-dir=${PREFIX}/share/htdig/common \
		--with-config-dir=${PKG_SYSCONFDIR:Q} \
		--with-database-dir=${DBDIR:Q} \
		--with-image-dir=${PREFIX}/share/examples/htdig \
		--with-search-dir=${PREFIX}/share/examples/htdig
CONFIGURE_ENV+=	PDF_PARSER="${LOCALBASE}/bin/acroread"
CXXFLAGS+=	-Wno-deprecated
CPPFLAGS+=	${CXXFLAGS}

INSTALL_EXTRA_TMPL=     ${PKGDIR}/INSTALL
PKG_SYSCONFSUBDIR=	htdig

DBDIR?=		${VARBASE}/db/htdig
MESSAGE_SUBST+=	DBDIR=${DBDIR}
OWN_DIRS+=	${DBDIR}

CONF_FILES+=	${PREFIX}/share/examples/htdig/htdig.conf \
		${PKG_SYSCONFDIR}/htdig.conf

EXTRACT_OPTS+=		-x
EXTRACT_ELEMENTS=	${DISTNAME}/db*

.include "../../databases/db/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"

post-patch:
	${TOUCH} ${WRKSRC}/configure

.include "../../mk/bsd.pkg.mk"