The NetBSD Project

CVS log for pkgsrc/www/hs-http2/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / www / hs-http2

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.14: download - view: text, markup, annotated - select for diffs
Wed Mar 5 03:40:10 2025 UTC (2 weeks, 5 days ago) by pho
Branches: MAIN
CVS tags: HEAD
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +2 -2 lines
recursive revbump after patching lang/ghc910

Revision 1.13: download - view: text, markup, annotated - select for diffs
Sun Feb 2 13:06:04 2025 UTC (7 weeks, 1 day ago) by pho
Branches: MAIN
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +2 -1 lines
Bump all Haskell packages after switching the default compiler.

Revision 1.12: download - view: text, markup, annotated - select for diffs
Thu Jan 30 16:29:53 2025 UTC (7 weeks, 4 days ago) by pho
Branches: MAIN
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +3 -4 lines
www/hs-http2: update to http2-5.3.9

# ChangeLog for http2

## 5.3.9

* Using `ThreadManager` of `time-manager`.

## 5.3.8

* `forkManagedTimeout` ensures that only one asynchronous exception is
  thrown. Fixing the thread leak via `Weak ThreadId` and `modifyTVar'`.
  [#156](https://github.com/kazu-yamamoto/http2/pull/156)

## 5.3.7

* Using `withHandle` of time-manager.
* Getting `Handle` for each thread.
* Providing allocSimpleConfig' to enable customizing WAI tiemout manager.
* Monitor option (-m) for h2c-client and h2c-server.

## 5.3.6

* Making `runIO` friendly with the new synchronism mechanism.
  [#152](https://github.com/kazu-yamamoto/http2/pull/152)
* Re-throwing asynchronous exceptions to prevent thread leak.
* Simplifying the synchronism mechanism between workers and the sender.
  [#148](https://github.com/kazu-yamamoto/http2/pull/148)

## 5.3.5

* Using `http-semantics` v0.3.
* Deprecating `numberOfWorkers`.
* Removing `unliftio`.
* Avoid `undefined` in client.
  [#146](https://github.com/kazu-yamamoto/http2/pull/146)

## 5.3.4

* Support stream cancellation
  [#142](https://github.com/kazu-yamamoto/http2/pull/142)

## 5.3.3

* Enclosing IPv6 literal authority with square brackets.
  [#143](https://github.com/kazu-yamamoto/http2/pull/143)

## 5.3.2

* Avoid unnecessary empty data frames at end of stream
  [#140](https://github.com/kazu-yamamoto/http2/pull/140)
* Removing unnecessary API from ServerIO

## 5.3.1

* Fix treatment of async exceptions
  [#138](https://github.com/kazu-yamamoto/http2/pull/138)
* Avoid race condition
  [#137](https://github.com/kazu-yamamoto/http2/pull/137)

## 5.3.0

* New server architecture: spawning worker on demand instead of the
  worker pool. This reduce huge numbers of threads for streaming into
  only 2. No API changes but workers do not terminate quicly. Rather
  workers collaborate with the sender after queuing a response and
  finish after all response data are sent.
* All threads are labeled with `labelThread`. You can see them by
  `listThreas` if necessary.

## 5.2.6

* Recover rxflow on closing.
  [#126](https://github.com/kazu-yamamoto/http2/pull/126)
* Fixing ClientSpec for stream errors.
* Allowing negative window. (h2spec http2/6.9.2)
* Update for latest http-semantics
  [#122](https://github.com/kazu-yamamoto/http2/pull/124)

## 5.2.5

* Setting peer initial window size properly.
  [#123](https://github.com/kazu-yamamoto/http2/pull/123)

## 5.2.4

* Update for latest http-semantics
  [#122](https://github.com/kazu-yamamoto/http2/pull/122)
* Measuring performance concurrently for h2c-client

## 5.2.3

* Update for latest http-semantics
  [#120](https://github.com/kazu-yamamoto/http2/pull/120)
* Enable containers 0.7 (ghc 9.10)
  [#117](https://github.com/kazu-yamamoto/http2/pull/117)

## 5.2.2

* Mark final chunk as final
  [#116](https://github.com/kazu-yamamoto/http2/pull/116)

Revision 1.11: download - view: text, markup, annotated - select for diffs
Thu May 9 01:32:54 2024 UTC (10 months, 2 weeks ago) by pho
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base, pkgsrc-2024Q4, pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +2 -1 lines
Recursive revbump after changing the default Haskell compiler

Revision 1.10: download - view: text, markup, annotated - select for diffs
Thu May 2 06:59:49 2024 UTC (10 months, 3 weeks ago) by pho
Branches: MAIN
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +5 -3 lines
www/hs-http2: Update to 5.2.1

5.2.1
    Using time-manager v0.1.0. #115

5.2.0
    Using http-semantics #114
    Header of http-types should be used as high-level header.
    TokenHeader of http-semantics should be used as low-level header.
    Breaking change: encodeHeader takes Header of http-types.
    Breaking change: decodeHeader returns Header of http-types.
    Breaking change: HeaderName as ByteString is removed.

5.1.4
    Using network-control v0.1.

5.1.3
    Defining SendRequest type synonym. #111

5.1.2
    Make ping rate limit configurable #108

5.1.1
    Deal with RST_STREAM in HalfClosedLocal state #107

5.1.0
    Drop frames after reset #106
    BREAKING CHANGE: Use String for Authority #105
    Properly close streams #104

5.0.1
    Allowing bytestring 0.12.

5.0.0
    Using the network-control package.
    The limits of resources can be specified in ServerConfig and ClientConfig.
    Open streams based on peer's MaxStreams.
    Rejecting Data if it is over the receiving limit.
    Informing MaxStreams properly.
    Informing WindowUpdate properly.
    New API: Server.Internal.runIO and Client.Internal.runIO.

Revision 1.9: download - view: text, markup, annotated - select for diffs
Thu Nov 2 06:37:46 2023 UTC (16 months, 3 weeks ago) by pho
Branches: MAIN
CVS tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +2 -1 lines
Revbump all Haskell after updating lang/ghc96

Revision 1.8: download - view: text, markup, annotated - select for diffs
Sun Oct 29 18:38:03 2023 UTC (16 months, 3 weeks ago) by pho
Branches: MAIN
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +3 -3 lines
www/hs-http2: Update to 4.2.2

4.2.2
* Adding rate limit for RST_STREAM to work around CVE-2023-44487. #94

4.2.1
* This version is identical to v4.2.0 by accident.

4.2.0
* Treating HALF_CLOSED_LOCAL correctly. #90
* Ensuring that GOAWAY is sent after DATA in the client side. #89
* Test uses a random port instead of 8080.
* Breaking change: adding two optional SockAddrs to Config to be copied
  into Aux.
* Close all streams on termination. #83
* Introducing OutBodyStreamingUnmask #80
* Introducing KilledByHttp2ThreadManager instead of ThreadKilled. #79 #81
  #82
* Handle RST_STREAM with NO_ERROR. #78
* Internal changes: #74
* Breaking change: Client is generalized into (forall b. Request ->
  (Response -> IO b) -> IO b) -> IO a. The RankNTypes language extension is
  required. #72

4.1.3
* Using crypton instead of cryptonite.

4.1.2
* Removing the race of frameSender and frameReceiver in the server
  side. This fixes the loss of RST_Stream and TLS bad MAC error. #67

4.1.1
* Fixing memory-blow-up due to no flow control. #62 #66

4.1.0
* Implementing streaming from the client side. #41
* Making use of SettingsMaxFrameSize #44 #57
* Disabling flow control #55
* Fixing buffer overrun by trailers #52
* Proper use of settings
* Breaking change: the data structure of Next was changed. The http3
  package is influenced.

4.0.0
* Breaking change: HTTP2Error is redefined.
* Breaking change: FrameTypeId, SettingsKeyId and ErrorCodeId are
  removed. Use FrameType, SettingsKey and ErrorCode instead.
* A client can receive a concrete HTTP2Error.
* Catching up RFC 9113. Host: and :authority cannot disagree.
* Breaking change: Network.HTTP2 and Network.HTTP2.Priority are removed.
* Breaking change: obsoleted stuff are removed.

Revision 1.7: download - view: text, markup, annotated - select for diffs
Mon Oct 9 04:54:59 2023 UTC (17 months, 2 weeks ago) by pho
Branches: MAIN
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +2 -2 lines
Bump Haskell packages after updating lang/ghc94

Revision 1.6: download - view: text, markup, annotated - select for diffs
Tue Feb 7 01:41:18 2023 UTC (2 years, 1 month ago) by pho
Branches: MAIN
CVS tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +2 -2 lines
revbump all the Haskell packages after modifying the runtime system of lang/ghc94

Revision 1.5: download - view: text, markup, annotated - select for diffs
Sat Feb 26 03:58:35 2022 UTC (3 years ago) by pho
Branches: MAIN
CVS tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +2 -2 lines
Bump all Haskell packages after enabling "split sections" in mk/haskell.mk

Revision 1.4: download - view: text, markup, annotated - select for diffs
Sat Feb 12 08:50:59 2022 UTC (3 years, 1 month ago) by pho
Branches: MAIN
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +2 -1 lines
revbump after changing the default Haskell compiler

Revision 1.3: download - view: text, markup, annotated - select for diffs
Sat Feb 12 05:05:55 2022 UTC (3 years, 1 month ago) by pho
Branches: MAIN
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +3 -3 lines
Update to http2-3.0.3

3.0.3
* Return correct status messages in HTTP2 client
  (#31)[https://github.com/kazu-yamamoto/http2/pull/31]
* Follow changes in Aeson 2
  (#32)[https://github.com/kazu-yamamoto/http2/pull/32]
* Make sure connection preface is always sent first
  (#33)[https://github.com/kazu-yamamoto/http2/pull/33]
* Avoid empty data (#34)[https://github.com/kazu-yamamoto/http2/pull/34]

3.0.2
* Skip inserting entries that do not fit in the encoding table
  (#28)[https://github.com/kazu-yamamoto/http2/pull/28]

Revision 1.2: download - view: text, markup, annotated - select for diffs
Tue Jan 18 02:48:32 2022 UTC (3 years, 2 months ago) by pho
Branches: MAIN
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +2 -1 lines
Bump packages that depends on GHC

Revision 1.1: download - view: text, markup, annotated - select for diffs
Wed May 5 15:18:44 2021 UTC (3 years, 10 months ago) by pho
Branches: MAIN
CVS tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2
Import http2-3.0.1

HTTP/2 library including frames, priority queues, HPACK, client and
server.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>