The NetBSD Project

CVS log for pkgsrc/www/firefox15-bin/Attic/Makefile.solaris-sparc

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / www / firefox15-bin

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.4, Tue Mar 25 13:42:25 2008 UTC (14 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2012Q4-base, pkgsrc-2012Q4, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2009Q4-base, pkgsrc-2009Q4, pkgsrc-2008Q4-base, pkgsrc-2008Q4, pkgsrc-2008Q3-base, pkgsrc-2008Q3, pkgsrc-2008Q2-base, pkgsrc-2008Q2, pkgsrc-2008Q1-base, pkgsrc-2008Q1, cube-native-xorg-base, cube-native-xorg, HEAD
Changes since 1.3: +1 -1 lines
FILE REMOVED

Remove firefox15 packages.
They have security problems and are not maintained.

Removal was announced on pkgsrc-users on March 13.

Revision 1.3 / (download) - annotate - [select for diffs], Tue Oct 9 19:19:16 2007 UTC (15 years, 3 months ago) by martti
Branch: MAIN
CVS Tags: pkgsrc-2007Q4-base, pkgsrc-2007Q4, pkgsrc-2007Q3-base, pkgsrc-2007Q3
Changes since 1.2: +2 -2 lines
Diff to previous 1.2 (colored)

Remove trailing spaces.

Revision 1.2 / (download) - annotate - [select for diffs], Thu Aug 23 18:20:34 2007 UTC (15 years, 5 months ago) by jlam
Branch: MAIN
Changes since 1.1: +5 -9 lines
Diff to previous 1.1 (colored)

Allow a nicer syntax for expressing needing at least a certain version
of an emulated operating system.  Instead of proliferating things like
SUSE_VERSION_REQD, NETBSD_VERSION_REQD, SOLARIS_VERSION_REQD, etc., a
package can say:

	EMUL_REQD=	suse>=9.1 netbsd>=2.0 solaris>=10

all in one, succinct line.

Revision 1.1 / (download) - annotate - [select for diffs], Sun Jul 29 05:19:57 2007 UTC (15 years, 6 months ago) by jlam
Branch: MAIN

* Add new emulator framework in pkgsrc/mk/emulator that handles all
  binary-only packages that require binary "emulation" on the native
  operating system.  Please see pkgsrc/mk/emulator/README for more
  details.

* Teach the plist framework to automatically use any existing
  PLIST.${EMUL_PLATFORM} as part of the default PLIST_SRC definition.

* Convert all of the binary-only packages in pkgsrc to use the
  emulator framework.  Most of them have been tested to install and
  deinstall correctly.  This involves the following cleanup actions:

    * Remove use of custom PLIST code and use PLIST.${EMUL_PLATFORM}
      more consistently.

    * Simplify packages by using default INSTALL and DEINSTALL scripts
      instead of custom INSTALL/DEINSTALL code.

    * Remove "SUSE_COMPAT32" and "PKG_OPTIONS.suse" from pkgsrc.
      Packages only need to state exactly which emulations they support,
      and the framework handles any i386-on-x86_64 or sparc-on-sparc64
      uses.

    * Remove "USE_NATIVE_LINUX" from pkgsrc.  The framework will
      automatically detect when the package is installing on Linux.

  Specific changes to packages include:

    * Bump the PKGREVISIONs for all of the suse100* and suse91* packages
      due to changes in the +INSTALL/+DEINSTALL scripts used in all
      of the packages.

    * Remove pkgsrc/emulators/suse_linux, which is unused by any
      packages.

    * cad/lc -- remove custom code to create the distinfo file for
	all supported platforms; just use "emul-fetch" and "emul-distinfo"
	instead.

    * lang/Cg-compiler -- install the shared libraries under ${EMULDIR}
	instead of ${PREFIX}/lib so that compiled programs will find
	the shared libraries.

    * mail/thunderbird-bin-nightly -- update to latest binary
	distributions for supported platforms.

    * multimedia/ns-flash -- update Linux version to 9.0.48 as the
	older version is no longer available for interactive fetch.

    * security/uvscan -- set LD_LIBRARY_PATH explicitly so that
	it's not necessary to install library symlinks into
	${EMULDIR}/usr/local/lib.

    * www/firefox-bin-flash -- update Linux version to 9.0.48 as the
	older version is no longer available for interactive fetch.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>