[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / www / firefox10

Annotation of pkgsrc/www/firefox10/Makefile, Revision 1.42

1.42    ! maya        1: # $NetBSD: Makefile,v 1.41 2017/08/01 14:59:07 wiz Exp $
1.1       ryoon       2:
                      3: .include "../../devel/xulrunner10/dist.mk"
                      4: PKGNAME=       firefox10-${FIREFOX_VER}
1.42    ! maya        5: PKGREVISION=   29
1.1       ryoon       6: CATEGORIES=    www
                      7:
1.12      wiz         8: MAINTAINER=    pkgsrc-users@NetBSD.org
1.41      wiz         9: HOMEPAGE=      https://www.mozilla.org/en-US/firefox/organizations/
1.21      dholland   10: COMMENT=       Web browser with support for extensions (version 10.x)
1.1       ryoon      11: LICENSE=       mpl-1.1
                     12:
                     13: MOZILLA_DIR=   # empty
                     14:
                     15: CONFIGURE_ARGS+=       --enable-application=browser
                     16: CONFIGURE_ARGS+=       --with-libxul-sdk=${PREFIX}/lib/xulrunner10-sdk
                     17: CONFIGURE_ARGS+=       --with-system-libxul
                     18:
                     19: ALL_ENV+=              MOZILLA_PKG_NAME=firefox10
                     20:
                     21: LDFLAGS.DragonFly=     -lplc4 -lnspr4
                     22:
                     23: .include "../../devel/xulrunner10/mozilla-common.mk"
                     24: .include "options.mk"
                     25:
                     26: MOZILLA=firefox10
                     27: MOZILLA_ICON=  ${WRKSRC}/dist/firefox/chrome/icons/default/default48.png
                     28: .if !empty(PKG_OPTIONS:Mofficial-mozilla-branding)
                     29: MOZILLA_NAME=  Firefox
                     30: .else
                     31: MOZILLA_NAME=  Browser
                     32: .endif
                     33:
                     34: pre-configure:
                     35:        cd ${WRKSRC} && autoconf
                     36: # XXX not built here, just to make check-portability.awk shut up.
                     37:        cd ${WRKSRC}/js/src && autoconf
                     38:
                     39: post-build:
                     40:        ${SED} -e 's|@MOZILLA@|${MOZILLA}|g'                            \
                     41:          -e 's|@MOZILLA_NAME@|${MOZILLA_NAME}|g'                       \
                     42:          -e 's|@FIREFOX_ICON@|${MOZILLA}.png|g'                        \
                     43:          < ${FILESDIR}/desktop.in                                      \
                     44:          > ${WRKDIR}/desktop
                     45:        ${SED} -e 's|@PREFIX@|${PREFIX}|g' < ${FILESDIR}/firefox.sh.in  \
                     46:          > ${WRKDIR}/${MOZILLA}
                     47:
                     48: INSTALLATION_DIRS+=    share/applications share/pixmaps
                     49: post-install:
                     50:        ${INSTALL_DATA} ${WRKDIR}/desktop                               \
                     51:          ${DESTDIR}${PREFIX}/share/applications/${MOZILLA}.desktop
                     52:        ${INSTALL_DATA} ${MOZILLA_ICON}                                 \
                     53:          ${DESTDIR}${PREFIX}/share/pixmaps/${MOZILLA}.png
1.2       ryoon      54:        rm -f ${DESTDIR}${PREFIX}/bin/firefox10
1.1       ryoon      55:        ${INSTALL_SCRIPT} ${WRKDIR}/${MOZILLA} ${DESTDIR}${PREFIX}/bin
                     56:
                     57: BUILDLINK_API_DEPENDS.xulrunner10+=    xulrunner10>=${MOZ_BRANCH}${MOZ_BRANCH_MINOR}
                     58: BUILD_DEPENDS+=                                xulrunner10-${MOZ_BRANCH}${MOZ_BRANCH_MINOR}{,nb*}:../../devel/xulrunner10
                     59: .include "../../devel/xulrunner10/buildlink3.mk"
                     60: PLIST_VARS+=   gnome
                     61: .if !empty(PKG_BUILD_OPTIONS.xulrunner10:Mgnome)
                     62: CONFIGURE_ARGS+=       --enable-gnomevfs --enable-dbus --enable-gnomeui
                     63: PLIST.gnome=   yes
                     64: .else
                     65: CONFIGURE_ARGS+=       --disable-gnomevfs --disable-dbus --disable-gnomeui
                     66: .endif
                     67: .if !empty(PKG_BUILD_OPTIONS.xulrunner10:Mdebug)
                     68: CONFIGURE_ARGS+=       --enable-debug --enable-debug-symbols
                     69: CONFIGURE_ARGS+=       --disable-install-strip
                     70: .else
                     71: CONFIGURE_ARGS+=       --disable-debug --disable-debug-symbols
                     72: CONFIGURE_ARGS+=       --enable-install-strip
                     73: .endif
                     74: .include "../../sysutils/desktop-file-utils/desktopdb.mk"
                     75: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>