File:  [cvs.NetBSD.org] / pkgsrc / www / crawl / Makefile
Revision 1.22: download - view: text, annotated - select for diffs
Tue Aug 1 14:59:07 2017 UTC (7 years, 4 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, HEAD
Follow some http -> https redirects.

# $NetBSD: Makefile,v 1.22 2017/08/01 14:59:07 wiz Exp $

DISTNAME=	crawl-0.4
PKGREVISION=	12
CATEGORIES=	www
MASTER_SITES=	http://monkey.org/~provos/

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://monkey.org/~provos/crawl/
COMMENT=	Small and efficient HTTP crawler

GNU_CONFIGURE=	yes
USE_DB185=	yes

# BDB detection is not sufficient, specify manually instead.
CONFIGURE_ARGS+=	--with-db=yes
CONFIGURE_ENV+=		DBLIB=${BDB_LIBS:Q}
CPPFLAGS+=		-DHAVE_DB_185_H

CONF_FILES=	${PREFIX}/share/examples/crawl/crawl.conf ${PKG_SYSCONFDIR}/crawl.conf

INSTALLATION_DIRS+=	share/examples/crawl

post-install:
	${INSTALL_DATA} ${WRKSRC}/crawl.conf ${DESTDIR}${PREFIX}/share/examples/crawl/crawl.conf

SUBST_CLASSES+=		path
SUBST_STAGE.path=	post-patch
SUBST_FILES.path=	cfg.h
SUBST_SED.path=		-e 's,crawl.conf,${PKG_SYSCONFDIR}/crawl.conf,g'
SUBST_MESSAGE.path=	Fixing hardcoded path.

.include "../../devel/libevent/buildlink3.mk"
.include "../../mk/bdb.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>