The NetBSD Project

CVS log for pkgsrc/www/ap-python/Attic/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / www / ap-python

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.7, Tue Jun 10 15:22:15 2014 UTC (5 years, 5 months ago) by joerg
Branch: MAIN
CVS Tags: HEAD
Changes since 1.6: +1 -1 lines
FILE REMOVED

Retire Apache 1.3 and 2.0.

Revision 1.6 / (download) - annotate - [select for diffs], Sun Aug 30 03:08:40 2009 UTC (10 years, 3 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2014Q1-base, pkgsrc-2014Q1, pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2013Q1-base, pkgsrc-2013Q1, pkgsrc-2012Q4-base, pkgsrc-2012Q4, pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3, pkgsrc-2010Q2-base, pkgsrc-2010Q2, pkgsrc-2010Q1-base, pkgsrc-2010Q1, pkgsrc-2009Q4-base, pkgsrc-2009Q4, pkgsrc-2009Q3-base, pkgsrc-2009Q3
Changes since 1.5: +5 -5 lines
Diff to previous 1.5 (colored)

Update ap-python to 2.7.11.

While here,
 * add user-destdir support
 * convert dynamic PLIST to static one
 * share/doc/html was deprecated, install in share/doc directly
 * Remove restriction to python23, and change PKGNAME to allow creating
   python valiant packages.

This release addresses a vulnerability in mod_python's publisher handler
whereby a carefully crafted URL would expose objects that should not be
visible, leading to an information leak. The Common Vulnerabilities and
Exposures project (http://cve.mitre.org/) has assigned the name CAN-2005-0088
to this issue.

Users of the publisher handler are urged to upgrade as soon as possible.

Revision 1.5 / (download) - annotate - [select for diffs], Thu Jul 10 14:59:57 2008 UTC (11 years, 5 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2009Q2-base, pkgsrc-2009Q2, pkgsrc-2009Q1-base, pkgsrc-2009Q1, pkgsrc-2008Q4-base, pkgsrc-2008Q4, pkgsrc-2008Q3-base, pkgsrc-2008Q3, pkgsrc-2008Q2-base, pkgsrc-2008Q2, cwrapper, cube-native-xorg-base, cube-native-xorg
Changes since 1.4: +2 -2 lines
Diff to previous 1.4 (colored)

Always build PIC. Don't try to use mkdep, it fails on NetBSD.
Bump revision.

Revision 1.4 / (download) - annotate - [select for diffs], Thu Feb 24 14:08:28 2005 UTC (14 years, 9 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2008Q1-base, pkgsrc-2008Q1, pkgsrc-2007Q4-base, pkgsrc-2007Q4, pkgsrc-2007Q3-base, pkgsrc-2007Q3, pkgsrc-2007Q2-base, pkgsrc-2007Q2, pkgsrc-2007Q1-base, pkgsrc-2007Q1, pkgsrc-2006Q4-base, pkgsrc-2006Q4, pkgsrc-2006Q3-base, pkgsrc-2006Q3, pkgsrc-2006Q2-base, pkgsrc-2006Q2, pkgsrc-2006Q1-base, pkgsrc-2006Q1, pkgsrc-2005Q4-base, pkgsrc-2005Q4, pkgsrc-2005Q3-base, pkgsrc-2005Q3, pkgsrc-2005Q2-base, pkgsrc-2005Q2, pkgsrc-2005Q1-base, pkgsrc-2005Q1
Changes since 1.3: +2 -1 lines
Diff to previous 1.3 (colored)

Add RMD160 checksums.

Revision 1.3 / (download) - annotate - [select for diffs], Tue Jul 20 21:22:24 2004 UTC (15 years, 4 months ago) by recht
Branch: MAIN
CVS Tags: pkgsrc-2004Q4-base, pkgsrc-2004Q4, pkgsrc-2004Q3-base, pkgsrc-2004Q3
Changes since 1.2: +4 -4 lines
Diff to previous 1.2 (colored)

update to mod_python 2.7.10

changes:
This release addresses a vulnerability in mod_python 2.7.9 whereby a
specific query string processed by mod_python would cause the httpd
process to crash.

The previously released version 2.7.9 was supposed to correct this issue,
but is still vulnerable.

There are no other changes or improvements from the previous version in
this release.

If you are currently using mod_python 2.7.9 or earlier, it is highly
recommended that you upgrade to 2.7.10 as soon as possible.

Revision 1.2 / (download) - annotate - [select for diffs], Wed Dec 3 09:44:10 2003 UTC (16 years ago) by darcy
Branch: MAIN
CVS Tags: pkgsrc-2004Q2-base, pkgsrc-2004Q2, pkgsrc-2004Q1-base, pkgsrc-2004Q1
Changes since 1.1: +6 -3 lines
Diff to previous 1.1 (colored)

As discussed in the mailing list:

Moved to latest version 2.7.8.

Added patch that fixed flags when sending location header.

Added patch to cgihandler to append local directory so that relative URLs
would work.

Added patch to cgihandler to handle SystemExit so that pages would not
ISE when sys.exit(0) was used to exit from the script.

Added patch to break HTTP headers off from page correctly when CRLF and LF
is used inconsistently in a page.

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Tue Feb 5 21:05:58 2002 UTC (17 years, 10 months ago) by drochner
Branch: TNF
CVS Tags: pkgviews-base, pkgviews, pkgsrc-base, pkgsrc-2003Q4-base, pkgsrc-2003Q4, netbsd-1-6-RELEASE-base, netbsd-1-6-1-base, netbsd-1-6-1, netbsd-1-6, netbsd-1-5-PATCH003, buildlink2-base, buildlink2
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

ap-mod_python->ap-python

Revision 1.1 / (download) - annotate - [select for diffs], Tue Feb 5 21:05:58 2002 UTC (17 years, 10 months ago) by drochner
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>