The NetBSD Project

CVS log for pkgsrc/www/R-shinyjs/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / www / R-shinyjs

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.3 / (download) - annotate - [select for diffs], Sun Jun 4 02:02:23 2023 UTC (10 months, 2 weeks ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, HEAD
Changes since 1.2: +2 -2 lines
Diff to previous 1.2 (colored)

(www/R-shinyjs) Updated  2.0.0 to  2.1.0

# shinyjs 2.1.0 (2021-12-20)
- New feature: you can now reset all inputs on the page by calling
  `reset()` with no arguments (#222)
- New feature: Add a `removeEvent()` function which removes events
  added to HTML elements with `onclick()` or `onevent()` (#244)
- Fix bug: `disable()` did not work on nested download buttons (#223)
- Fix bug: Don't automatically namespace ID arguments in custom
  extendShinyjs functions (#229)
- Fix bug: ensure that `extendShinyjs()` functions don't overwrite
  native {shinyjs} functions (#230)

Revision 1.2 / (download) - annotate - [select for diffs], Tue Aug 24 11:36:24 2021 UTC (2 years, 7 months ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3
Changes since 1.1: +5 -2 lines
Diff to previous 1.1 (colored)

(www/R-shinyjs) Updated 1.0 to 2.0.0

# shinyjs 2.0.0 (2020-08-24)

- **IMPORTANT CHANGE** Remove commercial license (it only existed
    because some big companies asked for it, but it ended up being a
    bigger headache for 99% of the community)

- **BREAKING CHANGE** When using `extendShinyjs()`, the `functions`
    parameter must always be provided.

- **BREAKING CHANGE** When using `extendShinyjs()`, the `script` path
    parameter now behaves like any other Shiny web resource, which
    means it cannot be loaded from the local file system. The path
    must be discoverable by the browser, so it either needs to be a
    public URL, inside a `www` folder, or available via
    `addResourcePath()`.

- New feature: add a `refresh()` function (#205)

- New feature: add `asis` parameter to `reset()` function, which works
  like it does in all other functions that support `asis` (#146)

- Fix bug: `extendShinyjs()` now works with any web URL or any
  resource path (#201)

- Fix bug: `reset()` didn't work when a sliderInput was initialized
  with `value=NULL` (#207)

- Remove `V8` as a package dependency.

# shinyjs 1.1 (2020-01-12)

This update was 2 years in the making because it required a lot of
testing by users to ensure none of these features cause any regression
bugs in real apps.

- **BREAKING CHANGE** The `includeShinyjs` parameter in `runcodeUI()`
    is now deprecated
- Fix bug: shinyjs functions used inside a module with a `selector`
  argument instead of an `id` argument didn't work (#175)
- Fix bug: shinyjs functions did not work with IDs that had a space in
  them (#176)
- Fix bug: non-selectize select inputs could not be disabled (#186)
- Fix bug: `click()` now works with download buttons (#198)

- New feature: added `asis` parameter to any function that takes an
  ID. When `asis=TRUE`, the ID will not be namespaced when inside a
  module (#118)

- New feature: added `id` parameter to `runcode()`, allowing it to
  work inside Shiny modules (#184)

- New feature: `onevent()` returns the `offsetX` and `offsetY` event
  properties

- New feature: `onevent()` accepts a `properties` parameter that
  allows the user to retrieve additional properties that are not
  whitelisted by default (#159)

- New feature: `hide()`/`show()` now only bubble up the DOM tree to
  the nearest input container if the current element is an input
  (#153)

- Documentation: added documentation about `useShinyjs()` side effects
  and about including `shinyjs` in packages (#182)

Revision 1.1 / (download) - annotate - [select for diffs], Fri Aug 9 20:53:39 2019 UTC (4 years, 8 months ago) by brook
Branch: MAIN
CVS Tags: pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3

R-shinyjs: initial commit

Perform common useful JavaScript operations in Shiny apps that will
greatly improve your apps without having to know any JavaScript.
Examples include: hiding an element, disabling an input, resetting an
input back to its original value, delaying code execution by a few
seconds, and many more useful functions for both the end user and the
developer. 'shinyjs' can also be used to easily call your own custom
JavaScript functions from R.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>