The NetBSD Project

CVS log for pkgsrc/wm/xmonad-contrib/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / wm / xmonad-contrib

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.27: download - view: text, markup, annotated - select for diffs
Wed Mar 5 03:40:08 2025 UTC (2 weeks, 2 days ago) by pho
Branches: MAIN
CVS tags: HEAD
Diff to: previous 1.26: preferred, colored
Changes since revision 1.26: +2 -2 lines
recursive revbump after patching lang/ghc910

Revision 1.26: download - view: text, markup, annotated - select for diffs
Sun Feb 2 13:06:02 2025 UTC (6 weeks, 5 days ago) by pho
Branches: MAIN
Diff to: previous 1.25: preferred, colored
Changes since revision 1.25: +2 -1 lines
Bump all Haskell packages after switching the default compiler.

Revision 1.25: download - view: text, markup, annotated - select for diffs
Sun Feb 2 06:02:11 2025 UTC (6 weeks, 5 days ago) by pho
Branches: MAIN
Diff to: previous 1.24: preferred, colored
Changes since revision 1.24: +2 -3 lines
wm/xmonad-contrib: update to xmonad-contrib-0.18.1

## _unreleased_

## 0.18.1 (August 20, 2024)

### Breaking Changes

  * `XMonad.Hooks.StatusBars`

    - Move status bar functions from the `IO` to the `X` monad to
      allow them to look up information from `X`, like the screen
      width. Existing configurations may need to use `io` from
      `XMonad.Core` or `liftIO` from `Control.Monad.IO.Class` in
      order to lift any existing `IO StatusBarConfig` values into
      `X StatusBarConfig` values.

  * `XMonad.Prompt`

    - Added an additional `XPConfig` argument to `historyCompletion` and
      `historyCompletionP`. Calls along the lines of `historyCompletionP
      myFunc` should be changed to `historyCompletionP myConf myFunc`.
      If not `myConf` is lying around, `def` can be used instead.

  * `XMonad.Actions.GridSelect`

    - Added the `gs_cancelOnEmptyClick` field to `GSConfig`, which makes
      mouse clicks into "empty space" cancel the current grid-select.
      Users explicitly defining their own `GSConfig` record will have to
      add this to their definitions. Additionally, the field defaults to
      `True`—to retain the old behaviour, set it to `False`.

### New Modules

  * `XMonad.Actions.Profiles`

    - Group workspaces by similarity. Useful when one has lots
      of workspaces and uses only a couple per unit of work.

  * `XMonad.Hooks.FloatConfigureReq`

    - Customize handling of floating windows' move/resize/restack requests
      (ConfigureRequest). Useful as a workaround for some misbehaving client
      applications (Steam, rxvt-unicode, anything that tries to restore
      absolute position of floats).

  * `XMonad.Layout.Columns`

    - Organize windows in columns. This layout allows to move/resize windows in
      every directions.

  * `XMonad.Prompt.WindowBringer`

    - Added `copyMenu`, a convenient way to copy a window to the current workspace.

### Bug Fixes and Minor Changes

  * Fix build-with-cabal.sh when XDG_CONFIG_HOME is defined.

  * `XMonad.Util.EZConfig`

    - Fixed `checkKeymap` warning that all keybindings are duplicates.

  * `XMonad.Hooks.ManageHelpers`

    - Added `isNotification` predicate to check for windows with
      `_NET_WM_WINDOW_TYPE` property of `_NET_WM_WINDOW_TYPE_NOTIFICATION`.

  * `XMonad.Prompt.OrgMode`

    - Added `HH:MM-HH:MM` and `HH:MM+HH` syntax to specify time spans.

  * `XMonad.Prompt`

    - The history file is not extraneously read and written anymore if
      the `historySize` is set to 0.

  * `XMonad.Hooks.EwmhDesktops`

    - Requests for unmanaged windows no longer cause a refresh. This avoids
      flicker and also fixes disappearing menus in the Steam client and
      possibly a few other client applications.

      (See also `XMonad.Hooks.FloatConfigureReq` and/or `XMonad.Util.Hacks`
      for additional Steam client workarounds.)

  * `XMonad.Actions.Submap`

    - Added `visualSubmapSorted` to enable sorting of the keymap
      descriptions.

  * `XMonad.Hooks.ScreenCorners`

    - Added screen edge support with `SCTop`, `SCBottom`, `SCLeft` and
      `SCRight`. Now both corners and edges are supported.

  * `XMonad.Actions.WindowNavigation`

    - Improve navigation in presence of floating windows.
    - Handle window switching when in `Full` layout.

### Other changes

Revision 1.24: download - view: text, markup, annotated - select for diffs
Thu May 9 01:32:51 2024 UTC (10 months, 1 week ago) by pho
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base, pkgsrc-2024Q4, pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2
Diff to: previous 1.23: preferred, colored
Changes since revision 1.23: +2 -1 lines
Recursive revbump after changing the default Haskell compiler

Revision 1.23: download - view: text, markup, annotated - select for diffs
Tue Apr 30 06:04:24 2024 UTC (10 months, 3 weeks ago) by pho
Branches: MAIN
Diff to: previous 1.22: preferred, colored
Changes since revision 1.22: +2 -3 lines
wm/xmonad-contrib: Update to 0.18.0

0.18.0 (February 3, 2024)

Breaking Changes

    Deprecated XMonad.Layout.Cross due to bitrot; refer to XMonad.Layout.Circle and XMonad.Layout.ThreeColumns for alternatives.
    Deprecated the XMonad.Layout.StateFull module and XMonad.Layout.TrackFloating.(t|T)rackFloating in favour of XMonad.Layout.FocusTracking.
    Dropped support for GHC 8.4.
    XMonad.Util.ExclusiveScratchpads
        Deprecated the module in favour of the (new) exclusive scratchpad functionality of XMonad.Util.NamedScratchpad.
    XMonad.Actions.CycleWorkspaceByScreen
        The type of repeatableAction has changed, and it's deprecated in favour of X.A.Repeatable.repeatable.
    XMonad.Hooks.DynamicProperty
        Deprecated the module in favour of the more aptly named XMonad.Hooks.OnPropertyChange.
    XMonad.Util.Scratchpad:
        Deprecated the module; use XMonad.Util.NamedScratchpad instead.
    XMonad.Actions.Navigation2D
        Removed deprecated function hybridNavigation.
    XMonad.Layout.Spacing
        Removed deprecated functions SpacingWithEdge, SmartSpacing, SmartSpacingWithEdge, ModifySpacing, setSpacing, and incSpacing.
    XMonad.Actions.MessageFeedback
        Removed deprecated functions send, sendSM, sendSM_, tryInOrder, tryInOrder_, tryMessage, and tryMessage_.
    XMonad.Prompt.Window
        Removed deprecated functions windowPromptGoto, windowPromptBring, and windowPromptBringCopy.
    XMonad.Hooks.ICCCMFocus
        Removed deprecated module. This was merged into xmonad.
    XMonad.Layout.LayoutBuilderP
        Removed deprecated module; use XMonad.Layout.LayoutBuilder instead.
    XMonad.Hooks.RestoreMinimized
        Removed deprecated module; use XMonad.Hooks.Minimize instead.
    XMonad.Layout.Named
        Deprecated the entire module, use XMonad.Layout.Renamed (which newly provides named for convenience) instead.
    XMonad.Actions.SinkAll
        Deprecated the entire module, use XMonad.Actions.WithAll instead.
    XMonad.Layout.Circle:
        Deprecated the entire module, use the circle function from XMonad.Layout.CircleEx instead.
    XMonad.Hooks.EwmhDesktops
        _NET_CLIENT_LIST_STACKING puts windows in the current workspace at the top in bottom-to-top order, followed by visible workspaces, followed by invisible workspaces. Within visible and invisible groups, workspaces are ordered lexicographically, as before. Currently focused window will always be the topmost, meaning the last in the list.
    XMonad.Util.NamedScratchpad
        Added nsSingleScratchpadPerWorkspace—a logHook to allow only one active scratchpad per workspace.
    XMonad.Util.EZConfig
        The function readKeySequence now returns a non-empty list if it succeeded.
    Deprecate XMonad.Util.Ungrab; it was moved to XMonad.Operations in core.

New Modules

    XMonad.Layout.CenterMainFluid
        A three column layout with main column in the center and two stack column surrounding it. Master window will be on center column and spaces on the sides are reserved.
    XMonad.Layout.FocusTracking.
        Replaces X.L.StateFull and half of X.L.TrackFloating.
    XMonad.Actions.MostRecentlyUsed
        Tab through windows by recency of use. Based on the Alt+Tab behaviour common outside of xmonad.
    XMonad.Util.History
        Track history in O(log n) time. Provides History, a variation on a LIFO stack with a uniqueness property. In order to achieve the desired asymptotics, the data type is implemented as an ordered Map.
    XMonad.Actions.Repeatable
        Actions you'd like to repeat. Factors out the shared logic of X.A.CycleRecentWS, X.A.CycleWorkspaceByScreen and X.A.CycleWindows.
    XMonad.Hooks.OnPropertyChange:
        A new module replicating the functionality of XMonad.Hooks.DynamicProperty, but with more discoverable names.
    XMonad.Actions.ToggleFullFloat:
        Fullscreen (float) a window while remembering its original state. There's both an action to be bound to a key, and hooks that plug into XMonad.Hooks.EwmhDesktops.
    XMonad.Layout.CircleEx:
        A new window layout, similar to X.L.Circle, but with more possibilities for customisation.
    XMonad.Layout.DecorationEx:
        A new, more extensible, mechanism for window decorations, and some standard types of decorations, including usual bar on top of window, tabbed decorations and dwm-like decorations.

Bug Fixes and Minor Changes

    XMonad.Layout.Magnifier
        Added magnifyxy to allow for different magnification in the horizontal and vertical directions. Added magnifierxy, magnifierxy', magnifierxyOff, and magnifierxyOff' as particular combinators.
    XMonad.Util.Loggers
        Added logClassname, logClassnames, logClassnames', logClassnameOnScreen, logClassnamesOnScreen, logClassnamesOnScreen', and ClassnamesFormat. These are all equivalents of their Title counterparts, allowing logging the window classname instead.
    XMonad.Hooks.StatusBar.PP
        dynamicLogString now forces its result and produces an error string if it throws an exception. Use dynamicLogString' if for some reason you need the old behavior.
    XMonad.Util.EZConfig
        Added remapKeysP, which remaps keybindings from one binding to another.
        Made additionalKeys{,P}, removeKeys{,P}, remapKeysP, and {additional,remove}MouseBindings infixl 4 so they can more easily be concatenated with (++).
    XMonad.Util.NamedScratchpad
        Added addExclusives, resetFocusedNSP, setNoexclusive, resizeNoexclusive, and floatMoveNoexclusive in order to augment named scratchpads with the exclusive scratchpad functionality of XMonad.Util.ExclusiveScratchpads.
    XMonad.Layout.BorderResize
        Added borderResizeNear as a variant of borderResize that can control how many pixels near a border resizing still works.
    XMonad.Util.Run
        It is now ensured that all arguments of execute and eval are quoted. Likewise, executeNoQuote is added as a version of execute that does not do that.
        Added findFile as a shorthand to call find-file.
        Added list and saveExcursion to the list of Emacs commands.
        Added toList to easily lift a String to an X Input.
        Added >&&> and >||> to glue together different inputs.
    XMonad.Util.Parser
        Added the gather, count, between, option, optionally, skipMany, skipMany1, chainr, chainr1, chainl, chainl1, and manyTill functions, in order to achieve feature parity with Text.ParserCombinators.ReadP.
    XMonad.Actions.FloatKeys
        Added directionMoveWindow and directionMoveWindow as more alternatives to the existing functions.
    XMonad.Hooks.InsertPosition
        Added setupInsertPosition as a combinator alternative to insertPosition.
    XMonad.Actions.Navigation2D
        Added sideNavigation as a fallback to the default tiling strategy, in case lineNavigation can't find a window. This benefits especially users who use XMonad.Layout.Spacing.
    XMonad.Prompt.OrgMode
        Added orgPromptRefile and orgPromptRefileTo for interactive and targeted refiling of the entered note into some existing tree of headings, respectively.
        Allowed the time specification in HHMM format.
    XMonad.Actions.Search
        Added aur, flora, ncatlab, protondb, rosettacode, sourcehut, steam, voidpgks_x86_64, voidpgks_x86_64_musl, arXiv, clojureDocs, cratesIo, rustStd, noogle, nixos, homeManager, and zbmath search engines.
    XMonad.Layout.ResizableThreeColumns
        Fixed an issue where the bottom right window would not respond to MirrorShrink and MirrorExpand messages.
    XMonad.Hooks.EwmhDesktops
        Added disableEwmhManageDesktopViewport to avoid setting the _NET_DESKTOP_VIEWPORT property, as it can lead to issues with some status bars (see this polybar issue).
        Added setEwmhFullscreenHooks to override the default fullfloat/sink behaviour of _NET_WM_STATE_FULLSCREEN requests. See also XMonad.Actions.ToggleFullFloat for a float-restoring implementation of fullscreening.
        Added ewmhDesktops(Maybe)ManageHook that places windows in their preferred workspaces. This is useful when restoring a browser session after a restart.
    XMonad.Hooks.StatusBar
        Added startAllStatusBars to start the configured status bars.
    XMonad.Util.NamedActions
        Changed addDescrKeys and addDescrKeys' to not discard the keybindings in the current config.
    XMonad.Prompt
        The emacsLikeXPKeymap and vimLikeXPKeymap keymaps now treat C-m the same as Return.
        Added prevCompletionKey to XPConfig, facilitating the ability to cycle through the completions backwards. This is bound to S-<TAB> by default.
        The vimLikeXPKeymap now accepts the prompt upon pressing enter in normal mode.
    XMonad.Actions.Prefix
        Added orIfPrefixed, a combinator to decide upon an action based on whether any prefix argument was given.
    XMonad.Actions.WorkspaceNames
        Enabled prompt completion (from history) in renameWorkspace.
    XMonad.Prompt.Pass
        Added passOTPTypePrompt to type out one-time-passwords via xdotool.
    XMonad.Util.Stack
        Added zipperFocusedAtFirstOf to differentiate two lists into a zipper.

Revision 1.22: download - view: text, markup, annotated - select for diffs
Sun Nov 12 13:23:53 2023 UTC (16 months, 1 week ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4
Diff to: previous 1.21: preferred, colored
Changes since revision 1.21: +2 -2 lines
*: revebump for new brotli option for freetype2

Addresses PR 57693

Revision 1.21: download - view: text, markup, annotated - select for diffs
Thu Nov 2 06:37:44 2023 UTC (16 months, 2 weeks ago) by pho
Branches: MAIN
Diff to: previous 1.20: preferred, colored
Changes since revision 1.20: +2 -2 lines
Revbump all Haskell after updating lang/ghc96

Revision 1.20: download - view: text, markup, annotated - select for diffs
Mon Oct 9 04:54:57 2023 UTC (17 months, 1 week ago) by pho
Branches: MAIN
Diff to: previous 1.19: preferred, colored
Changes since revision 1.19: +2 -2 lines
Bump Haskell packages after updating lang/ghc94

Revision 1.19: download - view: text, markup, annotated - select for diffs
Tue Feb 7 01:41:17 2023 UTC (2 years, 1 month ago) by pho
Branches: MAIN
CVS tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1
Diff to: previous 1.18: preferred, colored
Changes since revision 1.18: +2 -2 lines
revbump all the Haskell packages after modifying the runtime system of lang/ghc94

Revision 1.18: download - view: text, markup, annotated - select for diffs
Sun Jan 29 21:18:02 2023 UTC (2 years, 1 month ago) by ryoon
Branches: MAIN
Diff to: previous 1.17: preferred, colored
Changes since revision 1.17: +2 -1 lines
*: Recursive revbup from graphics/freetype2

Revision 1.17: download - view: text, markup, annotated - select for diffs
Thu Jan 26 10:01:04 2023 UTC (2 years, 1 month ago) by pho
Branches: MAIN
Diff to: previous 1.16: preferred, colored
Changes since revision 1.16: +3 -8 lines
wm/xmonad-contrib: Update to 0.17.1

The release note is too long to paste here. See
https://hackage.haskell.org/package/xmonad-contrib-0.17.1/changelog

Revision 1.16: download - view: text, markup, annotated - select for diffs
Sat Feb 26 03:58:33 2022 UTC (3 years ago) by pho
Branches: MAIN
CVS tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Diff to: previous 1.15: preferred, colored
Changes since revision 1.15: +2 -2 lines
Bump all Haskell packages after enabling "split sections" in mk/haskell.mk

Revision 1.15: download - view: text, markup, annotated - select for diffs
Sat Feb 12 08:50:58 2022 UTC (3 years, 1 month ago) by pho
Branches: MAIN
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +2 -1 lines
revbump after changing the default Haskell compiler

Revision 1.14: download - view: text, markup, annotated - select for diffs
Sat Feb 12 05:11:00 2022 UTC (3 years, 1 month ago) by pho
Branches: MAIN
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +2 -3 lines
Update to xmonad-contrib-0.17.0

The list of changes is too long to paste here:
https://hackage.haskell.org/package/xmonad-contrib-0.17.0/changelog

Revision 1.13: download - view: text, markup, annotated - select for diffs
Tue Jan 18 02:48:30 2022 UTC (3 years, 2 months ago) by pho
Branches: MAIN
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +2 -2 lines
Bump packages that depends on GHC

Revision 1.12: download - view: text, markup, annotated - select for diffs
Mon May 3 19:01:20 2021 UTC (3 years, 10 months ago) by pho
Branches: MAIN
CVS tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +2 -2 lines
*: Bump PKGREVISION for ghc-9.0.1

Revision 1.11: download - view: text, markup, annotated - select for diffs
Mon Aug 17 20:20:19 2020 UTC (4 years, 7 months ago) by leot
Branches: MAIN
CVS tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +2 -1 lines
*: revbump after fontconfig bl3 changes (libuuid removal)

Revision 1.10: download - view: text, markup, annotated - select for diffs
Sat Jan 11 14:29:29 2020 UTC (5 years, 2 months ago) by pho
Branches: MAIN
CVS tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +3 -12 lines
Update to xmonad-contrib-0.16

The list of changes is too long to paste here. See
http://hackage.haskell.org/package/xmonad-contrib-0.16/changelog

Revision 1.9: download - view: text, markup, annotated - select for diffs
Thu Jan 2 17:29:55 2020 UTC (5 years, 2 months ago) by pho
Branches: MAIN
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +12 -5 lines
Update to xmonad-contrib-0.14

The list of changes from 0.12 are too long to paste here. See
http://hackage.haskell.org/package/xmonad-contrib-0.14/changelog

Revision 1.8: download - view: text, markup, annotated - select for diffs
Mon Mar 12 11:17:45 2018 UTC (7 years ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +2 -1 lines
Recursive bumps for fontconfig and libzip dependency changes.

Revision 1.7: download - view: text, markup, annotated - select for diffs
Mon Jan 4 12:52:42 2016 UTC (9 years, 2 months ago) by szptvlfn
Branches: MAIN
CVS tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +2 -3 lines
Update to 0.12

CHANGES:
## 0.12 (December 14, 2015)

### Breaking Changes

  * `XMonad.Actions.UpdatePointer.updatePointer` arguments were
    changed. This allows including aspects of both of the
    `TowardsCentre` and `Relative` methods. To keep the same behavior,
    replace the entry in the left column with the entry on the right:

    | < 0.12                              |   >= 0.12                        |
    |-------------------------------------|----------------------------------|
    | `updatePointer Nearest`             | `updatePointer (0.5, 0.5) (1,1)` |
    | `updatePointer (Relative x y)`      | `updatePointer (x,y) (1,1)`      |
    | `updatePointer (TowardsCentre x y)` | `updatePointer (0.5,0.5) (x,y)`  |

### New Modules

  * `XMonad.Actions.AfterDrag`

    Perform an action after the current mouse drag is completed.

  * `XMonad.Actions.DynamicProjects`

    Imbues workspaces with additional features so they can be treated
    as individual project areas.

  * `XMonad.Actions.LinkWorkspaces`

    Provides bindings to add and delete links between workspaces. It
    is aimed at providing useful links between workspaces in a
    multihead setup. Linked workspaces are viewed at the same time.

  * `XMonad.Config.Bepo`

    This module fixes some of the keybindings for the francophone
    among you who use a BEPO keyboard layout. Based on
    `XMonad.Config.Azerty`

  * `XMonad.Config.Dmwit`

    Daniel Wagner's configuration.

  * `XMonad.Config.Mate`

    This module provides a config suitable for use with the MATE
    desktop environment.

  * `XMonad.Config.Prime`

    A draft of a brand new config syntax for xmonad.

  * `XMonad.Hooks.DynamicProperty`

    Module to apply a `ManageHook` to an already-mapped window when a
    property changes. This would commonly be used to match browser
    windows by title, since the final title will only be set after (a)
    the window is mapped, (b) its document has been loaded, (c) all
    load-time scripts have run.

  * `XMonad.Hooks.ManageDebug`

    A `manageHook` and associated `logHook` for debugging `ManageHook`s.
    Simplest usage: wrap your xmonad config in the `debugManageHook`
    combinator.  Or use `debugManageHookOn` for a triggerable version,
    specifying the triggering key sequence in `XMonad.Util.EZConfig`
    syntax. Or use the individual hooks in whatever way you see fit.

  * `XMonad.Hooks.WallpaperSetter`

    Log hook which changes the wallpapers depending on visible
    workspaces.

  * `XMonad.Hooks.WorkspaceHistory`

    Keeps track of workspace viewing order.

  * `XMonad.Layout.AvoidFloats`

    Find a maximum empty rectangle around floating windows and use
    that area to display non-floating windows.

  * `XMonad.Layout.BinarySpacePartition`

    Layout where new windows will split the focused window in half,
    based off of BSPWM.

  * `XMonad.Layout.Dwindle`

    Three layouts: The first, `Spiral`, is a reimplementation of
    `XMonad.Layout.Spiral.spiral` with, at least to me, more intuitive
    semantics.  The second, `Dwindle`, is inspired by a similar layout
    in awesome and produces the same sequence of decreasing window
    sizes as Spiral but pushes the smallest windows into a screen
    corner rather than the centre.  The third, `Squeeze` arranges all
    windows in one row or in one column, with geometrically decreasing
    sizes.

  * `XMonad.Layout.Hidden`

    Similar to `XMonad.Layout.Minimize` but completely removes windows
    from the window set so `XMonad.Layout.BoringWindows` isn't
    necessary.  Perfect companion to `XMonad.Layout.BinarySpacePartition`
    since it can be used to move windows to another part of the BSP tree.

  * `XMonad.Layout.IfMax`

    Provides `IfMax` layout, which will run one layout if there are
    maximum `N` windows on workspace, and another layout, when number
    of windows is greater than `N`.

  * `XMonad.Layout.PerScreen`

    Configure layouts based on the width of your screen; use your
    favorite multi-column layout for wide screens and a full-screen
    layout for small ones.

  * `XMonad.Layout.Stoppable`

    This module implements a special kind of layout modifier, which when
    applied to a layout, causes xmonad to stop all non-visible processes.
    In a way, this is a sledge-hammer for applications that drain power.
    For example, given a web browser on a stoppable workspace, once the
    workspace is hidden the web browser will be stopped.

  * `XMonad.Prompt.ConfirmPrompt`

    A module for setting up simple confirmation prompts for
    keybindings.

  * `XMonad.Prompt.Pass`

    This module provides 3 `XMonad.Prompt`s to ease passwords
    manipulation (generate, read, remove) via [pass][].

  * `XMonad.Util.RemoteWindows`

    This module implements a proper way of finding out whether the
    window is remote or local.

  * `XMonad.Util.SpawnNamedPipe`

    A module for spawning a pipe whose `Handle` lives in the xmonad state.

  * `XMonad.Util.WindowState`

    Functions for saving per-window data.

### Miscellaneous Changes

  * Fix issue #9: `XMonad.Prompt.Shell` `searchPredicate` is ignored,
    defaults to `isPrefixOf`

  * Fix moveHistory when alwaysHighlight is enabled

  * `XMonad.Actions.DynamicWorkspaceGroups` now exports `addRawWSGroup`

  * Side tabs were added to the tabbed layout

  * `XMonad/Layout/IndependentScreens` now exports `marshallSort`

  * `XMonad/Hooks/UrgencyHook` now exports `clearUrgency`

  * Exceptions are now caught when finding commands on `PATH` in `Prompt.Shell`

  * Switched to `Data.Default` wherever possible

  * `XMonad.Layout.IndependentScreens` now exports `whenCurrentOn`

  * `XMonad.Util.NamedActions` now exports `addDescrKeys'`

  * EWMH `DEMANDS_ATTENTION` support added to `UrgencyHook`

  * New `useTransientFor` modifier in `XMonad.Layout.TrackFloating`

  * Added the ability to remove arbitrary workspaces

Revision 1.6: download - view: text, markup, annotated - select for diffs
Sun May 31 12:59:16 2015 UTC (9 years, 9 months ago) by szptvlfn
Branches: MAIN
CVS tags: pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +2 -2 lines
Bump PKGREVISION for hs-dlist-0.7.1.1

Revision 1.5: download - view: text, markup, annotated - select for diffs
Sun Mar 1 20:02:50 2015 UTC (10 years ago) by joerg
Branches: MAIN
CVS tags: pkgsrc-2015Q1-base, pkgsrc-2015Q1
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +6 -3 lines
Fix X11 dependencies.

Revision 1.4: download - view: text, markup, annotated - select for diffs
Sun Nov 23 12:52:33 2014 UTC (10 years, 3 months ago) by szptvlfn
Branches: MAIN
CVS tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +2 -2 lines
Bump PKGREVISION for hs-transformers-0.4.2.0

Revision 1.3: download - view: text, markup, annotated - select for diffs
Tue Oct 21 21:28:58 2014 UTC (10 years, 5 months ago) by szptvlfn
Branches: MAIN
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +2 -2 lines
Bump PKGREVISION for hs-random-1.1

Revision 1.2: download - view: text, markup, annotated - select for diffs
Thu Aug 28 21:56:27 2014 UTC (10 years, 6 months ago) by szptvlfn
Branches: MAIN
CVS tags: pkgsrc-2014Q3-base, pkgsrc-2014Q3
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +2 -1 lines
Bump PKGREVISION for hs-random-1.0.1.3

Revision 1.1: download - view: text, markup, annotated - select for diffs
Mon Aug 25 13:58:21 2014 UTC (10 years, 6 months ago) by szptvlfn
Branches: MAIN
Import xmonad-contrib-0.11.3 as wm/xmonad-contrib,
packaged for wip by degroote.

Third party tiling algorithms, configurations and scripts to xmonad,
a tiling window manager for X.

For an introduction to building, configuring and using xmonad
extensions, see "XMonad.Doc". In particular:

"XMonad.Doc.Configuring", a guide to configuring xmonad

"XMonad.Doc.Extending", using the contributed extensions library

"XMonad.Doc.Developing", introduction to xmonad internals and writing
your own extensions.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>