File:  [cvs.NetBSD.org] / pkgsrc / wm / wmakerconf / Makefile
Revision 1.61: download - view: text, annotated - select for diffs
Sat Jan 26 21:39:00 2013 UTC (11 years, 10 months ago) by adam
Branches: MAIN
CVS tags: HEAD
Revbump after graphics/jpeg and textproc/icu

# $NetBSD: Makefile,v 1.61 2013/01/26 21:39:00 adam Exp $

DISTNAME=	wmakerconf-2.11
PKGREVISION=	26
CATEGORIES=	x11 wm windowmaker
MASTER_SITES=	http://starplot.org/wmakerconf/

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://starplot.org/wmakerconf/
COMMENT=	Gtk+ based configuration tool for Window Maker

USE_PKGLOCALEDIR=	yes
USE_X11BASE=		yes
GNU_CONFIGURE=		yes
USE_TOOLS+=		gzip tar perl:run pkg-config msgfmt

.if defined(PKG_SYSCONFDIR.windowmaker)
CONFIGURE_ARGS+=	--with-wmakeretcprefix=${PKG_SYSCONFDIR.windowmaker}
.else
CONFIGURE_ARGS+=	--with-wmakeretcprefix=${PKG_SYSCONFDIR}/WindowMaker
.endif

CONFIGURE_ENV+=		gzip=${TOOLS_GZIP_CMD:Q}
CONFIGURE_ENV+=		perlpath=${PERL5:Q}
CONFIGURE_ENV+=		tar=${TOOLS_TAR:Q}

REPLACE_PERL+=		scripts/*.pl.in
USE_TOOLS+=		perl:run

post-extract:
	${MV} ${WRKSRC}/data/WMWmakerconf ${WRKSRC}/data/WMWmakerconf.in

pre-configure:
	${SED} -e 's|@PREFIX@|${PREFIX}|g' < ${WRKSRC}/data/WMWmakerconf.in \
		> ${WRKSRC}/data/WMWmakerconf

.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../wm/windowmaker/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"

.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>