[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / wm / windowmaker

Annotation of pkgsrc/wm/windowmaker/Makefile, Revision 1.15

1.15    ! tron        1: # $NetBSD: Makefile,v 1.14 2001/07/23 18:54:55 wiz Exp $
1.1       wiz         2:
1.15    ! tron        3: DISTNAME=              WindowMaker-0.65.1
        !             4: PKGNAME=               windowmaker-0.65.1
1.1       wiz         5: CATEGORIES=            x11 wm
                      6: MASTER_SITES=          ftp://ftp.windowmaker.org/pub/beta/srcs/ \
                      7:                        ftp://ftp.ics.es.osaka-u.ac.jp/pub/mirrors/WindowMaker/beta/srcs/
                      8: EXTRACT_SUFX=          .tar.bz2
                      9:
                     10: MAINTAINER=            jlam@netbsd.org
                     11: HOMEPAGE=              http://www.windowmaker.org/
1.4       wiz        12: COMMENT=               GNUStep-compliant NEXTSTEP(tm) window manager clone
1.1       wiz        13:
1.8       hubertf    14: BUILD_DEPENDS+=                automake-1.4:../../devel/automake
                     15: BUILD_USES_MSGFMT=     yes
1.1       wiz        16:
1.11      zuntum     17: USE_BUILDLINK_ONLY=    YES
1.1       wiz        18: USE_LIBTOOL=           YES
                     19: LTCONFIG_OVERRIDE=     ${WRKSRC}/ltconfig
                     20: USE_X11BASE=           YES
                     21: GNU_CONFIGURE=         YES
                     22: CONFIGURE_ARGS+=       --enable-usermenu \
1.13      jlam       23:                        --with-nlsdir=${PREFIX}/${PKGLOCALEDIR}/locale
1.1       wiz        24: CONFIGURE_ENV+=                LINGUAS=yes
                     25:
                     26: INSTALL_TARGET=                install-strip
                     27:
                     28: .include "../../mk/bsd.prefs.mk"
                     29:
                     30: # "egcs" has an optimizer problem on "arm32".
                     31: .if ${OPSYS} == "NetBSD" && ${MACHINE_ARCH} == "arm32"
                     32: CFLAGS=
                     33: .endif
                     34:
                     35: # WINDOWMAKER_OPTIONS is a space-separated list of compile-time options
                     36: # to support.  Currently supported options:
                     37: #
                     38: #      kde             enable support for kde/kwm window manager hints
                     39: #      gnome           enable support for GNOME window manager hints
                     40: #      openlook        enable support for OPEN LOOK(tm) window manager hints
                     41: #      lite            remove Window Maker redundancies with KDE and GNOME
                     42: #
1.7       mjl        43: WINDOWMAKER_OPTIONS?=  gnome kde openlook
1.1       wiz        44:
                     45: BUILD_DEFS+=           WINDOWMAKER_OPTIONS
                     46:
                     47: .for OPTION in ${WINDOWMAKER_OPTIONS}
                     48: CONFIGURE_ARGS+=       --enable-${OPTION}
                     49: .endfor
                     50:
                     51: post-extract:
                     52:        ${RM} -f ${WRKSRC}/WindowMaker/Defaults/WMState \
                     53:                 ${WRKSRC}/WindowMaker/Defaults/WMWindowAttributes \
1.15    ! tron       54:                 ${WRKSRC}/WindowMaker/Defaults/WindowMaker \
        !            55:                 ${WRKSRC}/po/zh_TW.Big5.po
        !            56:        for manfile in ${WRKSRC}/doc/*.1x ${WRKSRC}/doc/*/*.1x; \
1.1       wiz        57:        do \
                     58:                ${MV} $${manfile} `${ECHO} $${manfile} | ${SED} "s/1x$$/1/"`; \
                     59:        done;
1.5       wiz        60:        cd ${WRKSRC} && \
                     61:        for f in WINGs/wapplication.c WindowMaker/Defaults/WindowMaker.in \
                     62:                WPrefs.app/Paths.c WindowMaker/menu* WindowMaker/plmenu*; do \
                     63:                ${SED} "s|/usr/local|${PREFIX}|g" $$f > $$f.new && \
                     64:                ${MV} $$f.new $$f; \
                     65:        done
1.1       wiz        66:
                     67: pre-configure:
                     68:        cd ${WRKSRC}; ${LOCALBASE}/bin/autoconf; \
                     69:                ${RM} doc/Makefile.in ; ${LOCALBASE}/bin/automake --no-force
                     70:
                     71: post-install:
                     72:        ${INSTALL_DATA_DIR} ${PREFIX}/share/WindowMaker/SoundSets
                     73:        ${INSTALL_DATA_DIR} ${PREFIX}/share/WindowMaker/Sounds
                     74:        ${TOUCH} ${PREFIX}/share/WindowMaker/SoundSets/.directory
                     75:        ${TOUCH} ${PREFIX}/share/WindowMaker/Sounds/.directory
                     76:        ${INSTALL_DATA_DIR} ${PREFIX}/share/doc/WindowMaker
                     77:        cd ${WRKSRC}; ${INSTALL_DATA} \
                     78:                README README.GNOME README.KDE README.definable-cursor \
                     79:                FAQ FAQ.I18N \
                     80:                ${PREFIX}/share/doc/WindowMaker
                     81:
1.13      jlam       82: .include "../../devel/gettext-lib/buildlink.mk"
1.11      zuntum     83: .include "../../devel/libproplist/buildlink.mk"
1.14      wiz        84: .include "../../graphics/hermes/buildlink.mk"
1.11      zuntum     85: .include "../../graphics/libungif/buildlink.mk"
                     86: .include "../../graphics/jpeg/buildlink.mk"
                     87: .include "../../graphics/png/buildlink.mk"
                     88: .include "../../graphics/tiff/buildlink.mk"
1.12      zuntum     89: .include "../../graphics/xpm/buildlink.mk"
1.1       wiz        90: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>