[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / wm / windowmaker

Annotation of pkgsrc/wm/windowmaker/Makefile, Revision 1.11

1.11    ! zuntum      1: # $NetBSD: Makefile,v 1.10 2001/05/22 10:42:13 wiz Exp $
1.1       wiz         2:
1.10      wiz         3: DISTNAME=              WindowMaker-0.65.0
                      4: PKGNAME=               windowmaker-0.65.0
1.1       wiz         5: CATEGORIES=            x11 wm
                      6: MASTER_SITES=          ftp://ftp.windowmaker.org/pub/beta/srcs/ \
                      7:                        ftp://ftp.ics.es.osaka-u.ac.jp/pub/mirrors/WindowMaker/beta/srcs/
                      8: EXTRACT_SUFX=          .tar.bz2
                      9:
                     10: MAINTAINER=            jlam@netbsd.org
                     11: HOMEPAGE=              http://www.windowmaker.org/
1.4       wiz        12: COMMENT=               GNUStep-compliant NEXTSTEP(tm) window manager clone
1.1       wiz        13:
1.8       hubertf    14: BUILD_DEPENDS+=                automake-1.4:../../devel/automake
                     15: BUILD_USES_MSGFMT=     yes
1.1       wiz        16:
1.11    ! zuntum     17: USE_BUILDLINK_ONLY=    YES
1.1       wiz        18: USE_LIBTOOL=           YES
                     19: USE_LIBINTL=           YES
                     20: LTCONFIG_OVERRIDE=     ${WRKSRC}/ltconfig
                     21: USE_X11BASE=           YES
                     22: USE_XPM=               YES
                     23: GNU_CONFIGURE=         YES
                     24: CONFIGURE_ARGS+=       --enable-usermenu \
1.11    ! zuntum     25:                        --with-nlsdir=${PREFIX}/share/locale
1.1       wiz        26: CONFIGURE_ENV+=                LINGUAS=yes
                     27:
                     28: INSTALL_TARGET=                install-strip
                     29:
                     30: .include "../../mk/bsd.prefs.mk"
                     31:
                     32: # "egcs" has an optimizer problem on "arm32".
                     33: .if ${OPSYS} == "NetBSD" && ${MACHINE_ARCH} == "arm32"
                     34: CFLAGS=
                     35: .endif
                     36:
                     37: # WINDOWMAKER_OPTIONS is a space-separated list of compile-time options
                     38: # to support.  Currently supported options:
                     39: #
                     40: #      kde             enable support for kde/kwm window manager hints
                     41: #      gnome           enable support for GNOME window manager hints
                     42: #      openlook        enable support for OPEN LOOK(tm) window manager hints
                     43: #      lite            remove Window Maker redundancies with KDE and GNOME
                     44: #
1.7       mjl        45: WINDOWMAKER_OPTIONS?=  gnome kde openlook
1.1       wiz        46:
                     47: BUILD_DEFS+=           WINDOWMAKER_OPTIONS
                     48:
                     49: .for OPTION in ${WINDOWMAKER_OPTIONS}
                     50: CONFIGURE_ARGS+=       --enable-${OPTION}
                     51: .endfor
                     52:
                     53: post-extract:
                     54:        ${RM} -f ${WRKSRC}/WindowMaker/Defaults/WMState \
                     55:                 ${WRKSRC}/WindowMaker/Defaults/WMWindowAttributes \
                     56:                 ${WRKSRC}/WindowMaker/Defaults/WindowMaker
                     57:        for manfile in ${WRKSRC}/doc/*.1x; \
                     58:        do \
                     59:                ${MV} $${manfile} `${ECHO} $${manfile} | ${SED} "s/1x$$/1/"`; \
                     60:        done;
1.5       wiz        61:        cd ${WRKSRC} && \
                     62:        for f in WINGs/wapplication.c WindowMaker/Defaults/WindowMaker.in \
                     63:                WPrefs.app/Paths.c WindowMaker/menu* WindowMaker/plmenu*; do \
                     64:                ${SED} "s|/usr/local|${PREFIX}|g" $$f > $$f.new && \
                     65:                ${MV} $$f.new $$f; \
                     66:        done
1.1       wiz        67:
                     68: pre-configure:
                     69:        cd ${WRKSRC}; ${LOCALBASE}/bin/autoconf; \
                     70:                ${RM} doc/Makefile.in ; ${LOCALBASE}/bin/automake --no-force
                     71:
                     72: post-install:
                     73:        ${INSTALL_DATA_DIR} ${PREFIX}/share/WindowMaker/SoundSets
                     74:        ${INSTALL_DATA_DIR} ${PREFIX}/share/WindowMaker/Sounds
                     75:        ${TOUCH} ${PREFIX}/share/WindowMaker/SoundSets/.directory
                     76:        ${TOUCH} ${PREFIX}/share/WindowMaker/Sounds/.directory
                     77:        ${INSTALL_DATA_DIR} ${PREFIX}/share/doc/WindowMaker
                     78:        cd ${WRKSRC}; ${INSTALL_DATA} \
                     79:                README README.GNOME README.KDE README.definable-cursor \
                     80:                FAQ FAQ.I18N \
                     81:                ${PREFIX}/share/doc/WindowMaker
                     82:
1.11    ! zuntum     83: .include "../../devel/libproplist/buildlink.mk"
        !            84: .include "../../graphics/libungif/buildlink.mk"
        !            85: .include "../../graphics/jpeg/buildlink.mk"
        !            86: .include "../../graphics/png/buildlink.mk"
        !            87: .include "../../graphics/tiff/buildlink.mk"
1.1       wiz        88: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>