[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / wm / fluxbox

File: [cvs.NetBSD.org] / pkgsrc / wm / fluxbox / Makefile (download)

Revision 1.43, Tue Oct 9 20:17:31 2007 UTC (16 years, 6 months ago) by xtraeme
Branch: MAIN
CVS Tags: pkgsrc-2007Q3-base, pkgsrc-2007Q3
Changes since 1.42: +3 -3 lines

Update to 1.0.0 (ok by agc)

News in 1.0.0:

* New default style: bloe
* New styles:
  ostrich zimek_darkblue, zimek_green, zimek_bisque,
  carp, arch, bora_black, bora_blue, bora_green, green_tea, bloe
* Fixed shape handling, now shaped corners have border.
* Allow negative numbers in command "Workspace"
* Added utility fluxbox-remote
* Allows script access to most fluxbox commands;
  Support must be turned on in the init file with
  session.screen.allowRemoteActions; the syntax is, e.g.,
  fluxbox-remote "CustomMenu ~/.fluxbox/custommenu"
* Added keycommands :AddWorkspace and :RemoveLastWorkspace
* Added some missing Open Office entries and window managers,
  plus some other minor changes in fluxbox-generate_menu
* Updated languages:
  sv_SE, zh_CN, de_*, es_ES, es_AR, en_US, en_GB, pt_*
  fi_FI, fr_FR, ru_RU

And a lot of bugfixes, please review the Changelog file for more info.

# $NetBSD: Makefile,v 1.43 2007/10/09 20:17:31 xtraeme Exp $
#

DISTNAME=	fluxbox-1.0.0
#PKGREVISION=	1
CATEGORIES=	wm x11
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=fluxbox/}
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	tonio@NetBSD.org
HOMEPAGE=	http://fluxbox.sourceforge.net/
COMMENT=	Window Manager for X based on Blackbox

USE_LANGUAGES=	c c++
GNU_CONFIGURE=	YES
USE_TOOLS+=	gmake
USE_LIBTOOL=	YES

.include "../../mk/bsd.prefs.mk"

.for option in 9 8 7 6 5 4 3 2 s
BUILDLINK_TRANSFORM+=	rename:-O${option}:-O1
.endfor

CONFIGURE_ARGS+=	--enable-shape
CONFIGURE_ARGS+=	--enable-nls
CONFIGURE_ARGS+=	--enable-xinerama

.include "options.mk"

SUBST_CLASSES+=		cmds
SUBST_STAGE.cmds=	post-build
SUBST_MESSAGE.cmds=	Fixing command names in data files.
SUBST_SED.cmds=		-e 's|bsetroot|fbsetroot|g'
SUBST_FILES.cmds=	data/README.style data/styles/Artwiz\
                        data/styles/MerleyKay data/styles/Outcomes\
		       	data/styles/Rampage data/styles/Results\
		       	data/styles/Spiff

BUILDLINK_DEPMETHOD.libXt?=	build

.include "../../converters/libiconv/buildlink3.mk"
.include "../../x11/libSM/buildlink3.mk"
.include "../../x11/libX11/buildlink3.mk"
.include "../../x11/libXext/buildlink3.mk"
.include "../../x11/libXinerama/buildlink3.mk"
.include "../../x11/libXpm/buildlink3.mk"
.include "../../x11/libXt/buildlink3.mk"
.include "../../x11/xextproto/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"