[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / time / py-icalendar

File: [cvs.NetBSD.org] / pkgsrc / time / py-icalendar / Makefile (download)

Revision 1.1.1.1 (vendor branch), Tue May 19 09:19:45 2009 UTC (14 years, 11 months ago) by wiz
Branch: TNF
CVS Tags: pkgsrc-20090519
Changes since 1.1: +0 -0 lines

Initial import of py-icalendar, packaged for pkgsrc-wip by mj_turner
with changed by jihbed.

The iCalendar package is a parser/generator of iCalendar files for
use with Python. It follows the RFC 2445 (iCalendar) specification

The package can both generate and parse iCalendar files, and can
easily be used as is.

The aim is to make a package that is fully compliant to RFC 2445,
well designed, simple to use and well documented.

# $NetBSD: Makefile,v 1.1.1.1 2009/05/19 09:19:45 wiz Exp $
#

DISTNAME=	iCalendar-1.2
PKGNAME=	${PYPKGPREFIX}-${DISTNAME:S/Calendar/calendar/}
CATEGORIES=	time python
MASTER_SITES=	http://codespeak.net/icalendar/
EXTRACT_SUFX=	.tgz

MAINTAINER=	mj@turner.org.za
HOMEPAGE=	http://codespeak.net/icalendar/
COMMENT=	Python parser/generator for iCalendar files, as per RFC2445
LICENSE=	gnu-lgpl-v2.1

PKG_DESTDIR_SUPPORT=	user-destdir

PY_PATCHPLIST=	yes
EGG_NAME=	${DISTNAME:S/C/c/}

DOCDIR=	${PREFIX}/share/doc/${PKGNAME}

INSTALLATION_DIRS=	${DOCDIR}

# Install documentation manually
post-install:
	${INSTALL_DATA} ${WRKSRC}/doc/* ${DESTDIR}${DOCDIR}

.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"