The NetBSD Project

CVS log for pkgsrc/time/py-dateparser/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / time / py-dateparser

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.18: download - view: text, markup, annotated - select for diffs
Wed Feb 5 16:22:31 2025 UTC (2 months, 2 weeks ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2025Q1-base, pkgsrc-2025Q1, HEAD
Diff to: previous 1.17: preferred, colored
Changes since revision 1.17: +4 -4 lines
py-dateparser: updated to 1.2.1

1.2.1 (2025-02-05)

Fixes:

- Fix PytzUsageWarning
- Fix date_parser with prefer_month_of_year wrong results
- Fix skipped day when UTC and tz are different days

Improvements:

- Avoid repeated loop over timezones
- Proofread README.rst
- Check for derived types for configuration
- Parse some abbreviated strings as relative dates
- Migrate from hijri-converter to hijridate
- Fixed ClusterFuzz build error by adding dateparser.data as a binary
- Fix an issue detected by OSSFuzz
- Support two-digit years in non-Gregorian calendars
- Refactored CI to run extras separately and test minimum versions of dependencies, replaced flake8 with ruff, fixed tests
- Set minimum versions for dependencies
- Limited ``numpy`` to 1.x when installing ``dateparser[fasttext]``

Revision 1.17: download - view: text, markup, annotated - select for diffs
Fri Nov 17 20:48:06 2023 UTC (17 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base, pkgsrc-2024Q4, pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4
Diff to: previous 1.16: preferred, colored
Changes since revision 1.16: +4 -4 lines
py-dateparser: updated to 1.2.0

1.2.0 (2023-11-17)
------------------

New features:

- New ``PREFER_MONTH_OF_YEAR`` setting

Fixes:

- Absolute years in Russian are no longer being treated as a number of years in
  the past

Cleanups and internal improvements:

- Removed the use of ``datetime.utcnow``, deprecated on Python 3.12
- Applied Black formatting to the code base
- Initial integration with OSSFuzz
- Extended test cases

Revision 1.16: download - view: text, markup, annotated - select for diffs
Wed Mar 29 12:57:16 2023 UTC (2 years ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2
Diff to: previous 1.15: preferred, colored
Changes since revision 1.15: +4 -4 lines
py-dateparser: updated to 1.1.8

1.1.8 (2023-03-22)
------------------

Improvements:
- Improved date parsing for Chinese
- Improved date parsing for Czech
- Reorder language by popularity
- Fix leak of memory in cache
- Add support for "\d units later"
- Move modification in CLDR data to yaml
- Add support to use timezone via settings to get PREFER_DATES_FROM result

Revision 1.15: download - view: text, markup, annotated - select for diffs
Tue Feb 7 12:30:59 2023 UTC (2 years, 2 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +4 -4 lines
py-dateparser: updated to 1.1.7

1.1.7 (2023-02-02)
------------------
Improvements:
- Add an “ago” synonym for Arabic
- Improved date parsing for Czech
- Improved date parsing for Indonesian


1.1.6 (2023-01-12)
------------------
Improvements:
- Fix the bug where Monday is parsed as a month
- Prevent ReDoS in Spanish sentence splitting regex

Revision 1.14: download - view: text, markup, annotated - select for diffs
Sun Jan 1 21:39:23 2023 UTC (2 years, 3 months ago) by adam
Branches: MAIN
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +4 -4 lines
py-dateparser: updated to 1.1.5

1.1.5 (2022-12-29)
------------------

Improvements:

- Parse short versions of day, month, and year
- Add a test for “in 1d”
- Update languages_info
- Add a workaround for zipimporter not having exec_module before Python 3.10
- Stabilize tests at midnight
- Add a test case for French

Cleanups:

- Remove the requirements-build file

Revision 1.13: download - view: text, markup, annotated - select for diffs
Tue Nov 22 10:16:00 2022 UTC (2 years, 4 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +4 -5 lines
py-dateparser: updated to 1.1.4

1.1.4 (2022-11-21)
------------------

Improvements:

- Improved support for languages such as Slovak, Indonesian, Hindi, German and Japanese
- Recursively create a model home
- Replace regex sub with simple string replace
- Add Python 3.10, 3.11 support
- Drop support for Python 3.5, 3.6 versions

Revision 1.12: download - view: text, markup, annotated - select for diffs
Mon Nov 21 10:00:48 2022 UTC (2 years, 5 months ago) by adam
Branches: MAIN
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +4 -4 lines
py-dateparser: updated to 1.1.3

1.1.3 (2022-11-03)
------------------

New features:

- Add support for fractional units

Improvements:

- Fix the returned datetime skipping a day with time+timezone input and PREFER_DATES_FROM = 'future'
- Fix input translatation breaking keep_formatting
- English: support "till date"
- English: support “after” and “before” in relative dates

Cleanups:

- Reorganize internal data
- CI updates

Revision 1.11: download - view: text, markup, annotated - select for diffs
Tue Oct 25 09:02:38 2022 UTC (2 years, 5 months ago) by adam
Branches: MAIN
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +4 -4 lines
py-dateparser: updated to 1.1.2

1.1.2 (2022-10-20)
------------------

Improvements:

- Added support for negative timestamp
- Fixed PytzUsageWarning for Python versions >= 3.6
- Added support for dates with dots and spaces
- Improved support for Ukrainian, Croatian and Russian
- Added support for parsing Unix timestamps consistently regardless of timezones
- Improved tests

Revision 1.10: download - view: text, markup, annotated - select for diffs
Sat Sep 17 21:26:31 2022 UTC (2 years, 7 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2022Q3-base, pkgsrc-2022Q3
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +2 -1 lines
py-dateparser: unrestrict py-regex dependency

Bump PKGREVISION.

Revision 1.9: download - view: text, markup, annotated - select for diffs
Mon Jul 11 13:31:46 2022 UTC (2 years, 9 months ago) by adam
Branches: MAIN
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +4 -4 lines
py-dateparser: updated to 1.1.1

1.1.1 (2022-03-17)
------------------

Improvements:

- Fixed issue with regex library by pinning dependencies to an earlier version.
- Extended support for Russian language dates starting with lowercase.
- Allowed to use_given_order for languages too.
- Fixed link to settings section.
- Defined UTF-8 encoding for Windows.
- Fixed directories creation error in CLI utils.


1.1.0 (2021-10-04)
------------------

New features:

* Support language detection based on ``langdetect``, ``fastText``, or a
  custom implementation
* Add support for 'by <time>'
* Sort default language list by internet usage

Improvements:

* Improved support of Chinese, Czech
* Improvements in ``search_dates``
* Make order of previous locales deterministic
* Fix parsing with trailing space
* Consider ``RETURN_TIME_AS_PERIOD`` for timestamp times
* Exclude failing regex version
* Ongoing work multithreading support
* Add demo URL

QA:

* Migrate pipelines from Travis CI to Github Actions
* Use versioned CLDR data
* Add a script to update table of supported languages and locales
* Sort 'skip' keys in yaml files
* Improve test coverage
* Code cleanup


1.0.0 (2020-10-29)
------------------

Breaking changes:

* Drop support for Python 2.7 and pypy
* Now ``DateDataParser.get_date_data()`` returns a ``DateData`` object instead of a ``dict``
* From now wrong ``settings`` are not silenced and raise ``SettingValidationError``
* Now ``dateparser.parse()`` is deterministic and doesn't try previous locales. Also, ``DateDataParser.get_date_data()`` doesn't try the previous locales by default
* Remove the ``'base-formats'`` parser
* Extract the ``'no-spaces-time'`` parser from the ``'absolute-time'`` parser and make it an optional parser
* Remove ``numeral_translation_data``
* Remove the undocumented ``SKIP_TOKENS_PARSER`` and ``FUZZY`` settings
* Remove support for using strings in ``date_formats``
* The undocumented ``ExactLanguageSearch`` class has been moved to the private scope and some internal methods have changed
* Changes in ``dateparser.utils``: ``normalize_unicode()`` doesn't accept ``bytes`` as input and ``convert_to_unicode`` has been deprecated

New features:

* Add Python 3.9 support
* Detect hours separated with a period/dot
* Add support for "decade"
* Add support for the hijri calendar in Python ≥ 3.6

Improvements:

* New logo!
* Improve the README and docs
* Fix the "calendars" extra
* Fix leap years when ``PREFER_DATES_FROM`` is set
* Fix ``STRICT_PARSING`` setting in ``no-spaces-time`` parser
* Consider ``RETURN_AS_TIME_PERIOD`` setting for ``relative-time`` parser
* Parse the 24hr time format with meridian info
* Other small improvements

Revision 1.8: download - view: text, markup, annotated - select for diffs
Tue Oct 26 11:24:32 2021 UTC (3 years, 5 months ago) by nia
Branches: MAIN
CVS tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +2 -2 lines
time: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes

Revision 1.7: download - view: text, markup, annotated - select for diffs
Thu Oct 7 15:04:08 2021 UTC (3 years, 6 months ago) by nia
Branches: MAIN
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +1 -2 lines
time: Remove SHA1 hashes for distfiles

Revision 1.6: download - view: text, markup, annotated - select for diffs
Sat Jun 20 07:18:42 2020 UTC (4 years, 10 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +5 -5 lines
py-dateparser: updated to 0.7.6

0.7.6:
Improvements:
* Rename ``scripts`` to ``dateparser_scripts`` to avoid name collisions with modules from other packages or projects


0.7.5:
New features:
* Add Python 3.8 support
* Implement a ``REQUIRE_PARTS`` setting
* Add support for subscript and superscript numbers
* Extended French support
* Extended German support

Improvements:
* Migrate test suite to Pytest
* Add test to check the `yaml` and `json` files content
* Add flake8 pipeline with pytest-flake8
* Add partial support for 8-digit dates without separators
* Fix possible ``OverflowError`` errors and explicitly avoid to raise ``ValueError`` when parsing relative dates
* Fix double-digit GMT and UTC parsing
* Fix bug when using ``DATE_ORDER``
* Fix bug when parsing relative time with timezone
* Fix milliseconds parsing
* Fix wrong values to be interpreted as ``'future'`` in ``PREFER_DATES_FROM``
* Other small improvements

Revision 1.5: download - view: text, markup, annotated - select for diffs
Sat Mar 7 12:22:43 2020 UTC (5 years, 1 month ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +5 -5 lines
py-dateparser: updated to 0.7.4

0.7.4:

Improvements:
* Fixed Python 2.7 tests


0.7.3:

New features:
* Extended Norwegian support
* Implement a PARSERS setting

Improvements:
* Add support for `PREFER_DATES_FROM` in relative/freshness parser
* Add support for `PREFER_DAY_OF_MONTH` in base-formats parser
* Added UTC -00:00 as a valid offset
* Fix support for “one”
* Fix TypeError when parsing some invalid dates
* Fix tokenizer for non recognized characters
* Prevent installing regex 2019.02.19
* Resolve DeprecationWarning related to raw string escape sequences
* Implement a tox environment to build the documentation
* Improve tests stability
* Documentation improvements
* Performance improvements

Revision 1.4: download - view: text, markup, annotated - select for diffs
Thu Sep 19 19:36:12 2019 UTC (5 years, 7 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +5 -5 lines
py-dateparser: updated to 0.7.2

0.7.2:
Features:
* Extended Czech support
* Added `time` to valid periods
* Added timezone information to dates found with `search_dates()`
* Support strings as date formats

Improvements:
* Fixed Collections ABCs depreciation warning
* Fixed dates with trailing colons not being parsed
* Fixed date format override on any settings change
* Fixed parsing current weekday as past date, regardless of settings
* Added UTC -2:30 as a valid offset
* Added Python 3.7 to supported versions, dropped support for Python 3.3 and 3.4
* Moved to importlib from imp where possible
* Improved support for Catalan
* Documentation improvements

Revision 1.3: download - view: text, markup, annotated - select for diffs
Wed Feb 13 12:54:27 2019 UTC (6 years, 2 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +5 -5 lines
py-dateparser: updated to 0.7.1

0.7.1:
Features/news:
Added detected language to return value of search_dates()
Performance improvements
Refreshed versions of dependencies

Improvements:
Fixed unpickleable DateTime objects with timezones
Fixed regex pattern to avoid new behaviour of re.split in Python 3.7
Fixed an exception thrown when parsing colons
Fixed tests failing on days with number greater than 30
Fixed ZeroDivisionError exceptions

Revision 1.2: download - view: text, markup, annotated - select for diffs
Fri Feb 9 09:17:23 2018 UTC (7 years, 2 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +5 -5 lines
py-dateparser: updated to 0.7.0

0.7.0:
Features added during Google Summer of Code 2017:
* Harvesting language data from Unicode CLDR database (https://github.com/unicode-cldr/cldr-json), which includes over 200 locales
See full currently supported locale list in README.
* Extracting dates from longer strings of text
Special thanks for their awesome contributions!

New features:
* Added (independently from CLDR) Georgian and Swedish

Improvements:
* Improved support of Chinese, Thai, French, Russian
* Removed ruamel.yaml from dependencies. This should reduce the number of installation issues and improve performance as the result of moving away from YAML as basic data storage format.
Note that YAML is still used as format for support language files.
* Improved performance through using pre-compiling frequent regexes and lazy loading of data
* Extended tests
* Updated nose_parameterized to its current package, parameterized

Revision 1.1: download - view: text, markup, annotated - select for diffs
Fri Sep 29 21:21:52 2017 UTC (7 years, 6 months ago) by joerg
Branches: MAIN
CVS tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4
Add py-dateparser-0.6.0:

dateparser provides modules to easily parse localized dates in almost any
string formats commonly found on web pages.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>