[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / time / p5-Time-HiRes

File: [cvs.NetBSD.org] / pkgsrc / time / p5-Time-HiRes / Attic / Makefile (download)

Revision 1.3, Fri Nov 15 02:50:24 2002 UTC (21 years, 4 months ago) by heinz
Branch: MAIN
CVS Tags: netbsd-1-6-1-base, netbsd-1-6-1
Changes since 1.2: +7 -4 lines

Update to 1.38


Revision history for Perl extension Time::HiRes.

1.38
	- no functional changes
	- move lib/Time/HiRes.pm as Hires.pm
	- libraries scanning was slightly broken (always scanned
	  for a library even when $Config{libs} already had it)
1.37
	- Ray Zimmerman ran into a race condition in Mac OS X.
	  A 0.01-second alarm fired before the test expected.
	  The test first slept indefinitely (blocking for signals)
	  and only after that tested for the signal having been sent.
	  Since the signal had already been sent, the test #12 never
	  completed.  The solution: test first, then block.
	- default to being silent on all probing attempts, set the
	  environment variable VERBOSE to a true value to see the
	  details (the probing command and the possible errors)
1.36
	- do not clear MAN3PODS in Makefile.PL (Radoslaw Zielinski)
	- INSTALLDIRS => 'perl' missing which means that Time::HiRes
	  cannot be upgraded from CPAN to override the 5.8.0 version
	  (Guido A. Ostkamp)
	- Time::HiRes 1.35 could not be dropped as-is to bleadperl
	  because the include directories did not adjust themselves
	  if $ENV{PERL_CORE} (Hugo van der Sanden)
	- add documentation about the restart of select() under alarm()
1.35
	- small documentation tweaks
1.34
	- better VMS operation (Craig Berry)
1.33
	- our time machine is accelerating: now works with Perl 5.004_01
	  (tried with 5.003_07 and 5.002 but I get segmentation faults
	   from running the Makefile.PL with those in Tru64 4.0D)


1.31 and 1.32 add more backward compatibility (now all the way back to
Perl 5.00404), and using nanosleep() (if available) for subsecond sleeps.

1.30 adds all the changes made during the Perl 5.6->5.7->5.8 development
cycle.  Most notably portability across platforms has been enhanced,
and the interval timers (setitimer, getitimer) have been added.
Note that the version of Time::HiRes that is included in Perl 5.8.0
calls itself 1.20_00, but it is equivalent to this Time::HiRes version.
Note also that in 1.30 Wegscheid turns over the maintenance to Jarkko
Hietaniemi.

1.20

# $NetBSD: Makefile,v 1.3 2002/11/15 02:50:24 heinz Exp $
#

DISTNAME=		Time-HiRes-1.38
PKGNAME=		p5-${DISTNAME}
SVR4_PKGNAME=		p5thr
CATEGORIES=		devel perl5
MASTER_SITES=		${MASTER_SITE_PERL_CPAN:=Time/}

MAINTAINER=		bad@netbsd.org
HOMEPAGE=		http://search.cpan.org/author/JHI/Time-HiRes/
COMMENT=		perl5 module for high resolution time, sleep, and alarm

USE_BUILDLINK2=		YES

PERL5_CONFIGURE=	YES
PERL5_PACKLIST=		${PERL5_SITEARCH}/auto/Time/HiRes/.packlist

TEST_TARGET=		test

.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"