[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / textproc / xmlto

File: [cvs.NetBSD.org] / pkgsrc / textproc / xmlto / Makefile (download)

Revision 1.9, Sat Mar 4 21:30:52 2006 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q2-base, pkgsrc-2006Q2, pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.8: +2 -2 lines

Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

# $NetBSD: Makefile,v 1.9 2006/03/04 21:30:52 jlam Exp $
#

DISTNAME=		xmlto-0.0.18
PKGREVISION=		3
CATEGORIES=		textproc
MASTER_SITES=		http://cyberelk.net/tim/data/xmlto/stable/
EXTRACT_SUFX=		.tar.bz2

MAINTAINER=		pkgsrc-users@NetBSD.org
HOMEPAGE=		http://cyberelk.net/tim/xmlto/index.html
COMMENT=		Tool to help transform XML documents into other formats

DEPENDS+=		getopt-[0-9]*:../../misc/getopt
DEPENDS+=		bash-[0-9]*:../../shells/bash
DEPENDS+=		docbook-xsl>=1.67.0nb1:../../textproc/docbook-xsl
DEPENDS+=		libxml2>=2.6.2:../../textproc/libxml2

USE_PKGLOCALEDIR=	yes
GNU_CONFIGURE=		yes
MAKE_ENV+=		SGML_CATALOG_FILES=${PREFIX:Q}/share/xml/catalog
CONFIGURE_ARGS+=	--with-getopt=${PREFIX:Q}/bin/getopt

pre-install:
	${INSTALL_DATA_DIR} ${PREFIX:Q}/share/xmlto/format/docbook
	${INSTALL_DATA_DIR} ${PREFIX:Q}/share/xmlto/format/fo
	@${SED} s,/bin/bash,${PREFIX:Q}/bin/bash, \
		${WRKSRC:Q}/xmlto  > ${WRKDIR:Q}/xmlto.new
	@${MV} ${WRKDIR:Q}/xmlto.new ${WRKSRC:Q}/xmlto

.include "../../textproc/libxslt/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"