File:  [cvs.NetBSD.org] / pkgsrc / textproc / ugrep / Makefile
Revision 1.77: download - view: text, annotated - select for diffs
Fri Apr 5 08:24:30 2024 UTC (9 months, 2 weeks ago) by adam
Branches: MAIN
CVS tags: HEAD
ugrep: updated to 5.1.3

ugrep v5.1.3

revert some of the third-party suggested configure scrip changes, this should make Homebrew ugrep include compression libraries again


ugrep v5.1.2

updated configure and makefiles to improve SIMD (SSE2/AVX2/AVX512BW/NEON/AArch64) detection and cross-compilation
removed unused m4/ax_check scripts, adding corresponding PKG_CHECK_MODULES to configure.ac instead
update some of the ctype function calls to avoid potential signedness pitfalls
AIX build
use statfs() with options --include-fs and --exclude-fs when the preferred statvfs() is not available
suppress --filter utility stderr messages when ugrep options -s (--no-messages) and -q (--quiet) are used
fix Cygwin --filter utility hanging after fork when worker threads are active, by forcing single-threaded search (a bit crude, but Cygwin fork isn't identical to Unix fork)
support the NO_COLOR environment variable to suppress color output
fix TUI scroll glitch (cursor down to scroll screen content up) in non-split screen (glitch appeared when adding the split screen feature)
TUI line selection mode top row number indicator added, for consistency
TUI quit & output after line selection mode now behaves the same as non-TUI search output, for consistency
faster -q (--quiet) search

# $NetBSD: Makefile,v 1.77 2024/04/05 08:24:30 adam Exp $

DISTNAME=	ugrep-5.1.3
CATEGORIES=	textproc
MASTER_SITES=	${MASTER_SITE_GITHUB:=Genivia/}
GITHUB_TAG=	v${PKGVERSION_NOREV}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://github.com/Genivia/ugrep
COMMENT=	Fast grep with many enhancements including Unicode support
LICENSE=	modified-bsd

.include "options.mk"

USE_LANGUAGES=	c c++
USE_TOOLS+=	bash:run gmake pkg-config
GNU_CONFIGURE=	yes

REPLACE_BASH+=	bin/ug+
REPLACE_BASH+=	bin/ugrep+

.include "../../archivers/bzip2/buildlink3.mk"
.include "../../archivers/lz4/buildlink3.mk"
.include "../../archivers/xz/buildlink3.mk"
.include "../../archivers/zstd/buildlink3.mk"
.include "../../devel/pcre2/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>