[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / textproc / suikyo-elisp

File: [cvs.NetBSD.org] / pkgsrc / textproc / suikyo-elisp / Attic / Makefile (download)

Revision 1.2, Sat Oct 11 09:31:58 2008 UTC (15 years, 6 months ago) by uebayasi
Branch: MAIN
CVS Tags: pkgsrc-2009Q2-base, pkgsrc-2009Q2, pkgsrc-2009Q1-base, pkgsrc-2009Q1, pkgsrc-2008Q4-base, pkgsrc-2008Q4
Changes since 1.1: +1 -1 lines

Move mk/emacs.mk to editors/emacs/modules.mk.

Don't call pkg_info to get the installed Emacs version; always use the
version matching EMACS_TYPE set by users.  Be DEPENDS to it.  This should
address pkg/37146 by Aleksey Cheusov.

While here convert some emacs lisp packages to user-destdir.

# $NetBSD: Makefile,v 1.2 2008/10/11 09:31:58 uebayasi Exp $
#

.include "../../textproc/suikyo/Makefile.common"

PKGNAME=	${EMACS_PKGNAME_PREFIX}${DISTNAME:S/-/-elisp-/}

MAINTAINER=	obache@NetBSD.org
HOMEPAGE=	http://taiyaki.org/suikyo/elisp/index.html
COMMENT=	Suikyo for Emacs Lisp

PKG_DESTDIR_SUPPORT=	user-destdir

DEPENDS+=	suikyo-conv-table>=${SUIKYO_VER}:../../textproc/suikyo-conv-table
DEPENDS+=	suikyo-docs>=${SUIKYO_VER}:../../textproc/suikyo-docs

BUILD_DIRS+=	elisp

CONFIGURE_ARGS+=	--with-emacs-sitelispdir=${EMACS_LISPPREFIX}

.include "../../editors/emacs/modules.mk"
.include "../../mk/bsd.pkg.mk"