[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / textproc / ruby-nqxml

Annotation of pkgsrc/textproc/ruby-nqxml/Makefile, Revision 1.4

1.4     ! taca        1: # $NetBSD: Makefile,v 1.3 2004/11/28 04:36:05 taca Exp $
1.1       taca        2: #
                      3:
                      4: DISTNAME=      nqxml-1.1.3p1
1.3       taca        5: PKGNAME=       ${RUBY_PKGPREFIX}-${DISTNAME:S/p/./}
1.2       taca        6: CATEGORIES=    textproc ruby
                      7: MASTER_SITES=  ${MASTER_SITE_SOURCEFORGE:=nqxml/} \
                      8:                http://rrr.jin.gr.jp/download/
1.1       taca        9:
                     10: MAINTAINER=    neumann@s-direktnet.de
1.2       taca       11: HOMEPAGE=      http://nqxml.sourceforge.net/
1.1       taca       12: COMMENT=       XML parser written in pure Ruby
                     13:
                     14: USE_RUBY=      yes
                     15: NO_BUILD=      yes
                     16:
                     17: DOC=           README
                     18: EXAMPLES=      data.xml doc.xml dumpXML.rb parseTestStream.rb \
                     19:                parseTestTree.rb printEntityClassNames.rb \
                     20:                reverseTags.rb reverseText.rb write.rb \
                     21:                write.rb writeManualDoc.rb writeParsedDoc.rb
                     22: CONTRIB_LIB=   autodis_1.rb autodis_2.rb
                     23: TESTS=         dispatchertester.rb oasis.rb streamingparsertester.rb test.rb \
                     24:                testresource.rb tokenizertester.rb treeparsertester.rb \
                     25:                writertester.rb
1.3       taca       26: REPLACE_RUBY_DIRS=     ${WRKSRC}/examples ${WRKSRC}/tests
1.1       taca       27:
                     28: do-install:
                     29:        cd ${WRKSRC}; ${RUBY} install.rb
                     30:
                     31: post-install:
                     32:        ${INSTALL_DATA_DIR} ${RUBY_DOCDIR}/nqxml
                     33: .for f in ${DOC}
1.4     ! taca       34:        ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/nqxml
1.1       taca       35: .endfor
                     36:        ${INSTALL_DATA_DIR} ${RUBY_EXAMPLESDIR}/nqxml/contrib
                     37: .for f in ${EXAMPLES}
1.4     ! taca       38:        ${INSTALL_DATA} ${WRKSRC}/examples/${f} ${RUBY_EXAMPLESDIR}/nqxml
1.1       taca       39: .endfor
                     40: .for f in ${CONTRIB_LIB}
1.4     ! taca       41:        ${INSTALL_DATA} ${WRKSRC}/contrib/${f} \
        !            42:                ${RUBY_EXAMPLESDIR}/nqxml/contrib
1.1       taca       43: .endfor
                     44:        ${INSTALL_DATA_DIR} ${RUBY_EXAMPLESDIR}/nqxml/tests
                     45: .for f in ${TESTS}
1.4     ! taca       46:        ${INSTALL_DATA} ${WRKSRC}/tests/${f} ${RUBY_EXAMPLESDIR}/nqxml/tests
1.1       taca       47: .endfor
                     48:
1.3       taca       49: .include "../../lang/ruby/modules.mk"
1.1       taca       50: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>