[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / textproc / ruby-nqxml

Annotation of pkgsrc/textproc/ruby-nqxml/Makefile, Revision 1.12

1.12    ! taca        1: # $NetBSD: Makefile,v 1.11 2008/06/19 14:56:48 taca Exp $
1.1       taca        2: #
                      3:
                      4: DISTNAME=      nqxml-1.1.3p1
1.3       taca        5: PKGNAME=       ${RUBY_PKGPREFIX}-${DISTNAME:S/p/./}
1.11      taca        6: PKGREVISION=   2
1.2       taca        7: CATEGORIES=    textproc ruby
1.9       wiz         8: MASTER_SITES=  ${MASTER_SITE_SOURCEFORGE:=nqxml/}
1.1       taca        9:
                     10: MAINTAINER=    neumann@s-direktnet.de
1.8       taca       11: HOMEPAGE=      http://sourceforge.net/projects/nqxml/
1.1       taca       12: COMMENT=       XML parser written in pure Ruby
                     13:
                     14: NO_BUILD=      yes
1.6       taca       15: USE_RUBY_INSTALL= yes
1.1       taca       16:
                     17: DOC=           README
                     18: EXAMPLES=      data.xml doc.xml dumpXML.rb parseTestStream.rb \
                     19:                parseTestTree.rb printEntityClassNames.rb \
                     20:                reverseTags.rb reverseText.rb write.rb \
                     21:                write.rb writeManualDoc.rb writeParsedDoc.rb
                     22: CONTRIB_LIB=   autodis_1.rb autodis_2.rb
                     23: TESTS=         dispatchertester.rb oasis.rb streamingparsertester.rb test.rb \
                     24:                testresource.rb tokenizertester.rb treeparsertester.rb \
                     25:                writertester.rb
1.10      jlam       26: REPLACE_RUBY_DIRS=     examples tests
1.1       taca       27:
1.12    ! taca       28: INSTALL_TARGET=                install \
        !            29:                        --install-dir=${DESTDIR}${PREFIX}/${RUBY_VENDORLIB}
1.11      taca       30: INSTALLATION_DIRS=     ${RUBY_DOC}/nqxml ${RUBY_EG}/nqxml/contrib \
                     31:                        ${RUBY_EG}/nqxml/tests
1.12    ! taca       32: PKG_DESTDIR_SUPPORT=   user-destdir
1.11      taca       33:
1.1       taca       34: post-install:
                     35: .for f in ${DOC}
1.11      taca       36:        ${INSTALL_DATA} ${WRKSRC}/${f} ${DESTDIR}${PREFIX}/${RUBY_DOC}/nqxml
1.1       taca       37: .endfor
                     38: .for f in ${EXAMPLES}
1.11      taca       39:        ${INSTALL_DATA} ${WRKSRC}/examples/${f} \
                     40:                ${DESTDIR}${PREFIX}/${RUBY_EG}/nqxml
1.1       taca       41: .endfor
                     42: .for f in ${CONTRIB_LIB}
1.4       taca       43:        ${INSTALL_DATA} ${WRKSRC}/contrib/${f} \
1.11      taca       44:                ${DESTDIR}${PREFIX}/${RUBY_EG}/nqxml/contrib
1.1       taca       45: .endfor
                     46: .for f in ${TESTS}
1.11      taca       47:        ${INSTALL_DATA} ${WRKSRC}/tests/${f} \
                     48:                ${DESTDIR}${PREFIX}/${RUBY_EG}/nqxml/tests
1.1       taca       49: .endfor
                     50:
1.3       taca       51: .include "../../lang/ruby/modules.mk"
1.1       taca       52: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>