File:  [cvs.NetBSD.org] / pkgsrc / textproc / ruby-json / Attic / Makefile
Revision 1.26: download - view: text, annotated - select for diffs
Thu Mar 13 11:08:53 2014 UTC (11 years ago) by jperkin
Branches: MAIN
CVS tags: HEAD
Set USE_GCC_RUNTIME=yes for packages which build shared libraries but do
not use libtool to do so.  This is required to correctly depend upon a
gcc runtime package (e.g. gcc47-libs) when using USE_PKGSRC_GCC_RUNTIME.

# $NetBSD: Makefile,v 1.26 2014/03/13 11:08:53 jperkin Exp $

DISTNAME=	json-1.8.0
CATEGORIES=	textproc

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://flori.github.com/json
COMMENT=	Native extension implementation of JSON for Ruby
LICENSE=	ruby-license

USE_GCC_RUNTIME=	yes

GEM_CLEANBUILD=	ext/json/ext/generator/* ext/json/ext/parser/*

post-extract:
	cd ${WRKSRC}; ${FIND} . -xdev -type f -print | ${XARGS} ${CHMOD} g-w

.include "../../lang/ruby/gem.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>