The NetBSD Project

CVS log for pkgsrc/textproc/ruby-diff-lcs/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / textproc / ruby-diff-lcs

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.25 / (download) - annotate - [select for diffs], Sat Feb 3 16:38:19 2024 UTC (7 weeks, 5 days ago) by taca
Branch: MAIN
CVS Tags: HEAD
Changes since 1.24: +2 -2 lines
Diff to previous 1.24 (colored)

textproc/ruby-diff-lcs: update to 1.5.1

1.5.1 (2024-01-31)

* Peter Goldstein updated CI configuration to add Ruby 3.1 and Masato
  Nakamura added Ruby 3.2 and 3.3. #82, #89
* Updated the CI configuration, resolving #82 to add Ruby 3.1. Masato
* Switched to standard ruby formatting.
* Justin Steele converted the licence file to Markdown. #84
* Updated the gem SPDX identifier for GPL 2.0 or later, resolving #86 by Vit
  Ondruch.
* Resolve a potential security issue with ldiff in its use of IO.read
  instead of File.read. #91
* Added MFA authentication requirement for release to RubyGems. #90
* Added dependabot management for actions and gems. #90
* Updated CodeQL coniguration. #90

Revision 1.24 / (download) - annotate - [select for diffs], Fri Apr 29 06:41:31 2022 UTC (23 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2
Changes since 1.23: +4 -4 lines
Diff to previous 1.23 (colored)

textproc/ruby-diff-lcs: update to 1.5.0

1.5.0 (2021-12-23)

* Updated the CI configuration and monkey-patch Hoe.

* Kenichi Kamiya fixed a test configuration deprecation in SimpleCov.  #69

* Tien introduced several corrections and code improvements:

	o Removed an off-by-one error when calculating an index value by
	  embracing Ruby iteration properly.  This had a side-effect of
	  fixing a long-standing bug in #traverse_sequences where the
	  traversal would not be transitive.  That is, LCS(s2, s1) should
	  produce a sequence that is transitive with LCS(s1, s2) on
	  traversal, and applying the diff computed from those results would
	  result in equivalent changes that could be played forward or
	  backward as appropriate. #71, #75

	o The above fix resulted in a changed order of the longest common
	  subsequence when callbacks were applied.  After analysis, it was
	  determined that the computed subsequence was equivalent to the
	  prior version, so the test was updated.  This also resulted in the
	  clarification of documentation when traversing the subsequences.
	  #79

	o An infinite loop case in the case where Diff::LCS would be
	  included into an enumerable class has been fixed.  #73

	o Clarified the purpose of a threshold test in calculation of
	  LCS. #72, #80

* Removed autotest directory

Revision 1.23 / (download) - annotate - [select for diffs], Mon Sep 14 14:26:02 2020 UTC (3 years, 6 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3
Changes since 1.22: +2 -2 lines
Diff to previous 1.22 (colored)

textproc/ruby-diff-lcs: update to 1.4.4

Update ruby-diff-lcs to 1.4.4.


## 1.4.4 / 2020-07-01

- Fixed an issue reported by Jun Aruga in the Diff::LCS::Ldiff binary text
  detection. [#44][]
- Fixed a theoretical issue reported by Jun Aruga in Diff::LCS::Hunk to raise
  a more useful exception. [#43][]
- Added documentation that should address custom object issues as reported in
  [#35][].

- Fixed more diff errors, in part reported in [#65][].

  - The use of `Numeric#abs` is incorrect in `Diff::LCS::Block#diff_size`.
    The diff size _must_ be accurate for correct change placement.
  - When selecting @max_diff_size in Diff::LCS::Hunk, choose it based on
    `block.diff_size.abs`.
  - Made a number of changes that will, unfortunately, increase allocations
    at the cost of being safe with frozen strings.
  - Add some knowledge that when `Diff::LCS::Hunk#diff` is called, that we
    are processing the _last_ hunk, so some changes will be made to how the
    output is generated.

    - `old`, `ed`, and `reverse_ed` formats have no differences.
    - `unified` format will report `\ No newline at end of file` given the
      correct conditions, at most once. Unified range reporting also
      differs for the last hunk such that the `length` of the range is
      reduced by one.
    - `context` format will report `\No newline at end of file` given the
      correct conditions, up to once per "file". Context range reporting also
      differs for the last hunk such that the `end` part of the range is
      reduced by one to a minimum of one.

- Added a bunch more tests for the cases above, and fixed `hunk_spec.rb` so
  that the phrase being compared isn't nonsense French.

- Updated formatting.
- Added a Rake task to assist with manual testing on Ruby 1.8.

## 1.4.3 / 2020-06-29

- Fixed several issues with the 1.4 on Rubies older than 2.0. Some of this was
  providing useful shim functions to Hoe 3.x (which dropped these older
  Rubies a while ago). Specifically:

  - Removed Array#lazy from a method in Diff::LCS::Hunk.
  - Changed some unit tests to use old-style Symbol-keyed hashes.
  - Changed some unit test helper functions to no longer use keyword
    parameters, but only a trailing options hash.
  - Made the use of `psych` dependent on `RUBY_VERSION >= 1.9`.

  Resolves [#63][].

## 1.4.2 / 2020-06-23

- Camille Drapier fixed a small issue with RuboCop configuration. [#59][]
- Applied another fix (and unit test) to fix an issue for the Chef team.
  [#60][], [#61][]

## 1.4.1 / 2020-06-23

- Fix an issue where diff sizes could be negative, and they should be. [#57][],
  [#58][]

## 1.4 / 2020-06-23

- Ruby versions lower than 2.4 are soft-deprecated and will not be run as
  part of the CI process any longer.
- Akinora MUSHA (knu) added the ability for Diff::LCS::Change objects to be
  implicitly treated arrays. Originally provided as pull request [#47][],
  but it introduced a number of test failures as documented in [#48][], and
  remediation of Diff::LCS itself was introduced in [#49][].
- Resolved [#5][] with some tests comparing output from `system` calls to
  `bin/ldiff` with some pre-generated output. Resolved [#6][] with these
  tests.
- Resolved a previously undetected `bin/ldiff` issue with `--context` output
  not matching `diff --context` output.
- Resolved an issue with later versions of Ruby not working with an `OptParse`
  specification of `Numeric`; this has been changed to `Integer`.
- Brandon Fish added truffleruby in [#52][].
- Fixed two missing classes as reported in [#53]

Revision 1.22 / (download) - annotate - [select for diffs], Mon Sep 4 18:01:02 2017 UTC (6 years, 6 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3
Changes since 1.21: +2 -2 lines
Diff to previous 1.21 (colored)

Comment out dead sites.

Revision 1.21 / (download) - annotate - [select for diffs], Tue May 30 14:22:40 2017 UTC (6 years, 10 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2
Changes since 1.20: +1 -3 lines
Diff to previous 1.20 (colored)

* Drop setting RUBY_VERSIONS_ACCEPTED since it is now default value.

Revision 1.20 / (download) - annotate - [select for diffs], Sat Apr 22 18:27:05 2017 UTC (6 years, 11 months ago) by taca
Branch: MAIN
Changes since 1.19: +2 -2 lines
Diff to previous 1.19 (colored)

Remove 18 from RUBY_VERSIONS_ACCEPTED.

Revision 1.19 / (download) - annotate - [select for diffs], Mon Mar 20 15:26:04 2017 UTC (7 years ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1
Changes since 1.18: +2 -3 lines
Diff to previous 1.18 (colored)

Update ruby-diff-lcs to 1.3.

## 1.3 / 2017-01-18

*   Bugs fixed:

    *   Fixed an error for bin/ldiff --version. Fixes [issue #21][].
    *   Force Diff::LCS::Change and Diff::LCS::ContextChange to only perform
        equality comparisons against themselves. Provided by Kevin Mook in
        [pull request #29][].
    *   Fix tab expansion in htmldiff, provided by Mark Friedgan in
        [pull request #25][].
    *   Silence Ruby 2.4 Fixnum deprecation warnings. Fixxues [issue #38][] and
        [pull request#36][].
    *   Ensure that test dependencies are loaded properly. Fixes [issue #33][]
        and [pull request #34][].
    *   Fix [issue #1][] with incorrect intuition of patch direction. Tentative
        fix, but the previous failure cases pass now.

*   Tooling changes:

    *   Added SimpleCov and Coveralls support.
    *   Change the homepage (temporarily) to the GitHub repo.
    *   Updated testing and gem infrastructure.
    *   Modernized the specs.

*   Cleaned up documentation.

*   Added a Code of Conduct.

Revision 1.18 / (download) - annotate - [select for diffs], Thu Sep 8 15:19:19 2016 UTC (7 years, 6 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3
Changes since 1.17: +2 -2 lines
Diff to previous 1.17 (colored)

Rename RUBY_VERSION_SUPPORTED into _RUBY_VERSIONS_ACCEPTED to follow the
naming scheme of the other multi-version packages. Add support for the
coorresponding RUBY_VERSIONS_INCOMPATIBLE list.

Revision 1.17 / (download) - annotate - [select for diffs], Mon Mar 14 00:59:06 2016 UTC (8 years ago) by tnn
Branch: MAIN
CVS Tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1
Changes since 1.16: +2 -2 lines
Diff to previous 1.16 (colored)

remove references to ruby200

Revision 1.16 / (download) - annotate - [select for diffs], Wed Dec 30 15:11:40 2015 UTC (8 years, 3 months ago) by taca
Branch: MAIN
Changes since 1.15: +2 -2 lines
Diff to previous 1.15 (colored)

Add support for ruby23.

Revision 1.15 / (download) - annotate - [select for diffs], Sat Dec 12 04:12:18 2015 UTC (8 years, 3 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2015Q4-base, pkgsrc-2015Q4
Changes since 1.14: +2 -2 lines
Diff to previous 1.14 (colored)

Fix ALTERNATIVES.

Bump PKGREVISION.

Revision 1.14 / (download) - annotate - [select for diffs], Mon Nov 23 15:46:59 2015 UTC (8 years, 4 months ago) by taca
Branch: MAIN
Changes since 1.13: +2 -2 lines
Diff to previous 1.13 (colored)

Remove 193 from RUBY_VERSION_SUPPORTED.

Revision 1.13 / (download) - annotate - [select for diffs], Sat Sep 26 23:41:10 2015 UTC (8 years, 6 months ago) by taca
Branch: MAIN
Changes since 1.12: +2 -2 lines
Diff to previous 1.12 (colored)

Update HOMEPAGE.

Revision 1.12 / (download) - annotate - [select for diffs], Sun May 17 16:29:58 2015 UTC (8 years, 10 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2
Changes since 1.11: +3 -1 lines
Diff to previous 1.11 (colored)

textproc/xhtmldiff needs ruby18-diff-lcs package.

Revision 1.11 / (download) - annotate - [select for diffs], Sun May 17 10:15:59 2015 UTC (8 years, 10 months ago) by taca
Branch: MAIN
Changes since 1.10: +1 -3 lines
Diff to previous 1.10 (colored)

Back out previous commit.  No need to explicitly set.

Revision 1.10 / (download) - annotate - [select for diffs], Sun May 17 10:14:38 2015 UTC (8 years, 10 months ago) by taca
Branch: MAIN
Changes since 1.9: +3 -1 lines
Diff to previous 1.9 (colored)

Correct supported Ruby's version.

Revision 1.9 / (download) - annotate - [select for diffs], Sun May 17 09:47:05 2015 UTC (8 years, 10 months ago) by taca
Branch: MAIN
Changes since 1.8: +3 -2 lines
Diff to previous 1.8 (colored)

* Add pkg_alternatives support.
* Allow ruby22.

Bump PKGREVISION.

Revision 1.8 / (download) - annotate - [select for diffs], Sun Mar 8 14:10:22 2015 UTC (9 years ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2015Q1-base, pkgsrc-2015Q1
Changes since 1.7: +3 -1 lines
Diff to previous 1.7 (colored)

Explicitly allow build with Ruby 1.8.7.

Revision 1.7 / (download) - annotate - [select for diffs], Fri Mar 14 18:08:39 2014 UTC (10 years ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1
Changes since 1.6: +2 -2 lines
Diff to previous 1.6 (colored)

Update ruby-diff-lcs to 1.2.5.

== 1.2.5 / 2013-11-08

* Bugs fixed:
  * Comparing arrays flattened them too far, especially with Diff::LCS.sdiff.
    https://github.com/halostatue/diff-lcs/pull/23

Revision 1.6 / (download) - annotate - [select for diffs], Sun Jun 16 17:21:49 2013 UTC (10 years, 9 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2
Changes since 1.5: +2 -2 lines
Diff to previous 1.5 (colored)

Update ruby-diff-lcs to 1.2.4.

=== 1.2.4 / 2013-04-20

* Bugs fixed:
  * A bug was introduced after 1.1.3 when pruning common sequences at the start
    of comparison. Paul Kunysch (@pck) fixed this in pull request 18. Thanks!
    https://github.com/halostatue/diff-lcs/pull/18
* The Rubinius (1.9 mode) bug in rubinius/rubinius#2268 has been fixed by the
  Rubinius team two days after it was filed. Thanks for fixing this so quickly!
  https://github.com/rubinius/rubinius/issues/2268
* Switching to Raggi's hoe-gemspec2 for gemspec generation.

== 1.2.3 / 2013-04-11

* Bugs Fixed:
  * The new encoding detection for diff output generation (added in 1.2.2)
    introduced a bug if the left side of the comparison was the empty set.
    Originally found in rspec/rspec-expectations#238 and
    rspec/rspec-expectations#239. Jon Rowe developed a reasonable heuristic
    (left side, right side, empty string literal) to avoid this bug.
    https://github.com/rspec/rspec-expectations/pull/238
    https://github.com/rspec/rspec-expectations/pull/239
* There is a known issue with Rubinius in 1.9 mode reported in
  rubinius/rubinius#2268 and demonstrated in the Travis CI builds. For all
  other tested platforms, diff-lcs is considered stable. As soon as a suitably
  small test-case can be created for the Rubinius team to examine, this will be
  added to the Rubinius issue around this.
  https://github.com/rubinius/rubinius/issues/2268
  https://travis-ci.org/halostatue/diff-lcs/jobs/6241195

== 1.2.2 / 2013-03-30

* Bugs Fixed:
  * Diff::LCS::Hunk could not properly generate a difference for comparison
    sets that are not US-ASCII-compatible because of the use of literal regular
    expressions and strings. Jon Rowe (JonRowe) found this in
    rspec/rspec-expectations#219 and provided a first pass implementation in
    diff-lcs#15. I've reworked it because of test failures in Rubinius when
    running in Ruby 1.9 mode. This coerces the added values to the encoding of
    the old dataset (as determined by the first piece of the old dataset).
    https://github.com/rspec/rspec-expectations/issues/219
    https://github.com/halostatue/diff-lcs/pull/15
* Adding Travis CI testing for Ruby 2.0.

Revision 1.5 / (download) - annotate - [select for diffs], Mon Feb 11 02:41:42 2013 UTC (11 years, 1 month ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2013Q1-base, pkgsrc-2013Q1
Changes since 1.4: +2 -2 lines
Diff to previous 1.4 (colored)

Update ruby-diff-lcs to 1.2.1.

== 1.2.1 / 2013-02-09

* Bugs Fixed:
  * As seen in https://github.com/rspec/rspec-expectations/pull/200, the
    release of Diff::LCS 1.2 introduced an unnecessary public API change to
    Diff::LCS::Hunk (see the change at
    https://github.com/rspec/rspec-expectations/commit/3d6fc82c for details).
    The new method name (and behaviour) is more correct, but I should not have
    renamed the function or should have at least provided an alias. This
    release restores Diff::LCS::Hunk#unshift as an alias to
    #merge. Note that the old #unshift behaviour was incorrect and will not be
    restored.

== 1.2.0 / 2013-01-21
* Minor Enhancements:
  * Added special case handling for Diff::LCS.patch so that it handles patches
    that are empty or contain no changes.
  * Added two new methods (#patch\_me and #unpatch\_me) to the includable
    module.
* Bugs Fixed:
  * Fixed issue #1 patch direction detection.
    https://github.com/halostatue/diff-lcs/issues/1
  * Resolved issue #2 by handling string[string.size, 1] properly (it returns
    "" not nil). https://github.com/halostatue/diff-lcs/issues/2
  * Michael Granger (ged) fixed an implementation error in Diff::LCS::Change
    and added specs in pull request #8. Thanks!
    https://github.com/halostatue/diff-lcs/issues/8
  * Made the code auto-testable.
  * Vít Ondruch (voxik) provided the latest version of the GPL2 license file in
    pull request #10. Thanks! https://github.com/halostatue/diff-lcs/issues/10
  * Fixed a documentation issue with the includable versions of #patch! and
    #unpatch! where they implied that they would replace the original value.
    Given that Diff::LCS.patch always returns a copy, the documentation was
    incorrect and has been corrected. To provide the behaviour that was
    originally documented, two new methods were added to provide this
    behaviour. Found by scooter-dangle in issue #12. Thanks!
    https://github.com/halostatue/diff-lcs/issues/12
* Code Style Changes:
  * Removed trailing spaces.
  * Calling class methods using '.' instead of '::'.
  * Vít Ondruch (voxik) removed unnecessary shebangs in pull request #9.
    Thanks! https://github.com/halostatue/diff-lcs/issues/9
  * Kenichi Kamiya (kachick) removed some warnings of an unused variable in
    lucky pull request #13. https://github.com/halostatue/diff-lcs/issues/13
    Thanks!
  * Embarked on a major refactoring to make the files a little more manageable
    and understand the code on a deeper level.
  * Adding to http://travis-ci.org.

Revision 1.4 / (download) - annotate - [select for diffs], Mon Sep 12 13:38:16 2011 UTC (12 years, 6 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2012Q4-base, pkgsrc-2012Q4, pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3
Changes since 1.3: +2 -2 lines
Diff to previous 1.3 (colored)

Update ruby-diff-lcs package to 1.1.3.


== 1.1.3 / 2011-08-27
* Converted to 'hoe' for release.
* Converted tests to RSpec 2.
* Extracted the body of htmldiff into a class available from
  diff/lcs/htmldiff.
* Migrated development and issue tracking to GitHub.
* Bugs fixed:
  - Eliminated the explicit use of RubyGems in both bin/htmldiff and bin/ldiff.
    Resolves issue 4 (https://github.com/halostatue/diff-lcs/issues/4).
  - Eliminated Ruby warnings. Resolves issue 3
    (https://github.com/halostatue/diff-lcs/issues/3).

Revision 1.3 / (download) - annotate - [select for diffs], Fri Sep 10 08:07:00 2010 UTC (13 years, 6 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3
Changes since 1.2: +3 -5 lines
Diff to previous 1.2 (colored)

* Use lang/ruby/gem.mk instead of misc/rubygems/rubygem.mk.
* Add LICENSE.
* Remove default value of GEM_BUILD.

Revision 1.2 / (download) - annotate - [select for diffs], Sun Jun 22 16:10:51 2008 UTC (15 years, 9 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2010Q2-base, pkgsrc-2010Q2, pkgsrc-2010Q1-base, pkgsrc-2010Q1, pkgsrc-2009Q4-base, pkgsrc-2009Q4, pkgsrc-2009Q3-base, pkgsrc-2009Q3, pkgsrc-2009Q2-base, pkgsrc-2009Q2, pkgsrc-2009Q1-base, pkgsrc-2009Q1, pkgsrc-2008Q4-base, pkgsrc-2008Q4, pkgsrc-2008Q3-base, pkgsrc-2008Q3, pkgsrc-2008Q2-base, pkgsrc-2008Q2, cwrapper, cube-native-xorg-base, cube-native-xorg
Changes since 1.1: +2 -1 lines
Diff to previous 1.1 (colored)

Add HOMEPAGE.

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Fri Apr 4 15:21:20 2008 UTC (15 years, 11 months ago) by jlam
Branch: TNF
CVS Tags: pkgsrc-base
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

Initial import of ruby18-diff-lcs-1.1.2 as textproc/ruby-diff-lcs.

Diff::LCS is a port of Perl's Algorithm::Diff that uses the McIlroy-Hunt
longest common subsequence (LCS) algorithm to compute intelligent
differences between two sequenced enumerable containers.

Revision 1.1 / (download) - annotate - [select for diffs], Fri Apr 4 15:21:20 2008 UTC (15 years, 11 months ago) by jlam
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>