[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / textproc / ruby-classifier-reborn

File: [cvs.NetBSD.org] / pkgsrc / textproc / ruby-classifier-reborn / Makefile (download)

Revision 1.4, Wed Mar 14 15:40:07 2018 UTC (6 years, 1 month ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1
Changes since 1.3: +2 -2 lines

textproc/ruby-classifier-reborn: update to 2.2.0

2.2.0 / 2017-12-14

* JRuby Support, thanks to @mach-kernel (#168)
* Add support to reset trained classifiers to their initial state (#143)
* Classifier evaluation and validation (#142)
* Abbility to add custom stopwords at classifier initialization (#129)
* Don't train/untrain the Bayesian classifier with empty word hashes (#132)
* Enable auto categorization if no initial categories (#128)
* Bayes integration test of Memory and Redis backends with real data (#92)
* Memory and Redis backend support (#84)

Minor Enhancements

* improved turkish stopwords (#159)
* Set Redis keys only if they don't exist (#156)
* Require bayes_redis_backend (#157)
* Validation documentation improvements (#150)
* Updated Dokcer image to Ruby 2.4 (#149)
* Classifier validation user documenation (#145)
* Fixed persistance for BayesMemoryBackend (#147)
* Fixed error on requiring 'classifier-reborn' without using Redis (#146)
* Removed magic train untrain methods from docs, (#141)
* Links corrected to point to the new domain (#139)
* Minor docs improvements (#138)
* Return the status of the training/untraining when run (#137)
* Refactoring of backend tests to move duplicate login in the common file (#134)
* Deal with Infinity score in test (#133)
* README file cleaned up to point to the documentation site (#121)
* Added and corrected RDoc for ceratin classes and methods (#122)
* Added favicon link and forced display (#120)
* Updated the truncated LICENSE file (#116)
* Docs visual improvement and refactoring (#119)
* Fixed relative URL issue on nav links and added benchmark data (#118)
* Added custom layout with navigation (#117)
* Created a static site for documentation (#115)
* Removed redis gem from Dockerfile as it is added in gemspec (#113)
* Speed up Docker image rebilding (#112)
* Improved Docker based development documentation (#106)
* Benchmark refactoring, improving efficiency, enhanced reporting (#107)
* Add Vietnamese stopwords (#110)
* Added stop words for Arabic, Bengali, Chinese, Hindi, and Russian (#105)
* Dockerfile and documentation (#104)
* Remove hard dep on Redis and update bin (#96)
* Documented Redis backend performance (#103)
* Rename Bayes memory test class (#102)
* Added Bayes backend benchmarks (#98)
* Disabled Redis disc persistence and refactored integration test (#97)
* Removed useless intermediate variables (#90)

# $NetBSD: Makefile,v 1.4 2018/03/14 15:40:07 taca Exp $

DISTNAME=	classifier-reborn-2.2.0
PKGNAME=	${RUBY_PKGPREFIX}-${DISTNAME}
CATEGORIES=	textproc

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://github.com/jekyll/classifier-reborn/
COMMENT=	General classifier module for Bayesian and other classificaions
LICENSE=	gnu-lgpl-v2.1

DEPENDS=	${RUBY_PKGPREFIX}-fast-stemmer>=1.0<2:../../textproc/ruby-fast-stemmer

RUBYGEM_OPTIONS+=	--format-executable

.include "../../lang/ruby/gem.mk"
.include "../../mk/bsd.pkg.mk"