[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / textproc / raptor

File: [cvs.NetBSD.org] / pkgsrc / textproc / raptor / Attic / Makefile (download)

Revision 1.1.1.1 (vendor branch), Sat Aug 30 16:18:58 2003 UTC (20 years, 7 months ago) by xtraeme
Branch: TNF
CVS Tags: pkgsrc-base
Changes since 1.1: +0 -0 lines

Initial import of raptor 0.9.12

A Parser for the RDF/XML syntax as updated by the W3C RDF Core working group.

 * Designed to integrate well with Redland
 * Handles RDF/XML syntax updates for XML Base, xml:lang and RDF datatyping.
 * Generates N-Triples supporting XML literals, language tagging and datatypes
 * Parses content on the web if libcurl or libxml2 is available.
 * Handles rdf:resource / resource attributes
 * Uses expat and/or (GNOME) libxml XML parsers as available or required
 * Optional features can be selected at run time.
 * (Perl, Python, Java, Tcl, Ruby, PHP interfaces when used via Redland)
 * No memory leaks
 * Fast

Ok'ed by wiz@

# $NetBSD: Makefile,v 1.1.1.1 2003/08/30 16:18:58 xtraeme Exp $
#

DISTNAME=	raptor-0.9.12
CATEGORIES=	textproc
MASTER_SITES=	http://www.redland.opensource.ac.uk/dist/source/

MAINTAINER=	xtraeme@NetBSD.org
HOMEPAGE=	http://www.redland.opensource.ac.uk/raptor/
COMMENT=	RDF Parser Toolkit written in C

USE_BUILDLINK2=		yes
USE_LIBTOOL=		yes
GNU_CONFIGURE=		yes

LIBTOOL_OVERRIDE=       ${WRKSRC}/libtool
PKGCONFIG_OVERRIDE+=    ${WRKSRC}/raptor.pc.in

.include "../../textproc/libxml2/buildlink2.mk"
.include "../../devel/glib2/buildlink2.mk"
.include "../../www/curl/buildlink2.mk"

.include "../../mk/bsd.pkg.mk"