File:  [cvs.NetBSD.org] / pkgsrc / textproc / queequeg / Makefile
Revision 1.6: download - view: text, annotated - select for diffs
Wed Nov 25 12:53:42 2015 UTC (8 years, 11 months ago) by jperkin
Branches: MAIN
CVS tags: HEAD
Remove mk/find-prefix.mk usage from the textproc category.

The find-prefix infrastructure was required in a pkgviews world where
packages installed from pkgsrc could have different installation
prefixes, and this was a way for a dependency prefix to be determined.

Now that pkgviews has been removed there is no longer any need for the
overhead of this infrastructure.  Instead we use BUILDLINK_PREFIX.pkg
for dependencies pulled in via buildlink, or LOCALBASE/PREFIX where the
dependency is coming from pkgsrc.

Provides a reasonable performance win due to the reduction of `pkg_info
-qp` calls, some of which were redundant anyway as they were duplicating
the same information provided by BUILDLINK_PREFIX.pkg.

# $NetBSD: Makefile,v 1.6 2015/11/25 12:53:42 jperkin Exp $

DISTNAME=	queequeg-0.91
PKGREVISION=	1
CATEGORIES=	textproc
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=queequeg/}

MAINTAINER=	ryoon@NetBSD.org
HOMEPAGE=	http://queequeg.sourceforge.net/index-e.html
COMMENT=	Tiny English grammar checker for non-native speakers
LICENSE=	gnu-gpl-v2

DEPENDS+=	${PYPKGPREFIX}-cdb-[0-9]*:../../databases/py-cdb
BUILD_DEPENDS+=	WordNet-[0-9]*:../../textproc/WordNet

USE_LANGUAGES=	# none
PY_PATCHPLIST=	yes
PYTHON_VERSIONS_INCOMPATIBLE=	33 34 # py-cdb

SUBST_CLASSES+=			fix-python
SUBST_STAGE.fix-python=		pre-configure
SUBST_MESSAGE.fix-python=	Fixing python interpreter
SUBST_FILES.fix-python+=	*.py
SUBST_FILES.fix-python+=	qq
SUBST_FILES.fix-python+=	Makefile
SUBST_SED.fix-python+=		-e 's,/usr/bin/env python,${PYTHONBIN},'
SUBST_SED.fix-python+=		-e 's,python ,${PYTHONBIN} ,'

BUILD_TARGET=		dict
BUILD_MAKE_FLAGS=	WORDNETDICT=${LOCALBASE}/dict

INSTALLATION_DIRS=	bin ${PYSITELIB} dict

do-install:
	${INSTALL_SCRIPT} ${WRKSRC}/qq ${DESTDIR}${PREFIX}/bin
	${INSTALL_SCRIPT} ${WRKSRC}/pstring.py \
		${WRKSRC}/dictionary.py \
		${WRKSRC}/abstfilter.py \
		${WRKSRC}/document.py \
		${WRKSRC}/sentence.py \
		${WRKSRC}/postagfix.py \
		${WRKSRC}/output.py \
		${WRKSRC}/constraint.py \
		${WRKSRC}/texparser.py \
		${WRKSRC}/sgmllib_rev.py \
		${WRKSRC}/markupbase_rev.py \
		${WRKSRC}/regpat.py \
		${WRKSRC}/grammarerror.py \
		${WRKSRC}/unification.py \
		${DESTDIR}${PREFIX}/${PYSITELIB}
	${INSTALL_DATA} ${WRKSRC}/dict.cdb ${DESTDIR}${PREFIX}/dict

.include "../../lang/python/extension.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>