Up to [cvs.NetBSD.org] / pkgsrc / textproc / py-openapi-spec-validator
Request diff between arbitrary revisions
Keyword substitution: kv
Default branch: MAIN
i*: clean up after python38 removal
py-openapi-spec-validator: updated to 0.7.1 0.7.1 Features Versions submodule Move to jsonschema-path package Validator accepts any schema (schema dictionary or SchemaPath) validate and validate_url shortcuts Deprecations validate_spec shortcut in deprecated. Usevalidate instead. validate_spec_url shortcut is deprecated. Use validate_url instead. 0.7.0 Features Allow validate multiple files (also with pre-commit hook) Validators and keywords refactor Python 3.12 support Bump docker image python from 3.11.5-alpine to 3.12.0-alpine Deprecations openapi_*_spec_validator objects are deprecated. Use *SpecValidator classes instead.
python/wheel.mk: simplify a lot, and switch to 'installer' for installation This follows the recommended bootstrap method (flit_core, build, installer). However, installer installs different files than pip, so update PLISTs for all packages using wheel.mk and bump their PKGREVISIONs.
py-openapi-spec-validator: updated to 0.6.0 0.6.0 Upgrades Compatibility with jsonschema 4.18, jsonschema-spec 0.2 and openapi-schema-validator 0.6 Update dependencies Deprecations spec_url parameter of spec validator is deprecated. Use base_uri instead. Backward incompatibilities Drop python 3.7 support
py-openapi-spec-validator: fix PKGNAME
py-openapi-spec-validator: updated to 0.5.6 0.5.6 Fix typo in server variables schema for OpenAPI 3.1.0 Include tests in sdist archives jsonschema 4.17 dependency limit add python 3.11 support 0.5.5 update openapi-schema-validator dependecy 0.5.4 schema properties validation recursion fix 0.5.3 fix custom format checker not found test fix property missing reference validation 0.5.2 Use stdlib importlib.resources on python >= 3.9 mypy typing module version fix Drop no longer used runtime dependency on PyYAML allow openapi-schema-validator 0.4
py-openapi-spec-validator: updated to 0.5.1 0.5.1 Responses schema validation 0.5.0 detect spec schema version static types and Mypy static type check tests mark network schemas and validators lazy loading proxy CLI detect spec version Shortcuts refactor and validators explicit usage Backward incompatibilities redundant shortcuts validate_v*_spec and validate_v*_spec_url removed. Use validate_spec and validate_spec_url with validator parameter instead. default_handlers (and whole handlers package) removed. Use handlers from jsonschema_spec.handlers instead.
py-openapi-spec-validator: updated to 0.4.0 0.4.0 Drop Python 2.7, 3.5 and 3.6 support Add Python 3.10 support Bump dependency upper bounds Drop pyrsistent direct dependency
python: egg.mk: add USE_PKG_RESOURCES flag This flag should be set for packages that import pkg_resources and thus need setuptools after the build step. Set this flag for packages that need it and bump PKGREVISION.
*: bump PKGREVISION for egg.mk users They now have a tool dependency on py-setuptools instead of a DEPENDS
textproc/py-openapi-spec-validator: import py-openapi-spec-validator-0.3.1 OpenAPI Spec Validator is a Python library that validates OpenAPI Specs against the OpenAPI 2.0 (aka Swagger) and OpenAPI 3.0 specification. The validator aims to check for full compliance with the Specification.