The NetBSD Project

CVS log for pkgsrc/textproc/py-openapi-core/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / textproc / py-openapi-core

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.20: download - view: text, markup, annotated - select for diffs
Mon Apr 21 05:48:41 2025 UTC (29 hours, 1 minute ago) by adam
Branches: MAIN
CVS tags: HEAD
Diff to: previous 1.19: preferred, colored
Changes since revision 1.19: +3 -3 lines
py-openapi-core: updated to 0.19.5

0.19.5

Features

Add django decorator

Updates

Allow Starlette 0.41.x and FastAPI 0.115.x; bump to 0.41.2 and 0.115.4, respectively

Revision 1.19: download - view: text, markup, annotated - select for diffs
Fri Mar 7 16:02:51 2025 UTC (6 weeks, 3 days ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2025Q1-base, pkgsrc-2025Q1
Diff to: previous 1.18: preferred, colored
Changes since revision 1.18: +2 -2 lines
depend on www/py-django instead of py-django3

Revision 1.18: download - view: text, markup, annotated - select for diffs
Tue Dec 10 07:55:28 2024 UTC (4 months, 1 week ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base, pkgsrc-2024Q4
Diff to: previous 1.17: preferred, colored
Changes since revision 1.17: +8 -5 lines
py-openapi-core: allow Python 3.13

Now that py-falcon supports it.

Update test dependencies and test status.

Revision 1.17: download - view: text, markup, annotated - select for diffs
Tue Nov 26 12:42:22 2024 UTC (4 months, 3 weeks ago) by nia
Branches: MAIN
Diff to: previous 1.16: preferred, colored
Changes since revision 1.16: +4 -1 lines
py-falcon: Broken with Python 3.13, uses deprecated cgi module

Revision 1.16: download - view: text, markup, annotated - select for diffs
Mon Oct 14 06:46:00 2024 UTC (6 months, 1 week ago) by wiz
Branches: MAIN
Diff to: previous 1.15: preferred, colored
Changes since revision 1.15: +1 -3 lines
*: clean-up after python38 removal

Revision 1.15: download - view: text, markup, annotated - select for diffs
Sat Sep 7 05:37:53 2024 UTC (7 months, 2 weeks ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +2 -2 lines
py-openapi-core: updated to 0.19.4

0.19.4

Features

Starlette 0.38.x support

Bug fixes

Fix resolvers not updating properly when referencing other files.
Fix RequestUnmarshalResult body type
Fix Starlette streaming response for HTTPMiddleware

Revision 1.14: download - view: text, markup, annotated - select for diffs
Tue Aug 20 11:13:16 2024 UTC (8 months ago) by adam
Branches: MAIN
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +3 -3 lines
py-openapi-core: updated to 0.19.3

0.19.3

Bug fixes

Fix resolver for jsonschema validator created by SchemaValidatorsFactory
Use base_uri from schema path for spec validation
Openapi 3.0 unmarshalling None with nullable subschema fix

Deprecations

spec_base_uri configuration is deprecated. Use base_uri parameter in OpenAPI.from_dict and OpenAPI.from_file if you want to define it.

Revision 1.13: download - view: text, markup, annotated - select for diffs
Thu Jun 13 05:17:06 2024 UTC (10 months, 1 week ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q2-base, pkgsrc-2024Q2
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +2 -2 lines
py-openapi-core: updated to 0.19.2

0.19.2

Falcon multi-value query parameters fix
Fix a DeprecationWarning from aiohttp in TestPetPhotoView
Fix hyphen characters in path parameters

Revision 1.12: download - view: text, markup, annotated - select for diffs
Thu Apr 11 07:58:04 2024 UTC (12 months, 1 week ago) by adam
Branches: MAIN
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +2 -2 lines
py-openapi-core: updated to 0.19.1

0.19.1

Features

Path finder cls configuration

Bug fixes

Invalid usage of super() when having multi-baseclass inheritance
Fix content-type when no space after semicolon
Protocols body and data attributes docstrings fix

Revision 1.11: download - view: text, markup, annotated - select for diffs
Wed Feb 21 19:53:03 2024 UTC (13 months, 4 weeks ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +3 -3 lines
py-openapi-core: updated to 0.19.0

0.19.0
This version focuses on OpenAPI app and support for binary requests and responses.

Features

FastAPI integration
Mimetype parameters (i.e. charset) handling
Parameter deserializers renamed to Style deserializers
Unmarshalling processor enhancement
Option to skip response validation in Django, Falcon and Flask integrations
use explicit arguments (instead of kwargs) in Spec.from_dict and add short note in documentation how to use base_url for Spec.from_dict
Parameter and header get value refactor
Python 3.12 support
Bump openapi-spec-validator from 0.6.0 to 0.7.0
Use openapi-spec-validator spec version finder
Move to SchemaPath from jsonschema-path package
Specification validation as part of shortcuts
Style deserializing reimplementation with support for all styles
Media type encoding support
Replace mimetype with content_type to include content parameters
Suport for primitive properties casting of urlencoded objects.
Request response binary format support
Starlette middleware
OpenAPI app and high level integration

Bug fixes

aiohttp request host_url include scheme
aiohttp response body check none
Validate empty request body fix
Path finder returns default server
OpenAPI config passed to validators and unmarshallers fix
milti types schema format unmarshal fix

Deprecations

Spec class is deprecated. Use SchemaPath from jsonschema-path package.

Breaking changes

request_class/response_class renamed to request_cls/response_cls in unmarshalling processors (Django, Falcon and Flask integrations)
ParameterDeserializersFactory renamed to StyleDeserializersFactory
unmarshalling byte and binary formats return bytes
Specification validation is no longer part of Spec object creation and moved to be part of OpenAPI object creation.
Request and Response protocols' mimetype attribute replaced with content_type
Request protocol's body attribute returns bytes instead of str
Response protocol's data attribute returns bytes instead of str
Unmarshalling no longer raises FormatUnmarshalError

Revision 1.10: download - view: text, markup, annotated - select for diffs
Thu Nov 9 18:59:14 2023 UTC (17 months, 1 week ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +3 -8 lines
py-openapi-core: updated to 0.18.2

0.18.2

Bug fixes

Deprecated spec validator fix + warnings resolved

Revision 1.9: download - view: text, markup, annotated - select for diffs
Tue Nov 7 22:38:05 2023 UTC (17 months, 2 weeks ago) by wiz
Branches: MAIN
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +2 -2 lines
*: latest py-sphinx only support Python 3.9+

Revision 1.8: download - view: text, markup, annotated - select for diffs
Sat Oct 28 19:57:18 2023 UTC (17 months, 3 weeks ago) by wiz
Branches: MAIN
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +2 -1 lines
python/wheel.mk: simplify a lot, and switch to 'installer' for installation

This follows the recommended bootstrap method (flit_core, build, installer).

However, installer installs different files than pip, so update PLISTs
for all packages using wheel.mk and bump their PKGREVISIONs.

Revision 1.7: download - view: text, markup, annotated - select for diffs
Sun Sep 17 09:03:14 2023 UTC (19 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +2 -2 lines
py-openapi-core: updated to 0.18.1

0.18.1

Bug fixes

Ignore formats for other types in unmarshalling process

Features

More media types supported
Unmarshalling customizations in middlewares (FalconOpenAPIMiddleware, FlaskOpenAPIView, FlaskOpenAPIViewDecorator)

Documentation

Changed doc indentation from 3 to 4

Revision 1.6: download - view: text, markup, annotated - select for diffs
Sun Aug 27 13:33:23 2023 UTC (19 months, 3 weeks ago) by adam
Branches: MAIN
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +8 -8 lines
py-openapi-core: updated to 0.18.0

0.18.0

Upgrades

Compatibility with jsonschema 4.18, jsonschema-spec 0.2, openapi-schema-validator 0.6 and openapi-spec-validator 0.6
Update dependencies

Deprecations

spec_url parameter of Spec.from_dict is deprecated. Use base_uri instead.
ref_resolver_handlers parameter of Spec.from_dict is deprecated. Use handlers instead.

Backward incompatibilities

Drop python 3.7 support
Format validators ignore other types and pass (in accordance with the specification)
Remove deprecated features
Spec.create method
spec as a first parameter for validate_request and validate_response shortcuts
validator parameter for validate_request and validate_response shortcuts
return unmarshalling data result for validate_request and validate_response shortcuts
RequestValidator, ResponseValidator and openapi_ objects
custom_deserializersparameter
custom_formattersparameter

Revision 1.5: download - view: text, markup, annotated - select for diffs
Mon May 15 20:33:32 2023 UTC (23 months, 1 week ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +12 -10 lines
py-openapi-core: updated to 0.17.1

0.17.1

Include tests in sdist archives
add python 3.11 support

0.17.0

shortcuts high level public api expose
ParametersError context property deprecated
Spec.create deprecated
Validators refactor
Webhooks support
Rename UnmarshalContext to ValidationContext
Fix PATH_PARAMETER_PATTERN for DRF default value pattern.
Fix falcon response data none
Shortcuts backward compatible
RequestValidator and ResponseValidator backward compatibility
Fix flask decorator function return other types
Fix integration Request Response factories check types fix
Fix Requests request dont allow fragments
Fix openapi packages update and tests
unmarshallers integration tests
Unmarshallers and validators refactor
Shortcuts refactor
Media type deserializers refactor

Backward incompatibilities

Schema unmarshalling/validation returns Invalid* exception (InvalidData, InvalidParameter, InvalidRequestBody, InvalidHeader). Use __cause__ property to get root cause exception.
InvalidSecurity exception renamed to SecurityNotFound

Revision 1.4: download - view: text, markup, annotated - select for diffs
Fri Oct 28 09:43:22 2022 UTC (2 years, 5 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +8 -11 lines
py-openapi-core: updated to 0.16.1

0.16.1
lists as additional properties fix
x-model extension optional

0.16.0
Switch to jsonschema-spec
Use auto-detect validator proxy
OpenAPI 3.1 support + Auto-detect proxies and request / response validator protocols
Add py.typed to mark package as supporting typing
Refuse to cast str or bytes to array
x-model extension import model class
Add deepObject support
Add anyOf support
Separate werkzeug support
Starlette support

0.15.0
Parameter deserialize complex scenario support
Response headers support
Response headers support for contrib
Drop python 2.7 support
Drop python 3.5 support
Drop python 3.6 support
Add python 3.10 support
Falcon2 support drop
Django2 support drop
Support basic re_path for Django integration
unused NoValue type removed
attrs remove and use dataclasses backport for python 3.6
Request validation parameters dataclass
Handle missing MIME type in MediaTypeFinder
Limit openapi dependencies upper bounds
switch to pathable
Get rid of create_spec shortcut
Request and Response protocols
validator factories removed from validation shortcuts
Predefined openapi validators
Customization refactor
Static types with mypy

Revision 1.3: download - view: text, markup, annotated - select for diffs
Tue Jan 4 20:55:00 2022 UTC (3 years, 3 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +2 -1 lines
*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

Revision 1.2: download - view: text, markup, annotated - select for diffs
Tue Nov 23 23:51:43 2021 UTC (3 years, 4 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +3 -1 lines
py-openapi-core: mark as not for python 2.7

Revision 1.1: download - view: text, markup, annotated - select for diffs
Tue Nov 23 12:45:01 2021 UTC (3 years, 4 months ago) by wiz
Branches: MAIN
textproc/py-openapi-core: import py-openapi-core-0.14.2

Openapi-core is a Python library that adds client-side and server-side
support for the OpenAPI Specification v3.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>