File:  [cvs.NetBSD.org] / pkgsrc / textproc / py-markups / Makefile
Revision 1.17: download - view: text, annotated - select for diffs
Mon Nov 11 07:29:05 2024 UTC (5 months, 1 week ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base, pkgsrc-2024Q4, HEAD
py-*: remove unused tool dependency

py-setuptools includes the py-wheel functionality nowadays

# $NetBSD: Makefile,v 1.17 2024/11/11 07:29:05 wiz Exp $

DISTNAME=	Markups-4.0.0
PKGNAME=	${PYPKGPREFIX}-${DISTNAME:tl}
PKGREVISION=	1
CATEGORIES=	textproc python
MASTER_SITES=	${MASTER_SITE_PYPI:=M/Markups/}

MAINTAINER=	gutteridge@NetBSD.org
HOMEPAGE=	https://github.com/retext-project/pymarkups
COMMENT=	Python text markup language wrapper module
LICENSE=	modified-bsd

TOOL_DEPENDS+=	${PYPKGPREFIX}-setuptools>=61.2:../../devel/py-setuptools
DEPENDS+=	${PYPKGPREFIX}-markdown-math-[0-9]*:../../textproc/py-markdown-math
# optional
DEPENDS+=	${PYPKGPREFIX}-docutils-[0-9]*:../../textproc/py-docutils
DEPENDS+=	${PYPKGPREFIX}-pygments-[0-9]*:../../textproc/py-pygments
DEPENDS+=	${PYPKGPREFIX}-textile-[0-9]*:../../textproc/py-textile
# As of 4.0.0, there is also asciidoc support, requiring textproc/asciidoc
# and textproc/py-lxml. This hasn't been enabled, in part because asciidoc
# (as packaged) doesn't seem intended to handle multiple Python versions.
# textproc/py-yaml is also an optional dependency for configurations using
# YAML.

USE_LANGUAGES=	# none

.include "../../lang/python/wheel.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>