[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / textproc / py-lxml

File: [cvs.NetBSD.org] / pkgsrc / textproc / py-lxml / Makefile (download)

Revision 1.36, Mon Aug 1 10:51:30 2016 UTC (7 years, 7 months ago) by wiz
Branch: MAIN
Changes since 1.35: +5 -3 lines

Updated py-lxml to 3.6.1.

3.6.1 (2016-07-24)
==================

Features added
--------------

* GH#180: Separate option ``inline_style`` for Cleaner that only removes ``style``
  attributes instead of all styles.  Patch by Christian Pedersen.

* GH#196: Windows build support for Python 3.5.  Contribution by Maximilian Hils.

Bugs fixed
----------

* GH#199: Exclude ``file`` fields from ``FormElement.form_values`` (as browsers do).
  Patch by Tomas Divis.

* GH#198, LP#1568167: Try to provide base URL from ``Resolver.resolve_string()``.
  Patch by Michael van Tellingen.

* GH#191: More accurate float serialisation in ``objectify.FloatElement``.
  Patch by Holger Joukl.

* LP#1551797: Repair XSLT error logging. Patch by Marcus Brinkmann.

# $NetBSD: Makefile,v 1.36 2016/08/01 10:51:30 wiz Exp $

DISTNAME=	lxml-3.6.1
PKGNAME=	${PYPKGPREFIX}-${DISTNAME}
CATEGORIES=	textproc
MASTER_SITES=	http://lxml.de/files/
EXTRACT_SUFX=	.tgz

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://lxml.de/
COMMENT=	Python binding for libxml2 and libxslt
LICENSE=	modified-bsd

# as of 3.6.1, two test failures on NetBSD, see
# https://bugs.launchpad.net/lxml/+bug/1522052
# third error in 3.6.1
# https://bugs.launchpad.net/lxml/+bug/1608479
TEST_TARGET=	test_inplace

.include "../../lang/python/egg.mk"
BUILDLINK_API_DEPENDS.libxml2+=	libxml2>=2.7.8
.include "../../textproc/libxml2/buildlink3.mk"
BUILDLINK_API_DEPENDS.libxslt+=	libxslt>=1.1.26
.include "../../textproc/libxslt/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"