The NetBSD Project

CVS log for pkgsrc/textproc/py-lunr/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / textproc / py-lunr

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.7: download - view: text, markup, annotated - select for diffs
Sat Mar 15 19:32:03 2025 UTC (6 weeks, 1 day ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2025Q1-base, pkgsrc-2025Q1, HEAD
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +2 -2 lines
py-lunr: updated to 0.8.0

0.8.0 (2025-03-08)

- Drop support for Python 3.7 and 3.8
- Add support for Python 3.12 and 3.13

Revision 1.6: download - view: text, markup, annotated - select for diffs
Mon Oct 14 06:46:00 2024 UTC (6 months, 1 week ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base, pkgsrc-2024Q4
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +1 -3 lines
*: clean-up after python38 removal

Revision 1.5: download - view: text, markup, annotated - select for diffs
Thu Jan 25 16:30:22 2024 UTC (15 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +7 -10 lines
py-lunr: updated to 0.7.0.post1

 0.7.0 (2023-08-16)

- Fix misleading usage of `__main__.py` without runnable code to be ran on `python -m lunr`
- Move to pyproject.toml packaging
- Drop support for Python 3.6
- Add support for Python 3.11
- Remove logging configuration @ping

Revision 1.4: download - view: text, markup, annotated - select for diffs
Tue Aug 1 23:20:53 2023 UTC (20 months, 3 weeks ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +2 -2 lines
*: remove more references to Python 3.7

Revision 1.3: download - view: text, markup, annotated - select for diffs
Sat Jul 1 08:37:46 2023 UTC (21 months, 3 weeks ago) by wiz
Branches: MAIN
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +2 -2 lines
*: restrict py-numpy users to 3.9+ in preparation for update

Revision 1.2: download - view: text, markup, annotated - select for diffs
Mon Sep 12 06:54:04 2022 UTC (2 years, 7 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +2 -2 lines
py-lunr, py-doctor: do not support python 3.7 due to py-nltk

Revision 1.1: download - view: text, markup, annotated - select for diffs
Sun Sep 11 17:46:07 2022 UTC (2 years, 7 months ago) by wiz
Branches: MAIN
textproc/py-lunr: import py-lunr-0.6.2

This Python version of Lunr.js aims to bring the simple and powerful
full text search capabilities into Python guaranteeing results as
close as the original implementation as possible.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>