The NetBSD Project

CVS log for pkgsrc/textproc/py-libxslt/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / textproc / py-libxslt

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.70 / (download) - annotate - [select for diffs], Thu Feb 1 10:22:49 2024 UTC (8 weeks ago) by adam
Branch: MAIN
CVS Tags: HEAD
Changes since 1.69: +4 -5 lines
Diff to previous 1.69 (colored)

libxslt py-libxslt: updated to 1.1.39

v1.1.39: Nov 16 2023

Bug fixes

- extensions: Don't search imports for extension prefixes

Improvements

- transform: Check maximum depth when processing default templates
- build: Add more missing includes
- python: Don't set deprecated global
- build: Add missing includes
- imports: Limit nesting depth
- extensions: Report top-level elements in xsltDebugDumpExtensions
- Add extern "C" { } block to xsltlocale.h (David Kilzer)

Portability

- python: Make it compatible with python3.12 (Daniel Garcia Moreno)
- date: Fix check for localtime_s
- date: Fix check for gmtime_s

Build systems

- pkg-config files include cflags for static builds (Mike Dalessio)
- Handle NOCONFIG case when setting locations from CMake target properties (Markus
 Rickert)
- autotools: Make xslt-config executable

Tests

- tests: Structured error handler now passes a const xmlError
- python: Fix tests on MinGW
- fuzz: Fix xmlFuzzEntityLoader after recent libxml2 changes

Revision 1.69 / (download) - annotate - [select for diffs], Wed Nov 8 13:21:08 2023 UTC (4 months, 2 weeks ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4
Changes since 1.68: +2 -2 lines
Diff to previous 1.68 (colored)

*: recursive bump for icu 74.1

Revision 1.68 / (download) - annotate - [select for diffs], Mon Oct 23 06:37:54 2023 UTC (5 months ago) by wiz
Branch: MAIN
Changes since 1.67: +3 -2 lines
Diff to previous 1.67 (colored)

*: update for Python base package change

Instead of depending on one of the removed packages (that are now included
in the base Python packages), include batteries-included.mk to require
a Python version that supplies them.

Remove now included packages.

Bump PKGREVISION.

Revision 1.67 / (download) - annotate - [select for diffs], Wed May 17 23:35:45 2023 UTC (10 months, 1 week ago) by gutteridge
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2
Changes since 1.66: +1 -2 lines
Diff to previous 1.66 (colored)

libxslt & py-libxslt: update to 1.1.38

### Major changes

About 40 memory errors in code paths handling malloc failures have been fixed.
While these issues shouldn't impact security, this improves robustness under
memory pressure.

The result of generate-id() is now deterministic across multiple
transformations fixing many issues with reproducible builds.

Most of the test suite has been ported to C.

### Bug fixes

- Fix memory errors in code handling malloc failures
- imports: Fix import/include cycle check
- xsltlocale: Fix xsltNewLocale on macOS
- Make xsl:sort thread-safe
- Make generate-id() deterministic

### Improvements

- Stop using xmlStringCurrentChar
- attributes.h needs to include xsltInternals.h (David Kilzer)
- transform: Avoid null deref on documents without root node
- numbers: Fix floating point overflows
- date: Fix integer overflow in exsltDateFormatDuration
- numbers: Fix harmless integer sign change
- date: Add more overflow checks to formatting code (David Kilzer)
- date: Fix rounding to make Windows tests pass
- date: Rewrite duration and seconds formatting
- xsltlocale: Make API platform-independent
- Also accept application/xslt+xml media type in stylesheet PIs
- warnings: Fix strict prototypes warning
- xsltEvalUserParams() and xsltQuoteUserParams() are susceptible to integer
  overflow when iterating through const char** array (David Kilzer)
- xslt: Return NULL stylesheet on attribute set errors
- xsltproc: Fix unused variable warning
- xslt: Remove declaration for old libxml2
- Fix various compiler warnings
- Fix compiler warnings in xsltGenerateIdFunction
- Disable Python bindings for debugger
- Don't declare disabled functions
- Migrate from PyEval_ to PyObject_

### Build system

- cmake: Use version script
- autotools: Link with --undefined-version
- win32: Remove broken libxslt.def.src
- Stop updating version script
- add support for Windows time functions (Rosen Penev)
- cmake: link against libm on UNIX systems (Alex Richardson)
- build: Add a distutils-based build system for the Python bits (Chun-wei Fan)
- CMake: Relax check for Python 3.x support on Windows (Chun-wei Fan)
- python/types.c: Fix building against older libxml2 (Chun-wei Fan)
- python/libxslt.c: Replace ssize_t with Py_ssize_t (Chun-wei Fan)
- cmake: Fix build with libxslt and libxml2 as subprojects
- cmake: Set SOVERSION
- cmake: Extract version from configure.ac
- Fix classic Windows configuration for libexslt (Christoph M. Becker)
- autotools: Fix Python tests in VPATH builds
- autotools: Disable parallel Python build
- autotools: Use AM_CFLAGS consistently
- autotools: Link with -no-undefined
- cmake: Fix Python installation
- cmake: Don't check for Python 2
- python: Don't output missing generators during build
- python: Create .pyd on Windows
- python: Fix build on Windows
- python: Support Python 3 on Windows
- cmake: Enable GCC compiler warnings
- Update GCC compiler warnings

### Tests

- python: Remove temp file when running tests/basic.py
- fuzz: Improve fuzzers
- xsltlocale: Add test
- gitlab-ci: Reenable MSan and LeakSanitizer
- tests: Remove unused files
- tests: Enable runtest.exe under MSVC
- tests: Fix LIBXSLT_PLUGINS_PATH for multi-config CMake
- tests: Remove unused leak statistics
- tests: Skip some tests if iconv/ICU is disabled
- gitlab-ci: Run Autotools tests with out-of-tree (VPATH) builds
- tests: Port most of the test suite to C
- tests: Fix out-of-tree Python tests
- tests: Fix source directory for reports tests
- gitlab-ci: Consolidate CMake test scripts
- gitlab-ci: Only install cmake MinGW package if needed
- gitlab-ci: Install 7-Zip using the .msi
- gitlab-ci: Add CI job for MinGW/Autotools
- gitlab-ci: Disable MSan for now
- Run CI tests with -fsanitize=integer
- Fix EXSLT functions tests when libxml2 is built --without-debug
- Make CI tests exit on failure
- Run Python 3 CI job with minimal configuration
- Set library path when running Python tests

### Documentation

- doc: Remove unused cross-reference data
- doc: Update apibuild.py

Revision 1.66 / (download) - annotate - [select for diffs], Wed Apr 19 08:11:39 2023 UTC (11 months, 1 week ago) by adam
Branch: MAIN
Changes since 1.65: +2 -2 lines
Diff to previous 1.65 (colored)

revbump after textproc/icu update

Revision 1.65 / (download) - annotate - [select for diffs], Wed Nov 23 16:21:13 2022 UTC (16 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4
Changes since 1.64: +2 -1 lines
Diff to previous 1.64 (colored)

massive revision bump after textproc/icu update

Revision 1.64 / (download) - annotate - [select for diffs], Thu Oct 13 11:22:25 2022 UTC (17 months, 2 weeks ago) by wiz
Branch: MAIN
Changes since 1.63: +1 -6 lines
Diff to previous 1.63 (colored)

{py-,}libxslt: update to 1.1.37

v1.1.37: Aug 29 2022

### Improvements

- Don't use deprecated libxml2 macros
- Don't mess with xmlDefaultSAXHandler

### Build system

- Require automake-1.16.3 or later
- Remove generated files from distribution
- Add missing compile definition for static builds to Autotools (Mike Dalessio)


v1.1.36: Aug 17 2022

### Removals and deprecations

- Remove SVN keyword anchors
- Remove CVS and SVN-related code
- Remove README.cvs-commits
- Remove ChangeLog
- Remove xsltwin32config.h

### Improvements

- Simplify xsltexports.h and exsltexports.h
- Don't overlink executables with gcrypt
- Fix quadratic behavior with variables and parameters
- Remove case labels with XPointer location types
- Add configure~ to .gitignore
- Stop calling deprecated libxml2 functions

### Portability

- Use portable python shebangs (David Seifert)
- Remove useless __CYGWIN__ checks
- Remove cruft from win32config.h
- crypto.c: Silence a compiler warning on Windows (Chun-wei Fan)

### Build system

- Add missing compile definition for static builds to CMake
- Avoid obsolescent `test -a` constructs (David Seifert)
- Only link libxml2 statically in purely static build
- Set AC_CONFIG_MACRO_DIR
- Allow AM_MAINTAINER_MODE to be disabled
- Streamline and fix documentation installation
- Don't try to recreate COPYING symlink
- Remove special configuration for certain maintainers
- configure.ac: produce tar.xz only (GNOME policy) (David Seifert)
- Detect libm using libtool's macros (David Seifert)
- configure.ac: disable static libraries by default (David Seifert)
- python/Makefile.am: nest python docs in $(docdir) (David Seifert)
- python/Makefile.am: rely on global AM_INIT_AUTOMAKE (David Seifert)
- configure.ac: remove useless AC_SUBST (David Seifert)
- Use AM_PATH_PYTHON/PKG_CHECK_MODULES for python bindings (David Seifert)
- Change libxml2 Python config
- Don't check for standard C89 library functions
- Don't check for standard C89 headers
- Remove --with-html-dir option
- Also check for glibtoolize in autogen.sh
- Rework documentation build system
- Remove old website
- CMake: Relax check for enabling crypto support on Windows (Chun-wei Fan)
- Remove obsolete AC_HEADER_STDC autoconf macro (Vadim Zeitlin)
- Remove special configuration for old maintainers

### Test suite, CI

- Remove test involving XPointer range-to function
- Test recursion in EXSLT dynamic functions
- Add CI job for static build

### Documentation

- Move tutorial images


v1.1.35: Feb 16 2022:
   - Security:
  [CVE-2021-30560] Fix use-after-free in xsltApplyTemplates
  Fix memory leak in xsltDocumentElem (David King)
  Fix memory leak in xsltCompileIdKeyPattern (David King)
  Fix double-free with stylesheets containing entity nodes

   - Fixed regressions:
  Fix performance regression with predicates in patterns
  Fix regression in xsltComputeSortResult

   - Bug fixes:
  Fix conflict resolution for templates with same priority
  Fix xsl:number generating invalid UTF-8
  Support attribute value templates in xsl:sort lang attributes
  Don't pass first <xsl:sort> in <xsl:apply-templates> twice
  Fix quadratic runtime with text and <xsl:message>
  Don't allow empty EXSLT durations

   - Improvements:
  Add xsltproc --huge Argument via libxml XML_PARSE_HUGE (William N. Braswell, Jr.)

   - Tests, code quality, fuzzing:
  Remove .travis.yml
  Fix some misleading indentation (David King)
  Use actual types for templates in struct _xsltStylesheet
  Add CI for CMake on MSVC (Markus Rickert)
  Check for null pointer before calling freelocale
  Add CI test for Python 3
  Don't set maxDepth in XPath contexts
  Transfer XPath limits to XPtr context
  Stop using maxParserDepth XPath limit
  Make long-to-double cast explicit in date.c
  Disable LeakSanitizer
  Run clang CI tests with -Wimplicit-int-conversion
  Fix implicit-int-conversion warning in exslt/crypto.c
  Fix clang -Wimplicit-int-conversion warning (David Kilzer)
  Fix clang -Wconditional-uninitialized warning in libxslt/numbers.c (David Kilzer)
  Fix -Wshadow warnings in libexslt/dynamic.c (David Kilzer)
  Also search parent dir for source XML when fuzzing

   - Build system, portability:
  Add CMake build files (Markus Rickert)
  Initial support for Python 3 (Suleyman Poyraz)
  Call ANSI versions of WinAPI functions explicitly
  Remove redundant flags from pkg-config files
  Suppress automake warning in tests/XSLTMark
  Fix linking libexslt dynamic library when using MinGW (Vadim Zeitlin)
  Added platform specific path separators (Dmitriy Korovkin)
  win32: allow passing *FLAGS on command line
  Fix export of xsltExtMarker on Windows (David Kilzer)
  Fix redundant includes already in libexslt.h (David Kilzer)
  Minor fixes to configure.js
  Fix variable syntax in Python configuration
  Add new EXSLT string tests to EXTRA_DIST
  Fix xml2-config check in configure script
  win32: Add configuration for profiler (Chun-wei Fan)
  Check whether 'xml2-config --dynamic' is supported

   - Documentation:
  Add Makefile rule to regenerate xsltproc.html
  Update links
  Remove MAINTAINERS
  Upload documentation to GitLab Pages
  Add documentation in devhelp format
  Add --enable-rebuild-docs configure option
  Fix libexslt header summaries
  Fix validity of tutorial XML (David King)
  Use DocBook URL for tutorial DTD (David King)
  Update libxslt.doap
  Add missing options to xsltproc man page

Revision 1.63 / (download) - annotate - [select for diffs], Mon Apr 18 19:12:12 2022 UTC (23 months, 1 week ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2
Changes since 1.62: +2 -2 lines
Diff to previous 1.62 (colored)

revbump for textproc/icu update

Revision 1.62 / (download) - annotate - [select for diffs], Fri Jan 14 19:36:29 2022 UTC (2 years, 2 months ago) by tnn
Branch: MAIN
CVS Tags: pkgsrc-2022Q1-base, pkgsrc-2022Q1
Changes since 1.61: +4 -3 lines
Diff to previous 1.61 (colored)

py27-libxslt: fix build

Revision 1.61 / (download) - annotate - [select for diffs], Mon Jan 10 23:46:49 2022 UTC (2 years, 2 months ago) by wiz
Branch: MAIN
Changes since 1.60: +3 -3 lines
Diff to previous 1.60 (colored)

*: convert to egg.mk

Revision 1.60 / (download) - annotate - [select for diffs], Wed Dec 8 16:06:46 2021 UTC (2 years, 3 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4
Changes since 1.59: +2 -2 lines
Diff to previous 1.59 (colored)

revbump for icu and libffi

Revision 1.59 / (download) - annotate - [select for diffs], Wed Apr 21 11:42:48 2021 UTC (2 years, 11 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2
Changes since 1.58: +2 -2 lines
Diff to previous 1.58 (colored)

revbump for textproc/icu

Revision 1.58 / (download) - annotate - [select for diffs], Thu Nov 5 09:09:15 2020 UTC (3 years, 4 months ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4
Changes since 1.57: +2 -2 lines
Diff to previous 1.57 (colored)

*: Recursive revbump from textproc/icu-68.1

Revision 1.57 / (download) - annotate - [select for diffs], Tue Jun 2 08:24:51 2020 UTC (3 years, 9 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2
Changes since 1.56: +2 -1 lines
Diff to previous 1.56 (colored)

Revbump for icu

Revision 1.56 / (download) - annotate - [select for diffs], Wed Nov 6 13:24:03 2019 UTC (4 years, 4 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4
Changes since 1.55: +1 -2 lines
Diff to previous 1.55 (colored)

py-libxslt: reset PKGREVISION after update

Revision 1.55 / (download) - annotate - [select for diffs], Tue May 21 21:56:57 2019 UTC (4 years, 10 months ago) by schmonz
Branch: MAIN
CVS Tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2
Changes since 1.54: +3 -1 lines
Diff to previous 1.54 (colored)

Update to 3.51. From the changelog:

- SVG output: added `white-space: pre` in styles
- HTML output: replaced &apos; by &#39; (https://bugs.debian.org/927410)
- HTML output: fixed index file format (missing close tags)
- CLI: moved syntax recognition functions to DataDir class
- CLI: added regular expressions and default false values to --verbose output
- CLI: fixed `--list-cat` without `--list-scripts` (https://gitlab.com/saalen/highlight/issues/107)
- CLI: added optional argument to `--base16` (https://gitlab.com/saalen/highlight/issues/113)
- CLI: added default base16 themes (https://gitlab.com/saalen/highlight/issues/113)
- CLI: added `--isolate` option (https://gitlab.com/saalen/highlight/issues/118)
- GUI: improved UTF16 input path handling on Windows

Revision 1.54 / (download) - annotate - [select for diffs], Tue Mar 19 17:25:40 2019 UTC (5 years ago) by prlw1
Branch: MAIN
CVS Tags: pkgsrc-2019Q1-base, pkgsrc-2019Q1
Changes since 1.53: +2 -2 lines
Diff to previous 1.53 (colored)

libxslt versionitis cure

Revision 1.53 / (download) - annotate - [select for diffs], Tue Mar 19 03:53:45 2019 UTC (5 years ago) by dholland
Branch: MAIN
Changes since 1.52: +5 -1 lines
Diff to previous 1.52 (colored)

py-libxslt was not actually depending on python.
Juggle the includes to fix that.

Because py-libxml2's bl3 file includes pyversion.mk, py-libxslt must
include pyversion.mk itself first; otherwise, because pyversion.mk can
only be applied once, the python dependence ends up in the wrong place
in the buildlink tree.

PKGREVISION -> 1.

Revision 1.52 / (download) - annotate - [select for diffs], Wed Jan 9 19:12:14 2019 UTC (5 years, 2 months ago) by adam
Branch: MAIN
Changes since 1.51: +2 -2 lines
Diff to previous 1.51 (colored)

libxslt: updated to 1.1.33

v1.1.33:
Portability:
Variables need 'extern' in static lib on Cygwin
Really declare dllexport/dllimport for Cygwin
Fix callback signatures in Python bindings
Fix transform callback signatures
Fix extension callback signatures
Fix deallocator signatures
Fix XPath callback signatures
Fix hash callback signatures

Bug Fixes:
Don't cache direct evaluation of patterns with variables
Move function result RVTs to context variable
Fix EXSLT functions returning RVTs from outer scopes
Fix handling of RVTs returned from nested EXSLT functions
Fix typos

Improvements:
Run Travis ASan tests with "sudo: required"

Cleanups:
Remove doc/libxslt-decl.txt
Docs for 1.1.32 release

Revision 1.51 / (download) - annotate - [select for diffs], Tue Jul 3 05:03:37 2018 UTC (5 years, 8 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3
Changes since 1.50: +2 -2 lines
Diff to previous 1.50 (colored)

extend PYTHON_VERSIONS_ for Python 3.7

Revision 1.50 / (download) - annotate - [select for diffs], Sun Sep 10 20:56:48 2017 UTC (6 years, 6 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3
Changes since 1.49: +1 -2 lines
Diff to previous 1.49 (colored)

Updated py-libxslt to 1.1.30.

Changes: same as for libxslt.

Revision 1.49 / (download) - annotate - [select for diffs], Mon May 15 18:07:40 2017 UTC (6 years, 10 months ago) by dholland
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2
Changes since 1.48: +6 -1 lines
Diff to previous 1.48 (colored)

PR pkg/47444 diro: py-libxslt is broken. Needs to link explicitly to
libxml2mod.so, so do that and fix rpath handling.

Revision 1.48 / (download) - annotate - [select for diffs], Sun Jan 1 14:44:01 2017 UTC (7 years, 2 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1
Changes since 1.47: +2 -2 lines
Diff to previous 1.47 (colored)

Add python-3.6 to incompatible versions.

Revision 1.47 / (download) - annotate - [select for diffs], Sat Jul 9 13:04:10 2016 UTC (7 years, 8 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3
Changes since 1.46: +2 -2 lines
Diff to previous 1.46 (colored)

Remove python33: adapt all packages that refer to it.

Revision 1.46 / (download) - annotate - [select for diffs], Sun May 29 21:07:59 2016 UTC (7 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2
Changes since 1.45: +11 -15 lines
Diff to previous 1.45 (colored)

Switch to using libxslt/Makefile.common; update to 1.1.29.

Revision 1.45 / (download) - annotate - [select for diffs], Sat Dec 5 21:26:02 2015 UTC (8 years, 3 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4
Changes since 1.44: +2 -2 lines
Diff to previous 1.44 (colored)

Extend PYTHON_VERSIONS_INCOMPATIBLE to 35

Revision 1.44 / (download) - annotate - [select for diffs], Fri May 9 07:37:22 2014 UTC (9 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2
Changes since 1.43: +2 -2 lines
Diff to previous 1.43 (colored)

Mark packages that are not ready for python-3.3 also not ready for 3.4,
until proven otherwise.

Revision 1.43 / (download) - annotate - [select for diffs], Sat Jan 25 10:30:24 2014 UTC (10 years, 2 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q1-base, pkgsrc-2014Q1
Changes since 1.42: +3 -1 lines
Diff to previous 1.42 (colored)

Mark packages as not ready for python-3.x where applicable;
either because they themselves are not ready or because a
dependency isn't. This is annotated by
PYTHON_VERSIONS_INCOMPATIBLE=  33 # not yet ported as of x.y.z
or
PYTHON_VERSIONS_INCOMPATIBLE=  33 # py-foo, py-bar
respectively, please use the same style for other packages,
and check during updates.

Use versioned_dependencies.mk where applicable.
Use REPLACE_PYTHON instead of handcoded alternatives, where applicable.
Reorder Makefile sections into standard order, where applicable.

Remove PYTHON_VERSIONS_INCLUDE_3X lines since that will be default
with the next commit.

Whitespace cleanups and other nits corrected, where necessary.

Revision 1.42 / (download) - annotate - [select for diffs], Wed Jan 1 11:52:36 2014 UTC (10 years, 2 months ago) by wiz
Branch: MAIN
Changes since 1.41: +2 -2 lines
Diff to previous 1.41 (colored)

Recursive PKGREVISION bump for libgcrypt-1.6.0 shlib major bump.

Revision 1.41 / (download) - annotate - [select for diffs], Tue Jul 16 22:29:07 2013 UTC (10 years, 8 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3
Changes since 1.40: +3 -1 lines
Diff to previous 1.40 (colored)

Explicitly depend on py-expat. Bump revision.

Revision 1.40 / (download) - annotate - [select for diffs], Fri Jul 12 22:36:54 2013 UTC (10 years, 8 months ago) by adam
Branch: MAIN
Changes since 1.39: +7 -9 lines
Diff to previous 1.39 (colored)

Match textproc/libxslt version

Revision 1.39 / (download) - annotate - [select for diffs], Sat Apr 6 21:07:36 2013 UTC (10 years, 11 months ago) by rodent
Branch: MAIN
CVS Tags: pkgsrc-2013Q2-base, pkgsrc-2013Q2
Changes since 1.38: +4 -4 lines
Diff to previous 1.38 (colored)

"Each sed command should appear in an assignment of its own."

Revision 1.38 / (download) - annotate - [select for diffs], Thu Oct 25 06:56:51 2012 UTC (11 years, 5 months ago) by asau
Branch: MAIN
CVS Tags: pkgsrc-2013Q1-base, pkgsrc-2013Q1, pkgsrc-2012Q4-base, pkgsrc-2012Q4
Changes since 1.37: +1 -3 lines
Diff to previous 1.37 (colored)

Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

Revision 1.37 / (download) - annotate - [select for diffs], Thu Jun 14 07:44:43 2012 UTC (11 years, 9 months ago) by sbd
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2
Changes since 1.36: +2 -2 lines
Diff to previous 1.36 (colored)

Recursive PKGREVISION bump for libxml2 buildlink addition.

Revision 1.36 / (download) - annotate - [select for diffs], Fri Apr 22 13:44:51 2011 UTC (12 years, 11 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2
Changes since 1.35: +2 -1 lines
Diff to previous 1.35 (colored)

recursive bump from gettext-lib shlib bump.

Revision 1.35 / (download) - annotate - [select for diffs], Tue Apr 13 16:16:49 2010 UTC (13 years, 11 months ago) by drochner
Branch: MAIN
CVS Tags: pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3, pkgsrc-2010Q2-base, pkgsrc-2010Q2
Changes since 1.34: +2 -2 lines
Diff to previous 1.34 (colored)

sync w/ base pkg

Revision 1.34 / (download) - annotate - [select for diffs], Sat Jan 30 16:28:00 2010 UTC (14 years, 2 months ago) by heinz
Branch: MAIN
CVS Tags: pkgsrc-2010Q1-base, pkgsrc-2010Q1
Changes since 1.33: +2 -1 lines
Diff to previous 1.33 (colored)

Added LICENSE information.

Revision 1.33 / (download) - annotate - [select for diffs], Thu Mar 5 18:51:32 2009 UTC (15 years ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2009Q4-base, pkgsrc-2009Q4, pkgsrc-2009Q3-base, pkgsrc-2009Q3, pkgsrc-2009Q2-base, pkgsrc-2009Q2, pkgsrc-2009Q1-base, pkgsrc-2009Q1
Changes since 1.32: +1 -2 lines
Diff to previous 1.32 (colored)

Remove PYBINMODULE. All it did was mark some packages as not available
on some platforms that lacked shared library support in the past. The
list hasn't been maintained at all and the gain is very limited, so just
get rid of it.

Revision 1.32 / (download) - annotate - [select for diffs], Mon May 26 16:52:21 2008 UTC (15 years, 10 months ago) by drochner
Branch: MAIN
CVS Tags: pkgsrc-2008Q4-base, pkgsrc-2008Q4, pkgsrc-2008Q3-base, pkgsrc-2008Q3, pkgsrc-2008Q2-base, pkgsrc-2008Q2, cwrapper, cube-native-xorg-base, cube-native-xorg
Changes since 1.31: +2 -2 lines
Diff to previous 1.31 (colored)

sync with base pkg

Revision 1.31 / (download) - annotate - [select for diffs], Fri Apr 25 20:39:13 2008 UTC (15 years, 11 months ago) by joerg
Branch: MAIN
Changes since 1.30: +1 -2 lines
Diff to previous 1.30 (colored)

Update PYTHON_VERSIONS_COMPATIBLE
- assume that Python 2.4 and 2.5 are compatible and allow checking for
fallout.
- remove PYTHON_VERSIONS_COMPATIBLE that are obsoleted by the 2.3+
default. Modify the others to deal with the removals.

Revision 1.30 / (download) - annotate - [select for diffs], Mon Apr 21 19:44:14 2008 UTC (15 years, 11 months ago) by drochner
Branch: MAIN
Changes since 1.29: +2 -2 lines
Diff to previous 1.29 (colored)

sync w/ base pkg

Revision 1.29 / (download) - annotate - [select for diffs], Thu Apr 17 08:43:07 2008 UTC (15 years, 11 months ago) by abs
Branch: MAIN
Changes since 1.28: +2 -2 lines
Diff to previous 1.28 (colored)

PYTHON_VERSIONS_ACCEPTED+=25

Revision 1.28 / (download) - annotate - [select for diffs], Wed Oct 24 15:02:14 2007 UTC (16 years, 5 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2008Q1-base, pkgsrc-2008Q1, pkgsrc-2007Q4-base, pkgsrc-2007Q4
Changes since 1.27: +3 -1 lines
Diff to previous 1.27 (colored)

Supports DESTDIR.

Revision 1.27 / (download) - annotate - [select for diffs], Fri Aug 31 17:29:52 2007 UTC (16 years, 7 months ago) by drochner
Branch: MAIN
CVS Tags: pkgsrc-2007Q3-base, pkgsrc-2007Q3
Changes since 1.26: +2 -2 lines
Diff to previous 1.26 (colored)

sync w/ base pkg, no changes to Python part

Revision 1.26 / (download) - annotate - [select for diffs], Thu Jul 12 19:33:04 2007 UTC (16 years, 8 months ago) by drochner
Branch: MAIN
Changes since 1.25: +2 -3 lines
Diff to previous 1.25 (colored)

update to 1.1.21
changes: bugfixes, documentation update

Revision 1.25 / (download) - annotate - [select for diffs], Sat Jun 16 13:16:11 2007 UTC (16 years, 9 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2007Q2-base, pkgsrc-2007Q2
Changes since 1.24: +2 -1 lines
Diff to previous 1.24 (colored)

Switch to use .tar.bz2 file as libxslt package.

Revision 1.24 / (download) - annotate - [select for diffs], Thu Feb 1 18:46:41 2007 UTC (17 years, 1 month ago) by drochner
Branch: MAIN
CVS Tags: pkgsrc-2007Q1-base, pkgsrc-2007Q1
Changes since 1.23: +2 -2 lines
Diff to previous 1.23 (colored)

sync w/ libxslt

Revision 1.23 / (download) - annotate - [select for diffs], Thu Dec 7 14:38:12 2006 UTC (17 years, 3 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2006Q4-base, pkgsrc-2006Q4
Changes since 1.22: +2 -1 lines
Diff to previous 1.22 (colored)

py-libxml2 needs Python 2.3+, so py-libxslt has the same limitation.

Revision 1.22 / (download) - annotate - [select for diffs], Sun Nov 5 08:37:04 2006 UTC (17 years, 4 months ago) by rillig
Branch: MAIN
Changes since 1.21: +2 -2 lines
Diff to previous 1.21 (colored)

Typo: The second MASTER_SITES definition must use the += operator
instead of =, otherwise the first one is overwritten. That's fatal,
because the GNOME sites don't have the distfile yet.

Revision 1.21 / (download) - annotate - [select for diffs], Mon Oct 30 21:04:22 2006 UTC (17 years, 5 months ago) by drochner
Branch: MAIN
Changes since 1.20: +3 -3 lines
Diff to previous 1.20 (colored)

sync with libxslt, no specific changes

Revision 1.20 / (download) - annotate - [select for diffs], Tue Jun 13 15:54:04 2006 UTC (17 years, 9 months ago) by drochner
Branch: MAIN
CVS Tags: pkgsrc-2006Q3-base, pkgsrc-2006Q3, pkgsrc-2006Q2-base, pkgsrc-2006Q2
Changes since 1.19: +2 -2 lines
Diff to previous 1.19 (colored)

update to 1.1.17
changes:
-bug fixes: some regression tests, attribute/namespaces output,
 problem in mixed xsl:value-of and xsl:text uses
-improvements: internal refactoring,
 use of the XPath object cache in libxml2-2.6.25

Revision 1.19 / (download) - annotate - [select for diffs], Wed May 3 11:03:29 2006 UTC (17 years, 11 months ago) by drochner
Branch: MAIN
Changes since 1.18: +2 -3 lines
Diff to previous 1.18 (colored)

sync with main lib sources

Revision 1.18 / (download) - annotate - [select for diffs], Sat Apr 22 09:22:15 2006 UTC (17 years, 11 months ago) by rillig
Branch: MAIN
Changes since 1.17: +2 -2 lines
Diff to previous 1.17 (colored)

Removed the superfluous "quotes" and 'quotes' from variables that don't
need them, for example RESTRICTED and SUBST_MESSAGE.*.

Revision 1.17 / (download) - annotate - [select for diffs], Thu Apr 6 06:22:51 2006 UTC (17 years, 11 months ago) by reed
Branch: MAIN
Changes since 1.16: +2 -2 lines
Diff to previous 1.16 (colored)

Over 1200 files touched but no revisions bumped :)

RECOMMENDED is removed. It becomes ABI_DEPENDS.

BUILDLINK_RECOMMENDED.foo becomes BUILDLINK_ABI_DEPENDS.foo.

BUILDLINK_DEPENDS.foo becomes BUILDLINK_API_DEPENDS.foo.

BUILDLINK_DEPENDS does not change.

IGNORE_RECOMMENDED (which defaulted to "no") becomes USE_ABI_DEPENDS
which defaults to "yes".

Added to obsolete.mk checking for IGNORE_RECOMMENDED.

I did not manually go through and fix any aesthetic tab/spacing issues.

I have tested the above patch on DragonFly building and packaging
subversion and pkglint and their many dependencies.

I have also tested USE_ABI_DEPENDS=no on my NetBSD workstation (where I
have used IGNORE_RECOMMENDED for a long time). I have been an active user
of IGNORE_RECOMMENDED since it was available.

As suggested, I removed the documentation sentences suggesting bumping for
"security" issues.

As discussed on tech-pkg.

I will commit to revbump, pkglint, pkg_install, createbuildlink separately.

Note that if you use wip, it will fail!  I will commit to pkgsrc-wip
later (within day).

Revision 1.16 / (download) - annotate - [select for diffs], Sun Feb 5 23:11:07 2006 UTC (18 years, 1 month ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.15: +2 -1 lines
Diff to previous 1.15 (colored)

Recursive revision bump / recommended bump for gettext ABI change.

Revision 1.15 / (download) - annotate - [select for diffs], Mon Dec 5 20:51:07 2005 UTC (18 years, 3 months ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2005Q4-base, pkgsrc-2005Q4
Changes since 1.14: +4 -4 lines
Diff to previous 1.14 (colored)

Fixed pkglint warnings. The warnings are mostly quoting issues, for
example MAKE_ENV+=FOO=${BAR} is changed to MAKE_ENV+=FOO=${BAR:Q}. Some
other changes are outlined in

    http://mail-index.netbsd.org/tech-pkg/2005/12/02/0034.html

Revision 1.14 / (download) - annotate - [select for diffs], Fri Oct 7 15:42:30 2005 UTC (18 years, 5 months ago) by drochner
Branch: MAIN
Changes since 1.13: +2 -2 lines
Diff to previous 1.13 (colored)

sync Python wrappers with base libraries

Revision 1.13 / (download) - annotate - [select for diffs], Fri May 13 11:13:12 2005 UTC (18 years, 10 months ago) by drochner
Branch: MAIN
CVS Tags: pkgsrc-2005Q3-base, pkgsrc-2005Q3, pkgsrc-2005Q2-base, pkgsrc-2005Q2
Changes since 1.12: +2 -2 lines
Diff to previous 1.12 (colored)

sync with base libraries
no changes as far as Python wrappers are concerned, afaict

Revision 1.12 / (download) - annotate - [select for diffs], Mon Apr 11 21:47:42 2005 UTC (18 years, 11 months ago) by tv
Branch: MAIN
Changes since 1.11: +1 -2 lines
Diff to previous 1.11 (colored)

Remove USE_BUILDLINK3 and NO_BUILDLINK; these are no longer used.

Revision 1.11 / (download) - annotate - [select for diffs], Wed Nov 3 16:47:44 2004 UTC (19 years, 4 months ago) by minskim
Branch: MAIN
CVS Tags: pkgsrc-2005Q1-base, pkgsrc-2005Q1, pkgsrc-2004Q4-base, pkgsrc-2004Q4
Changes since 1.10: +2 -3 lines
Diff to previous 1.10 (colored)

Sync with libxslt-1.1.12.  No Python-specific change.

Revision 1.10 / (download) - annotate - [select for diffs], Sun Oct 3 00:18:20 2004 UTC (19 years, 5 months ago) by tv
Branch: MAIN
Changes since 1.9: +2 -1 lines
Diff to previous 1.9 (colored)

Libtool fix for PR pkg/26633, and other issues.  Update libtool to 1.5.10
in the process.  (More information on tech-pkg.)

Bump PKGREVISION and BUILDLINK_DEPENDS of all packages using libtool and
installing .la files.

Bump PKGREVISION (only) of all packages depending directly on the above
via a buildlink3 include.

Revision 1.9 / (download) - annotate - [select for diffs], Tue Aug 24 11:55:19 2004 UTC (19 years, 7 months ago) by drochner
Branch: MAIN
CVS Tags: pkgsrc-2004Q3-base, pkgsrc-2004Q3
Changes since 1.8: +2 -2 lines
Diff to previous 1.8 (colored)

sync with libxslt update to 1.1.9

Revision 1.8 / (download) - annotate - [select for diffs], Thu Jul 22 09:16:02 2004 UTC (19 years, 8 months ago) by recht
Branch: MAIN
Changes since 1.7: +2 -2 lines
Diff to previous 1.7 (colored)

add python as category
ok'd a while back at pkgsrcCon by agc and wiz

Revision 1.7 / (download) - annotate - [select for diffs], Tue Jul 6 16:44:50 2004 UTC (19 years, 8 months ago) by recht
Branch: MAIN
Changes since 1.6: +2 -2 lines
Diff to previous 1.6 (colored)

Catch up with the libxslt update and update to 1.1.8

Python related changes:
1.1.8: July 5 2004:
   - bug fixes: undefined namespace message (William Brack), search engine
    (William), multiple namespace fixups (William), namespace fix for key
    evaluation (William), Python memory debug bindings,

Revision 1.6 / (download) - annotate - [select for diffs], Mon Apr 19 15:44:05 2004 UTC (19 years, 11 months ago) by minskim
Branch: MAIN
CVS Tags: pkgsrc-2004Q2-base, pkgsrc-2004Q2
Changes since 1.5: +2 -2 lines
Diff to previous 1.5 (colored)

Update py-libxslt to 1.1.6 to sync with textproc/libxslt.
No Python-specific change.

Revision 1.5 / (download) - annotate - [select for diffs], Sat Apr 10 09:02:06 2004 UTC (19 years, 11 months ago) by minskim
Branch: MAIN
Changes since 1.4: +16 -10 lines
Diff to previous 1.4 (colored)

Update py-libxslt to 1.1.5.

Changes since 1.1.2:
  - patch for OS-X
  - enums export

Revision 1.4 / (download) - annotate - [select for diffs], Thu Feb 12 16:22:51 2004 UTC (20 years, 1 month ago) by minskim
Branch: MAIN
CVS Tags: pkgsrc-2004Q1-base, pkgsrc-2004Q1
Changes since 1.3: +7 -7 lines
Diff to previous 1.3 (colored)

bl3ify.  While here, update MAINTAINER email addr.

Revision 1.3 / (download) - annotate - [select for diffs], Fri Jan 23 21:50:49 2004 UTC (20 years, 2 months ago) by jmmv
Branch: MAIN
Changes since 1.2: +2 -1 lines
Diff to previous 1.2 (colored)

Bump PKGREVISION due to xmlcatmgr update to 2.0beta1.  I know; this is a PITA.
This shouldn't be needed if we had non-recursive dependancies *sigh*.

Revision 1.2 / (download) - annotate - [select for diffs], Sun Jan 4 22:24:05 2004 UTC (20 years, 2 months ago) by recht
Branch: MAIN
Changes since 1.1: +2 -2 lines
Diff to previous 1.1 (colored)

fix path to py-libxml2
noted by Min Sik Kim in private mail

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Sun Jan 4 11:48:30 2004 UTC (20 years, 2 months ago) by recht
Branch: TNF
CVS Tags: pkgsrc-base
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

initial import of py--libxslt-1.1.2
provided by Min Sik Kim via pkgsrc-wip

This is the libxslt python module, providing access to the libxslt
library.

Revision 1.1 / (download) - annotate - [select for diffs], Sun Jan 4 11:48:30 2004 UTC (20 years, 2 months ago) by recht
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>