Up to [cvs.NetBSD.org] / pkgsrc / textproc / py-jsonschema
Request diff between arbitrary revisions
Default branch: MAIN
Revision 1.21 / (download) - annotate - [select for diffs], Wed Sep 20 16:45:52 2023 UTC (4 days, 21 hours ago) by adam
Branch: MAIN
CVS Tags: HEAD
Changes since 1.20: +4 -4
lines
Diff to previous 1.20 (colored)
py-jsonschema: updated to 4.19.1 v4.19.1 * Single label hostnames are now properly considered valid according to the ``hostname`` format. This is the behavior specified by the relevant RFC (1123). IDN hostname behavior was already correct.
Revision 1.20 / (download) - annotate - [select for diffs], Fri Aug 25 21:35:08 2023 UTC (4 weeks, 2 days ago) by adam
Branch: MAIN
Changes since 1.19: +4 -4
lines
Diff to previous 1.19 (colored)
py-jsonschema: updated to 4.19.0 v4.19.0 ======= * Importing the ``Validator`` protocol directly from the package root is deprecated. Import it from ``jsonschema.protocols.Validator`` instead. * Automatic retrieval of remote references (which is still deprecated) now properly succeeds even if the retrieved resource does not declare which version of JSON Schema it uses. Such resources are assumed to be 2020-12 schemas. This more closely matches the pre-referencing library behavior. v4.18.6 ======= * Set a ``jsonschema`` specific user agent when automatically retrieving remote references (which is deprecated). v4.18.5 ======= * Declare support for Py3.12 v4.18.4 ======= * Improve the hashability of wrapped referencing exceptions when they contain hashable data. v4.18.3 ======= * Properly preserve ``applicable_validators`` in extended validators. Specifically, validators extending early drafts where siblings of ``$ref`` were ignored will properly ignore siblings in the extended validator. v4.18.2 ======= * Fix an additional regression with the deprecated ``jsonschema.RefResolver`` and pointer resolution. v4.18.1 ======= * Fix a regression with ``jsonschema.RefResolver`` based resolution when used in combination with a custom validation dialect (via ``jsonschema.validators.create``). v4.18.0 ======= This release majorly rehauls the way in which JSON Schema reference resolution is configured. It does so in a way that *should* be backwards compatible, preserving old behavior whilst emitting deprecation warnings. * ``jsonschema.RefResolver`` is now deprecated in favor of the new `referencing library <https://github.com/python-jsonschema/referencing/>`_. ``referencing`` will begin in beta, but already is more compliant than the existing ``$ref`` support. This change is a culmination of a meaningful chunk of work to make ``$ref`` resolution more flexible and more correct. Backwards compatibility *should* be preserved for existing code which uses ``RefResolver``, though doing so is again now deprecated, and all such use cases should be doable using the new APIs. Please file issues on the ``referencing`` tracker if there is functionality missing from it, or here on the ``jsonschema`` issue tracker if you have issues with existing code not functioning the same, or with figuring out how to change it to use ``referencing``. In particular, this referencing change includes a change concerning *automatic* retrieval of remote references (retrieving ``http://foo/bar`` automatically within a schema). This behavior has always been a potential security risk and counter to the recommendations of the JSON Schema specifications; it has survived this long essentially only for backwards compatibility reasons, and now explicitly produces warnings. The ``referencing`` library itself will *not* automatically retrieve references if you interact directly with it, so the deprecated behavior is only triggered if you fully rely on the default ``$ref`` resolution behavior and also include remote references in your schema, which will still be retrieved during the deprecation period (after which they will become an error). * Support for Python 3.7 has been dropped, as it is nearing end-of-life. This should not be a "visible" change in the sense that ``requires-python`` has been updated, so users using 3.7 should still receive ``v4.17.3`` when installing the library. * On draft 2019-09, ``unevaluatedItems`` now properly does *not* consider items to be evaluated by an ``additionalItems`` schema if ``items`` is missing from the schema, as the specification says in this case that ``additionalItems`` must be completely ignored. * Fix the ``date`` format checker on Python 3.11 (when format assertion behavior is enabled), where it was too liberal * Speed up validation of ``unevaluatedProperties`` Deprecations ------------ * ``jsonschema.RefResolver`` -- see above for details on the replacement * ``jsonschema.RefResolutionError`` -- see above for details on the replacement * relying on automatic resolution of remote references -- see above for details on the replacement * importing ``jsonschema.ErrorTree`` -- instead import it via ``jsonschema.exceptions.ErrorTree`` * importing ``jsonschema.FormatError`` -- instead import it via ``jsonschema.exceptions.FormatError``
Revision 1.19 / (download) - annotate - [select for diffs], Mon Dec 19 08:22:10 2022 UTC (9 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base,
pkgsrc-2023Q2,
pkgsrc-2023Q1-base,
pkgsrc-2023Q1,
pkgsrc-2022Q4-base,
pkgsrc-2022Q4
Changes since 1.18: +4 -4
lines
Diff to previous 1.18 (colored)
py-jsonschema: updated to 4.17.3 v4.17.3 ======= * Fix instantiating validators with cached refs to boolean schemas rather than objects. v4.17.2 ======= * Empty strings are not valid relative JSON Pointers (aren't valid under the RJP format). * Durations without (trailing) units are not valid durations (aren't valid under the duration format). This involves changing the dependency used for validating durations (from ``isoduration`` to ``isodate``).
Revision 1.18 / (download) - annotate - [select for diffs], Sun Nov 27 12:09:29 2022 UTC (9 months, 4 weeks ago) by adam
Branch: MAIN
Changes since 1.17: +4 -4
lines
Diff to previous 1.17 (colored)
py-jsonschema: updated to 4.17.1 v4.17.1 ======= * The error message when using ``unevaluatedProperties`` with a non-trivial schema value (i.e. something other than ``false``) has been improved
Revision 1.17 / (download) - annotate - [select for diffs], Mon Nov 21 20:06:08 2022 UTC (10 months ago) by adam
Branch: MAIN
Changes since 1.16: +4 -4
lines
Diff to previous 1.16 (colored)
py-jsonschema: updated to 4.17.0 v4.17.0 ======= * The ``check_schema`` method on ``jsonschema.protocols.Validator`` instances now *enables* format validation by default when run. This can catch some additional invalid schemas (e.g. containing invalid regular expressions) where the issue is indeed uncovered by validating against the metaschema with format validation enabled as an assertion. * The ``jsonschema`` CLI (along with ``jsonschema.cli`` the module) are now deprecated. Use ``check-jsonschema`` instead, which can be installed via ``pip install check-jsonschema`` and found `here <https://github.com/python-jsonschema/check-jsonschema>`_.
Revision 1.16 / (download) - annotate - [select for diffs], Wed Sep 14 11:04:57 2022 UTC (12 months, 1 week ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q3-base,
pkgsrc-2022Q3
Changes since 1.15: +4 -4
lines
Diff to previous 1.15 (colored)
py-jsonschema: updated to 4.16.0 v4.16.0 ======= * Improve the base URI behavior when resolving a ``$ref`` to a resolution URI which is different from the resolved schema's declared ``$id``. * Accessing ``jsonschema.draftN_format_checker`` is deprecated. Instead, if you want access to the format checker itself, it is exposed as ``jsonschema.validators.DraftNValidator.FORMAT_CHECKER`` on any ``jsonschema.protocols.Validator``.
Revision 1.15 / (download) - annotate - [select for diffs], Mon Sep 5 14:14:17 2022 UTC (12 months, 2 weeks ago) by adam
Branch: MAIN
Changes since 1.14: +4 -4
lines
Diff to previous 1.14 (colored)
py-jsonschema: updated to 4.15.0 v4.15.0 * A specific API Reference page is now present in the documentation. * ``$ref`` on earlier drafts (specifically draft 7 and 6) has been "fixed" to follow the specified behavior when present alongside a sibling ``$id``. Specifically the ID is now properly ignored, and references are resolved against whatever resolution scope was previously relevant. v4.14.0 * ``FormatChecker.cls_checks`` is deprecated. Use ``FormatChecker.checks`` on an instance of ``FormatChecker`` instead. * ``unevaluatedItems`` has been fixed for draft 2019. It's nonetheless discouraged to use draft 2019 for any schemas, new or old. * Fix a number of minor annotation issues in ``protocols.Validator`` v4.13.0 * Add support for creating validator classes whose metaschema uses a different dialect than its schemas. In other words, they may use draft2020-12 to define which schemas are valid, but the schemas themselves use draft7 (or a custom dialect, etc.) to define which *instances* are valid. Doing this is likely not something most users, even metaschema authors, may need, but occasionally will be useful for advanced use cases. v4.12.1 * Fix some stray comments in the README. v4.12.0 * Warn at runtime when subclassing validator classes. Doing so was not intended to be public API, though it seems some downstream libraries do so. A future version will make this an error, as it is brittle and better served by composing validator objects instead. Feel free to reach out if there are any cases where changing existing code seems difficult and I can try to provide guidance. v4.11.0 * Make the rendered README in PyPI simpler and fancier. v4.10.3 * ``jsonschema.validators.validator_for`` now properly uses the explicitly provided default validator even if the ``$schema`` URI is not found. v4.10.2 * Fix a second place where subclasses may have added attrs attributes. v4.10.1 * Fix Validator.evolve (and APIs like ``iter_errors`` which call it) for cases where the validator class has been subclassed. Doing so wasn't intended to be public API, but given it didn't warn or raise an error it's of course understandable. The next release however will make it warn (and a future one will make it error). If you need help migrating usage of inheriting from a validator class feel free to open a discussion and I'll try to give some guidance. v4.10.0 * Add support for referencing schemas with ``$ref`` across different versions of the specification than the referrer's v4.9.1 * Update some documentation examples to use newer validator releases in their sample code. v4.9.0 * Fix relative ``$ref`` resolution when the base URI is a URN or other scheme. * ``pkgutil.resolve_name`` is now used to retrieve validators provided on the command line. This function is only available on 3.9+, so 3.7 and 3.8 (which are still supported) now rely on the `pkgutil_resolve_name <https://pypi.org/project/pkgutil_resolve_name/>`_ backport package. Note however that the CLI itself is due to be deprecated shortly in favor of `check-jsonschema <https://github.com/python-jsonschema/check-jsonschema>`_. v4.8.0 * ``best_match`` no longer traverses into ``anyOf`` and ``oneOf`` when all of the errors within them seem equally applicable. This should lead to clearer error messages in some cases where no branches were matched.
Revision 1.14 / (download) - annotate - [select for diffs], Fri Jul 8 07:54:06 2022 UTC (14 months, 2 weeks ago) by adam
Branch: MAIN
Changes since 1.13: +4 -4
lines
Diff to previous 1.13 (colored)
py-jsonschema: updated to 4.6.2 v4.6.2 * Fix a number of minor typos in docstrings, mostly private ones
Revision 1.13 / (download) - annotate - [select for diffs], Thu Jul 7 10:41:40 2022 UTC (14 months, 2 weeks ago) by adam
Branch: MAIN
Changes since 1.12: +4 -4
lines
Diff to previous 1.12 (colored)
py-jsonschema: updated to 4.6.1 v4.6.1 ------ * Gut the (incomplete) implementation of ``recursiveRef`` on draft 2019. It needs completing, but for now can lead to recursion errors. v4.6.0 ------ * Fix ``unevaluatedProperties`` and ``unevaluatedItems`` for types they should ignore * ``jsonschema`` now uses `hatch <https://hatch.pypa.io/>`_ for its build process. This should be completely transparent to end-users (and only matters to contributors).
Revision 1.12 / (download) - annotate - [select for diffs], Wed May 11 09:30:52 2022 UTC (16 months, 2 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q2-base,
pkgsrc-2022Q2
Changes since 1.11: +4 -4
lines
Diff to previous 1.11 (colored)
py-jsonschema: updated to 4.5.1 v4.5.0 ------ * Validator classes for each version now maintain references to the correct corresponding format checker * Development has moved to a `GitHub organization <https://github.com/python-jsonschema/>`_. No functional behavior changes are expected from the change.
Revision 1.11 / (download) - annotate - [select for diffs], Thu Apr 7 06:49:20 2022 UTC (17 months, 2 weeks ago) by adam
Branch: MAIN
Changes since 1.10: +4 -4
lines
Diff to previous 1.10 (colored)
py-jsonschema: updated to 4.4.0 v4.4.0 ------ * Add ``mypy`` support * Add support for Python 3.11 v4.3.3 ------ * Properly report deprecation warnings at the right stack level v4.3.2 ------ * Additional performance improvements for resolving refs v4.3.1 ------ * Resolving refs has had performance improvements v4.3.0 ------ * Fix undesired fallback to brute force container uniqueness check on certain input types * Implement a PEP544 Protocol for validator classes v4.2.1 ------ * Pin ``importlib.resources`` from below v4.2.0 ------ * Use ``importlib.resources`` to load schemas * Ensure all elements of arrays are verified for uniqueness by ``uniqueItems`` v4.1.2 ------ * Fix ``dependentSchemas`` to properly consider non-object instances to be valid v4.1.1 ------ * Fix ``prefixItems`` not indicating which item was invalid within the instance path v4.1.0 ------ * Add Python 3.10 to the list of supported Python versions v4.0.1 ------ * Fix the declaration of minimum supported Python version v4.0.0 ------ * Partial support for Draft 2020-12 (as well as 2019-09). Thanks to Thomas Schmidt and Harald Nezbeda. * ``False`` and ``0`` are now properly considered non-equal even recursively within a container ``uniqueItems`` validation may be *slower* in some cases. Please feel free to report any significant performance regressions, though in some cases they may be difficult to address given the specification requirement. * The CLI has been improved, and in particular now supports a ``--output`` option (with ``plain`` (default) or ``pretty`` arguments) to control the output format. Future work may add additional machine-parsable output formats. * Code surrounding ``DEFAULT_TYPES`` and the legacy mechanism for specifying types to validators have been removed, as per the deprecation policy. Validators should use the ``TypeChecker`` object to customize the set of Python types corresponding to JSON Schema types. * Validation errors now have a ``json_path`` attribute, describing their location in JSON path format * Support for the IP address and domain name formats has been improved * Support for Python 2 and 3.6 has been dropped, with ``python_requires`` properly set. * ``multipleOf`` could overflow when given sufficiently large numbers. Now, when an overflow occurs, ``jsonschema`` will fall back to using fraction division * ``jsonschema.__version__``, ``jsonschema.validators.validators``, ``jsonschema.validators.meta_schemas`` and ``jsonschema.RefResolver.in_scope`` have been deprecated, as has passing a second-argument schema to ``Validator.iter_errors`` and ``Validator.is_valid``.
Revision 1.10 / (download) - annotate - [select for diffs], Tue Oct 26 11:23:06 2021 UTC (22 months, 4 weeks ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2022Q1-base,
pkgsrc-2022Q1,
pkgsrc-2021Q4-base,
pkgsrc-2021Q4
Changes since 1.9: +2 -2
lines
Diff to previous 1.9 (colored)
textproc: Replace RMD160 checksums with BLAKE2s checksums All checksums have been double-checked against existing RMD160 and SHA512 hashes Unfetchable distfiles (fetched conditionally?): ./textproc/convertlit/distinfo clit18src.zip
Revision 1.9 / (download) - annotate - [select for diffs], Thu Oct 7 15:02:13 2021 UTC (23 months, 2 weeks ago) by nia
Branch: MAIN
Changes since 1.8: +1 -2
lines
Diff to previous 1.8 (colored)
textproc: Remove SHA1 hashes for distfiles
Revision 1.8 / (download) - annotate - [select for diffs], Tue Dec 3 16:50:59 2019 UTC (3 years, 9 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base,
pkgsrc-2021Q3,
pkgsrc-2021Q2-base,
pkgsrc-2021Q2,
pkgsrc-2021Q1-base,
pkgsrc-2021Q1,
pkgsrc-2020Q4-base,
pkgsrc-2020Q4,
pkgsrc-2020Q3-base,
pkgsrc-2020Q3,
pkgsrc-2020Q2-base,
pkgsrc-2020Q2,
pkgsrc-2020Q1-base,
pkgsrc-2020Q1,
pkgsrc-2019Q4-base,
pkgsrc-2019Q4
Changes since 1.7: +5 -5
lines
Diff to previous 1.7 (colored)
py-jsonschema: updated to 3.2.0 v3.2.0 * Added a ``format_nongpl`` setuptools extra, which installs only ``format`` dependencies that are non-GPL
Revision 1.7 / (download) - annotate - [select for diffs], Sat Oct 19 14:32:09 2019 UTC (3 years, 11 months ago) by adam
Branch: MAIN
Changes since 1.6: +5 -5
lines
Diff to previous 1.6 (colored)
py-jsonschema: updated to 3.1.1 3.1.1: * Regular expressions throughout schemas now respect the ECMA 262 dialect, as recommended by the specification.
Revision 1.6 / (download) - annotate - [select for diffs], Thu Aug 22 11:47:04 2019 UTC (4 years, 1 month ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q3-base,
pkgsrc-2019Q3
Changes since 1.5: +5 -5
lines
Diff to previous 1.5 (colored)
py-jsonschema: updated to 3.0.2 v3.0.2 * Fixed a bug where 0 and False were considered equal by const and enum.
Revision 1.5 / (download) - annotate - [select for diffs], Sat Mar 2 14:31:51 2019 UTC (4 years, 6 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base,
pkgsrc-2019Q2,
pkgsrc-2019Q1-base,
pkgsrc-2019Q1
Changes since 1.4: +5 -5
lines
Diff to previous 1.4 (colored)
py-jsonschema: updated to 3.0.1 v3.0.0 * Support for Draft 6 and Draft 7 * Draft 7 is now the default * New TypeChecker object for more complex type definitions (and overrides) * Falling back to isodate for the date-time format checker is no longer attempted, in accordance with the specification
Revision 1.4 / (download) - annotate - [select for diffs], Thu May 4 17:46:53 2017 UTC (6 years, 4 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q4-base,
pkgsrc-2018Q4,
pkgsrc-2018Q3-base,
pkgsrc-2018Q3,
pkgsrc-2018Q2-base,
pkgsrc-2018Q2,
pkgsrc-2018Q1-base,
pkgsrc-2018Q1,
pkgsrc-2017Q4-base,
pkgsrc-2017Q4,
pkgsrc-2017Q3-base,
pkgsrc-2017Q3,
pkgsrc-2017Q2-base,
pkgsrc-2017Q2
Changes since 1.3: +5 -5
lines
Diff to previous 1.3 (colored)
v2.6.0 Support for Python 2.6 has been dropped. Improve a few error messages for uniqueItems and additionalProperties Fix an issue with ErrorTree's handling of multiple errors
Revision 1.3 / (download) - annotate - [select for diffs], Sun Oct 9 21:30:58 2016 UTC (6 years, 11 months ago) by bsiegert
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base,
pkgsrc-2017Q1,
pkgsrc-2016Q4-base,
pkgsrc-2016Q4
Changes since 1.2: +5 -5
lines
Diff to previous 1.2 (colored)
Update py-jsonschema to 2.5.1. There is no changelog for this version. v2.5.0 ------ * Improved performance on CPython by adding caching around ref resolution (#203)
Revision 1.2 / (download) - annotate - [select for diffs], Wed Nov 4 02:00:03 2015 UTC (7 years, 10 months ago) by agc
Branch: MAIN
CVS Tags: pkgsrc-2016Q3-base,
pkgsrc-2016Q3,
pkgsrc-2016Q2-base,
pkgsrc-2016Q2,
pkgsrc-2016Q1-base,
pkgsrc-2016Q1,
pkgsrc-2015Q4-base,
pkgsrc-2015Q4
Changes since 1.1: +2 -1
lines
Diff to previous 1.1 (colored)
Add SHA512 digests for distfiles for textproc category Problems found locating distfiles: Package cabocha: missing distfile cabocha-0.68.tar.bz2 Package convertlit: missing distfile clit18src.zip Package php-enchant: missing distfile php-enchant/enchant-1.1.0.tgz Otherwise, existing SHA1 digests verified and found to be the same on the machine holding the existing distfiles (morden). All existing SHA1 digests retained for now as an audit trail.
Revision 1.1 / (download) - annotate - [select for diffs], Wed Dec 31 13:18:58 2014 UTC (8 years, 8 months ago) by bsiegert
Branch: MAIN
CVS Tags: pkgsrc-2015Q3-base,
pkgsrc-2015Q3,
pkgsrc-2015Q2-base,
pkgsrc-2015Q2,
pkgsrc-2015Q1-base,
pkgsrc-2015Q1
Add a package for py-jsonschema. From DESCR: jsonschema is an implementation of JSON Schema for Python (supporting 2.6+ including Python 3). Features: - Full support for Draft 3 and Draft 4 of the schema. - Lazy validation that can iteratively report all validation errors. - Small and extensible - Programmatic querying of which properties or items failed validation.