The NetBSD Project

CVS log for pkgsrc/textproc/py-deepdiff/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / textproc / py-deepdiff

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.22: download - view: text, markup, annotated - select for diffs
Mon Apr 14 12:02:36 2025 UTC (2 weeks ago) by adam
Branches: MAIN
CVS tags: HEAD
Diff to: previous 1.21: preferred, colored
Changes since revision 1.21: +3 -3 lines
py-deepdiff: updated to 8.4.2

- v8-4-2
    - fixes the type hints for the base
    - fixes summarize so if json dumps fails, we can still get a repr of the results
    - adds ipaddress support

- v8-4-1
    - Adding BaseOperatorPlus base class for custom operators
    - default_timezone can be passed now to set your default timezone to something other than UTC.
    - New summarization algorithm that produces valid json
    - Better type hint support
    - Breaking change in DeepHash where we raise Exception instead of logging if we can't hash a value.
   - Added the log_stacktrace parameter to DeepDiff. When True, it will log the stacktrace along with the error.

Revision 1.21: download - view: text, markup, annotated - select for diffs
Sat Mar 15 19:33:33 2025 UTC (6 weeks, 2 days ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2025Q1-base, pkgsrc-2025Q1
Diff to: previous 1.20: preferred, colored
Changes since revision 1.20: +2 -2 lines
py-deepdiff: updated to 8.3.0

8.3.0

Fixed some static typing issues
Added the summarize module for better repr of nested values

Revision 1.20: download - view: text, markup, annotated - select for diffs
Fri Feb 7 14:29:57 2025 UTC (2 months, 2 weeks ago) by adam
Branches: MAIN
Diff to: previous 1.19: preferred, colored
Changes since revision 1.19: +4 -4 lines
py-deepdiff: updated to 8.2.0

8.2.0
- Small optimizations so we don't load functions that are not needed
- Updated the minimum version of Orderly-set
- Normalize all datetimes into UTC. Assume timezone naive datetimes are UTC.

Revision 1.19: download - view: text, markup, annotated - select for diffs
Mon Jan 6 10:30:17 2025 UTC (3 months, 3 weeks ago) by adam
Branches: MAIN
Diff to: previous 1.18: preferred, colored
Changes since revision 1.18: +4 -4 lines
py-deepdiff: updated to 8.1.1

- v8-1-0

  - Removing deprecated lines from setup.py
  - Added ``prefix`` option to ``pretty()``
  - Fixes hashing of numpy boolean values.
  - Fixes **slots** comparison when the attribute doesn’t exist.
  - Relaxing orderly-set reqs
  - Added Python 3.13 support
  - Only lower if clean_key is instance of str
  - Fixes issue where the key deep_distance is not returned when both
    compared items are equal
  - Fixes exclude_paths fails to work in certain cases
  - exclude_paths fails to work
  - Fixes to_json() method chokes on standard json.dumps() kwargs such as
    sort_keys
  - to_dict() method chokes on standard json.dumps() kwargs
  - Fixes accessing the affected_root_keys property on the diff object
    returned by DeepDiff fails when one of the dicts is empty
  - Fixes accessing the affected_root_keys property on the
    diff object returned by DeepDiff fails when one of the dicts is empty

- v8-0-1

  - Bugfix. Numpy should be optional.

- v8-0-0

   - With the introduction of `threshold_to_diff_deeper`, the values returned are different than in previous versions of DeepDiff. You can still get the older values by setting `threshold_to_diff_deeper=0`. However to signify that enough has changed in this release that the users need to update the parameters passed to DeepDiff, we will be doing a major version update.
   - `use_enum_value=True` makes it so when diffing enum, we use the enum's value. It makes it so comparing an enum to a string or any other value is not reported as a type change.
   - `threshold_to_diff_deeper=float` is a number between 0 and 1. When comparing dictionaries that have a small intersection of keys, we will report the dictionary as a `new_value` instead of reporting individual keys changed. If you set it to zero, you get the same results as DeepDiff 7.0.1 and earlier, which means this feature is disabled. The new default is 0.33 which means if less that one third of keys between dictionaries intersect, report it as a new object.
   - Deprecated `ordered-set` and switched to `orderly-set`. The `ordered-set` package was not being maintained anymore and starting Python 3.6, there were better options for sets that ordered. I forked one of the new implementations, modified it, and published it as `orderly-set`.
   - Added `use_log_scale:bool` and `log_scale_similarity_threshold:float`. They can be used to ignore small changes in numbers by comparing their differences in logarithmic space. This is different than ignoring the difference based on significant digits.
   - json serialization of reversed lists.
   - Fix for iterable moved items when `iterable_compare_func` is used.
   - Pandas and Polars support

Revision 1.18: download - view: text, markup, annotated - select for diffs
Mon Nov 11 07:29:01 2024 UTC (5 months, 2 weeks ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base, pkgsrc-2024Q4
Diff to: previous 1.17: preferred, colored
Changes since revision 1.17: +1 -2 lines
py-*: remove unused tool dependency

py-setuptools includes the py-wheel functionality nowadays

Revision 1.17: download - view: text, markup, annotated - select for diffs
Mon Oct 14 06:46:00 2024 UTC (6 months, 2 weeks ago) by wiz
Branches: MAIN
Diff to: previous 1.16: preferred, colored
Changes since revision 1.16: +1 -3 lines
*: clean-up after python38 removal

Revision 1.16: download - view: text, markup, annotated - select for diffs
Mon May 27 10:28:40 2024 UTC (11 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2
Diff to: previous 1.15: preferred, colored
Changes since revision 1.15: +4 -4 lines
py-deepdiff: updated to 7.0.1

v7-0-1

- Fixes the translation between Difflib opcodes and Delta flat rows.

v7-0-0

-  When verbose=2, return ``new_path`` when the ``path`` and
   ``new_path`` are different (for example when ignore_order=True and
   the index of items have changed).
-  Dropping support for Python 3.7
-  Introducing serialize to flat rows for delta objects.
-  fixes the issue with hashing ``datetime.date`` objects where it
   treated them as numbers instead of dates
-  upgrading orjson to the latest version
-  Fix for bug when diffing two lists with ignore_order and providing
   compare_func
-  Fixes “Wrong diff on list of strings”
-  Supporting Python 3.12 in the build process by `Leo
   Sin <https://github.com/leoslf>`__
-  Fixes “Instantiating a Delta with a flat_dict_list unexpectedly
   mutates the flat_dict_list”
-  Fixes “Error on Delta With None Key and Removed Item from List”
-  Fixes “Error when comparing two nested dicts with 2 added fields”
-  Fixes “Error when subtracting Delta from a dictionary”

Revision 1.15: download - view: text, markup, annotated - select for diffs
Sun Jan 28 21:00:06 2024 UTC (15 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +6 -10 lines
py-deepdiff: updated to 6.7.1

v6-7-1

-  Support for subtracting delta objects when iterable_compare_func
   is used.
-  Better handling of force adding a delta to an object.
-  Fix for
   ```Can't compare dicts with both single and double quotes in keys`` <https://github.com/seperman/deepdiff/issues/430>`__
-  Updated docs for Inconsistent Behavior with math_epsilon and
   ignore_order = True

v6-7-0

-  Delta can be subtracted from other objects now.
-  verify_symmetry is deprecated. Use bidirectional instead.
-  always_include_values flag in Delta can be enabled to include
   values in the delta for every change.
-  Fix for Delta.\__add\_\_ breaks with esoteric dict keys.

v6-6-1

 -  Fix for `DeepDiff raises decimal exception when using significant
    digits <https://github.com/seperman/deepdiff/issues/426>`__
 -  Introducing group_by_sort_key
 -  Adding group_by 2D. For example
    ``group_by=['last_name', 'zip_code']``

v6-6-0

-  Numpy 2.0 support
-  Adding
   `Delta.to_flat_dicts <https://zepworks.com/deepdiff/current/serialization.html#delta-serialize-to-flat-dictionaries>`__

v6-5-0

-  Adding
   ```parse_path`` <https://github.com/seperman/deepdiff/pull/419>`__

v6-4-1

-  Bugfix: Keep Numpy Optional

Revision 1.14: download - view: text, markup, annotated - select for diffs
Mon Jul 17 11:54:43 2023 UTC (21 months, 1 week ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +3 -3 lines
py-deepdiff: updated to 6.3.1

v6-3-1
- Bugfix deephash for paths
- Bugfix deephash compiled regex
- Fix tests dependent on toml
- Bugfix for ``include_paths`` for nested dictionaries
- Use tomli and tomli-w for dealing with tomli files
- Bugfix for ``datetime.date``

Revision 1.13: download - view: text, markup, annotated - select for diffs
Sat Jul 1 08:37:42 2023 UTC (21 months, 4 weeks ago) by wiz
Branches: MAIN
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +2 -2 lines
*: restrict py-numpy users to 3.9+ in preparation for update

Revision 1.12: download - view: text, markup, annotated - select for diffs
Mon Apr 17 20:28:15 2023 UTC (2 years ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +10 -8 lines
py-deepdiff: updated to 6.3.0

v6-3-0

- ``PrefixOrSuffixOperator``: This operator will skip strings that
  are suffix or prefix of each other.
- ``include_obj_callback`` and ``include_obj_callback_strict`` are
  added by `Håvard Thom <https://github.com/havardthom>`__.
- Fixed a corner case where numpy’s ``np.float32`` nans are not
  ignored when using ``ignore_nan_equality`` by `Noam
  Gottlieb <https://github.com/noamgot>`__
- ``orjson`` becomes optional again.
- Fix for ``ignore_type_in_groups`` with numeric values so it does
  not report number changes when the number types are different.

v6-2-3

- Switching to Orjson for serialization to improve the performance.
- Setting ``equal_nan=ignore_nan_inequality`` in the call for
  ``np.array_equal``
- Using Pytest’s tmp_path fixture instead of ``/tmp/``

v6-2-2

- Enum test fix for python 3.11
- Adding support for dateutils rrules

v6-2-1

- Removed the print statements.

v6-2-0

- Major improvement in the diff report for lists when items are all
  hashable and the order of items is important.

v6-1-0

- DeepDiff.affected_paths can be used to get the list of all paths
  where a change, addition, or deletion was reported for.
- DeepDiff.affected_root_keys can be used to get the list of all
  paths where a change, addition, or deletion was reported for.
- Bugfix: ValueError when using Decimal 0.x
- Serialization of UUID

v6-0-0

- `Exclude obj callback
  strict <https://github.com/seperman/deepdiff/pull/320/files>`__
  parameter is added to DeepDiff by Mikhail Khviyuzov
  `mskhviyu <https://github.com/mskhviyu>`__.
- A fix for diffing using ``iterable_compare_func`` with nested
  objects by `dtorres-sf <https://github.com/dtorres-sf>`__ who
  originally contributed this feature.

Revision 1.11: download - view: text, markup, annotated - select for diffs
Wed Jan 5 15:41:24 2022 UTC (3 years, 3 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +4 -2 lines
python: egg.mk: add USE_PKG_RESOURCES flag

This flag should be set for packages that import pkg_resources
and thus need setuptools after the build step.

Set this flag for packages that need it and bump PKGREVISION.

Revision 1.10: download - view: text, markup, annotated - select for diffs
Tue Jan 4 20:54:53 2022 UTC (3 years, 3 months ago) by wiz
Branches: MAIN
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +2 -1 lines
*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

Revision 1.9: download - view: text, markup, annotated - select for diffs
Fri Jul 9 19:07:45 2021 UTC (3 years, 9 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +7 -4 lines
py-deepdiff: updated to 5.5.0

v5-5-0: adding iterable_compare_func for DeepDiff, adding output_format of list for path() in tree view.
v5-4-0: adding strict_checking for numbers in DeepSearch.
v5-3-0: add support for regular expressions in DeepSearch.
v5-2-3: Retaining the order of multiple dictionary items added via Delta. Fixed the typo with yml files in deep cli. Fixing Grep RecursionError where using non UTF-8 character. Allowing kwargs to be passed to to_json method.
v5-2-2: Fixed Delta serialization when None type is present.
v5-2-0: Removed Murmur3 as the preferred hashing method. Using SHA256 by default now. Added commandline for deepdiff. Added group_by. Added math_epsilon. Improved ignoring of NoneType.

Revision 1.8: download - view: text, markup, annotated - select for diffs
Mon Jul 27 16:51:52 2020 UTC (4 years, 9 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +2 -2 lines
py-deepdiff: updated to 5.0.2

v5-0-2: Bug Fix NoneType in ignore type groups https://github.com/seperman/deepdiff/issues/207

Revision 1.7: download - view: text, markup, annotated - select for diffs
Tue Jul 21 10:59:04 2020 UTC (4 years, 9 months ago) by adam
Branches: MAIN
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +2 -2 lines
py-deepdiff: updated to 5.0.1

- v5-0-1: Bug fix to not apply format to non numbers.
- v5-0-0: Introducing the Delta object, Improving Numpy support, Fixing tuples comparison when ignore_order=True, Dramatically improving the results when ignore_order=True by running in passes, Introducing pretty print view, deep_distance, purge, progress logging, cache and truncate_datetime.
- v4-3-3: Adds support for datetime.time

Revision 1.6: download - view: text, markup, annotated - select for diffs
Wed May 13 15:10:11 2020 UTC (4 years, 11 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +6 -2 lines
py-deepdiff: updated to 4.3.2

v4-3-2: Deprecation Warning Enhancement
v4-3-1: Fixing the issue with exclude_path and hash calculations when dictionaries were inside iterables. https://github.com/seperman/deepdiff/issues/174
v4-3-0: adding exclude_obj_callback
v4-2-0: .json property is finally removed. Fix for Py3.10. Dropping support for EOL Python 3.4. Ignoring private keys when calculating hashes. For example init is not a part of hash calculation anymore. Fix for 166 Problem with comparing lists, with an boolean as element.
v4-0-9: Fixing the bug for hashing custom unhashable objects
v4-0-8: Adding ignore_nan_inequality for float('nan')

Revision 1.5: download - view: text, markup, annotated - select for diffs
Sat Jul 13 09:21:59 2019 UTC (5 years, 9 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +2 -2 lines
py-deepdiff: updated to 4.0.7

4.0.7:
Hashing of the number 1 vs. True

Revision 1.4: download - view: text, markup, annotated - select for diffs
Sun Apr 28 19:07:08 2019 UTC (6 years ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +7 -3 lines
py-deepdiff: updated to 4.0.6

v4.0.6:
Found a tiny bug in Python formatting of numbers in scientific notation. Added a workaround.

v4-0-5: Fixing number diffing. Adding number_format_notation and number_to_string_func.
v4-0-4: Adding ignore_string_case and ignore_type_subclasses
v4-0-3: Adding versionbump tool for release
v4-0-2: Fixing installation issue where rst files are missing.
v4-0-1: Fixing installation Tarball missing requirements.txt . DeepDiff v4+ should not show up as pip installable for Py2. Making Murmur3 installation optional.

v4.0.0:
Ending Python 2 support, Adding more functionalities and documentation for DeepHash. Switching to Pytest for testing. Switching to Murmur3 128bit for hashing. Fixing classes which inherit from classes with slots didn't have all of their slots compared. Renaming ContentHash to DeepHash. Adding exclude by path and regex path to DeepHash. Adding ignore_type_in_groups. Adding match_string to DeepSearch. Adding Timedelta object diffing.

Revision 1.3: download - view: text, markup, annotated - select for diffs
Fri Sep 29 11:06:32 2017 UTC (7 years, 7 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +4 -2 lines
py-deepdiff: update to 3.3.0

v3.3.0: Searching for objects and class attributes

Revision 1.2: download - view: text, markup, annotated - select for diffs
Thu Dec 8 09:04:44 2016 UTC (8 years, 4 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +5 -5 lines
whitespace.

Revision 1.1: download - view: text, markup, annotated - select for diffs
Wed Nov 30 20:19:29 2016 UTC (8 years, 4 months ago) by jdolecek
Branches: MAIN
add py-deepdiff 2.5.1 - Deep Difference of dictionaries, iterables, strings
and other objects

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>