[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / textproc / p5-highlight

File: [cvs.NetBSD.org] / pkgsrc / textproc / p5-highlight / Makefile (download)

Revision 1.10, Mon Jul 23 05:16:43 2018 UTC (5 years, 8 months ago) by schmonz
Branch: MAIN
Changes since 1.9: +1 -2 lines

Update to 3.44. From the changelog:

- fixed gcc 8 compilation warnings
- fixed Ruby string interpolation
  (https://github.com/andre-simon/highlight/issues/70)
- added support for ALAN IF (thanks to Tristano Ajmone)
- added 107 Base16 themes [https://github.com/chriskempson/base16]
  (thanks to Tristano Ajmone)
- updated Rust and Java reserved words lists
- revised documentation
- moved extras/css-themes into extras/themes-resources
- added extras/themes-resources/base16 (thanks to Tristano Ajmone)
- GUI: added Base16 theme selection checkbox
- CLI: added --base16 option to enable the new themes
- CLI: accept - as argument to read from stdin
  (https://github.com/andre-simon/highlight/issues/73)

# $NetBSD: Makefile,v 1.10 2018/07/23 05:16:43 schmonz Exp $

.include "../../textproc/libhighlight/Makefile.common"

PKGNAME=		p5-highlight-${VERSION}
COMMENT+=		 (Perl bindings)

BUILD_DEPENDS+=		swig3-[0-9]*:../../devel/swig3

BUILD_DIRS=		extras/swig
BUILD_TARGET=		perl

USE_TOOLS+=		perl:run
CFLAGS+=		-fPIC

INSTALLATION_DIRS=	${PERL5_SUB_INSTALLVENDORARCH}/auto/highlight

.include "../../mk/bsd.prefs.mk"

.if ${OPSYS} == "Darwin"
PERL_DLEXT=		bundle
SUBST_CLASSES+=		load
SUBST_STAGE.load=	pre-configure
SUBST_FILES.load=	extras/swig/makefile
SUBST_SED.load=		-e 's|-shared -s highlight_wrap\.o|-bundle -s highlight_wrap.o|g'
.else
PERL_DLEXT=		so
.endif
PLIST_SUBST+=		PERL_DLEXT=${PERL_DLEXT}

do-install:
	cd ${WRKSRC}/extras/swig && \
	${INSTALL_DATA} highlight.pm ${DESTDIR}${PREFIX}/${PERL5_SUB_INSTALLVENDORARCH}/ && \
	${INSTALL_LIB} highlight.so ${DESTDIR}${PREFIX}/${PERL5_SUB_INSTALLVENDORARCH}/auto/highlight/highlight.${PERL_DLEXT}

PERL5_LDFLAGS=		-L${PERL5_INSTALLARCHLIB}/CORE
.include "../../lang/perl5/module.mk"
.include "../../textproc/libhighlight/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"