Up to [cvs.NetBSD.org] / pkgsrc / textproc / p5-PDF-API2
Request diff between arbitrary revisions
Default branch: MAIN
Revision 1.29 / (download) - annotate - [select for diffs], Tue Jul 4 02:17:16 2023 UTC (2 months, 2 weeks ago) by wen
Branch: MAIN
CVS Tags: HEAD
Changes since 1.28: +4 -4
lines
Diff to previous 1.28 (colored)
Update to 2.044 Upstream changes: 2.044 2022-11-16 - Added support for QR codes. - [GH-44] The X coordinate returned by $text->position() or (deprecated) $text->textpos() was incorrect when read after being set twice (report by Johan Vromans). - [GH-45] Renamed transform's "relative" option to "repeat" and fixed the documentation describing what it does (report by Johan Vromans). - [GH-49] Fix page_layout storing its value as page_mode (report by Johan Vromans). - [GH-50] Fix $pdf->viewer_preferences to return the same values it accepts for non_full_screen_page_mode (report by Johan Vromans). - Minor doc clarifications and improved error messages.
Revision 1.28 / (download) - annotate - [select for diffs], Tue Jan 18 10:15:59 2022 UTC (20 months ago) by wen
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base,
pkgsrc-2023Q2,
pkgsrc-2023Q1-base,
pkgsrc-2023Q1,
pkgsrc-2022Q4-base,
pkgsrc-2022Q4,
pkgsrc-2022Q3-base,
pkgsrc-2022Q3,
pkgsrc-2022Q2-base,
pkgsrc-2022Q2,
pkgsrc-2022Q1-base,
pkgsrc-2022Q1
Changes since 1.27: +4 -4
lines
Diff to previous 1.27 (colored)
Update to 2.043 Upstream changes: 2.043 2021-12-07 - Restores backward compatibility (with a warning) when the deprecated $pdf->pageLabel is given an invalid -style option starting with "a" or "r" (report by Johan Vromans). - Fix incorrect default in documentation for annotation borders (report and patch by Johan Vromans).
Revision 1.27 / (download) - annotate - [select for diffs], Sat Oct 30 02:21:32 2021 UTC (22 months, 3 weeks ago) by wen
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base,
pkgsrc-2021Q4
Changes since 1.26: +4 -4
lines
Diff to previous 1.26 (colored)
Update to 2.042 Upstream changes: 2.042 2021-09-16 - This release includes many changes to method names, options, and documentation aimed at improving approachability, but existing code should continue to work. See the new Backward Compatibility section in the main PDF::API2 documentation for details about deprecation timelines and a suggested workflow for handling upgrades. See the new Migration section for a consolidated list of deprecated methods/options and their replacements. - Renamed several methods in the PDF::API2 base class: - end -> close - open_scalar -> from_string - stringify -> to_string - pages -> page_count - importPageIntoForm -> embed_page - isEncrypted -> is_encrypted - xmpMetadata -> xml_metadata - outlines -> outline - Merged saveas into save. - Added individual accessors for PDF metadata (title, author, producer, etc.). Replaced info and infoMetaAttributes with info_metadata for custom metadata. - Renamed the following methods in the PDF::API2::Page class: - gfx -> graphics - rotate -> rotation - Added $page->boundaries() and $pdf->default_page_boundaries() to replace the separate methods for the various page boundaries. The supported arguments are slightly different; some edge cases have been removed and new options have been added. See below and the PDF::API2::Page documentation for details. - Added $page->size() and $pdf->default_page_size() as a shortcut for setting the media box. - Both $page->size() and $page->boundaries() (and their $pdf default equivalents) now accept "WxH" page sizes in inches (e.g. 11x17 or 8.5x11). This does not apply to the deprecated versions of these methods. - Both $page->size() and $page->boundaries() (and their $pdf default equivalents) now accept a single number for page boundaries other than the media box, representing an amount in points to shrink the next larger box. This does not apply to the deprecated versions of these methods. - Replaced pageLabel with page_labels. The option syntax is slightly different (pass options as a hash instead of a hashref; remove hyphens from option names). - Replaced image_jpeg, image_tiff, image_pnm, image_png, image_gif, and image_gd with $pdf->image. - Replaced the individual barcode methods with $pdf->barcode, which is fully documented and includes reasonable defaults based on the chosen barcode format. - Improved spacing between barcodes and labels when both bar_extend (formerly -lmzn) and font_size (formerly -fnsz) are set and the font size is larger than the bar extension. - Replaced corefont, ttfont, psfont, and bdfont with $pdf->font. Unlike corefont, font requires the exact name of one of the standard fonts. Kerning is on by default (vs. off by default in the type-specific methods). - Renamed synfont to synthetic_font. Renamed and documented the options. The new hscale option (formerly -slant) now takes a percentage (100 = no change, vs. 1 = no change for -slant) to match the hscale method in Content. The new "bold" option is in thousandths of a text unit, vs. hundredths for "-bold", so multiply the old value by 10 when migrating. - Replaced the individual colorspace methods with $pdf->colorspace. Added documentation and examples for the various colorspace types except for the former colorspace_hue, because I couldn't find the standard that it implements (if one exists). - Renamed several methods in PDF::API2::Content: - linewidth -> line_width - linecap -> line_cap - linejoin -> line_join - miterlimit -> miter_limit - flatness -> flatness_tolerance - endpath -> end - rectxy -> rectangle - fillstroke -> paint - charspace -> character_spacing - wordspace -> word_spacing - nl -> crlf - advancewidth -> text_width - In PDF::API2::Content, replaced image and formimage with object. Added a $page->object() convenience method that is equivalent to $page->graphics->object(). - In PDF::API2::Content, merged text_center and text_right into text. Use the "align" option to set alignment to "center" or "right". - In PDF::API2::Content, merged paragraphs into paragraph. - In PDF::API2::Content, deprecated poly and added polyline. poly was the only path-drawing method that took a starting position as its first two arguments. These should be passed to a move call instead, with the remaining arguments passed to the new polyline method. - In PDF::API2::Content, added position, which combines the functionality of distance and textpos2 (which was undocumented). Deprecated textpos, which attempted to return the position of the "cursor" after taking into account coordinate transformations. textpos2 and the new position method return the text position before any coordinate transformations are applied, which is consistent with how the other methods in this class behave. - In PDF::API2::Content, deprecated bogen. Recreate using arc, if feasible. If not, I'm likely to leave the code in place indefinitely as an undocumented method. - In PDF::API2::Content, deprecated cr. Replace with either position (if called with arguments) or crlf (if called without arguments). - Tentatively deprecated $pdf->cjkfont. If you're successfully using this method for CJK font support, read PDF::API2::Resource::CIDFont::CJKFont and contact me to discuss your use case. - Tentatively deprecated $pdf->unifont. If you're successfully using this method for Unicode support, please contact me to discuss your use case. - Replaced $pdf->preferences() with separate page_mode, page_layout, viewer_preferences, and open_action methods, all of which are now fully documented. - Added font_path and set_font_path accessors for the font search path (the list of directories searched when a font name is included without its full path). Renamed addFontDirs to add_to_font_path. - Removed C:/WinNT/Fonts from the default font search path. - Named Destinations are now fully documented, with updated method names and arguments. - Outlines are now fully documented, with additional methods for examining and modifying the outline tree. Existing method names and arguments have been updated to match those used in Named Destinations. Various bugs have been fixed when reading or modifying outlines in existing PDFs. - Updated annotation documentation. Revised methods and arguments to match those used in Named Destinations and Outlines. - A PDF version number specified in the document catalog is now respected by $pdf->version(). - Fixed space calculation between words in justified text (report and fix by Vladislav Glinsky).
Revision 1.26 / (download) - annotate - [select for diffs], Tue Oct 26 11:22:31 2021 UTC (22 months, 3 weeks ago) by nia
Branch: MAIN
Changes since 1.25: +2 -2
lines
Diff to previous 1.25 (colored)
textproc: Replace RMD160 checksums with BLAKE2s checksums All checksums have been double-checked against existing RMD160 and SHA512 hashes Unfetchable distfiles (fetched conditionally?): ./textproc/convertlit/distinfo clit18src.zip
Revision 1.25 / (download) - annotate - [select for diffs], Thu Oct 7 15:01:38 2021 UTC (23 months, 2 weeks ago) by nia
Branch: MAIN
Changes since 1.24: +1 -2
lines
Diff to previous 1.24 (colored)
textproc: Remove SHA1 hashes for distfiles
Revision 1.24 / (download) - annotate - [select for diffs], Wed Jul 28 14:09:14 2021 UTC (2 years, 1 month ago) by wen
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base,
pkgsrc-2021Q3
Changes since 1.23: +5 -5
lines
Diff to previous 1.23 (colored)
Update to 2.041 Upstream changes: 2.041 2021-07-27 - Bug reports should now be made at GitHub Issues rather than RT. - Rename openpage to open_page in PDF::API2. The old name is deprecated. - [RT #136648] Fix when writing PDFs containing cross-reference streams (reported by Chris Papademetrious, fix by Vadim Repin from RT #117184). - [RT #44877] GIFs containing comments or plain-text representations will no longer result in an error (reported by Chris Czub). - [RT #132844] Fix corruption when a PGM image is included (reported by Jeff Ratcliffe, fix by Vadim Repin). - Expand PNM support to include all image types. - [RT #131657] Disable recursion warnings while releasing (destroying) PDF indirect objects, which can be highly-interconnected (reported by Leon Winter). - [RT #41971] Fix when attempting to read an existing PDF's outlines (reported by Damyan Ivanov, fix based on a patch by Vadim Repin). 2.040 2021-04-13 - Fix open() followed by stringify() resulting in a corrupt (mostly-empty) PDF, which was broken by changes in 2.039 (reported by Gareth Tunley). - [RT #134993] Calling open($filename) followed by saveas($same_filename) instead of update() resulted in a corrupt PDF in 2.039, which no longer reads the entire file into memory on open (reported by Marco Pessotto). - [RT #134957] Fix encoding of \n in a PDF string containing non-printable characters (reported by Stuart Henderson). - [RT #133131] Fix endianness of 64-bit numbers in cross-reference stream widths array (reported by Christopher Papademetrious, fix by Vadim Repin).
Revision 1.23 / (download) - annotate - [select for diffs], Sat Mar 27 23:31:07 2021 UTC (2 years, 5 months ago) by wen
Branch: MAIN
CVS Tags: pkgsrc-2021Q2-base,
pkgsrc-2021Q2,
pkgsrc-2021Q1-base,
pkgsrc-2021Q1
Changes since 1.22: +5 -5
lines
Diff to previous 1.22 (colored)
Update to 2.039 Upstream changes: 2.039 2021-03-04 - PDF::API2->open($filename) no longer reads the entire file into memory before working on it, instead reading from the file as needed. This results in a substantial reduction in memory usage and start-up time for large PDF files, particularly in cases where the calling script doesn't need to access all of the contents of the PDF. - PDF files containing cross-reference streams can now be modified and saved normally. Previously, they were read-only. - $text->paragraph(...) and $text->paragraphs(...) (formerly "section") are no longer undocumented and experimental. If you were previously using them at your own risk, note that "-spillover" is no longer an option (text will always wrap inside the specified width if possible). In addition, paragraphs(...) no longer collapses consecutive newlines. - [RT #98546] There is now an -align-last option for justified text to specify how the final line should be justified. Left is still the default. - Code in the PDF::API2::Basic::PDF namespace was originally licensed under the Perl Artistic License, which has been determined to not be (L)GPL-compatible. Martin Hosken has graciously granted an MIT license for use of his code contained in PDF::API2, so the distribution may now be used solely under the terms of the LGPL rather than requiring both licenses simultaneously. Many thanks to Petr Pisar for his help in working through the licensing issues. - Renamed $text->lead(...) to $text->leading(...). The old name is deprecated but will continue to work. If you're modifying PDF::API2 objects by editing their hash values instead of using these accessors, you'll need to update your code. - Added a -compress option (on by default) to PDF::API2->new(), open(), and open_scalar(). If disabled, most streams won't be compressed, which can simplify debugging.
Revision 1.22 / (download) - annotate - [select for diffs], Mon Sep 7 14:44:55 2020 UTC (3 years ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2020Q4-base,
pkgsrc-2020Q4,
pkgsrc-2020Q3-base,
pkgsrc-2020Q3
Changes since 1.21: +5 -5
lines
Diff to previous 1.21 (colored)
p5-PDF-API2: update to 2.038. 2.038 2020-08-31 - Use PDF::API2::XS or Image::PNG::Libpng, if either is installed, to speed up inclusion of PNG files with an alpha channel by an order of magnitude (written by Rob Scovell, sponsored by prayerletters.com). 2.037 2020-02-05 - Allow PDF 2.0 files to be opened. - [RT #131147] Ignore dictionary entries with null values (reported by Klaus Ethgen, fix by Vadim Repin).
Revision 1.21 / (download) - annotate - [select for diffs], Wed Sep 18 14:25:01 2019 UTC (4 years ago) by wen
Branch: MAIN
CVS Tags: pkgsrc-2020Q2-base,
pkgsrc-2020Q2,
pkgsrc-2020Q1-base,
pkgsrc-2020Q1,
pkgsrc-2019Q4-base,
pkgsrc-2019Q4,
pkgsrc-2019Q3-base,
pkgsrc-2019Q3
Changes since 1.20: +5 -5
lines
Diff to previous 1.20 (colored)
Update to 2.036 Upstream changes: 2.036 2019-09-17 - Eliminate another uninitialized value warning in BaseFont.pm. 2.035 2019-08-09 - The bounding box methods (mediabox, cropbox, bleedbox, trimbox, and artbox) now return their values when called without arguments. - The get_[media|crop|bleed|trim|art]box page methods have been deprecated since they're now redundant, but they continue to work. - [RT #130074] Remove unneeded (and newly-broken) calls to is_utf8 in Annotation.pm and NamedDestination.pm (reported by Mathieu Arnold). - Eliminate some uninitialized value warnings in BaseFont.pm. 2.034 2019-06-29 - SUPPORTED PERL VERSIONS: Starting with this release, PDF::API2 will support major Perl versions released in the past six years, plus the major release before that one. This should provide backward compatibility for the life of most LTS server distributions, while eliminating the need to troubleshoot warnings and bugs that only show up in increasingly-ancient versions of Perl. For this release, it means that the minimum supported Perl is 5.18, which was first released on 2013-05-18. - Add support for cross-reference streams using 64-bit field widths. - When the utf8 flag is set for a PDF string, automatically encode it as UCS-16BE instead of requiring a separate flag to be set in the PDF object. This resolves [RT #33497] and [RT #117031] in addition to making the code easier to maintain. - [RT #126274] Fix alignment when using UniFont with text_center or text_right when all characters are in the same block. - [RT #121911] Fix adding pages to a document structure with nested Pages elements. This included a fairly substantial rewrite of the relevant code, so please report any new bugs related to adding pages (report and troubleshooting by Vadim Repin). - Renamed pdfile() to pdf_file() in PDF::API2::Annotation and PDF::API2::Outline. The old name continues to work, but is deprecated.
Revision 1.20 / (download) - annotate - [select for diffs], Sun Jul 9 00:41:59 2017 UTC (6 years, 2 months ago) by wen
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base,
pkgsrc-2019Q2,
pkgsrc-2019Q1-base,
pkgsrc-2019Q1,
pkgsrc-2018Q4-base,
pkgsrc-2018Q4,
pkgsrc-2018Q3-base,
pkgsrc-2018Q3,
pkgsrc-2018Q2-base,
pkgsrc-2018Q2,
pkgsrc-2018Q1-base,
pkgsrc-2018Q1,
pkgsrc-2017Q4-base,
pkgsrc-2017Q4,
pkgsrc-2017Q3-base,
pkgsrc-2017Q3
Changes since 1.19: +5 -5
lines
Diff to previous 1.19 (colored)
Update to 2.033 Upstream changes: 2.033 2017-07-06 - [RT #122371] Remove a couple of improperly-placed weaken statements (reported by Phil Perry). - [RT #122372] Fix weakening when a page is added to the end of a multiple page document (reported by Phil Perry). - Fix Bank Gothic core font (reported by Phil Perry). 2.032 2017-07-02 - PDF::API2 has many circular references, and the end() method doesn't clear them all, so memory is leaked. This release uses Scalar::Util's weaken() function to improve garbage collection. A significant number of circular references have been weakened, though many likely still remain. - [RT #120756] Eliminate a warning for an ambiguous call to CORE::open (first reported by Abdelbaki Brahmia). - $text->text_justified() and $text->text_fill_justified() now adjust the space between words rather than stretching individual characters in order to get the text to fit. - [RT #120397] Indirect references and indirect objects can have comments embedded in their whitespace, and their object number and generation may be split across multiple lines, which may not all be buffered (reported by SPROUT). - [RT #120450] Fix PDF::API2->open($filename)->stringify() (reported by SPROUT). - Fix an off-by-one error when calculating text width while charspace is non-zero. - [RT #120048] Fix PDF::API2->synfont() (broken in 2.029, fixed by Vadim Repin) and add basic testing.
Revision 1.19 / (download) - annotate - [select for diffs], Sat Mar 4 11:48:09 2017 UTC (6 years, 6 months ago) by wen
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base,
pkgsrc-2017Q2,
pkgsrc-2017Q1-base,
pkgsrc-2017Q1
Changes since 1.18: +5 -5
lines
Diff to previous 1.18 (colored)
Update to 2.031 Upstream changes: 2.031 2017-01-26 - Fix use of cache files when reading streams: temp files will now be used any time a stream is larger than 16MB (by default). Formerly, due to a bug, they would only be created when a 4kB chunk of a stream increased to 16kB or more after being decompressed. - Numbers, booleans, and null values can now be read from object streams. - Update to [RT #113290]: Objects inside a large object stream are now read without loading the entire object stream into memory. - DEPRECATION: The low-level new_api methods have been deprecated in favor of calling new directly. If your code uses new_api($api2, ...), replace it with new($api2->{'pdf'}, ...). - [RT #118352] Don't crash when adding an annotation to a page that has an existing annotations array stored as an indirect object (reported by Johan Vromans). - [RT #118717] Die with an informative error if a file can't be opened during open() or saveas() (reported by Johan Vromans).
Revision 1.18 / (download) - annotate - [select for diffs], Sat Oct 15 07:35:31 2016 UTC (6 years, 11 months ago) by wen
Branch: MAIN
CVS Tags: pkgsrc-2016Q4-base,
pkgsrc-2016Q4
Changes since 1.17: +5 -5
lines
Diff to previous 1.17 (colored)
Update to 2.030 Upstream changes: 2.030 2016-10-13 - Fix a font naming issue introduced while satisfying Perl::Critic. 2.029 2016-10-10 - [RT #113293] Files with cross-reference streams weren't correctly setting the max object number (report and troubleshooting by Marco Pessotto). - Handle TIFF images with strips that are wider than the image (report and patch by Jeffrey Ratcliffe). - [RT #98574] Increase test coverage of PDF::API2::Content (tests by Phil Perry). - A bunch of code cleanup and documentation updates by Paul Cochrane. - Add a missing prereq on Win32 systems (patch by Michiel Beijen). - [RT #113514, #98552] Fix the dash() and renderingintent() methods in ExtGState (reported by Vadim Repin and Phil Perry). - Satisfy all Perl::Critic severity 5 policies. - [RT #117940] Allow PNG, GIF, and PNM files to be opened from filehandles in addition to filenames (patch by Johan Vromans). - [RT #33970] Fail fast when a referenced file can't be opened (requested by Barrie Slaymaker a mere 8.5 years ago). - Add -simplex, -duplexfliplongedge and -duplexflipshortedge as options to $pdf->preferences() (requested by Doug Poulin).
Revision 1.17 / (download) - annotate - [select for diffs], Fri Jul 15 13:36:08 2016 UTC (7 years, 2 months ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2016Q3-base,
pkgsrc-2016Q3
Changes since 1.16: +5 -5
lines
Diff to previous 1.16 (colored)
Updated textproc/p5-PDF-API2 to 2.028 ------------------------------------- 2.028 2016-06-08 - [RT #113290] Fix for reading objects inside an object stream in a large PDF (patch by Marco Pessotto). - Eliminate an infinite loop when reading a corrupt dictionary.
Revision 1.16 / (download) - annotate - [select for diffs], Sun Jun 5 13:19:17 2016 UTC (7 years, 3 months ago) by wen
Branch: MAIN
CVS Tags: pkgsrc-2016Q2-base,
pkgsrc-2016Q2
Changes since 1.15: +5 -5
lines
Diff to previous 1.15 (colored)
Update to 2.027 Upstream changes: 2.027 2016-03-11 - This release contains seven fixes for parsing PDFs. They mostly affect files using cross-reference streams, which were first supported in the previous release. Thanks to Marco Pessotto and Stuart Henderson for their help identifying and troubleshooting bugs. - Added contrib/pdf-debug.pl to help track down issues related to opening and parsing PDFs. 2.026 2016-02-24 - [RT #48683] Add support for PDFs with cross-reference streams and object streams (patch by Don Huettl of Grant Street Group). - [RT #107333] Accept an empty string as a valid Name, per PDF spec 1.7 section 7.3.5 (patch by Mark Balitsky). - [RT #98551] Rename aliases 2A, 4A, 2B, and 4B to 2A0, 4A0, 2B0, and 4B0. The old names will continue to work, but are now undocumented (patch by Phil Perry). - Add -mils and -color as options for barcodes. Reset linedash so that barcodes are always solid lines (patch by Erelen). - [RT #98549] Rename meterlimit to miterlimit (patch by Phil Perry). - [RT #98534] Rename hspace to hscale (patch by Phil Perry). - Fixed an infinite loop when RunLengthDecode is used for output. - [RT #65582] Fix embedding of OpenType fonts (fix by Simon Cozens). - [RT #67767] Allow an empty page to be imported into a PDF using importPageIntoForm (reported by Antti Lankila). - [RT #66341] Various fixes for ASCII85Decode and LZWDecode.
Revision 1.15 / (download) - annotate - [select for diffs], Wed Nov 4 01:59:46 2015 UTC (7 years, 10 months ago) by agc
Branch: MAIN
CVS Tags: pkgsrc-2016Q1-base,
pkgsrc-2016Q1,
pkgsrc-2015Q4-base,
pkgsrc-2015Q4
Changes since 1.14: +2 -1
lines
Diff to previous 1.14 (colored)
Add SHA512 digests for distfiles for textproc category Problems found locating distfiles: Package cabocha: missing distfile cabocha-0.68.tar.bz2 Package convertlit: missing distfile clit18src.zip Package php-enchant: missing distfile php-enchant/enchant-1.1.0.tgz Otherwise, existing SHA1 digests verified and found to be the same on the machine holding the existing distfiles (morden). All existing SHA1 digests retained for now as an audit trail.
Revision 1.14 / (download) - annotate - [select for diffs], Sun Oct 4 10:45:51 2015 UTC (7 years, 11 months ago) by wen
Branch: MAIN
Changes since 1.13: +4 -4
lines
Diff to previous 1.13 (colored)
Update to 2.025 Upstream changes: 2.025 2015-09-23 - The previous release included a patch that broke compatibility with Perl 5.8.x. The minimum supported version is now Perl 5.8.5, and there is a .perl-version file to facilitate testing using plenv. 2.024 2015-09-18 - [RT #104133] Include all bounding boxes when importing a page (patch by Don Huettl of Grant Street Group). - [RT #104133] When retrieving bounding boxes for a page, fall back according to the defaults listed in the PDF spec (patch by Don Huettl of Grant Street Group). - Barcodes now take an optional -caption argument that will be printed beneath the barcode. This can replace or be used in conjunction with the text representation of the barcode (requested by Gareth Tunley). - [RT #105581] Calls to width() in BaseFont are now significantly faster (patch by Dmitri Tikhonov).
Revision 1.13 / (download) - annotate - [select for diffs], Sun Apr 26 08:37:26 2015 UTC (8 years, 4 months ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2015Q3-base,
pkgsrc-2015Q3,
pkgsrc-2015Q2-base,
pkgsrc-2015Q2
Changes since 1.12: +4 -4
lines
Diff to previous 1.12 (colored)
Update 2.021 to 2.023 --------------------- 2.023 2014-09-12 - The fix for [RT #69503] broke a previously-working case where a page object could be passed (and was expected). The -firstpage option now accepts a page object or a page number. Thanks to Marco Pessotto for the bug report and test. 2.022 2014-07-04 - Added $pdf->version() get/set method. When opening an existing PDF, the existing version number will now be retained. - Renamed the following in PDF::API2: - importpage to import_page - openScalar to open_scalar The old names are deprecated. - [RT #69503] Fix the -firstpage option to $pdf->preferences() so that it doesn't always lead to a crash (reported by Dietrich Streifert). - [RT #47974] Accept malformed xref subsections (with a warning) that have extraneous spaces on the first line (reported by Abhinav Kaushik). - [RT #94505] For Code128 barcodes, the initial character set is now optional (defaults to B or C depending on the content to be encoded). The initial character set can be passed as a capital letter, and the program will die if an invalid character set is requested (requested by Andrea Nall). - Interleaved 2 of 5 barcodes now prepend a zero when an odd number of digits is specified, which is standard behavior. Previously, a zero was appended instead. - $page->rotate(0) now sets rotation to 0 degrees rather than deleting an existing page rotation command. Page rotation is inherited, so this is necessary to undo any inherited page rotation. - Fix: Attempts to use EAN-128 barcodes resulted in an error. - Add a more informative error when text() is called without first setting a font(), and when font() is called without including a font size.
Revision 1.12 / (download) - annotate - [select for diffs], Sat Feb 22 08:57:04 2014 UTC (9 years, 7 months ago) by wen
Branch: MAIN
CVS Tags: pkgsrc-2015Q1-base,
pkgsrc-2015Q1,
pkgsrc-2014Q4-base,
pkgsrc-2014Q4,
pkgsrc-2014Q3-base,
pkgsrc-2014Q3,
pkgsrc-2014Q2-base,
pkgsrc-2014Q2,
pkgsrc-2014Q1-base,
pkgsrc-2014Q1
Changes since 1.11: +4 -4
lines
Diff to previous 1.11 (colored)
Update to 2.021 Upstream changes: 2.021 2014-02-20 - Fixed numerous bugs in the string parsing code, including the one reported in [RT #63918] by Frank Doepper. - [RT #41049] Rewrote literal string parsing to prevent a stack overflow due to an inefficient regex (reported by Sergei Fetisov). - [RT #91822] Fix compression of GIF images to ensure that output codes don't exceed 12 bits (reported by Vadim Repin). - The RunLengthDecode filter didn't actually work. Its code has been rewritten and now passes basic encoding and decoding tests. - Fix Code128 barcode switching from Code C to Code B in certain cases (reported by Doru Petrescu).
Revision 1.11 / (download) - annotate - [select for diffs], Wed Jan 23 01:30:02 2013 UTC (10 years, 8 months ago) by wen
Branch: MAIN
CVS Tags: pkgsrc-2013Q4-base,
pkgsrc-2013Q4,
pkgsrc-2013Q3-base,
pkgsrc-2013Q3,
pkgsrc-2013Q2-base,
pkgsrc-2013Q2,
pkgsrc-2013Q1-base,
pkgsrc-2013Q1
Changes since 1.10: +4 -4
lines
Diff to previous 1.10 (colored)
Update to 2.020 Upstream changes: 2.020 2013-01-20 - Give a more informative error message when a PDF file using a cross-reference stream is encountered. The Known Issues section of the documentation includes pointers on how to add support in case someone else can get to this before I do. - Text using TrueType fonts is now searchable again. In version 0.61, an undocumented -unicodemap option was added to nearly all of the font resource methods, which only included a ToUnicode CMap if it was set (and it's required in order for PDF readers to be able to identify individual characters if BaseEncoding isn't present, which it isn't for TrueType fonts). I've left the -unicodemap option in place, and it's still undocumented (except here), but it's now on by default. Call $pdf->ttfont($fontfile, -unicodemap => 0) if you want to disable it for performance or file size reasons. - Add a note to the stringify method's documentation saying that it's a destructive operation. - The various filter types have their own classes in the PDF::API2::Basic::PDF::Filter namespace now, rather than having all of the packages in Filter.pm. - To facilitate testing and ensure that identically-generated PDFs have identical output in Perl 5.17.5 or later, PDF dictionary keys are now sorted during output.
Revision 1.10 / (download) - annotate - [select for diffs], Mon Apr 11 09:12:51 2011 UTC (12 years, 5 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2012Q4-base,
pkgsrc-2012Q4,
pkgsrc-2012Q3-base,
pkgsrc-2012Q3,
pkgsrc-2012Q2-base,
pkgsrc-2012Q2,
pkgsrc-2012Q1-base,
pkgsrc-2012Q1,
pkgsrc-2011Q4-base,
pkgsrc-2011Q4,
pkgsrc-2011Q3-base,
pkgsrc-2011Q3,
pkgsrc-2011Q2-base,
pkgsrc-2011Q2
Changes since 1.9: +4 -4
lines
Diff to previous 1.9 (colored)
Changes 2.019: * Fix a typo in the require statement for code128 barcodes. * Numerous modules are now only loaded when they're needed, which should help speed up the load time and reduce the memory footprint. * Test coverage is up to about 45% of the codebase. Changes 2.018: * The tests in 2.017 exposed a floating point issue where some computers give more trailing zeros than others. It doesn't affect the output, but it does break the tests on those computers, since the PDFs are slightly different. This version modifies the float() method to remove trailing zeros, which should fix the test breakage and give consistent PDFs. Changes 2.017: * The DejaVu fonts have been removed from the distribution, since they were only used by one example script. If you need them for your project, you can download them from http://dejavu-fonts.org * Fix: Content->bogen() didn't behave as documented if $move was set (it started drawing from the center of the circle rather than [x1, y1]). * The undocumented nettfont method has been removed, along with the supporting PDF::API2::Resource::Font::neTrueType module. * The undocumented save_xml method has been removed, along with the supporting functions in PDF::API2::Basic::*. * The undocumented textstate2 method has been removed from PDF::API2::Content. * Fix create_egs call in Lite.pm * Fix string interpolation in pdf-merge.pl * Fix an error in the synopsis * Fix rename of .cmap files so that they actually work now. * The test suite has grown to nearly 200 tests, covering about 40% of the codebase. There's still plenty of room for improvement.
Revision 1.9 / (download) - annotate - [select for diffs], Wed Aug 5 10:55:55 2009 UTC (14 years, 1 month ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2011Q1-base,
pkgsrc-2011Q1,
pkgsrc-2010Q4-base,
pkgsrc-2010Q4,
pkgsrc-2010Q3-base,
pkgsrc-2010Q3,
pkgsrc-2010Q2-base,
pkgsrc-2010Q2,
pkgsrc-2010Q1-base,
pkgsrc-2010Q1,
pkgsrc-2009Q4-base,
pkgsrc-2009Q4,
pkgsrc-2009Q3-base,
pkgsrc-2009Q3
Changes since 1.8: +4 -4
lines
Diff to previous 1.8 (colored)
Changes 0.73: * Bug fixes.
Revision 1.8 / (download) - annotate - [select for diffs], Sun Jan 11 16:01:29 2009 UTC (14 years, 8 months ago) by he
Branch: MAIN
CVS Tags: pkgsrc-2009Q2-base,
pkgsrc-2009Q2,
pkgsrc-2009Q1-base,
pkgsrc-2009Q1
Changes since 1.7: +4 -4
lines
Diff to previous 1.7 (colored)
Update from version 0.72 to 0.72.003. Upstream changes: No change log available (lazy bums!). Judging from the diff they are minor.
Revision 1.7 / (download) - annotate - [select for diffs], Tue Nov 18 17:28:29 2008 UTC (14 years, 10 months ago) by he
Branch: MAIN
CVS Tags: pkgsrc-2008Q4-base,
pkgsrc-2008Q4
Changes since 1.6: +4 -4
lines
Diff to previous 1.6 (colored)
Updated from version 0.71.001nb1 to 0.72. Pkgsrc changes: o Tweak MASTER_SITES so that the distfile is found Upstream changes: No change log available. From looking at the diff and the RT database: o Improve forward compatibility with perl 5.10.0 maintenance releases (RT #39875?) o fixed [rt.cpan.org #40648] Unicode text prints text on top of text before it
Revision 1.6 / (download) - annotate - [select for diffs], Mon Aug 11 13:22:34 2008 UTC (15 years, 1 month ago) by he
Branch: MAIN
CVS Tags: pkgsrc-2008Q3-base,
pkgsrc-2008Q3,
cube-native-xorg-base,
cube-native-xorg
Changes since 1.5: +4 -4
lines
Diff to previous 1.5 (colored)
Update from version 0.69 to 0.71.001. The upstream package does not have a change log, and there is already an open RT ticket for this problem as well. A diff doesn't reveal anything which appears to be earth-shattering.
Revision 1.5 / (download) - annotate - [select for diffs], Wed Feb 6 20:13:57 2008 UTC (15 years, 7 months ago) by heinz
Branch: MAIN
CVS Tags: pkgsrc-2008Q2-base,
pkgsrc-2008Q2,
pkgsrc-2008Q1-base,
pkgsrc-2008Q1,
cwrapper
Changes since 1.4: +4 -4
lines
Diff to previous 1.4 (colored)
Updated to version 0.69. Pkgsrc changes: - List version independent HOMEPAGE. - The package supports installation to DESTDIR. - The module needs at least Compress::Zlib 1.0. Changes since version 0.65: =========================== not provided.
Revision 1.4 / (download) - annotate - [select for diffs], Sat Oct 13 11:57:38 2007 UTC (15 years, 11 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2007Q4-base,
pkgsrc-2007Q4
Changes since 1.3: +4 -4
lines
Diff to previous 1.3 (colored)
Changes 0.65: * Bug fixes
Revision 1.3 / (download) - annotate - [select for diffs], Sat Feb 4 02:18:04 2006 UTC (17 years, 7 months ago) by ben
Branch: MAIN
CVS Tags: pkgsrc-2007Q3-base,
pkgsrc-2007Q3,
pkgsrc-2007Q2-base,
pkgsrc-2007Q2,
pkgsrc-2007Q1-base,
pkgsrc-2007Q1,
pkgsrc-2006Q4-base,
pkgsrc-2006Q4,
pkgsrc-2006Q3-base,
pkgsrc-2006Q3,
pkgsrc-2006Q2-base,
pkgsrc-2006Q2,
pkgsrc-2006Q1-base,
pkgsrc-2006Q1
Changes since 1.2: +4 -4
lines
Diff to previous 1.2 (colored)
Update PDF-API2 to version 0.51. The API is not backward compatible with the previous version of this package. Over the last several years, there have been too many changes and fixes to list here.
Revision 1.2 / (download) - annotate - [select for diffs], Thu Feb 24 14:48:44 2005 UTC (18 years, 7 months ago) by agc
Branch: MAIN
CVS Tags: pkgsrc-2005Q4-base,
pkgsrc-2005Q4,
pkgsrc-2005Q3-base,
pkgsrc-2005Q3,
pkgsrc-2005Q2-base,
pkgsrc-2005Q2,
pkgsrc-2005Q1-base,
pkgsrc-2005Q1
Changes since 1.1: +2 -1
lines
Diff to previous 1.1 (colored)
Add RMD160 digests to the SHA1 ones.
Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Wed Nov 28 12:11:12 2001 UTC (21 years, 9 months ago) by martti
Branch: TNF
CVS Tags: pkgviews-base,
pkgviews,
pkgsrc-base,
pkgsrc-2004Q4-base,
pkgsrc-2004Q4,
pkgsrc-2004Q3-base,
pkgsrc-2004Q3,
pkgsrc-2004Q2-base,
pkgsrc-2004Q2,
pkgsrc-2004Q1-base,
pkgsrc-2004Q1,
pkgsrc-2003Q4-base,
pkgsrc-2003Q4,
netbsd-1-6-RELEASE-base,
netbsd-1-6-1-base,
netbsd-1-6-1,
netbsd-1-6,
netbsd-1-5-PATCH003,
buildlink2-base,
buildlink2
Changes since 1.1: +0 -0
lines
Diff to previous 1.1 (colored)
Added p5-PDF-API2-0.2.0.2 (PR#14144). Changes for PR: - use version 0.2.0.2 - moved pkg/* From DESCR: Perl module for the next generation API for creating and modifing PDFs.
Revision 1.1 / (download) - annotate - [select for diffs], Wed Nov 28 12:11:12 2001 UTC (21 years, 9 months ago) by martti
Branch: MAIN
Initial revision