[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / textproc / namazu2

File: [cvs.NetBSD.org] / pkgsrc / textproc / namazu2 / Attic / Makefile (download)

Revision 1.28, Sat Mar 4 21:30:47 2006 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
Changes since 1.27: +2 -2 lines

Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

# $NetBSD: Makefile,v 1.28 2006/03/04 21:30:47 jlam Exp $

DISTNAME=	namazu-2.0.15
CATEGORIES=	japanese textproc www
MASTER_SITES=	http://www.namazu.org/stable/

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://www.namazu.org/index.html.en
COMMENT=	Full-text search system intended for easy use

DEPENDS+=	p5-File-MMagic>=1.09:../../misc/p5-File-MMagic
DEPENDS+=	p5-Text-Kakasi>=1.04:../../textproc/p5-Text-Kakasi
DEPENDS+=	p5-nkf>=1.7:../../converters/p5-nkf
DEPENDS+=	p5-Text-ChaSen>=1.0:../../textproc/p5-Text-ChaSen

CONFLICTS+=	namazu-[0-9]*

USE_PKGLOCALEDIR=	yes
USE_TOOLS+=		perl:run
GNU_CONFIGURE=		yes
USE_LANGUAGES=		c
USE_LIBTOOL=		yes
TEST_TARGET=		check
LTCONFIG_OVERRIDE+=	${WRKSRC}/ltconfig

CONFIGURE_ARGS+= 	--localstatedir=${DATADIR:Q} \
			--libexecdir=${PREFIX}/libexec/cgi-bin \
			--sysconfdir=${PKG_SYSCONFBASE:Q}

DATADIR=		${PREFIX}/libdata
EXAMPLESDIR=		${PREFIX}/share/examples/namazu
EXAMPLES=		mknmzrc namazurc

.include "../../mk/bsd.prefs.mk"

PKG_SYSCONFSUBDIR?=	namazu
.for f in ${EXAMPLES}
CONF_FILES+=		${EXAMPLESDIR}/${f}	${PKG_SYSCONFDIR}/${f}
.endfor
MAKE_DIRS+=		${DATADIR}/namazu/index
OWN_DIRS+=		${PKG_SYSCONFDIR} ${DATADIR}/namazu

post-install:
	${INSTALL_DATA_DIR} ${DATADIR}/namazu
	${INSTALL_DATA_DIR} ${EXAMPLESDIR}
.for f in ${EXAMPLES}
	cd ${WRKSRC}/conf; ${INSTALL_DATA} ${f}-sample ${EXAMPLESDIR}/${f}
.endfor

.include "../../converters/libiconv/buildlink3.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"