File:  [cvs.NetBSD.org] / pkgsrc / textproc / link-grammar / Makefile.common
Revision 1.1: download - view: text, annotated - select for diffs
Sun Oct 15 06:39:25 2023 UTC (15 months, 3 weeks ago) by ryoon
Branches: MAIN
CVS tags: HEAD
link-grammar: Update to 5.12.3

* Split Makefile into Makefile and Makefile.common to use for
  upcomming py-link-grammar.

Changelog:
Version 5.12.3 (24 March 2023)
 * Assorted Atomese fixes.
 * Fix SAT-solver build breaks.
 * Add dictionary flag to disable built-in capitlization rules. #1468

Version 5.12.2 (9 March 2023)
 * Fix null-pointer deref in Atomese code.

Version 5.12.1 (5 March 2023)
 * Assorted enhancements and fixes for the AtomSpace dictionary. #1362
 * Fix missing HAVE_THREADS_H, affects Apple Homebrew. #1363
 * Fix regex thread-safety issue. #1370
 * Disable aspell; it leaks memory. #1373
 * Deduplicate linkages when overflow forces random selection. #1378 #1396
 * Fix direct dialect settings on connectors. #1382
 * Cleanup dictionary backends. #1391 thru #1395
 * English dict: paraphrasing fixes. #1398
 * Report CPU time usage only for the current thread. #1399
 * Extensive performance optimizations for MST dictionaries. #1402
 * Remove old broken max-cost computations. #1456

Version 5.12.0 (26 Nov 2022)
 * Fix crash when using the Atomese dictionary backend.
 * Fix generation tokenization bug when dict has no unknown word token.
 * Major Atomese dictionary extensions, including generation support.
 * Minor tweaks to `any` uniform random parse tree language.
 * Include U+202F NARROW NO-BREAK SPACE as a space character.
 * Fix the various regexes so that they're thread-safe! #1354
 * Maybe(?) fix FreeBSD missing -lstdthreads #1355

Version 5.11.0 (27 Sept 2022)
 * Prototype support for dictionary in the AtomSpace.
 * English dict: assorted missing nouns, verbs. #1289
 * Performance improvements. #1309
 * Fix Windows build break in 5.10.4, 5.10.5 fixed in #1313
 * Fix "amy" language #1312
 * Fix multilib systems, e.g. elf32-i386 #1314
 * Corrected grapheme support for random morpheme sampling. #1315
 * Thai language dictionary updates #1322
 * Punctuation fixes #1331
 * Affixes can now be specified with regexes #1334
 * The regex library PCRE2 is required by default.

# $NetBSD: Makefile.common,v 1.1 2023/10/15 06:39:25 ryoon Exp $
#
# used by textproc/link-grammar/Makefile
# used by textproc/py-link-grammar/Makefile

DISTNAME=	link-grammar-5.12.3
MASTER_SITES=	https://www.abisource.com/downloads/link-grammar/${PKGVERSION_NOREV}/

HOMEPAGE=	https://www.abisource.com/projects/link-grammar/
LICENSE=	modified-bsd AND gnu-lgpl-v2.1

DISTINFO_FILE=	${.CURDIR}/../link-grammar/distinfo
FILESDIR=	${.CURDIR}/../link-grammar/files
PATCHDIR=	${.CURDIR}/../link-grammar/patches

USE_LANGUAGES=	c99 c++
USE_LIBTOOL=	yes
USE_TOOLS+=	gmake pkg-config
GNU_CONFIGURE=	yes

CONFIGURE_ARGS+=	--disable-java-bindings

# Not all currently supported compilers provide this option.
# The configure script purports to check whether the compiler
# supports it, but doesn't do so correctly.
BUILDLINK_TRANSFORM+=	rm:-Wformat-signedness

.include "../../devel/pcre2/buildlink3.mk"

CVSweb <webmaster@jp.NetBSD.org>