[BACK]Return to PLIST CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / textproc / libxslt

File: [cvs.NetBSD.org] / pkgsrc / textproc / libxslt / PLIST (download)

Revision 1.42, Thu Oct 13 11:22:24 2022 UTC (17 months, 2 weeks ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, HEAD
Changes since 1.41: +50 -84 lines

{py-,}libxslt: update to 1.1.37

v1.1.37: Aug 29 2022

### Improvements

- Don't use deprecated libxml2 macros
- Don't mess with xmlDefaultSAXHandler

### Build system

- Require automake-1.16.3 or later
- Remove generated files from distribution
- Add missing compile definition for static builds to Autotools (Mike Dalessio)


v1.1.36: Aug 17 2022

### Removals and deprecations

- Remove SVN keyword anchors
- Remove CVS and SVN-related code
- Remove README.cvs-commits
- Remove ChangeLog
- Remove xsltwin32config.h

### Improvements

- Simplify xsltexports.h and exsltexports.h
- Don't overlink executables with gcrypt
- Fix quadratic behavior with variables and parameters
- Remove case labels with XPointer location types
- Add configure~ to .gitignore
- Stop calling deprecated libxml2 functions

### Portability

- Use portable python shebangs (David Seifert)
- Remove useless __CYGWIN__ checks
- Remove cruft from win32config.h
- crypto.c: Silence a compiler warning on Windows (Chun-wei Fan)

### Build system

- Add missing compile definition for static builds to CMake
- Avoid obsolescent `test -a` constructs (David Seifert)
- Only link libxml2 statically in purely static build
- Set AC_CONFIG_MACRO_DIR
- Allow AM_MAINTAINER_MODE to be disabled
- Streamline and fix documentation installation
- Don't try to recreate COPYING symlink
- Remove special configuration for certain maintainers
- configure.ac: produce tar.xz only (GNOME policy) (David Seifert)
- Detect libm using libtool's macros (David Seifert)
- configure.ac: disable static libraries by default (David Seifert)
- python/Makefile.am: nest python docs in $(docdir) (David Seifert)
- python/Makefile.am: rely on global AM_INIT_AUTOMAKE (David Seifert)
- configure.ac: remove useless AC_SUBST (David Seifert)
- Use AM_PATH_PYTHON/PKG_CHECK_MODULES for python bindings (David Seifert)
- Change libxml2 Python config
- Don't check for standard C89 library functions
- Don't check for standard C89 headers
- Remove --with-html-dir option
- Also check for glibtoolize in autogen.sh
- Rework documentation build system
- Remove old website
- CMake: Relax check for enabling crypto support on Windows (Chun-wei Fan)
- Remove obsolete AC_HEADER_STDC autoconf macro (Vadim Zeitlin)
- Remove special configuration for old maintainers

### Test suite, CI

- Remove test involving XPointer range-to function
- Test recursion in EXSLT dynamic functions
- Add CI job for static build

### Documentation

- Move tutorial images


v1.1.35: Feb 16 2022:
   - Security:
  [CVE-2021-30560] Fix use-after-free in xsltApplyTemplates
  Fix memory leak in xsltDocumentElem (David King)
  Fix memory leak in xsltCompileIdKeyPattern (David King)
  Fix double-free with stylesheets containing entity nodes

   - Fixed regressions:
  Fix performance regression with predicates in patterns
  Fix regression in xsltComputeSortResult

   - Bug fixes:
  Fix conflict resolution for templates with same priority
  Fix xsl:number generating invalid UTF-8
  Support attribute value templates in xsl:sort lang attributes
  Don't pass first <xsl:sort> in <xsl:apply-templates> twice
  Fix quadratic runtime with text and <xsl:message>
  Don't allow empty EXSLT durations

   - Improvements:
  Add xsltproc --huge Argument via libxml XML_PARSE_HUGE (William N. Braswell, Jr.)

   - Tests, code quality, fuzzing:
  Remove .travis.yml
  Fix some misleading indentation (David King)
  Use actual types for templates in struct _xsltStylesheet
  Add CI for CMake on MSVC (Markus Rickert)
  Check for null pointer before calling freelocale
  Add CI test for Python 3
  Don't set maxDepth in XPath contexts
  Transfer XPath limits to XPtr context
  Stop using maxParserDepth XPath limit
  Make long-to-double cast explicit in date.c
  Disable LeakSanitizer
  Run clang CI tests with -Wimplicit-int-conversion
  Fix implicit-int-conversion warning in exslt/crypto.c
  Fix clang -Wimplicit-int-conversion warning (David Kilzer)
  Fix clang -Wconditional-uninitialized warning in libxslt/numbers.c (David Kilzer)
  Fix -Wshadow warnings in libexslt/dynamic.c (David Kilzer)
  Also search parent dir for source XML when fuzzing

   - Build system, portability:
  Add CMake build files (Markus Rickert)
  Initial support for Python 3 (Suleyman Poyraz)
  Call ANSI versions of WinAPI functions explicitly
  Remove redundant flags from pkg-config files
  Suppress automake warning in tests/XSLTMark
  Fix linking libexslt dynamic library when using MinGW (Vadim Zeitlin)
  Added platform specific path separators (Dmitriy Korovkin)
  win32: allow passing *FLAGS on command line
  Fix export of xsltExtMarker on Windows (David Kilzer)
  Fix redundant includes already in libexslt.h (David Kilzer)
  Minor fixes to configure.js
  Fix variable syntax in Python configuration
  Add new EXSLT string tests to EXTRA_DIST
  Fix xml2-config check in configure script
  win32: Add configuration for profiler (Chun-wei Fan)
  Check whether 'xml2-config --dynamic' is supported

   - Documentation:
  Add Makefile rule to regenerate xsltproc.html
  Update links
  Remove MAINTAINERS
  Upload documentation to GitLab Pages
  Add documentation in devhelp format
  Add --enable-rebuild-docs configure option
  Fix libexslt header summaries
  Fix validity of tutorial XML (David King)
  Use DocBook URL for tutorial DTD (David King)
  Update libxslt.doap
  Add missing options to xsltproc man page

@comment $NetBSD: PLIST,v 1.42 2022/10/13 11:22:24 wiz Exp $
bin/xslt-config
bin/xsltproc
include/libexslt/exslt.h
include/libexslt/exsltconfig.h
include/libexslt/exsltexports.h
include/libxslt/attributes.h
include/libxslt/documents.h
include/libxslt/extensions.h
include/libxslt/extra.h
include/libxslt/functions.h
include/libxslt/imports.h
include/libxslt/keys.h
include/libxslt/namespaces.h
include/libxslt/numbersInternals.h
include/libxslt/pattern.h
include/libxslt/preproc.h
include/libxslt/security.h
include/libxslt/templates.h
include/libxslt/transform.h
include/libxslt/variables.h
include/libxslt/xslt.h
include/libxslt/xsltInternals.h
include/libxslt/xsltconfig.h
include/libxslt/xsltexports.h
include/libxslt/xsltlocale.h
include/libxslt/xsltutils.h
lib/cmake/libxslt/FindGcrypt.cmake
lib/cmake/libxslt/libxslt-config.cmake
lib/libexslt.la
lib/libxslt.la
lib/pkgconfig/libexslt.pc
lib/pkgconfig/libxslt.pc
lib/xsltConf.sh
man/man1/xsltproc.1
man/man3/libexslt.3
man/man3/libxslt.3
share/aclocal/libxslt.m4
share/doc/libxslt/tutorial/images/callouts/1.png
share/doc/libxslt/tutorial/images/callouts/10.png
share/doc/libxslt/tutorial/images/callouts/2.png
share/doc/libxslt/tutorial/images/callouts/3.png
share/doc/libxslt/tutorial/images/callouts/4.png
share/doc/libxslt/tutorial/images/callouts/5.png
share/doc/libxslt/tutorial/images/callouts/6.png
share/doc/libxslt/tutorial/images/callouts/7.png
share/doc/libxslt/tutorial/images/callouts/8.png
share/doc/libxslt/tutorial/images/callouts/9.png
share/doc/libxslt/tutorial/libxslt_tutorial.c
share/doc/libxslt/tutorial/libxslttutorial.html
share/doc/libxslt/tutorial2/libxslt_pipes.c
share/doc/libxslt/tutorial2/libxslt_pipes.html
share/doc/libxslt/xsltproc.html
share/gtk-doc/html/libexslt/general.html
share/gtk-doc/html/libexslt/home.png
share/gtk-doc/html/libexslt/index.html
share/gtk-doc/html/libexslt/left.png
share/gtk-doc/html/libexslt/libexslt-exslt.html
share/gtk-doc/html/libexslt/libexslt-exsltexports.html
share/gtk-doc/html/libexslt/libexslt.devhelp2
share/gtk-doc/html/libexslt/right.png
share/gtk-doc/html/libexslt/style.css
share/gtk-doc/html/libexslt/up.png
share/gtk-doc/html/libxslt/general.html
share/gtk-doc/html/libxslt/home.png
share/gtk-doc/html/libxslt/index.html
share/gtk-doc/html/libxslt/left.png
share/gtk-doc/html/libxslt/libxslt-attributes.html
share/gtk-doc/html/libxslt/libxslt-documents.html
share/gtk-doc/html/libxslt/libxslt-extensions.html
share/gtk-doc/html/libxslt/libxslt-extra.html
share/gtk-doc/html/libxslt/libxslt-functions.html
share/gtk-doc/html/libxslt/libxslt-imports.html
share/gtk-doc/html/libxslt/libxslt-keys.html
share/gtk-doc/html/libxslt/libxslt-namespaces.html
share/gtk-doc/html/libxslt/libxslt-numbersInternals.html
share/gtk-doc/html/libxslt/libxslt-pattern.html
share/gtk-doc/html/libxslt/libxslt-preproc.html
share/gtk-doc/html/libxslt/libxslt-security.html
share/gtk-doc/html/libxslt/libxslt-templates.html
share/gtk-doc/html/libxslt/libxslt-transform.html
share/gtk-doc/html/libxslt/libxslt-variables.html
share/gtk-doc/html/libxslt/libxslt-xslt.html
share/gtk-doc/html/libxslt/libxslt-xsltInternals.html
share/gtk-doc/html/libxslt/libxslt-xsltexports.html
share/gtk-doc/html/libxslt/libxslt-xsltlocale.html
share/gtk-doc/html/libxslt/libxslt-xsltutils.html
share/gtk-doc/html/libxslt/libxslt.devhelp2
share/gtk-doc/html/libxslt/right.png
share/gtk-doc/html/libxslt/style.css
share/gtk-doc/html/libxslt/up.png
@pkgdir lib/libxslt-plugins