The NetBSD Project

CVS log for pkgsrc/textproc/libxslt/Makefile.common

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / textproc / libxslt

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.8 / (download) - annotate - [select for diffs], Wed May 17 23:35:45 2023 UTC (4 months, 2 weeks ago) by gutteridge
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, HEAD
Changes since 1.7: +2 -2 lines
Diff to previous 1.7 (colored)

libxslt & py-libxslt: update to 1.1.38

### Major changes

About 40 memory errors in code paths handling malloc failures have been fixed.
While these issues shouldn't impact security, this improves robustness under
memory pressure.

The result of generate-id() is now deterministic across multiple
transformations fixing many issues with reproducible builds.

Most of the test suite has been ported to C.

### Bug fixes

- Fix memory errors in code handling malloc failures
- imports: Fix import/include cycle check
- xsltlocale: Fix xsltNewLocale on macOS
- Make xsl:sort thread-safe
- Make generate-id() deterministic

### Improvements

- Stop using xmlStringCurrentChar
- attributes.h needs to include xsltInternals.h (David Kilzer)
- transform: Avoid null deref on documents without root node
- numbers: Fix floating point overflows
- date: Fix integer overflow in exsltDateFormatDuration
- numbers: Fix harmless integer sign change
- date: Add more overflow checks to formatting code (David Kilzer)
- date: Fix rounding to make Windows tests pass
- date: Rewrite duration and seconds formatting
- xsltlocale: Make API platform-independent
- Also accept application/xslt+xml media type in stylesheet PIs
- warnings: Fix strict prototypes warning
- xsltEvalUserParams() and xsltQuoteUserParams() are susceptible to integer
  overflow when iterating through const char** array (David Kilzer)
- xslt: Return NULL stylesheet on attribute set errors
- xsltproc: Fix unused variable warning
- xslt: Remove declaration for old libxml2
- Fix various compiler warnings
- Fix compiler warnings in xsltGenerateIdFunction
- Disable Python bindings for debugger
- Don't declare disabled functions
- Migrate from PyEval_ to PyObject_

### Build system

- cmake: Use version script
- autotools: Link with --undefined-version
- win32: Remove broken libxslt.def.src
- Stop updating version script
- add support for Windows time functions (Rosen Penev)
- cmake: link against libm on UNIX systems (Alex Richardson)
- build: Add a distutils-based build system for the Python bits (Chun-wei Fan)
- CMake: Relax check for Python 3.x support on Windows (Chun-wei Fan)
- python/types.c: Fix building against older libxml2 (Chun-wei Fan)
- python/libxslt.c: Replace ssize_t with Py_ssize_t (Chun-wei Fan)
- cmake: Fix build with libxslt and libxml2 as subprojects
- cmake: Set SOVERSION
- cmake: Extract version from configure.ac
- Fix classic Windows configuration for libexslt (Christoph M. Becker)
- autotools: Fix Python tests in VPATH builds
- autotools: Disable parallel Python build
- autotools: Use AM_CFLAGS consistently
- autotools: Link with -no-undefined
- cmake: Fix Python installation
- cmake: Don't check for Python 2
- python: Don't output missing generators during build
- python: Create .pyd on Windows
- python: Fix build on Windows
- python: Support Python 3 on Windows
- cmake: Enable GCC compiler warnings
- Update GCC compiler warnings

### Tests

- python: Remove temp file when running tests/basic.py
- fuzz: Improve fuzzers
- xsltlocale: Add test
- gitlab-ci: Reenable MSan and LeakSanitizer
- tests: Remove unused files
- tests: Enable runtest.exe under MSVC
- tests: Fix LIBXSLT_PLUGINS_PATH for multi-config CMake
- tests: Remove unused leak statistics
- tests: Skip some tests if iconv/ICU is disabled
- gitlab-ci: Run Autotools tests with out-of-tree (VPATH) builds
- tests: Port most of the test suite to C
- tests: Fix out-of-tree Python tests
- tests: Fix source directory for reports tests
- gitlab-ci: Consolidate CMake test scripts
- gitlab-ci: Only install cmake MinGW package if needed
- gitlab-ci: Install 7-Zip using the .msi
- gitlab-ci: Add CI job for MinGW/Autotools
- gitlab-ci: Disable MSan for now
- Run CI tests with -fsanitize=integer
- Fix EXSLT functions tests when libxml2 is built --without-debug
- Make CI tests exit on failure
- Run Python 3 CI job with minimal configuration
- Set library path when running Python tests

### Documentation

- doc: Remove unused cross-reference data
- doc: Update apibuild.py

Revision 1.7 / (download) - annotate - [select for diffs], Thu Oct 13 11:22:24 2022 UTC (11 months, 2 weeks ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4
Changes since 1.6: +6 -6 lines
Diff to previous 1.6 (colored)

{py-,}libxslt: update to 1.1.37

v1.1.37: Aug 29 2022

### Improvements

- Don't use deprecated libxml2 macros
- Don't mess with xmlDefaultSAXHandler

### Build system

- Require automake-1.16.3 or later
- Remove generated files from distribution
- Add missing compile definition for static builds to Autotools (Mike Dalessio)


v1.1.36: Aug 17 2022

### Removals and deprecations

- Remove SVN keyword anchors
- Remove CVS and SVN-related code
- Remove README.cvs-commits
- Remove ChangeLog
- Remove xsltwin32config.h

### Improvements

- Simplify xsltexports.h and exsltexports.h
- Don't overlink executables with gcrypt
- Fix quadratic behavior with variables and parameters
- Remove case labels with XPointer location types
- Add configure~ to .gitignore
- Stop calling deprecated libxml2 functions

### Portability

- Use portable python shebangs (David Seifert)
- Remove useless __CYGWIN__ checks
- Remove cruft from win32config.h
- crypto.c: Silence a compiler warning on Windows (Chun-wei Fan)

### Build system

- Add missing compile definition for static builds to CMake
- Avoid obsolescent `test -a` constructs (David Seifert)
- Only link libxml2 statically in purely static build
- Set AC_CONFIG_MACRO_DIR
- Allow AM_MAINTAINER_MODE to be disabled
- Streamline and fix documentation installation
- Don't try to recreate COPYING symlink
- Remove special configuration for certain maintainers
- configure.ac: produce tar.xz only (GNOME policy) (David Seifert)
- Detect libm using libtool's macros (David Seifert)
- configure.ac: disable static libraries by default (David Seifert)
- python/Makefile.am: nest python docs in $(docdir) (David Seifert)
- python/Makefile.am: rely on global AM_INIT_AUTOMAKE (David Seifert)
- configure.ac: remove useless AC_SUBST (David Seifert)
- Use AM_PATH_PYTHON/PKG_CHECK_MODULES for python bindings (David Seifert)
- Change libxml2 Python config
- Don't check for standard C89 library functions
- Don't check for standard C89 headers
- Remove --with-html-dir option
- Also check for glibtoolize in autogen.sh
- Rework documentation build system
- Remove old website
- CMake: Relax check for enabling crypto support on Windows (Chun-wei Fan)
- Remove obsolete AC_HEADER_STDC autoconf macro (Vadim Zeitlin)
- Remove special configuration for old maintainers

### Test suite, CI

- Remove test involving XPointer range-to function
- Test recursion in EXSLT dynamic functions
- Add CI job for static build

### Documentation

- Move tutorial images


v1.1.35: Feb 16 2022:
   - Security:
  [CVE-2021-30560] Fix use-after-free in xsltApplyTemplates
  Fix memory leak in xsltDocumentElem (David King)
  Fix memory leak in xsltCompileIdKeyPattern (David King)
  Fix double-free with stylesheets containing entity nodes

   - Fixed regressions:
  Fix performance regression with predicates in patterns
  Fix regression in xsltComputeSortResult

   - Bug fixes:
  Fix conflict resolution for templates with same priority
  Fix xsl:number generating invalid UTF-8
  Support attribute value templates in xsl:sort lang attributes
  Don't pass first <xsl:sort> in <xsl:apply-templates> twice
  Fix quadratic runtime with text and <xsl:message>
  Don't allow empty EXSLT durations

   - Improvements:
  Add xsltproc --huge Argument via libxml XML_PARSE_HUGE (William N. Braswell, Jr.)

   - Tests, code quality, fuzzing:
  Remove .travis.yml
  Fix some misleading indentation (David King)
  Use actual types for templates in struct _xsltStylesheet
  Add CI for CMake on MSVC (Markus Rickert)
  Check for null pointer before calling freelocale
  Add CI test for Python 3
  Don't set maxDepth in XPath contexts
  Transfer XPath limits to XPtr context
  Stop using maxParserDepth XPath limit
  Make long-to-double cast explicit in date.c
  Disable LeakSanitizer
  Run clang CI tests with -Wimplicit-int-conversion
  Fix implicit-int-conversion warning in exslt/crypto.c
  Fix clang -Wimplicit-int-conversion warning (David Kilzer)
  Fix clang -Wconditional-uninitialized warning in libxslt/numbers.c (David Kilzer)
  Fix -Wshadow warnings in libexslt/dynamic.c (David Kilzer)
  Also search parent dir for source XML when fuzzing

   - Build system, portability:
  Add CMake build files (Markus Rickert)
  Initial support for Python 3 (Suleyman Poyraz)
  Call ANSI versions of WinAPI functions explicitly
  Remove redundant flags from pkg-config files
  Suppress automake warning in tests/XSLTMark
  Fix linking libexslt dynamic library when using MinGW (Vadim Zeitlin)
  Added platform specific path separators (Dmitriy Korovkin)
  win32: allow passing *FLAGS on command line
  Fix export of xsltExtMarker on Windows (David Kilzer)
  Fix redundant includes already in libexslt.h (David Kilzer)
  Minor fixes to configure.js
  Fix variable syntax in Python configuration
  Add new EXSLT string tests to EXTRA_DIST
  Fix xml2-config check in configure script
  win32: Add configuration for profiler (Chun-wei Fan)
  Check whether 'xml2-config --dynamic' is supported

   - Documentation:
  Add Makefile rule to regenerate xsltproc.html
  Update links
  Remove MAINTAINERS
  Upload documentation to GitLab Pages
  Add documentation in devhelp format
  Add --enable-rebuild-docs configure option
  Fix libexslt header summaries
  Fix validity of tutorial XML (David King)
  Use DocBook URL for tutorial DTD (David King)
  Update libxslt.doap
  Add missing options to xsltproc man page

Revision 1.6 / (download) - annotate - [select for diffs], Wed Nov 6 13:23:45 2019 UTC (3 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4
Changes since 1.5: +2 -2 lines
Diff to previous 1.5 (colored)

libxslt: update to 1.1.34.

The release is out, includes a number of bug fixes and portability
patches.  Some improvement about enabling fuzzers and removings
some of the issues found, some having security implications, users
are invited to upgrade.

Documentation:
- Fix EXSLT web pages (Nick Wellnhofer)
- Regenerate web pages (Nick Wellnhofer)
- Fix Git link in news.html (Nick Wellnhofer)
- Minor documentation fixes after recent changes (Nick Wellnhofer)
- Fix typos (Jan Pokorný)
- Regenerate symbols and API docs (Nick Wellnhofer)
- Regenerate EXSLT website (Nick Wellnhofer)

Portability:
- Remove stubs when compiling without debugger or profiler (Nick Wellnhofer)
- configure.ac: Invoke PKG_CHECK_MODULES for building shared libraries (Hugh McMaster)
- configure.ac: Conditionally determine whether xml2-config should pass shared libraries or static libraries
(Hugh McMaster)
- xslt-config.in: Fix broken --prefix=DIR support (Hugh McMaster)
- libexslt.pc.in: Do not expose private library  dependencies unless invoked (Hugh McMaster)
- libxslt.pc.in: Do not expose private library dependencies  unless invoked (Hugh McMaster)
- Fix -Wformat-overflow warning (GCC 9) (Nick Wellnhofer)
- Stop including ansidecl.h (Nick Wellnhofer)
- Remove WIN32_EXTRA_* variables (Nick Wellnhofer)
- Fix vsnprintf in Python bindings on Windows (Nick Wellnhofer)
- Build without winsock (Nick Wellnhofer)
- Stop redefining snprintf on MinGW (Nick Wellnhofer)

Bug Fixes:
- xsl:template without name and match attributes should not be allowed (Nikolai Weibull)
- Make sure that Python tests exit with error code (Nick Wellnhofer)
- Improve handling of invalid UTF-8 in format-number (Nick Wellnhofer)
- Fix dangling pointer in xsltCopyText (Nick Wellnhofer)
- Fix memory leak in pattern compilation error path (Nick Wellnhofer)
- Fix uninitialized read with UTF-8 grouping chars (Nick Wellnhofer)
- Fix integer overflow in FORMAT_GYEAR (Nick Wellnhofer)
- Fix performance regression with xsl:number (Nick Wellnhofer)
- Backup XPath context node in xsltInitCtxtKey (Nick Wellnhofer)
- Fix unsigned integer overflow in date.c (Nick Wellnhofer)
- Fix insertion of xsl:fallback content (Nick Wellnhofer)
- Avoid quadratic behavior in xsltSaveResultTo (Nick Wellnhofer)
- Fix numbering in non-Latin scripts (Nick Wellnhofer)
- Fix uninitialized read of xsl:number token (Nick Wellnhofer)
- Fix integer overflow in _exsltDateDayInWeek (Nick Wellnhofer)
- Rework xsltAttrVT allocation (Nick Wellnhofer)
- Fix check of xsltTestCompMatch return value (Nick Wellnhofer)
- Fix security framework bypass (Nick Wellnhofer)
- Use xmlNewTextChild in EXSLT dyn:map (Nick Wellnhofer)
- Fix float casts in exsltDateDuration (Nick Wellnhofer)
- Always set context node before calling XPath iterators (Nick Wellnhofer)
- Fix attribute precedence with xsl:use-attribute-sets (Nick Wellnhofer)
- Backup context node in exsltFuncFunctionFunction (Nick Wellnhofer)
- Initialize ctxt->output before evaluating global vars (Nick Wellnhofer)
- Fix memory leak in EXSLT functions error path (Nick Wellnhofer)

Improvements:
- Enable continuous integration via GitLab CI (Nick Wellnhofer)
- Fix -Wimplicit-fallthrough warnings (Nick Wellnhofer)
- Adjust number of API index pages (Nick Wellnhofer)
- Make xsltCompileRelativePathPattern non-recursive (Nick Wellnhofer)
- Check that crypto:rc4_decrypt produces valid UTF-8 (Nick Wellnhofer)
- Avoid recursion in keys.c:skipPredicate (Nick Wellnhofer)
- xslt-config.in: Simply handling of $all_flags (Hugh McMaster)
- xslt-config.in: Add a --dynamic option to --libs (Hugh McMaster)
- xslt-config.in: Simplify basic library handling (Hugh McMaster)
- xslt-config.in: Remove unused variable (Hugh McMaster)
- xslt-config: Simply handling of --cflags (Hugh McMaster)
- Add Travis test with MemorySanitizer (Nick Wellnhofer)
- Run Travis ASan tests under Xenial (Nick Wellnhofer)
- Improve fuzzers (Nick Wellnhofer)
- Always reuse XPath context (Nick Wellnhofer)
- Compile with -Wextra (Nick Wellnhofer)
- Make profiler support optional (Nick Wellnhofer)
- Hide unused code when compiling without debugger (Nick Wellnhofer)
- Reorganize fuzzing code (Nick Wellnhofer)
- Simplify .gitignore (Nick Wellnhofer)
- Optional operation limit (Nick Wellnhofer)
- Improve seed corpus and dictionary (Nick Wellnhofer)
- Reuse XPath context when compiling stylesheets (Nick Wellnhofer)
- Reuse XPath context in dyn:map (Nick Wellnhofer)
- Reuse XPath context in saxon:expression (Nick Wellnhofer)
- Add libFuzzer targets (Nick Wellnhofer)
- Adjust error message in expected test output (Nick Wellnhofer)
- Change bug tracker URL (Nick Wellnhofer)
- Change git repo URL (Nick Wellnhofer)
- Regenerate NEWS (Nick Wellnhofer)
- Fix misleading indentation in security.c (Nick Wellnhofer)

Cleanups:
- Remove empty TODO file (Nick Wellnhofer)
- Remove generated file libxsltclass.txt from version control (Nick Wellnhofer)
- Rebuild docs (Nick Wellnhofer)

Thanks to Nick and everybody who helped to build this release!

Revision 1.5 / (download) - annotate - [select for diffs], Wed Jan 9 19:12:14 2019 UTC (4 years, 8 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1
Changes since 1.4: +2 -2 lines
Diff to previous 1.4 (colored)

libxslt: updated to 1.1.33

v1.1.33:
Portability:
Variables need 'extern' in static lib on Cygwin
Really declare dllexport/dllimport for Cygwin
Fix callback signatures in Python bindings
Fix transform callback signatures
Fix extension callback signatures
Fix deallocator signatures
Fix XPath callback signatures
Fix hash callback signatures

Bug Fixes:
Don't cache direct evaluation of patterns with variables
Move function result RVTs to context variable
Fix EXSLT functions returning RVTs from outer scopes
Fix handling of RVTs returned from nested EXSLT functions
Fix typos

Improvements:
Run Travis ASan tests with "sudo: required"

Cleanups:
Remove doc/libxslt-decl.txt
Docs for 1.1.32 release

Revision 1.4 / (download) - annotate - [select for diffs], Thu Nov 23 15:48:10 2017 UTC (5 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4
Changes since 1.3: +2 -2 lines
Diff to previous 1.3 (colored)

libxslt: update to 1.1.32.

1.1.32: Nov 02 2017

  Portability:
  Add missing limits.h include (Nick Wellnhofer),
  Also run Windows tests with --maxdepth 200 (Nick Wellnhofer),
  Disable some MSVC warnings (Nick Wellnhofer),
  Fix deprecated Travis compiler flag (Nick Wellnhofer),
  Run general tests with maxdepth=200 (Nick Wellnhofer),
  Use _WIN32 macro instead of WIN32 (Nick Wellnhofer),
  Fix xsltproc newlines on Windows (Nick Wellnhofer),
  Fix Windows compiler warnings (Nick Wellnhofer),
  Rework locale feature tests (Nick Wellnhofer)


  Improvements:
  Rebuild win32/libxslt.def.src (Nick Wellnhofer),
  Fix compiler warnings in Python bindings (Nick Wellnhofer)


v1.1.31: Oct 06 2017

  Portability:
  Fix win32/configure.js (Nick Wellnhofer)


  Bug Fixes:
  Fix pkg-config related regressions in configure script (Nick Wellnhofer)


  Improvements:
  Adjust expected error output for libxml2 changes (Nick Wellnhofer),
  Misc autoconf updates (Nick Wellnhofer)

Revision 1.3 / (download) - annotate - [select for diffs], Sun Sep 10 20:56:24 2017 UTC (6 years ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2017Q3-base, pkgsrc-2017Q3
Changes since 1.2: +2 -2 lines
Diff to previous 1.2 (colored)

Updated libxslt to 1.1.30.

.1.30: Sep 04 2017
Documentation:
  Misc doc fixes (Nick Wellnhofer)
Portability:
  Look for libxml2 via pkg-config first (Elliott
  Sales de Andrade),
  Change default SOPREFIX on Windows to "bin" (Nick
  Wellnhofer),
  Add WIN32_EXTRA_LDFLAGS to tests/plugins/
  Makefile.am (Michael Haubenwallner)
Bug Fixes:
  Also fix memory hazards in exsltFuncResultElem
  (Nick Wellnhofer),
  Fix NULL deref in xsltDefaultSortFunction (Nick
  Wellnhofer),
  Fix memory hazards in exsltFuncFunctionFunction
  (Nick Wellnhofer),
  Fix memory leaks in EXSLT error paths (Nick
  Wellnhofer),
  Fix memory leak in str:concat with empty node-set
  (Nick Wellnhofer),
  Fix memory leaks in error paths (Nick
  Wellnhofer),
  Switch to xmlUTF8Strsize in numbers.c (Nick
  Wellnhofer),
  Fix NULL pointer deref in
  xsltFormatNumberFunction (Nick Wellnhofer),
  Fix UTF-8 check in str:padding (Nick Wellnhofer),
  Fix xmlStrPrintf argument (Nick Wellnhofer),
  Check for overflow in _exsltDateParseGYear (Nick
  Wellnhofer),
  Fix double to int conversion (Nick Wellnhofer),
  Check for overflow in exsltDateParseDuration
  (Nick Wellnhofer),
  Change version of xsltMaxVars back to 1.0.24
  (Nick Wellnhofer),
  Disable xsltCopyTextString optimization for
  extensions (Nick Wellnhofer),
  Create DOCTYPE for HTML version 5 (Nick
  Wellnhofer),
  Make xsl:decimal-format work with namespaces
  (Nick Wellnhofer),
  Remove norm:localTime extension function (Nick
  Wellnhofer),
  Check for integer overflow in xsltAddTextString
  (Nick Wellnhofer),
  Detect infinite recursion when evaluating
  function arguments (Nick Wellnhofer),
  Fix memory leak in xsltElementAvailableFunction
  (Nick Wellnhofer),
  Fix for pattern predicates calling functions
  (Nick Wellnhofer),
  Fix cmd.exe invocations in Makefile.mingw (Nick
  Wellnhofer),
  Don't try to install index.sgml (Nick
  Wellnhofer),
  Fix symbols.xml (Nick Wellnhofer),
  Fix heap overread in xsltFormatNumberConversion
  (Nick Wellnhofer),
  Fix <xsl:number level="any"/> for non-element
  nodes (Nick Wellnhofer),
  Fix unreachable code in xsltAddChild
  (mahendra.n),
  Change version number in xsl:version warning
  (Nick Wellnhofer),
  Avoid infinite recursion after failed param
  evaluation (Nick Wellnhofer),
  Stop if potential recursion is detected (Nick
  Wellnhofer),
  Consider built-in templates in apply-imports
  (Nick Wellnhofer),
  Fix precedence with multiple attribute sets (Nick
  Wellnhofer),
  Rework attribute set resolution (Nick Wellnhofer)
Improvements:
  Add .travis.yml (Nick Wellnhofer),
  Silence tests a little (Nick Wellnhofer),
  Set LIBXML_SRC to absolute path (Nick
  Wellnhofer),
  Add missing #include (Nick Wellnhofer),
  Adjust expected error messages in tests (Nick
  Wellnhofer),
  Make xsltDebug more quiet (Nick Wellnhofer),
  New-line terminate error message that missed this
  convention (Jan Pokorný),
  Use xmlBuffers in EXSLT string functions (Nick
  Wellnhofer),
  Switch to xmlUTF8Strsize in EXSLT string
  functions (Nick Wellnhofer),
  Check for return value of xmlUTF8Strlen (Nick
  Wellnhofer),
  Avoid double/long round trip in FORMAT_ITEM (Nick
  Wellnhofer),
  Separate date and duration structs (Nick
  Wellnhofer),
  Check for overflow in _exsltDateDifference (Nick
  Wellnhofer),
  Clamp seconds field of durations (Nick
  Wellnhofer),
  Change _exsltDateAddDurCalc parameter types (Nick
  Wellnhofer),
  Fix date:difference with time zones (Nick
  Wellnhofer),
  Rework division/remainder arithmetic in date.c
  (Nick Wellnhofer),
  Remove exsltDateCastDateToNumber (Nick
  Wellnhofer),
  Change internal representation of years (Nick
  Wellnhofer),
  Optimize IS_LEAP (Nick Wellnhofer),
  Link libraries with libm (Jussi Kukkonen),
  Rename xsltCopyTreeInternal to xsltCopyTree (Nick
  Wellnhofer),
  Update linker version script (Nick Wellnhofer),
  Add local wildcard to version script (Nick
  Wellnhofer),
  Make some symbols static (Nick Wellnhofer),
  Remove redundant NULL check in xsltNumberComp
  (mahendra.n),
  Fix forwards compatibility for imported
  stylesheets (Nick Wellnhofer),
  Reduce warnings in forwards-compatible mode (Nick
  Wellnhofer),
  Precompute XSLT elements after preprocessing
  (Nick Wellnhofer),
  Fix whitespace in xsltParseStylesheetTop (Nick
  Wellnhofer),
  Consolidate recursion checks (Nick Wellnhofer),
  Treat XSLT_STATE_STOPPED same as errors (Nick
  Wellnhofer),
  Make sure that XSLT_STATE_STOPPED isn't
  overwritten (Nick Wellnhofer),
  Add comment regarding built-in templates and
  params (Nick Wellnhofer),
  Rewrite memory management of local RVTs (Nick
  Wellnhofer),
  Validate QNames of attribute sets (Nick
  Wellnhofer),
  Add xsl:attribute-set regression tests (Nick
  Wellnhofer),
  Ignore imported stylesheets in
  xsltApplyAttributeSet (Nick Wellnhofer)

Revision 1.2 / (download) - annotate - [select for diffs], Thu Jan 19 18:52:27 2017 UTC (6 years, 8 months ago) by agc
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1
Changes since 1.1: +3 -3 lines
Diff to previous 1.1 (colored)

Convert all occurrences (353 by my count) of

	MASTER_SITES= 	site1 \
			site2

style continuation lines to be simple repeated

	MASTER_SITES+= site1
	MASTER_SITES+= site2

lines. As previewed on tech-pkg. With thanks to rillig for fixing pkglint
accordingly.

Revision 1.1 / (download) - annotate - [select for diffs], Sun May 29 21:06:46 2016 UTC (7 years, 4 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2

Updated libxslt to 1.1.29.

Add Makefile.common for use by py-libxslt.

1.1.29: May 24 2016:
   - Security:
  CVE-2015-7995 Fix for type confusion in preprocessing attributes (Daniel Veillard)

   - Documentation:

   - Portability:
  Fix a portibility problem with previous commit (Eduard Sanou),
  Fix MingW build (Nick Wellnhofer),
  Correctly emulate snprintf on older MSVC versions (Nick Wellnhofer),
  Add Python script to run some tests on Windows (Nick Wellnhofer),
  Remove /OPT:NOWIN98 option (Nick Wellnhofer),
  Visual Studio 14 CTP defines snprintf() (Daniel Veillard),
  Use AC_PATH_TOOL to find libgcrypt-config and xml2-config (MichaGóòny),
  Use $libdir for LIBXSLT_DEFAULT_PLUGINS_PATH (larryhaja),
  Use mkdir macro also in case if mingw32. (Lars Kanis),
  Add math library to executable link flags (Nick Wellnhofer),
  Fix quoting of xlocale test program in configure.in (Nick Wellnhofer)

   - Bug Fixes:
  Fix OOB heap read in xsltExtModuleRegisterDynamic (Nick Wellnhofer),
  Remove CDATA markup from libxslt_tutorial.c (Nick Wellnhofer),
  Remove generated headers from dist tarball (Nick Wellnhofer),
  Mark XML file argument as repeatable (Nick Wellnhofer),
  Keep timezone in date:add (Nick Wellnhofer),
  Fix buffer overflow in exsltDateFormat (Nick Wellnhofer),
  Fix saxon:line-number with namespace nodes (Nick Wellnhofer),
  Fix dyn:map with namespace nodes (Nick Wellnhofer),
  Fix error handling in Saxon extension functions (Nick Wellnhofer),
  Fix double free in libexslt hash functions (Nick Wellnhofer),
  Fix libxslt format warnings (David Kilzer),
  Fix xsltNumberFormatGetMultipleLevel (Nick Wellnhofer),
  Fix use-after-free in xsltDocumentFunctionLoadDocument (Nick Wellnhofer),
  Always initialize EXSLT month and day to 1 (Nick Wellnhofer),
  Fix possible NULL pointer deref in transform.c (mahendra.n),
  Fix possible NULL pointer deref in xsltCopyTextString (Nick Wellnhofer),
  Fix possible NULL pointer deref in libexslt/functions.c (Nick Wellnhofer),
  Fix possible NULL pointer deref in xsltproc.c (mahendra.n),
  Fix possible NULL pointer deref in preproc.c (mahendra.n),
  Fix LIBXSLT_DEFAULT_PLUGINS_PATH in xsltconfig.h (Nick Wellnhofer),
  Fix memory leak in xsltNumberFormat (Albert Astals Cid),
  Error in doc/Makefile.am (Brice De Bruyne),
  Detect attribute sets recursions in more cases (Daniel Veillard),
  Check name vales for attribute-set elements (Daniel Veillard),
  Fix hang with namespace-alias, fixes #700689 (Shaun McCance),
  Fix str:align with UTF-8 strings (Nick Wellnhofer),
  Fix for compiled XPath helpers (Nick Wellnhofer),
  Check return value of exsltFuncNewFunctionData (Nick Wellnhofer),
  Fix return value of xsltRegisterExtModuleElement (Nick Wellnhofer),
  Call xmlNodeGetSpacePreserve with element node (Nick Wellnhofer),
  Set namespaces before evaluating xsl:number (Nick Wellnhofer),
  Make --maxvars option work (Per Hedeland),
  Set correct context node when initializing xsl:keys (Nick Wellnhofer),
  Fix for bug 436589 (Imran Azeezullah),
  Memory leak in xsltCompileIdKeyPattern error path (Nick Wellnhofer),
  Fix handling of UTF-8 strings in EXSLT crypto module (Nick Wellnhofer),
  Fix certain patterns with predicates (Nick Wellnhofer),
  Fix direct pattern matching (Nick Wellnhofer),
  Fix str:padding to work with UTF-8 strings (Nick Wellnhofer),
  EXSLT function str:replace() is broken as-is (Nick Wellnhofer),
  Fix a couple of places where (f)printf parameters were broken (Daniel Veillard)

   - Improvements:
  Add support timestamps from environment (Daniel Veillard),
  Add missing tests to dist tarball (Nick Wellnhofer),
  Improve error message in xsltAddTemplate and fix test (Nick Wellnhofer),
  Allow REC tests with empty stdout (Nick Wellnhofer),
  Fix GPL license in HTML files as well (Nick Wellnhofer),
  Fix status message in EXSLT dynamic tests (Nick Wellnhofer),
  Add public function macros to xsltlocale.h (Nick Wellnhofer),
  Make valgrind tests work with libtool (Nick Wellnhofer),
  Add a couple of xsl:number tests (Nick Wellnhofer),
  Lower and upper bound for format token "i" (Nick Wellnhofer),
  Lower bound for format token "a" (Nick Wellnhofer),
  Handle negative xsl:number values (Nick Wellnhofer),
  Round xsl:number values to nearest integer (Nick Wellnhofer),
  Allow {URI}NCName syntax for user parameters (Nick Wellnhofer),
  Fix endTimer parameter type (Nick Wellnhofer),
  Fix error messages for unsupported methods (Nick Wellnhofer),
  Replace sprintf with snprintf (David Kilzer),
  Enforce two digit exponent under MSVC (Nick Wellnhofer),
  Rework xsltNumberFormat to fix warning (Nick Wellnhofer),
  Fix a couple of GPL licences found in the documentation (Daniel Veillard),
  Use hash table to lookup named templates (Christian Ceelen),
  Fix to reg tests post 737840 fix (Daniel Veillard),
  Don't fail build the man page if xsltproc is not present (Daniel Veillard),
  Re-adding xsltproc.1 (Daniel Veillard),
  Fix time type in xsltSaveProfiling (Nick Wellnhofer),
  Remove unused parameters (Nick Wellnhofer),
  Suppress unused variable warning. (Nick Wellnhofer),
  Remove unused variable in xsltGenerateIdFunction (Nick Wellnhofer),
  Add test case for XPath function args in error case (Nick Wellnhofer),
  Add comment about known-to-fail test (Nick Wellnhofer),
  Adjust expected test output (Nick Wellnhofer),
  Helper functions to evaluate compiled XPath expressions (Nick Wellnhofer),
  Add tests for crypto:rc4 (Nick Wellnhofer),
  Add first test case for EXSLT crypto module (Nick Wellnhofer),
  Separate function for predicate matching in patterns (Nick Wellnhofer),
  Initialize pseudo random number generator with current time or optional command line parameter (Nils Werner),
  Adding doc update related to 1.1.28 (Daniel Veillard)

   - Cleanups:
  Remove bogus test file (Nick Wellnhofer),
  Add warning message to expected test output (Nick Wellnhofer)

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>