File:
[cvs.NetBSD.org] /
pkgsrc /
textproc /
jansson /
Makefile
Revision
1.7:
download - view:
text,
annotated -
select for diffs
Sun Dec 9 20:33:12 2018 UTC (6 years ago) by
adam
Branches:
MAIN
CVS tags:
pkgsrc-2020Q1-base,
pkgsrc-2020Q1,
pkgsrc-2019Q4-base,
pkgsrc-2019Q4,
pkgsrc-2019Q3-base,
pkgsrc-2019Q3,
pkgsrc-2019Q2-base,
pkgsrc-2019Q2,
pkgsrc-2019Q1-base,
pkgsrc-2019Q1,
pkgsrc-2018Q4-base,
pkgsrc-2018Q4,
HEAD
jansson: updated to 2.12
Version 2.12
* Bug fixes:
- Fix error message in `json_pack()` for NULL object.
- Avoid invalid memory read in `json_pack()`.
- Call va_end after va_copy in `json_vsprintf()`.
- Improve handling of formats with '?' and '*' in `json_pack()`.
- Remove inappropriate `jsonp_free()` which caused segmentation fault in
error handling.
* Build:
- Add function attributes for GCC and CLANG to provide warnings on improper
use of jansson routines.
- Many CMake fixes.
- Enable -Bsymbolic-functions linker flag whenever possible.
- Resolve various compiler warnings.
- Fix code coverage ignored paths.
* Other:
- Test coverage improvements.
- Add VS 2017 to appveyor, update Visual Studio documentation.
- Update copyright for 2018.
- Update install instructions in README
# $NetBSD: Makefile,v 1.7 2018/12/09 20:33:12 adam Exp $
DISTNAME= jansson-2.12
CATEGORIES= textproc
MASTER_SITES= http://www.digip.org/jansson/releases/
EXTRACT_SUFX= .tar.bz2
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://www.digip.org/jansson/
COMMENT= C library for encoding, decoding and manipulating JSON data
LICENSE= mit
USE_LANGUAGES= c99
USE_LIBTOOL= yes
USE_TOOLS+= pkg-config
GNU_CONFIGURE= yes
PKGCONFIG_OVERRIDE+= jansson.pc.in
# Fails a self-test because the library exports more symbols than it should.
# It seems "libtool ... -export-symbols-regex '^json_' ..." doesn't work,
# at least not on NetBSD-6.99.20/amd64.
TEST_TARGET= check
.include "../../mk/bsd.pkg.mk"
CVSweb <webmaster@jp.NetBSD.org>