[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / textproc / iso-codes

File: [cvs.NetBSD.org] / pkgsrc / textproc / iso-codes / Makefile (download)

Revision 1.6, Sat Mar 4 21:30:46 2006 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.5: +2 -2 lines

Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

# $NetBSD: Makefile,v 1.6 2006/03/04 21:30:46 jlam Exp $
#

DISTNAME=	iso-codes_0.48-1
PKGNAME=	${DISTNAME:S/_/-/:S/-1//}
PKGREVISION=	2
CATEGORIES=	textproc
MASTER_SITES=	${MASTER_SITE_DEBIAN:=pool/main/i/iso-codes/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://alioth.debian.org/projects/pkg-isocodes/
COMMENT=	List of country, language and currency names

GNU_CONFIGURE=		yes
USE_PKGLOCALEDIR=	yes
USE_TOOLS+=		autoconf automake gmake
WRKSRC=			${WRKDIR}/${PKGNAME_NOREV}

PKGCONFIG_OVERRIDE=	iso-codes.pc.in

PYTHON_PATCH_SCRIPTS=	*.py */*.py
REPLACE_PERL=		tab2h.pl

PYTHON_FOR_BUILD_ONLY=		yes
BUILDLINK_DEPMETHOD.perl5=	build
BUILDLINK_DEPMETHOD.py-xml=	build
BUILDLINK_DEPMETHOD.gettext=	build
BUILD_USES_MSGFMT=		yes

pre-configure:
	${TOUCH} ${WRKSRC}/AUTHORS
	${TOUCH} ${WRKSRC}/NEWS
	cd ${WRKSRC} && autoreconf -i

post-install:
	${INSTALL_DATA_DIR} ${PREFIX}/share/doc/${PKGNAME_NOREV}
	${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/${PKGNAME_NOREV}
	${INSTALL_DATA} ${WRKSRC}/TODO ${PREFIX}/share/doc/${PKGNAME_NOREV}

.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../lang/perl5/buildlink3.mk"
.include "../../lang/python/application.mk"
.include "../../textproc/py-xml/buildlink3.mk"
.include "../../textproc/xmlcatmgr/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"