The NetBSD Project

CVS log for pkgsrc/textproc/hs-typst/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / textproc / hs-typst

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.8: download - view: text, markup, annotated - select for diffs
Wed Mar 5 03:40:05 2025 UTC (2 weeks ago) by pho
Branches: MAIN
CVS tags: HEAD
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +2 -1 lines
recursive revbump after patching lang/ghc910

Revision 1.7: download - view: text, markup, annotated - select for diffs
Sun Feb 23 22:03:42 2025 UTC (3 weeks, 2 days ago) by wiz
Branches: MAIN
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +3 -4 lines
textproc/hs-typst: update to typst-0.6.2

## 0.6.2

  * Allow types to act as constructor functions, as in typst (#61).
    Add new unexported module, Typst.Constructors, defining the
    constructors for each of the typst types.
    Fix name of string type: it is `str`, not `string` (which is only
    the `repr`).

  * Support `dict`, `datetime`, `symbol` constructors.

  * Improve path handling when loading files (#60).
    We now look in the "local path" (the path of the containing file)
    except when the path begins with `/` (in which case it is resolved
    relative to the package path).

  * Fix issue with expression parsing involving labels (#59).

  * Remove spurious trace in `getPath`.

Revision 1.6: download - view: text, markup, annotated - select for diffs
Sun Feb 2 13:05:59 2025 UTC (6 weeks, 3 days ago) by pho
Branches: MAIN
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +2 -1 lines
Bump all Haskell packages after switching the default compiler.

Revision 1.5: download - view: text, markup, annotated - select for diffs
Thu Jan 30 13:44:12 2025 UTC (6 weeks, 6 days ago) by pho
Branches: MAIN
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +6 -7 lines
textproc/hs-typst: update to typst-0.6.1

## 0.6.1

  * Fix precedence for functions (#55).
    `1(x)` and `!(x)` should not be parsed as functions.
    Note that we still don't match typst's behavior for `f_"!"(x)`.
    For us this works just like `f_!(x)`, but for typst we get
    a function in the subscript for the former but not the latter.
    Fixing this would require some changes in the types.

  * Define sys.version and sys.inputs.typst-hs-version (#56).
    The former is set to the version of typst we are trying to
    implement. The latter is a stringified version number from typst-hs.
    This will allow typst programs to tell when they're running
    on typst-hs (or pandoc), and react accordingly.

  * Rename stBeforeSpace -> stSpaceBefore to avoid confusion.

  * Fix precedence issues in math parsing (#54).
    Increased precedence of ! (factorial).
    `_` or `^` should eagerly gobble a grouped argument (`c_(a)`).

  * Minimal support for `context` (#53). Parse `context` keyword.
    New Context constructor in Expr [API change].
    Evaluate this by just evaluating the expression, for now.
    Note that we don't support the features (like location or
    numbering) that context is used to affect anyway, so this change
    probably won't be enough for meaningful support. But it might
    prevent some documents from issuing errors.

  * Arguments at method.

  * Array windows, reduce, to-dict methods.

  * Allow parentheses in import.

  * Make standard module available under std (typst 0.12).

  * Add over/underparen, over/undershell in math module.

  * Add stretch function.

  * Add skew.

  * Depend on typst-symbols 0.1.7 and start to target typst 0.12.

  * Reset indentation requirements inside `[]` content block. e.g.
    ```
    / B: #block[
    - a
    ]
    ```
    We don't need indentation inside the block content.


## 0.6

  * Recognize figure.caption function (#52).

  * Allow defined identifiers to override math defaults (#51).
    Previously we evaluated all math in a special environment that
    shadowed any user-defined functions with the same-named functions
    from the math or sym modules. This change gives user-defined identifiers
    priority over the math defaults, allowing things like `bb` to be
    overridden.

  * Typst.Types: EvalState now has two new fields, `evalMathIdentifiers` and
    `evalStandardIdentifiers`. `evalIdentifiers` is now just for user-defined
    identifiers. [API change]

  * Don't implicitly load sys module for math.

## 0.5.0.5

  * Allow numbers like `1.` in math mode (#50).

## 0.5.0.4

  * Add built-in identifiers for standard types (#21):
    array, bool, content, int, float, regex, length,
    alignment, color, symbol, string.

  * Adjust emphasis parser for CJK characters (#49).
    Typst documentation says that `*` strong emphasis
    "only works at word boundaries." However, in typst/typst#2648
    this was changed for CJK.

Revision 1.4: download - view: text, markup, annotated - select for diffs
Thu May 9 01:32:48 2024 UTC (10 months, 1 week ago) by pho
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base, pkgsrc-2024Q4, pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +2 -1 lines
Recursive revbump after changing the default Haskell compiler

Revision 1.3: download - view: text, markup, annotated - select for diffs
Thu May 2 10:49:38 2024 UTC (10 months, 2 weeks ago) by pho
Branches: MAIN
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +2 -4 lines
textproc/hs-typst: Update to 0.5.0.3

The release note is too long to paste here:
https://hackage.haskell.org/package/typst-0.5.0.3/changelog

Revision 1.2: download - view: text, markup, annotated - select for diffs
Thu Nov 2 06:37:40 2023 UTC (16 months, 2 weeks ago) by pho
Branches: MAIN
CVS tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +2 -1 lines
Revbump all Haskell after updating lang/ghc96

Revision 1.1: download - view: text, markup, annotated - select for diffs
Mon Oct 30 12:54:19 2023 UTC (16 months, 2 weeks ago) by pho
Branches: MAIN
textproc/hs-typst: import hs-typst-0.3.2.1

A library for parsing and evaluating typst syntax. Typst
(https://typst.app) is a document layout and formatting language. This
library targets typst 0.7 and currently offers only partial support.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>