[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / textproc / groff

File: [cvs.NetBSD.org] / pkgsrc / textproc / groff / Makefile (download)

Revision 1.17, Fri Apr 30 15:11:28 2004 UTC (19 years, 11 months ago) by reed
Branch: MAIN
CVS Tags: pkgsrc-2004Q2-base, pkgsrc-2004Q2
Changes since 1.16: +16 -6 lines

This configures the to-be-installed mdoc.local file so the
"volume-operating-system" macro is ${OPSYS}.  And sets the default
.Os value to "pkgsrc" as suggested by wiz@.  (It was hard-coded
"NetBSD\~1.6".)

Usually the mdoc.local "volume-operating-system" definition is for
the operating system name often displayed on top of man pages. And
"operating-system" is for the default .Os value (operating system
and version/release) and is usually displayed at bottom of man page.

Bump PKGREVISION.

This closes my PR #23100.

# $NetBSD: Makefile,v 1.17 2004/04/30 15:11:28 reed Exp $
#

DISTNAME=	groff-1.19
PKGREVISION=	4
CATEGORIES=	textproc
MASTER_SITES=	${MASTER_SITE_GNU:=groff/}

MAINTAINER=	wiz@NetBSD.org
HOMEPAGE=	http://www.gnu.org/software/groff/groff.html
COMMENT=	GNU roff text processing suite

DEPENDS+=	netpbm>=10.0:../../graphics/netpbm
DEPENDS+=	psutils>=1.17:../../print/psutils

GNU_CONFIGURE=		YES
USE_GCC_SHLIB=		YES
USE_PERL5=		YES
USE_BUILDLINK3=		YES

INFO_FILES=	groff

.include "../../mk/bsd.prefs.mk"

.ifdef PAPERSIZE
CONFIGURE_ENV+=	PAGE=${PAPERSIZE}
.endif

# Usually the mdoc.local "volume-operating-system" definition is for
# the operating system name often displayed on top of man pages. And
# "operating-system" is for the default .Os value (operating system
# and version/release) and is usually displayed at bottom of man page.
# XXX Use "pkgsrc" as default .Os value.
post-patch:
	${SED}	-e "s,@@VOLUME_OPERATING_SYSTEM@@,${OPSYS},g"	\
		-e "s,@@OPERATING_SYSTEM@@,pkgsrc,g"	\
		${FILESDIR}/mdoc.local > ${WRKDIR}/mdoc.local

post-install:
	${INSTALL_DATA} ${WRKDIR}/mdoc.local \
		${PREFIX}/share/groff/site-tmac

.include "../../mk/ghostscript.mk"
.include "../../mk/bsd.pkg.mk"