The NetBSD Project

CVS log for pkgsrc/textproc/aspell/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / textproc / aspell

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.79 / (download) - annotate - [select for diffs], Tue Jun 28 11:36:08 2022 UTC (17 months, 2 weeks ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, HEAD
Changes since 1.78: +2 -2 lines
Diff to previous 1.78 (colored)

*: recursive bump for perl 5.36

Revision 1.78 / (download) - annotate - [select for diffs], Mon May 24 19:54:22 2021 UTC (2 years, 6 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2
Changes since 1.77: +2 -2 lines
Diff to previous 1.77 (colored)

*: recursive bump for perl 5.34

Revision 1.77 / (download) - annotate - [select for diffs], Tue May 11 01:26:25 2021 UTC (2 years, 7 months ago) by rin
Branch: MAIN
Changes since 1.76: +2 -2 lines
Diff to previous 1.76 (colored)

aspell: Fix for recent regex(3) update for NetBSD. Bump revision.

Stop using GNU regex(3) extension \w.

XXX
Alternatively, should we build lang/perl5 with REG_GNU?

Revision 1.76 / (download) - annotate - [select for diffs], Mon Aug 31 18:11:40 2020 UTC (3 years, 3 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3
Changes since 1.75: +2 -1 lines
Diff to previous 1.75 (colored)

*: bump PKGREVISION for perl-5.32.

Revision 1.75 / (download) - annotate - [select for diffs], Tue Mar 17 21:23:22 2020 UTC (3 years, 8 months ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1
Changes since 1.74: +1 -2 lines
Diff to previous 1.74 (colored)

textproc/aspell: remove unknown configure option --enable-doc-dir

The correct spelling of that option is --enable-docdir, and its default
value is $prefix/share/doc/aspell, thus there is no need to specify it at
all.

Revision 1.73.2.1 / (download) - annotate - [select for diffs], Tue Oct 22 11:05:37 2019 UTC (4 years, 1 month ago) by bsiegert
Branch: pkgsrc-2019Q3
Changes since 1.73: +5 -5 lines
Diff to previous 1.73 (colored) next main 1.74 (colored)

Pullup ticket #6072 - requested by nia
textproc/aspell: security fix

Revisions pulled up:
- textproc/aspell/Makefile                                      1.74
- textproc/aspell/PLIST                                         1.18
- textproc/aspell/distinfo                                      1.31
- textproc/aspell/options.mk                                    deleted

---
   Module Name:	pkgsrc
   Committed By:	nia
   Date:		Sat Oct 19 10:43:28 UTC 2019

   Modified Files:
   	pkgsrc/textproc/aspell: Makefile PLIST distinfo
   Removed Files:
   	pkgsrc/textproc/aspell: options.mk

   Log Message:
   aspell: Update to 0.68.8

   Please note that this version has the potential to break some applications
   that use null-terminated UCS-2 and UCS-4 encoded strings in order to fix a
   potentially unbounded buffer over-read.  Very few applications do this
   however.  For additional information please see "Upgrading from Aspell 0.60.7"
   in the manual.
   (http://aspell.net/man-html/Upgrading-from-Aspell-0_002e60_002e7.html)

   Major changes from 0.60.7 to 0.68.8:

       * Prevent a potentially unbounded buffer over-read by no longer
         supporting null-terminated UCS-2 and UCS-4 encoded strings with the
         original C API.

       * Ensure that possible typos are listed before other suggestions when
         typo analysis is used.  Also fix a bug so that suggestions that
         split a word using a space or hyphen are not always first.

       * Add Markdown filter.

       * Add new 'wordlists' option, which is a list of UTF-8 files that
         contain additional words to accept.

       * Add new 'camel-case' option, which enables support for checking
         camelCase words.

       * Sort personal and replacement dictionaries.

       * Change 'ultra' suggestion mode to only find words that are within
         one-edit distance or have the same soundslike.

   Other changes from 0.60.7:

       * Implement the 'aspell filter' command.
       * Fix a bug in 'AspellDocumentChecker' that prevented it from working
         with UCS-2 and UCS-4 encoded strings.
       * Remove unused 'sug-edit-dist' option.
       * 'AspellDocumentChecker' now expects the document a line at a time
         in order to work with the new Markdown filter.  If the document is
         split on white space characters instead, nothing will break, but
         new filters such as the Markdown filter may give incorrect results.
       * The 'clean' option and command will no longer split a word.
       * Various documentation improvements.
       * Removal of several outdated appendices that don't really belong in
         the main manual.  Parts that are still relevent may eventually be
         moved elsewhere, but for now they are available online at
         <http://aspell.net/0.60.7/man-html/>.
       * Fix various crashes and other problems found by Google's OSS-Fuzz.

Revision 1.74 / (download) - annotate - [select for diffs], Sat Oct 19 10:43:28 2019 UTC (4 years, 1 month ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4
Changes since 1.73: +5 -5 lines
Diff to previous 1.73 (colored)

aspell: Update to 0.68.8

Please note that this version has the potential to break some applications
that use null-terminated UCS-2 and UCS-4 encoded strings in order to fix a
potentially unbounded buffer over-read.  Very few applications do this
however.  For additional information please see "Upgrading from Aspell 0.60.7"
in the manual.
(http://aspell.net/man-html/Upgrading-from-Aspell-0_002e60_002e7.html)

Major changes from 0.60.7 to 0.68.8:

    * Prevent a potentially unbounded buffer over-read by no longer
      supporting null-terminated UCS-2 and UCS-4 encoded strings with the
      original C API.

    * Ensure that possible typos are listed before other suggestions when
      typo analysis is used.  Also fix a bug so that suggestions that
      split a word using a space or hyphen are not always first.

    * Add Markdown filter.

    * Add new 'wordlists' option, which is a list of UTF-8 files that
      contain additional words to accept.

    * Add new 'camel-case' option, which enables support for checking
      camelCase words.

    * Sort personal and replacement dictionaries.

    * Change 'ultra' suggestion mode to only find words that are within
      one-edit distance or have the same soundslike.

Other changes from 0.60.7:

    * Implement the 'aspell filter' command.
    * Fix a bug in 'AspellDocumentChecker' that prevented it from working
      with UCS-2 and UCS-4 encoded strings.
    * Remove unused 'sug-edit-dist' option.
    * 'AspellDocumentChecker' now expects the document a line at a time
      in order to work with the new Markdown filter.  If the document is
      split on white space characters instead, nothing will break, but
      new filters such as the Markdown filter may give incorrect results.
    * The 'clean' option and command will no longer split a word.
    * Various documentation improvements.
    * Removal of several outdated appendices that don't really belong in
      the main manual.  Parts that are still relevent may eventually be
      moved elsewhere, but for now they are available online at
      <http://aspell.net/0.60.7/man-html/>.
    * Fix various crashes and other problems found by Google's OSS-Fuzz.

Revision 1.73 / (download) - annotate - [select for diffs], Sun Sep 15 06:53:36 2019 UTC (4 years, 2 months ago) by maya
Branch: MAIN
CVS Tags: pkgsrc-2019Q3-base
Branch point for: pkgsrc-2019Q3
Changes since 1.72: +2 -3 lines
Diff to previous 1.72 (colored)

aspell: update to 0.60.7

Changes from 0.60.6.1 to 0.60.7 (July 29, 2019)

    Add partial support for recognizing the Unicode apostrophe („ŗ in words. In particular Aspell will accept the Unicode apostrophe when the language uses an ISO Latin charset that doesn„ŗ—’ already have a Unicode apostrophe. For now, Aspell will still use the ASCII version in suggestions.
    Detect when a dictionary compiled on a 32-bit machine is used on a 64-bit one (and vise versa), as due to an oversight, compiled dictionaries depend on more than the endianness. Also added a compile time option to remove this dependency, but at the cost of breaking compatibility with already compiled dictionaries on 64-bit systems.
    Fix a bug which caused Aspell to crash when passing in a null string to almost any of the C API functions. This should not happen if the size is also zero as the pointer should never be derefrenced.
    Fix a bug that caused Aspell to crash with a SEGFAULT when built with mingw-w64.
    In addition to outputting a warning when building with NDEBUG defined, also include NDEBUG in the version string.
    Various compile fixes for newer version of Gcc and Clang.
    Fix VPATH builds.
    Use utf-8 encoding for manual instead of iso-8859-1.
    Other minor updates and bug fixes.


Patch provided by Iku Iwasa in PR pkg/54548

Revision 1.72 / (download) - annotate - [select for diffs], Sun Aug 11 13:23:21 2019 UTC (4 years, 4 months ago) by wiz
Branch: MAIN
Changes since 1.71: +2 -2 lines
Diff to previous 1.71 (colored)

Bump PKGREVISIONs for perl 5.30.0

Revision 1.71 / (download) - annotate - [select for diffs], Wed Jul 24 19:04:29 2019 UTC (4 years, 4 months ago) by rin
Branch: MAIN
Changes since 1.70: +10 -4 lines
Diff to previous 1.70 (colored)

NetBSD curses has been fixed since 8.1.
So, ncurses is no longer required.

Bump PKGREVISION.

Revision 1.70 / (download) - annotate - [select for diffs], Wed Aug 22 09:46:44 2018 UTC (5 years, 3 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3
Changes since 1.69: +2 -2 lines
Diff to previous 1.69 (colored)

Recursive bump for perl5-5.28.0

Revision 1.69 / (download) - annotate - [select for diffs], Sat Jul 9 06:39:04 2016 UTC (7 years, 5 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3
Changes since 1.68: +2 -2 lines
Diff to previous 1.68 (colored)

Bump PKGREVISION for perl-5.24.0 for everything mentioning perl.

Revision 1.68 / (download) - annotate - [select for diffs], Tue Aug 18 07:31:18 2015 UTC (8 years, 3 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3
Changes since 1.67: +2 -2 lines
Diff to previous 1.67 (colored)

Bump all packages that depend on curses.bui* or terminfo.bui* since they
might incur ncurses dependencies on some platforms, and ncurses just bumped
its shlib.
Some packages were bumped twice now, sorry for that.

Revision 1.67 / (download) - annotate - [select for diffs], Mon Aug 17 17:11:30 2015 UTC (8 years, 3 months ago) by wiz
Branch: MAIN
Changes since 1.66: +2 -2 lines
Diff to previous 1.66 (colored)

Bump PKGREVISION for ncurses shlib bump.

Revision 1.66 / (download) - annotate - [select for diffs], Fri Jun 12 10:51:19 2015 UTC (8 years, 6 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q2-base, pkgsrc-2015Q2
Changes since 1.65: +2 -2 lines
Diff to previous 1.65 (colored)

Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.

Revision 1.65 / (download) - annotate - [select for diffs], Thu May 29 23:37:33 2014 UTC (9 years, 6 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2
Changes since 1.64: +2 -2 lines
Diff to previous 1.64 (colored)

Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.

Revision 1.64 / (download) - annotate - [select for diffs], Fri May 31 12:42:06 2013 UTC (10 years, 6 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q1-base, pkgsrc-2014Q1, pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2
Changes since 1.63: +2 -2 lines
Diff to previous 1.63 (colored)

Bump all packages for perl-5.18, that
a) refer 'perl' in their Makefile, or
b) have a directory name of p5-*, or
c) have any dependency on any p5-* package

Like last time, where this caused no complaints.

Revision 1.63 / (download) - annotate - [select for diffs], Thu Oct 25 06:55:39 2012 UTC (11 years, 1 month ago) by asau
Branch: MAIN
CVS Tags: pkgsrc-2013Q1-base, pkgsrc-2013Q1, pkgsrc-2012Q4-base, pkgsrc-2012Q4
Changes since 1.62: +1 -3 lines
Diff to previous 1.62 (colored)

Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

Revision 1.62 / (download) - annotate - [select for diffs], Wed Oct 3 21:57:46 2012 UTC (11 years, 2 months ago) by wiz
Branch: MAIN
Changes since 1.61: +2 -1 lines
Diff to previous 1.61 (colored)

Bump all packages that use perl, or depend on a p5-* package, or
are called p5-*.

I hope that's all of them.

Revision 1.61 / (download) - annotate - [select for diffs], Tue Jul 12 14:06:02 2011 UTC (12 years, 5 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3
Changes since 1.60: +2 -3 lines
Diff to previous 1.60 (colored)

Update to 0.60.6.1:
    Update to Automake 1.10.3
    Fix a bug which caused a race condition (leading to a likely
    crash) when two threads try to update the dictionary cache at
    the same time.
    Make it very clear that compiling Aspell with NDEBUG is a bad
    idea (see http://aspell.net/ndebug.html) by outputting a warning
    when building with NDEBUG defined.
    Numerous other minor updates and bug fixes.

Revision 1.60 / (download) - annotate - [select for diffs], Fri Apr 22 13:41:59 2011 UTC (12 years, 7 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2011Q2-base, pkgsrc-2011Q2
Changes since 1.59: +2 -2 lines
Diff to previous 1.59 (colored)

recursive bump from gettext-lib shlib bump.

Revision 1.59 / (download) - annotate - [select for diffs], Wed Oct 27 07:17:24 2010 UTC (13 years, 1 month ago) by markd
Branch: MAIN
CVS Tags: pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4
Changes since 1.58: +3 -2 lines
Diff to previous 1.58 (colored)

Force use of ncurses as NetBSD curses causes segfaults when running
  aspell -c file.   Should fix PR pkg/44005.

Revision 1.58 / (download) - annotate - [select for diffs], Fri Feb 19 20:16:40 2010 UTC (13 years, 9 months ago) by heinz
Branch: MAIN
CVS Tags: pkgsrc-2010Q3-base, pkgsrc-2010Q3, pkgsrc-2010Q2-base, pkgsrc-2010Q2, pkgsrc-2010Q1-base, pkgsrc-2010Q1
Changes since 1.57: +2 -1 lines
Diff to previous 1.57 (colored)

Added LICENSE information.

Revision 1.57 / (download) - annotate - [select for diffs], Mon Sep 22 08:53:13 2008 UTC (15 years, 2 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2009Q4-base, pkgsrc-2009Q4, pkgsrc-2009Q3-base, pkgsrc-2009Q3, pkgsrc-2009Q2-base, pkgsrc-2009Q2, pkgsrc-2009Q1-base, pkgsrc-2009Q1, pkgsrc-2008Q4-base, pkgsrc-2008Q4, pkgsrc-2008Q3-base, pkgsrc-2008Q3
Changes since 1.56: +2 -1 lines
Diff to previous 1.56 (colored)

Add patch fixing problem checking html files, reported by Chris Ross
and Uwe Klaus on pkgsrc-users; using upstream patch.

Bump PKGREVISION.

Revision 1.56 / (download) - annotate - [select for diffs], Tue Apr 29 11:40:50 2008 UTC (15 years, 7 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2008Q2-base, pkgsrc-2008Q2, cwrapper, cube-native-xorg-base, cube-native-xorg
Changes since 1.55: +3 -18 lines
Diff to previous 1.55 (colored)

Update to 0.60.6:

Complete list of changes from 0.60.5:

  * Compile fixes for Gcc 4.3.

  * Updated to Libtool 2.2.2 and Automake 1.10.1

  * Minor tweak to suggestion code which improved suggestion results in
    certain cases.

  * Always line buffer stdout and stderr in the Aspell utility when
    there is the potential for it to be used interactively through a
    pipe.

  * Removed debug output in `aspell munch-list'.

  * Other minor updates and bug fixes.

Revision 1.55 / (download) - annotate - [select for diffs], Sat Apr 12 22:43:13 2008 UTC (15 years, 8 months ago) by jlam
Branch: MAIN
Changes since 1.54: +3 -3 lines
Diff to previous 1.54 (colored)

Convert to use PLIST_VARS instead of manually passing "@comment "
through PLIST_SUBST to the plist module.

Revision 1.54 / (download) - annotate - [select for diffs], Tue Mar 11 18:47:41 2008 UTC (15 years, 9 months ago) by tnn
Branch: MAIN
CVS Tags: pkgsrc-2008Q1-base, pkgsrc-2008Q1
Changes since 1.53: +2 -2 lines
Diff to previous 1.53 (colored)

Put back a couple of IRIX conditionals the way they used to behave,
e.g. match IRIX 5.x but not 6.x. Some of these may indeed apply to 6.x
too, but let's be conservative. PR pkg/38224.

Revision 1.53 / (download) - annotate - [select for diffs], Tue Oct 16 23:49:00 2007 UTC (16 years, 1 month ago) by tnn
Branch: MAIN
CVS Tags: pkgsrc-2007Q4-base, pkgsrc-2007Q4
Changes since 1.52: +2 -2 lines
Diff to previous 1.52 (colored)

Fix abusers of LOWER_OPSYS to check OPSYS or MACHINE_PLATFORM instead.

Revision 1.52 / (download) - annotate - [select for diffs], Tue Sep 11 18:42:30 2007 UTC (16 years, 3 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2007Q3-base, pkgsrc-2007Q3
Changes since 1.51: +2 -2 lines
Diff to previous 1.51 (colored)

Drop maintainership.

Revision 1.51 / (download) - annotate - [select for diffs], Sat Sep 8 21:58:00 2007 UTC (16 years, 3 months ago) by jlam
Branch: MAIN
Changes since 1.50: +8 -7 lines
Diff to previous 1.50 (colored)

Convert to use the features framework.

Revision 1.50 / (download) - annotate - [select for diffs], Thu Sep 6 21:51:54 2007 UTC (16 years, 3 months ago) by jlam
Branch: MAIN
Changes since 1.49: +4 -4 lines
Diff to previous 1.49 (colored)

Convert all libnbcompat/buildlink3.mk references to inplace.mk.

Revision 1.49 / (download) - annotate - [select for diffs], Sun Jun 10 16:03:45 2007 UTC (16 years, 6 months ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2007Q2-base, pkgsrc-2007Q2
Changes since 1.48: +2 -1 lines
Diff to previous 1.48 (colored)

At the moment, there aren't any package options. Reported by Ondrej Tuma
in PR 36467.

Revision 1.48 / (download) - annotate - [select for diffs], Sat Jan 6 22:07:42 2007 UTC (16 years, 11 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2007Q1-base, pkgsrc-2007Q1
Changes since 1.47: +3 -4 lines
Diff to previous 1.47 (colored)

Update to 0.60.5:

   * Compile fix for gcc 4.1

   * Updated to Gettext 0.16.1, Libtool 1.5.22, Automake 1.10, Autoconf
     2.61

   * Documentation improvements, including an updated `man' page.

   * Complain if more than one file is specified when checking files
     using the `aspell check' command, rather than ignoring the other
     files.

   * Large number of bug fixes.

Revision 1.47 / (download) - annotate - [select for diffs], Fri Nov 24 16:31:48 2006 UTC (17 years ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2006Q4-base, pkgsrc-2006Q4
Changes since 1.46: +2 -1 lines
Diff to previous 1.46 (colored)

Made the package work on Solaris. It needed an obscure patch and
USE_PKGLOCALEDIR.

Revision 1.46 / (download) - annotate - [select for diffs], Sun Nov 5 17:02:18 2006 UTC (17 years, 1 month ago) by joerg
Branch: MAIN
Changes since 1.45: +1 -5 lines
Diff to previous 1.45 (colored)

Remove post-install, is this directory has files anyways.

Revision 1.45 / (download) - annotate - [select for diffs], Mon Oct 9 12:52:36 2006 UTC (17 years, 2 months ago) by joerg
Branch: MAIN
Changes since 1.44: +3 -1 lines
Diff to previous 1.44 (colored)

Flag a number of packages I use as supporting (user-)destdir.
apg is a bit special as it has some hardcoded ownership, so
mark that as "destdir".

Revision 1.44 / (download) - annotate - [select for diffs], Sun Oct 1 08:52:01 2006 UTC (17 years, 2 months ago) by schwarz
Branch: MAIN
Changes since 1.43: +9 -1 lines
Diff to previous 1.43 (colored)


added support for IRIX 5

Revision 1.43 / (download) - annotate - [select for diffs], Fri May 5 03:11:53 2006 UTC (17 years, 7 months ago) by minskim
Branch: MAIN
CVS Tags: pkgsrc-2006Q3-base, pkgsrc-2006Q3, pkgsrc-2006Q2-base, pkgsrc-2006Q2
Changes since 1.42: +4 -2 lines
Diff to previous 1.42 (colored)

Enable NLS on every platform.  Previously, it was enabled on Linux only.
Approved by the maintainer.  Bump PKGREVISION.

Revision 1.42 / (download) - annotate - [select for diffs], Fri Mar 31 23:56:30 2006 UTC (17 years, 8 months ago) by jlam
Branch: MAIN
Changes since 1.41: +2 -3 lines
Diff to previous 1.41 (colored)

List the info pages directly in the PLIST and ensure that we honor
PKGINFODIR.

Revision 1.41 / (download) - annotate - [select for diffs], Thu Mar 9 11:14:50 2006 UTC (17 years, 9 months ago) by ghen
Branch: MAIN
CVS Tags: pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.40: +1 -7 lines
Diff to previous 1.40 (colored)

All scripts use #!/bin/sh now.

Revision 1.40 / (download) - annotate - [select for diffs], Sun Feb 5 23:10:59 2006 UTC (17 years, 10 months ago) by joerg
Branch: MAIN
Changes since 1.39: +2 -1 lines
Diff to previous 1.39 (colored)

Recursive revision bump / recommended bump for gettext ABI change.

Revision 1.39 / (download) - annotate - [select for diffs], Sun Jan 29 22:02:45 2006 UTC (17 years, 10 months ago) by wiz
Branch: MAIN
Changes since 1.38: +15 -3 lines
Diff to previous 1.38 (colored)

Prepare some code for an aspell-loadable-filter options,
which is not yet enabled because it currently does not work, but this
way it is easier to test.

Revision 1.38 / (download) - annotate - [select for diffs], Fri Jan 6 14:51:19 2006 UTC (17 years, 11 months ago) by wiz
Branch: MAIN
Changes since 1.37: +2 -3 lines
Diff to previous 1.37 (colored)

Update to 0.60.4:

Complete list of changes from 0.60.3:

   * Fixed a bug that caused Aspell to crash when checking certain
     Russian words, this bug likely affected other languages as well.

   * Updated to Gettext 0.14.5 which is required for AMD64, also
     updated to to Libtool 1.5.20.

   * Fixed an alignment bug which causes mmap to always fail when
     reading in dictionaries.

   * Added note about how `make clean' will remove the HTML manuals.

   * Added manual page for prezip-bin and enhanced word-list-compress
     manual page thanks to the work of Jose Da Silva.

   * Other minor updates and bug fixes.

Revision 1.37 / (download) - annotate - [select for diffs], Thu Oct 27 01:08:06 2005 UTC (18 years, 1 month ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2005Q4-base, pkgsrc-2005Q4
Changes since 1.36: +1 -7 lines
Diff to previous 1.36 (colored)

Added two more patches for Solaris, which makes the package build.
Removed the extra LIBS for the SunPro compiler from the Makefile, as
they made the build fail for me.

Revision 1.36 / (download) - annotate - [select for diffs], Sun Sep 11 16:29:58 2005 UTC (18 years, 3 months ago) by minskim
Branch: MAIN
CVS Tags: pkgsrc-2005Q3-base, pkgsrc-2005Q3
Changes since 1.35: +6 -1 lines
Diff to previous 1.35 (colored)

Make sure that filters are built statically until dlopen() detection
in configure is fixed.  The problem was reported to the author by
wiz@.  This makes installed files match with PLIST on platforms with
libdl.  Bump PKGREVISION.

Approved by wiz@.

Revision 1.35 / (download) - annotate - [select for diffs], Fri Jul 15 20:14:03 2005 UTC (18 years, 5 months ago) by jlam
Branch: MAIN
Changes since 1.34: +3 -3 lines
Diff to previous 1.34 (colored)

Drop support for TOOLS_DEPMETHOD.<tool>.  The new way to specify a
run-time dependency (DEPENDS) on a tool is to append a ":run" modifier
to the tool name, e.g.,

	USE_TOOLS+=	perl:run

Tools without modifiers or with an explicit ":build" modifier will
cause build dependencies (BUILD_DEPENDS) on those tools to be added.
This makes the notation a bit more compact.

Revision 1.34 / (download) - annotate - [select for diffs], Tue Jun 28 14:18:55 2005 UTC (18 years, 5 months ago) by wiz
Branch: MAIN
Changes since 1.33: +4 -3 lines
Diff to previous 1.33 (colored)

USE_PERL5 -> USE_TOOLS+=perl.

Revision 1.33 / (download) - annotate - [select for diffs], Tue Jun 28 14:17:49 2005 UTC (18 years, 5 months ago) by wiz
Branch: MAIN
Changes since 1.32: +2 -3 lines
Diff to previous 1.32 (colored)

Update to 0.60.3.

Complete list of changes from 0.60.2:

   * Fixed bugs involving several of the C API functions.

   * Fixed bug where `ultra' or `fast' mode will not return any
     suggestions when soundslike lookup is not used.

   * Made a minor, yet significant, optimization to the suggestion code.
     This speed things up by an order of magnitude in some cases.

   * Avoid using the slow ngram scan except when the `sug-mode' is
     `slow' or `bad-speller'.

   * Fixed a bug in curses mode which causes word-wrap to not work
     correctly in some cases.

   * Fixed a bug in pipe mode with a missing newline.

   * Fixed the `spell' compatibility script.

   * Several other minor bugs fixed.

   * Made note about the change in behavior of the `-l' command line
     switch.

   * Other manual update/fixes.

   * Updated to Libtool 1.5.18, Automake 1.9.6, and Makeinfo 4.8.

Revision 1.32 / (download) - annotate - [select for diffs], Sun Jun 26 05:19:10 2005 UTC (18 years, 5 months ago) by wiz
Branch: MAIN
Changes since 1.31: +2 -1 lines
Diff to previous 1.31 (colored)

Add patch from program's author that fixes aspell-cz build.
Bump PKGREVISION to 1.

Revision 1.31 / (download) - annotate - [select for diffs], Sun May 22 20:08:34 2005 UTC (18 years, 6 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2005Q2-base, pkgsrc-2005Q2
Changes since 1.30: +2 -2 lines
Diff to previous 1.30 (colored)

Remove USE_GNU_TOOLS and replace with the correct USE_TOOLS definitions:

	USE_GNU_TOOLS	-> USE_TOOLS
	awk		-> gawk
	m4		-> gm4
	make		-> gmake
	sed		-> gsed
	yacc		-> bison

Revision 1.30 / (download) - annotate - [select for diffs], Mon Apr 11 21:47:31 2005 UTC (18 years, 8 months ago) by tv
Branch: MAIN
Changes since 1.29: +1 -2 lines
Diff to previous 1.29 (colored)

Remove USE_BUILDLINK3 and NO_BUILDLINK; these are no longer used.

Revision 1.29 / (download) - annotate - [select for diffs], Sat Dec 25 02:27:14 2004 UTC (18 years, 11 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2005Q1-base, pkgsrc-2005Q1
Changes since 1.28: +2 -1 lines
Diff to previous 1.28 (colored)

Set USE_PERL5 to "run" for aspell-import script; perl is also needed during the build phase.

Revision 1.28 / (download) - annotate - [select for diffs], Fri Dec 24 02:55:53 2004 UTC (18 years, 11 months ago) by wiz
Branch: MAIN
Changes since 1.27: +13 -10 lines
Diff to previous 1.27 (colored)

Update to 0.60.2.

New in 0.60.2:

   * Added the `munch-list' command to the aspell utility.  The `munch'
     program in the `myspell/' directory will disappear in Aspell 0.61.
     The `munchlist' script will also likely disappear or be replaced
     when Aspell 0.61 is released since it doesn't work correctly
     anyway.

   * Several important bug fixes some of which rendered some non-English
     languages unusable.

   * Other minor changes.

New in 0.60.1.1:

   * Fix bug involving checking of capitalized word when affix
     compression is used.

   * Compile fixes.

   * Added an option to disable using the "wide" curses version in case
     it causes compile problems.

   * Minor manual updates

   * Avoided including some unnecessary files in the distribution.

New in 0.60.1:

   * Lots of compile fixes for various platforms.

   * Miscellaneous bug fixes.

   * Added Nroff filter thanks to Sergey Poznyakoff.

   * The default filter mode when in pipe mode is now nroff for
     compatibility with Ispell.

   * Added Texinfo filter.

   * Added a section detailing the differences between Ispell and
     Aspell.

   * Updated the section on thread safety.

   * Other miscellaneous manual changes such as updating the To Do and
     Authors section.

Changes since 0.50.5:

    * Added support for Affix Compression. Affix compression stores
    the root word and then a list of prefixes and suffixes that
    the word can take, and thus saves a lot of space. The codebase
    comes from MySpell found in OpenOffice. It uses the same affix
    file that OpenOffice (and Mozilla) use. Affix compression will
    even work with soundslike lookup to a limited extent.
    * Added support for accepting all input and printing all output
    in UTF-8 or some other encoding different from the one Aspell
    uses. This includes support for Unicode normalization. Aspell
    can now support any language with no more than 210 distinct
    characters, including different capitalizations and accents,
    _even if_ there is not an existing 8-bit encoding that supports
    the language.
    * Added support for loadable filters and customizable filter
    modes thanks to Christoph Hinterm√ľller.
    * Enhanced SGML filter to also support skipping sgml tags such
    as "script" blocks thanks to Tom Snyder.
    * Added gettext support thanks to Sergey Poznyakoff
    * Reworked the compiled dictionary format. Compiled dictionaries
    now take up less space (less than 80% for the English language)
    and creating them is significantly faster (over 4 times for
    the English language).
    * Reworked suggestion code. It is significantly faster when
    dealing with short words (up to 10 times). Also added support
    for MySpell Replacement Tables and n-gram lookup. In addition,
    added basic support for compound words.
    * Manual has has been converted to texinfo format thanks to
    the work of Chris Martin.
    * Reworked the build system so that a single Makefile is used
    for most of the code.
    * All data, by default, is now included in `LIBDIR/aspell-0.60'.
    Also added a built time option to increment the major version
    number of the shared library. This should allow both Aspell
    version 0.50 and 0.60 to coexist. The major version number is
    _not_ incremented by default as Aspell 0.60 is binary compatible
    with Aspell 0.50.
	NOTE: this is not true for pkgsrc.
    * The code to handle dictionaries has been rewritten. Because
    of this support for the dictionary option `strip-accents' has
    been removed. In addition the `ignore-accents' option is
    currently unimplemented.
    * Lots of other minor changes due to massive overhaul of the
    source code.

Revision 1.27 / (download) - annotate - [select for diffs], Sun Dec 19 00:21:59 2004 UTC (18 years, 11 months ago) by grant
Branch: MAIN
CVS Tags: pkgsrc-2004Q4-base, pkgsrc-2004Q4
Changes since 1.26: +3 -1 lines
Diff to previous 1.26 (colored)

this won't build with xlc without some work, mark it as such.

Revision 1.26 / (download) - annotate - [select for diffs], Sat Nov 13 22:04:53 2004 UTC (19 years, 1 month ago) by jlam
Branch: MAIN
Changes since 1.25: +1 -2 lines
Diff to previous 1.25 (colored)

Replace USE_GCC_SHLIB with "USE_LANGUAGE=c c++" (the latter implies the
former) for applications that are known to require C++.

Revision 1.25 / (download) - annotate - [select for diffs], Thu Oct 7 16:36:47 2004 UTC (19 years, 2 months ago) by tv
Branch: MAIN
Changes since 1.24: +2 -2 lines
Diff to previous 1.24 (colored)

Extra PKGREVISION bump to cover the libtool/compiler-wrapper problems.
Since dependencies were actually failing to build, they fortunately don't
require PKGREVISION bumps themselves.

Revision 1.24 / (download) - annotate - [select for diffs], Sun Oct 3 00:18:17 2004 UTC (19 years, 2 months ago) by tv
Branch: MAIN
Changes since 1.23: +2 -2 lines
Diff to previous 1.23 (colored)

Libtool fix for PR pkg/26633, and other issues.  Update libtool to 1.5.10
in the process.  (More information on tech-pkg.)

Bump PKGREVISION and BUILDLINK_DEPENDS of all packages using libtool and
installing .la files.

Bump PKGREVISION (only) of all packages depending directly on the above
via a buildlink3 include.

Revision 1.23 / (download) - annotate - [select for diffs], Sun Jul 25 07:42:02 2004 UTC (19 years, 4 months ago) by grant
Branch: MAIN
CVS Tags: pkgsrc-2004Q3-base, pkgsrc-2004Q3
Changes since 1.22: +8 -1 lines
Diff to previous 1.22 (colored)

link against libm on Solaris for sqrt(), as well as libCrun and libCstd
when using SunPro so libaspell.so can resolve all symbols required.

bump PKGREVISION for library dependency change.

Revision 1.22 / (download) - annotate - [select for diffs], Sat Jul 24 19:05:37 2004 UTC (19 years, 4 months ago) by salo
Branch: MAIN
Changes since 1.21: +8 -1 lines
Diff to previous 1.21 (colored)

Make it compile with SunPro C++

Revision 1.21 / (download) - annotate - [select for diffs], Mon Feb 23 21:58:56 2004 UTC (19 years, 9 months ago) by snj
Branch: MAIN
CVS Tags: pkgsrc-2004Q2-base, pkgsrc-2004Q2, pkgsrc-2004Q1-base, pkgsrc-2004Q1
Changes since 1.20: +2 -2 lines
Diff to previous 1.20 (colored)

Update to 0.50.5.  Changes sine 0.50.4.1:
* Reworked url filter which fixed several bugs and now accepts "bla.bla/
  kdkdl" as a url.
* Fixed bug in which the url filter was coming before all other filters
  when it was suppose to come after. This solved a number of problems
  where the url filter was interfering with other filters.
* Small bug fix in SGML filter.
* Added code page charsets, ie cp125?.dat.
* Added natural (split) keyboard data file as "split.kbd"
* Compile fixes for the upcoming GCC 3.4
* Removed Solaris link hack as it was causing more problems than it
  fixes.
* Compile fixes for Sun WorkShop 6 compiler, but there may still be some
  problems, especially with linking.
* Minor manual fixes.

Okayed by wiz.

Revision 1.20 / (download) - annotate - [select for diffs], Sat Feb 14 17:21:53 2004 UTC (19 years, 10 months ago) by jlam
Branch: MAIN
Changes since 1.19: +1 -2 lines
Diff to previous 1.19 (colored)

LIBTOOL_OVERRIDE and SHLIBTOOL_OVERRIDE are now lists of shell globs
relative to ${WRKSRC}.  Remove redundant LIBTOOL_OVERRIDE settings that
are automatically handled by the default setting in bsd.pkg.mk.

Revision 1.19 / (download) - annotate - [select for diffs], Wed Feb 11 04:35:20 2004 UTC (19 years, 10 months ago) by xtraeme
Branch: MAIN
Changes since 1.18: +3 -3 lines
Diff to previous 1.18 (colored)

bl3ify

Revision 1.18 / (download) - annotate - [select for diffs], Wed Feb 11 01:46:30 2004 UTC (19 years, 10 months ago) by abs
Branch: MAIN
Changes since 1.17: +2 -1 lines
Diff to previous 1.17 (colored)

USE_LANGUAGES=c c++

Revision 1.17 / (download) - annotate - [select for diffs], Sat Jan 24 15:13:19 2004 UTC (19 years, 10 months ago) by grant
Branch: MAIN
Changes since 1.16: +2 -2 lines
Diff to previous 1.16 (colored)

replace deprecated USE_GMAKE with USE_GNU_TOOLS+=make.

Revision 1.16 / (download) - annotate - [select for diffs], Wed Dec 3 16:49:06 2003 UTC (20 years ago) by recht
Branch: MAIN
Changes since 1.15: +2 -3 lines
Diff to previous 1.15 (colored)

update to 0.50.4.1

changes since 0.50.2:
# Fixed major bug in pipe mode which caused the last character to be
  chopped off words before they were stored.
# Minor formating fixes in the manual.
# Minor changes in URL filter to avoid treating the double quote character
  as part of the URL, and to avoid treating words ending in more than one
  period as a URL.
# Document fixes in Aspell API
# Small compile fixes, including one for GCC 3.3
# Updated Win32 section since a port now exists thanks to Thorsten Maerz.
# Complain instead of doing nothing or aborting for unimplemented functions
  in Aspell utility.
# Portability bug fixes.
# Upgraded to Autoconf 2.57, Automake 1.7.7, Libtool 1.5 (no longer use
  CVS version of libtool).

ok'ed by wiz@

Revision 1.15 / (download) - annotate - [select for diffs], Thu Oct 2 01:07:52 2003 UTC (20 years, 2 months ago) by itojun
Branch: MAIN
CVS Tags: pkgsrc-2003Q4-base, pkgsrc-2003Q4
Changes since 1.14: +2 -5 lines
Diff to previous 1.14 (colored)

work around to remove dependency to ncurses on netbsd.  PR pkg/22992

Revision 1.14 / (download) - annotate - [select for diffs], Sun Sep 28 09:13:59 2003 UTC (20 years, 2 months ago) by jlam
Branch: MAIN
Changes since 1.13: +2 -2 lines
Diff to previous 1.13 (colored)

Back out last change related to moving ncurses/buildlink2.mk to
curses.buildlink2.mk.  This was wrong because we _really_ do want to
express that we want _n_curses when we include the buildlink2.mk file.

We should have a better way to say that the NetBSD curses doesn't
quite work well enough.  In fact, it's far better to depend on ncurses
by default, and exceptionally note when it's okay to use NetBSD curses
for specific packages.  We will look into this again in the future.

Revision 1.13 / (download) - annotate - [select for diffs], Sat Sep 27 17:07:38 2003 UTC (20 years, 2 months ago) by grant
Branch: MAIN
Changes since 1.12: +2 -2 lines
Diff to previous 1.12 (colored)

move ncurses/buildlink2.mk to mk/curses.buildlink2.mk, as it provides
support for base system curses/ncurses as well as ncurses itself.

suggested by wiz.

Revision 1.12 / (download) - annotate - [select for diffs], Sat Jul 19 10:55:53 2003 UTC (20 years, 4 months ago) by jmmv
Branch: MAIN
Changes since 1.11: +2 -2 lines
Diff to previous 1.11 (colored)

... and bump PKGREVISION to 3.  The package will have an extra dependancy on
systems using gcc from a package.

Revision 1.11 / (download) - annotate - [select for diffs], Sat Jul 19 10:53:26 2003 UTC (20 years, 4 months ago) by jmmv
Branch: MAIN
Changes since 1.10: +4 -3 lines
Diff to previous 1.10 (colored)

- Set USE_GCC_SHLIB.
- Use INSTALL_DATA_DIR instead of MKDIR.
- Capitalize comment.

Revision 1.10 / (download) - annotate - [select for diffs], Thu Jul 17 22:54:01 2003 UTC (20 years, 4 months ago) by grant
Branch: MAIN
Changes since 1.9: +2 -2 lines
Diff to previous 1.9 (colored)

s/netbsd.org/NetBSD.org/

Revision 1.9 / (download) - annotate - [select for diffs], Sun Jul 13 14:06:08 2003 UTC (20 years, 5 months ago) by wulf
Branch: MAIN
Changes since 1.8: +3 -1 lines
Diff to previous 1.8 (colored)

Added REPLACE_PERL to fix incorrect path to perl in aspell-import script

Revision 1.8 / (download) - annotate - [select for diffs], Sun Jul 13 13:53:31 2003 UTC (20 years, 5 months ago) by wiz
Branch: MAIN
Changes since 1.7: +2 -2 lines
Diff to previous 1.7 (colored)

PKGREVISION bump for libiconv update.

Revision 1.7 / (download) - annotate - [select for diffs], Thu Jan 23 09:16:19 2003 UTC (20 years, 10 months ago) by salo
Branch: MAIN
CVS Tags: netbsd-1-6-1-base, netbsd-1-6-1
Changes since 1.6: +2 -3 lines
Diff to previous 1.6 (colored)

Add NetBSD-1.6_* to INCOMPAT_CURSES.  Noted by Cesar Catrian on tech-pkg.
Simplify the pattern.

Revision 1.6 / (download) - annotate - [select for diffs], Thu Jan 23 00:01:43 2003 UTC (20 years, 10 months ago) by salo
Branch: MAIN
Changes since 1.5: +3 -1 lines
Diff to previous 1.5 (colored)

New aspell acts as a replacement for libpspell and contains the same
libraries so make it conflict with all installed libpspell packages.

Revision 1.5 / (download) - annotate - [select for diffs], Wed Jan 22 10:26:14 2003 UTC (20 years, 10 months ago) by salo
Branch: MAIN
Changes since 1.4: +4 -2 lines
Diff to previous 1.4 (colored)

Limit dependency on ncurses only to systems which really need it.
We have halfdelay() in NetBSD 1.6M curses already.  Also fix PLIST.
Bump PKGREVISION.

Per discussion with wiz.  Addresses PR pkg/19985.

XXX: Operating systems other than NetBSD and SunOS don't have any
     reasonable defaults set in devel/ncurses/buildlink2.mk.
     This should be addressed!

Revision 1.4 / (download) - annotate - [select for diffs], Wed Jan 15 00:23:55 2003 UTC (20 years, 11 months ago) by salo
Branch: MAIN
Changes since 1.3: +10 -12 lines
Diff to previous 1.3 (colored)

Update to version 0.50.3.

- added buildlink2.mk for applications using aspell and pspell
- updated DESCR

Changes:

Aspell has undergone an extremely large number of changes since the previous
Aspell/Pspell release. For one thing Pspell has been merged with Aspell so
there in no longer two separate libraries you have to worry about.

Because of the massive changes between Aspell/Pspell and Aspell 0.50 you may
want to clean out the old files before installing the the new Aspell.  To do
so do a "make uninstall" in the original Aspell and Pspell source directories.

The way dictionaries are handled has also changed. This includes a change in
the naming conventions of both language names and dictionaries. Due to the
language name change, your old personal dictionaries will not be recognized.
However, you can import the old dictionaries by running the "aspell-import"
script. This also means that dictionaries designed to work with older versions
of Aspell are not likely to function correctly.  Fortunately new dictionary
packages are available for most languages. You can find them off of the Aspell
home page at http://aspell.net.

The Pspell ABI is now part of Aspell except that the name of everything has
changed due to the renaming of Pspell to Aspell. In particular please note the
following name changes:

    pspell -> aspell
    manager -> speller
    emulation -> enumeration
    master_word_list -> main_word_list

Please also note that the name of the language-tag option has changed to lang.
However, for backward compatible the language-tag option will still work.

However, you should also be able to build applications that require Pspell
with the new Aspell as a backward compatibility header file is provided.

Due to a change in the way dictionaries are handled, scanning for .pwli files
in order to get find out which dictionaries are available will no longer work.
This means that programs that relied on this technique may have problems
finding dictionaries. Fortunately, GNU Aspell now provided a uniform way to
list all installed dictionaries via the C API. See the file "list-dicts.c" in
the examples/ directory for an example of how to due this. Unfortunately there
is isn't any simply way to find out which dictionaries are installed which
will work with both the old Aspell/Pspell and the new GNU Aspell.

Revision 1.3 / (download) - annotate - [select for diffs], Wed Dec 25 03:47:36 2002 UTC (20 years, 11 months ago) by wiz
Branch: MAIN
Changes since 1.2: +5 -1 lines
Diff to previous 1.2 (colored)

Add a distribution patch fixing the following two problems:
- Workaround a bug in Pspell where multi-byte words are not getting
  null terminated properly.
- Truly fix a bug in suggest.cc so that Aspell will suggest correctly
  when typo-analysis is not used such as when sug-mode is ultra
  or bad spellers.
Bump PKGREVISION to 1.

Revision 1.2 / (download) - annotate - [select for diffs], Sat Oct 5 02:54:22 2002 UTC (21 years, 2 months ago) by wiz
Branch: MAIN
Changes since 1.1: +5 -4 lines
Diff to previous 1.1 (colored)

Convert to buildlink2.

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Tue Jan 15 01:07:25 2002 UTC (21 years, 11 months ago) by wiz
Branch: TNF
CVS Tags: pkgviews-base, pkgviews, pkgsrc-base, netbsd-1-6-RELEASE-base, netbsd-1-6, netbsd-1-5-PATCH003, buildlink2-base, buildlink2
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

Initial import of aspell:
Aspell is an Open Source spell checker designed to eventually replace
Ispell. Its main feature is that it does a much better job of coming up
with possible suggestions than Ispell does. In fact recent tests shows
that it even does better than Microsoft Word 97's spell checker in some
cases. In addition it has both compile time and run time support for other
non English languages. Aspell is also a library however the recommend way
to use aspell is through the Pspell library as the actual interface to the
aspell library is constantly changing.

Revision 1.1 / (download) - annotate - [select for diffs], Tue Jan 15 01:07:25 2002 UTC (21 years, 11 months ago) by wiz
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>