The NetBSD Project

CVS log for pkgsrc/textproc/R-markdown/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / textproc / R-markdown

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.9 / (download) - annotate - [select for diffs], Sat Jun 3 14:10:00 2023 UTC (3 months, 3 weeks ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, HEAD
Changes since 1.8: +4 -4 lines
Diff to previous 1.8 (colored)

(textproc/R-markdown) Updated 1.5 to 1.7

# CHANGES IN markdown VERSION 1.7

- The `file` argument of `mark()` will be treated as a file path only
  if the file exists and the value is not wrapped in
  `I()`. Previously, it would be treated as a file path when it has a
  file extension, which could lead to confusing errors like #100
  (thanks, @LukasWallrich).

- When there are emojis in the text, `mark()` may fail to identify and
  embed web resources (thanks, @tdhock, yihui/knitr#2254).

# CHANGES IN markdown VERSION 1.6

- Added support for footnotes, fenced `Div`s, section numbers, `{}`
  attributes for images/headings/fenced `Div`s, and appendices. See
  `vignette('intro', package = 'markdown')` for details.

- A lot of enhancements to the HTML slides format. See
  `vignette('slides', package = 'markdown')` for details.

- Added `vignette('article', package = 'markdown')` to demonstrate how
  to write an HTML article.

- If the input to `mark()` is a file, the output will also be a file
  by default. Previously the output would be text. If you want
  `mark()` to return text output when the input is a file, you may
  specify the argument `output = NULL`.

- The Markdown option `base64_images` has been renamed to
  `embed_resources`. This option can take two possible values,
  `"local"` and `"https"`, meaning whether to embed local and/or web
  (https) resources. You can specify none, either, or both of
  them. See `vignette('intro', package = 'markdown')` for details.

- Removed the option `standalone` from the list of Markdown
  options. Please use the argument `template = TRUE/FALSE` of `mark()`
  instead. The option `standalone = TRUE` was equivalent to `template
  = TRUE`.

- Added the option `auto_identifiers` (enabled by default) to
  automatically add IDs to headings, e.g., `# Hello world!` will be
  converted to `<h1 id="hello-world">Hello world!</h1>`. You can
  certainly override the automatic ID by providing an ID manually via
  the `{#id}` attribute, e.g., `# Hello world! {#hello}`.

- Renamed the `mathjax` option to `js_math` to allow for other JS math
  libraries. The default library was changed from MathJax to KaTeX. To
  continue using MathJax, you may set `js_math: mathjax`.

- Removed the option `mathjax_embed` from the list of Markdown
  options. To embed the MathJax library, enable `"https"` in the
  `embed_resources` option instead. Note that only MathJax v3 can be
  partially embedded, and lower versions cannot.

- Renamed the option `highlight_code` to `js_highlight`, and added
  support for an alternative syntax highlighting JS library Prism.js,
  which became the default. To continue using the old default
  `highlight.js`, you may set the `js_highlight` option to
  `highlight`.

- The default version of MathJax has been changed from v2 to v3.

- The default version of highlight.js has been changed from 11.6.0 to
  11.7.0, and the default style has been switched from `github` to
  `xcode`.

Revision 1.8 / (download) - annotate - [select for diffs], Sun Mar 12 09:52:10 2023 UTC (6 months, 2 weeks ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1
Changes since 1.7: +4 -4 lines
Diff to previous 1.7 (colored)

(textproc/R-markdown) Updated 1.1 to 1.5

# CHANGES IN markdown VERSION 1.5

- Values of meta variables `title`, `author`, and `date` (if provided)
  will be transformed to the target output format before they are
  passed into templates.

- Fixed the bug that the default CSS was not added to HTML output.

- Removed dependency on the **mime** package.

- Added experimental support for HTML slides:
  `markdown::mark_html(..., meta = list(css = c('default', 'slides'),
  js = 'slides'))`. If you prefer knitting `Rmd` documents in RStudio,
  you may use the output format:

  ```yaml
  output:
    markdown::html_format:
      meta:
        css: [default, slides]
        js: [slides]
  ```

  See https://yihui.org/en/2023/01/minimal-r-markdown/ for a demo.

# CHANGES IN markdown VERSION 1.4

- Empty `\title{}` in LaTeX output will be removed (along with `\maketitle`).

- highlight.js is loaded from
  https://www.jsdelivr.com/package/gh/highlightjs/cdn-release by
  default now. This means more languages are supported (not only R),
  but also means syntax-highlighting will not work offline at the
  moment (it will be improved in future).

- MathJax failed to load in the previous version. The bug has been
  fixed now.

- Removed the function `markdownExtensions()`.

# CHANGES IN markdown VERSION 1.3

- Switched the underlying Markdown rendering engine from the C library
  **sundown** (which has been deprecated for a decade) to the R
  package **commonmark** (thanks, @jeroen, yihui/knitr#1329).

- The functions `renderMarkdown()` and `markdownToHTML()` have been
  renamed to `mark()` and `mark_html()`, respectively. The old names
  are still kept in this package for backward-compatibility.

- Removed the arguments `stylesheet` and `fragment.only` in
  `mark_html()`. For `stylesheet`, please use the argument `meta =
  list(css = ...)` to provide the CSS stylesheet. For `fragment.only`,
  please use `mark_html(template = FALSE)` or `mark_html(options =
  '-standalone')` instead of `fragment.only = TRUE`. Currently these
  old arguments are still accepted internally, but may be deprecated
  and dropped in the long run.

- The `file` argument of `mark()` and `mark_html()` can also take a
  character vector of Markdown text now.

- Removed functions `rendererExists()`, `rendererOutputType()`, and
  `registeredRenderer()`. They were primarily for internal use.

- Deprecated the function `markdownExtensions()`. All extensions
  should be specified via the `options` argument of functions like
  `mark()`, e.g., `mark(options = '+table+tasklist')`. See all options
  on the help page `?markdown::markdown_options`.

- Renamed `markdownHTMLOptions()` to `markdown_options()`.

# CHANGES IN markdown VERSION 1.2

- Fixed the warnings "a function declaration without a prototype is
  deprecated in all versions of C" (#94).

Revision 1.7 / (download) - annotate - [select for diffs], Tue Oct 26 11:21:31 2021 UTC (23 months ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4
Changes since 1.6: +2 -2 lines
Diff to previous 1.6 (colored)

textproc: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes

Unfetchable distfiles (fetched conditionally?):
./textproc/convertlit/distinfo clit18src.zip

Revision 1.6 / (download) - annotate - [select for diffs], Thu Oct 7 15:00:37 2021 UTC (23 months, 3 weeks ago) by nia
Branch: MAIN
Changes since 1.5: +1 -2 lines
Diff to previous 1.5 (colored)

textproc: Remove SHA1 hashes for distfiles

Revision 1.5 / (download) - annotate - [select for diffs], Sat Jun 5 07:17:09 2021 UTC (2 years, 3 months ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2
Changes since 1.4: +5 -5 lines
Diff to previous 1.4 (colored)

(textproc/R-markdown) Updated 1.0 to 1.1

     CHANGES IN markdown VERSION 1.1
MAJOR CHANGES

  o renderMarkdown() and markdownToHTML() will signal an error if the input file
  is not encoded in "UTF-8".

Revision 1.4 / (download) - annotate - [select for diffs], Wed Jul 31 20:54:53 2019 UTC (4 years, 2 months ago) by brook
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3
Changes since 1.3: +5 -5 lines
Diff to previous 1.3 (colored)

R-markdown: update to version 1.0.

Update to the canonical form of an R package.

Revision 1.3 / (download) - annotate - [select for diffs], Wed Apr 13 14:18:23 2016 UTC (7 years, 5 months ago) by wen
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2
Changes since 1.2: +5 -5 lines
Diff to previous 1.2 (colored)

Update to 0.7.7
Update DEPENDS

Upstream changes:
CHANGES IN markdown VERSION 0.7.7

BUG FIXES

  o renderMarkdown() works now even if text = character(0) or ""

  o added an `encoding` argument to renderMarkdown() since multi-byte characters
  in renderMarkdown() did not work on Windows (thanks, Kohske Takahashi, #63)

  o fixed #64: invalid 'n' argument in rpubsUpload() (thanks, Wouter van
  Atteveldt)

MAJOR CHANGES

  o if renderMarkdown() returns a character vector, it will be marked with the
  UTF-8 encoding if it contains multi-byte characters

Revision 1.2 / (download) - annotate - [select for diffs], Wed Nov 4 01:59:18 2015 UTC (7 years, 10 months ago) by agc
Branch: MAIN
CVS Tags: pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4
Changes since 1.1: +2 -1 lines
Diff to previous 1.1 (colored)

Add SHA512 digests for distfiles for textproc category

Problems found locating distfiles:
	Package cabocha: missing distfile cabocha-0.68.tar.bz2
	Package convertlit: missing distfile clit18src.zip
	Package php-enchant: missing distfile php-enchant/enchant-1.1.0.tgz

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.

Revision 1.1 / (download) - annotate - [select for diffs], Fri Sep 19 22:44:40 2014 UTC (9 years ago) by brook
Branch: MAIN
CVS Tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3

Initial import of markdown v0.7.4 as textproc/R-markdown.

Markdown is a plain-text formatting syntax that can be converted to
XHTML or other formats. This package provides R bindings to the
Sundown markdown rendering library.

Note: this commit is part of reorganizing some of the recently
imported R packages, which are being reimported into more appropriate
categories (and removed from math) as a result of a recent discussion
on tech-pkg and privately with wiz@.  See the thread starting with:

  http://mail-index.netbsd.org/tech-pkg/2014/09/05/msg013558.html

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>