[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / sysutils / tre-command

File: [cvs.NetBSD.org] / pkgsrc / sysutils / tre-command / Makefile (download)

Revision 1.3, Tue Jun 28 09:32:10 2022 UTC (21 months, 3 weeks ago) by pin
Branch: MAIN
CVS Tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, HEAD
Changes since 1.2: +4 -3 lines

sysutils/tre-command: update to 0.4.0

0.4.0
-Add M1 builds to release.
-Support installing from Nix flake.
-Add -E/--exclude PATTERN option to exclude paths from results.
-Add -e/--color WHEN option to control colors in output.
-The short flag for --version is renamed from -v to -V.
-Provide completion scripts for various shells in scripts/completion.
-Add -p/--portable option, which enables portable paths when generating editor
 aliases. Without this flag, editor alias only works in the same working
 directory in which tre was last invoked.
-Files untracked by git is now included in output by default.
-Output order is now deterministic.

# $NetBSD: Makefile,v 1.3 2022/06/28 09:32:10 pin Exp $

DISTNAME=	tre-command-0.4.0
CATEGORIES=	sysutils
MASTER_SITES=	${MASTER_SITE_GITHUB:=dduan/}
GITHUB_PROJECT=	tre
GITHUB_TAG=	v${PKGVERSION_NOREV}

MAINTAINER=	pin@NetBSD.org
HOMEPAGE=	https://github.com/dduan/tre/
COMMENT=	Tree command, improved
LICENSE=	mit

.include "cargo-depends.mk"

INSTALLATION_DIRS=	bin

do-install:
	${INSTALL_PROGRAM} ${WRKSRC}/target/release/tre \
		${DESTDIR}${PREFIX}/bin

.include "../../lang/rust/cargo.mk"
.include "../../mk/bsd.pkg.mk"