The NetBSD Project

CVS log for pkgsrc/sysutils/syslog-ng/Attic/Makefile.module

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / sysutils / syslog-ng

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.6
Thu Sep 16 09:22:46 2021 UTC (3 years, 7 months ago) by wiz
Branches: MAIN
CVS tags: HEAD
FILE REMOVED
Changes since revision 1.5: +1 -1 lines
syslog-ng: update to 3.34.1

Based on package provided by Peter Czanik in PR 56406.

Changes below are for 3.34.1 only, the other 16 releases before
that are not summarized.

3.34.1
======

## Highlights

 * `regexp-parser()`: new parser that can parse messages with regular expressions

 * `redis()`: `workers()` and batching support

   The Redis driver now support the `workers()` option, which specifies the
   number of parallel workers, and the `batch-lines()` option.

   This could drastically increase the throughput of the Redis destination driver.

 * `mqtt()`: TLS and WebSocket Secure support

   The MQTT destination now supports TLS and WSS.

## Features

 * `system()` source: added support for NetBSD

 * `stats`: new statistics counter

 * `mqtt()`: username/password authentication

 * `mqtt()`: new option `http-proxy()` for specifying HTTP/HTTPS proxy for WebSocket connections
   ([#3747](https://github.com/syslog-ng/syslog-ng/pull/3747))

 * `syslog-ng-ctl`: new flag for pruning statistics

 * `disk-buffer()`: added a new option to reliable disk-buffer: `qout-size()`.

## Bugfixes

 * `network(), syslog()`: fixed network sources on NetBSD

 * `disk-buffer()`: fixed a very rare case, where the reliable disk-buffer never resumed
   after triggering `flow-control`.

 * `disk-buffer()`: fixed a rare memory leak that occurred when `mem-buf-length()`
   or `mem-buf-size()` was configured incorrectly

 * `redis()`: fixed command errors that were not detected and marked as successful delivery

Revision 1.5: download - view: text, markup, annotated - select for diffs
Wed Feb 28 13:26:08 2018 UTC (7 years, 1 month ago) by fhajny
Branches: MAIN
CVS tags: pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +4 -1 lines
sysutils/syslog-ng*: Update to 3.14.1.

Features
- Password protected ssl keys
- Add OpenBSD module to system() source
- Add Ubuntu Trusty support to Docker build

Bugfixes
- Fix increased memory usage during saving disk-buffer
- Fix maximum record length limitations of disk-buffer
- Fix a memory leak in cfg-lexer
- Fix some issues found by pylint in python module
- Fix a crash due to a race condition in kv-parser()
- Fix a crash due to a race condition in file() destination
- Fix deprecated API usage in python module tests
- Fix a race condition in internal() source
- Fix a locale issue in merge-grammar python tool
- Fix compile problems with autotools when '--disable-all-modules'
  used
- Fix a file descriptor leak in persist-state
- Fix a file descriptor leak in pseudofile()
- Fix memory/fd leaks in loggen tool
- Fix compile problems on Fedora, RHEL6, CentOS6 and SUSE based
  platforms
- Fix a crash when large variety of keys added to messages
- Fix compile problems when PATH_MAX not defined
- Fix integer overflow problems in grammar
- Fix a memory leak in filter()
- Fix memory leak of persist-name() option
- Fix message corruption caused by a bug in the subst() rewrite rule
- Fix silently dropped messages in elasticsearch2() when sending in
  bulk mode
- Fix broken disk-buffer() support in elasticsearch2()
- Fix Hy support in python module
- Fix an event scheduler related crash during reloading syslog-ng
- Fix a crash with SIGBUS when persist file cannot grow

Other changes
- Improve error reporting in "block" definitions in config
- Add warning message when disk-buffer() directory is changed in
  configuration
- Syslog-ng debun improvements
- Refactor in rewrite() module init
- Missing child program (exit status 127) handling is changed in
  program() destination:
- stopping destination instead of polling for the child program
- Refactor in filter() module
- Improve thread synchronization in mainloop and refactor
- Adapted json-c v0.13 API changes to json-parser
- Add filters as selectors in contextual data

Revision 1.4: download - view: text, markup, annotated - select for diffs
Mon Dec 11 14:45:11 2017 UTC (7 years, 4 months ago) by fhajny
Branches: MAIN
CVS tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +1 -2 lines
Update sysutils/syslog-ng* to 3.13.2.

- Remove separate sysutils/syslog-ng-json package, it is now a core
  module/dependency.

3.13.2

Fixes
- Missing manpages from release tarball
- Package syslog-ng-mod-json is removed from
- Drop syslog-ng-abi virtual packages


3.13.1

Features
- Add app-parser() framework (automatic parsing of log messages)
- Support microseconds in Riemann destination
- Add osquery destination as an SCL plugin
- Add network load balancer destination
- Add possibility to only signal re-open of file handles (SIGUSR1)
- It is possible from now to limit the number of registered dynamic
  counters
- Add $(binary) template function
- Add experimental transport for transferring messages in whole
  between syslog-ng instances (EWMM)
- Docker based build and debian package generation
- Add auto-parse(yes/no) to app-paser(), system() and
  default-network-drivers()
- Add Graylog2 destination and $(format-gelf) template function

Bugfixes
- Exit when a read fails on an included config file instead of
  starting up with an empty configuration.
- Fix double free
- Add missing discarded counter to groupingby
- Fix a reference leak in Python destination
- Fix timezone issue in snmptrapd parser
- Fix potential crash in stdin driver
- Fix a crash when initializing new config fails for socket with
  keep_alive off
- Fix filter evaluation in case of contexts with multiple elements
- Various grouping-by fixes
- Fix potential use after free around dns-cache during shutdown
- Fix access to indirect values within Java destination
- Fix a crash in affile
- Fix a memory leak
- Fix a crash when getent is used empty group
- Fix jvm-options()
- Fix a crash in Python language binding
- Fix a crash in afmongodb
- Fix a memory leak in afmongodb
- Fix name-to-GID calculation in the $(getent) template function
- Fix a crash when redis is configured without the command() option
- Fix a race condition in kv-parser()

Other changes
- Cleanup diskq related warning messages
- Provide tls block for tls options in amqp(), http(), riemann()
  destination drivers
- It it possible from now to register blocks and generators as plugins
- Drop compatiblity with configurations below 3.0
- Do not change permissions of a file by default
- Allow source files to specify permissions locally
- Minor performance improvement
- The current config version can be queried with "--version"
- Increase the performance of kv-parser()

Revision 1.3: download - view: text, markup, annotated - select for diffs
Thu Aug 31 12:53:50 2017 UTC (7 years, 7 months ago) by fhajny
Branches: MAIN
CVS tags: pkgsrc-2017Q3-base, pkgsrc-2017Q3
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +2 -1 lines
Update sysutils/syslog-ng* to 3.11.1.

3.11.1

Features

- Add geoip2 parser and template function.
- Add SSL support to AMQP.
- Add template option to apache-accesslog-parser.
- Add configurable event time to Riemann destination.
- Add drop-unmatched() option to dbparser.
- Add Ubuntu Xenial to the bundled docker images.
- Support multi-instance support for Solaris 10 and 11.
- Support multi-instance for systemd.
- Add configurable timeout to HTTP destination.
- Add prefix() option to cisco-parser.

Bugfixes

- Fix a memory usage counter underflow for threaded destination drivers
  and writers.
- Fix a potential crash in AMQP.
- Fix a potential crash during reload.
- Fix a reload/shutdown issue.
- Fix a potential crash in afsocket destination during reload.
- Fix a counter registration bug.
- Fix a build issue on FreeBSD.
- Fix a memory leak in diskq plugin.
- Fix systemd-journal error codes validation.
- Fix a potential crash in diskq when it is used with file
  destination and the file is reaped.
- Fix a memory leak in HTTP destination
- Fix ENABLE_DEBUG in dbparser.
- Fix a unit tests that caused build issue on 32 bit platforms.

Other changes

- The eventlog library is part of syslog-ng from now.
- Improve error messages when the config cannot be initialized.
- Improve source suspended/resumed debug messages.
- Rename syslog-debun to syslog-ng-debun.
- Update manpages to v3.11
- Remove tgz2build directory.


3.10.1

Features

- Support https in http (curl) module
- Docker support : from now Dockerfile for CentOS7, Ubuntu Zesty and for
  Debian Jessie is part of our upstream
- Add --database parameter for geoip template function
- Metric improvements
- Add snmp-parser (v1, v2)
- Add snmp-soure
- Add osquery source
- Add cisco-parser
- Add wildcard filesource
- Add startdate template function
- Add $(basename) and $(dirname) template functions
- Add Kerberos support for HDFS destination
- Add AUTH support for redis destination
- Add map-value-pairs() parser
- Extend Python language binding by Python parser
- Add support for extract-stray-words() option in kv-parser()
- Add $(context-values) template function
- Add $(context-lookup) function
- Add list related template functions
- Add add query commands to syslog-ng-ctl
- Support multiple servers in elasticsearch2-http destination
- Implements elastic-v2 https in http mode
- Add getent module (ported from incubator)
-  Add support for IP_FREEBIND

Bugfixes

- Fix a libnet detection check error that caused problem configuring
  enable-spoof-source.
- Avoid warnings about _DEFAULT_SOURCE on recent glibc versions
- Fix invalid database warning for geoip parser
- Fix prefix() default in systemd-journal for new config versions
- Fix a potential message loss in Riemann destination
- Fix a potential crash in the Riemann destination when the client is
  not connected to the Riemann server.
- Fix a possible add-contextual-data() related data loss in case of
  multiple
  reference to the same add-contextual-data parser in several logpaths.
- Fix dbparser deadlock
- Fix Python destination
- Fix processed stats counter for afsocket
- Fix stats source for pipes
- Fix csv-parser multithreaded support
- Fix a message loss in case of filesource when syslog-ng was restarted
  and the log_msg_size > file size.
- Fix a potential crash in cryptofuncs
- Fix a potential crash in syslog-ng-ctl when no command line parameters
  was set.
- Fix token duplication in the output of '--preprocess-into'
- Fix UTF-8 support in syslog-ng-ctl
- Fix a potential crash during X.509 certificate validation.
- Fix a segfault in Python module startup
- Fix a possible endless reading loop issue in case of multi-line
  filesource.
- Fix soname for the http module from "curl" to "http"
- Avoid openssl 1.1.0 deprecated APIs

Other changes

- Increase processed counter by queued counter after reload or restart
  when diskqueue is used otherwise the newly added written counter would
  underflow.
- Set the default time-zone to UTC for elasticsearch2
- Add retries support for python destination
- Prefer server side cipher suite order
- Always include librabbitmq in the dist tarball
- Always include ivykis in the dist tarball
- Marking parse error locations with >@<.
- Default log_msg_size is increased to 64Kbyte from 8Kb
- Tons of syslog-debun improvements
- Exit with 0 return code when --help is specified for syslog-ng-ctl
- syslog-ng: make '--preprocess-into' foreground only
- Add debug messages on log_msg_set_value()
- Add more detail to filter evaluation related debug messages

Revision 1.2: download - view: text, markup, annotated - select for diffs
Sun Aug 21 20:18:30 2016 UTC (8 years, 8 months ago) by fhajny
Branches: MAIN
CVS tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +3 -1 lines
Update sysutils/syslog-ng and modules to 3.8.1.

3.8.1

Library updates
- Kafka-client updated to version to 0.9.0.0
- Minimal required version of hiredis is set to 0.11.0 to avoid
  possible deadlocks
- Minimal version of libdbi is set to 0.9.0

Improvements and features
- Added the long-waited disk-buffer.
- date-parser ported from incubator to upstream
- New template functions: min, max, sum, average
- Added Apache-accesslog-parser
- Added loggly destination
- Added logmatic destination
- Added template function for supporting CEF.
- cURL-based HTTP destination driver added (implemented in C
  programming language)
- SELinux policy installer script now has support for Red Hat
  Enterprise Linux/CentOS/ Oracle Linux 5, 6 and 7.
- Implemented add-contextual-data: With add-context-data syslog-ng
  can use an external database file to append custom name-value
  pairs on incoming logs (to enrich messages).

Program destination/source drivers
- Added inherit-environment configuration option to program source
  and destination.
- Added keep-alive option to program destination (afprog).

Java drivers
- HTTP destination: Added the ability to use templates in both url
  and message.
- ElasticSearch Destination driver: Support 2.2.x series of
  ElasticSearch (transport and node mode).

MongoDB destination driver
- Replaced submodule limongo-client with mongo-c-driver.
- Additional support for previous syntax used by libmongo-client
  before we started using mongo-c-driver and its URI syntax
  exclusively.

Riemann destination driver
- Use cert-file() and key-file() options to match afsocket
  keywords as the same way as afsocket drivers use these options.

Rewrite rules
- Introduced template options in rewrite rules.
- Added unset operation to make it possible to unset a specific
  name-value pair for a logmessage.

Parsers
- kvformat: make it possible to specify name-value separator
- linux-audit-scanner: recognize a0-a9* as fields to be decoded
- csv-parser has been refactored, extended with new dialect and
  prefix options.

PatternDB
- added groupingby() parser that can perform simple correlation on
  log messages
- added create-context action
- Added NLSTRING parser that captures a string until the following
  end-of-line

Miscellaneous features
- syslog-debun (debug bundle script for syslog-ng) has been
  improved

Bugfixes
- geoip-parser: When default database if not specified, syslog-ng
  crashed.
- Added support for multiple drivers with the same name in
  syslog-ng config.
- Fixed aack counting logic for junctions that have branches that
  modify the LogMessage.
- Fixed a potential crash for code that uses log_msg_clear() in
  production (e.g. syslog-parser()).
- Fixed potential crash in reload logic
- system(): use string comparison instead of numeric in PID
  rewrite
- Support encoding on glib compiled with libiconv
- pdbtool: Fix the ordering of the debug-info list in PatternDB
- afprog: Don't kill our own process group
- Handle option names with hyphen (-) characters in java scls
- dnscache performance improved
- Fixed IPv6 parser in patterndb.
- Fixed journald program name flapping
- Fixed create-dirs() inheritance in file destinations
- Fixed pass-unix-credentials() global inheritance in afunix
- Fixed create-dirs() global inheritance in afunix
- Fixed byteorder handling on bigendian systems in netmask6 filter
- Fixed flow-control issue when overflow queue is full (suspending
  source by setting the window size to 0).
- Log HTTP response error codes in HTTPDestination (Java).
- Fixed potential leaks related $(sanitize) argument parsing in
  basicfuncs.
- Fixed a memory leak in python debugger
- Fixed a use-after-free bug in templates.
- Fixed a memory leak around reload in netmask6 filter.
- Fixed a memory leak in LogProtoBufferedServer in case the
  encoding() option is used.
- configure: don't override $enable_python while executing
  pkg-config
- Fixed BSD timestamp parsing in syslog-format.
- Fixed a SIGPIPE bug in program destination.
- Error handling has been improved in AMQP destination.
- value-pairs performance improvements, memleak fixes
- Various issues around UTF-8 support fixed.
- Fixed integer overflow in numerical operations template function
- Fixed an integer underflow in afsocket.
- Fixed numerical comperisons issues around filters.
- Fixed kernel log message time drift on Linux.
- Take CRLF sequences equivalent to an LF in patterndb.
- When syslog-ng failed to insert data into Redis, it has crashed.
- When device file is set as a file destination then syslog-ng
  will not try to change the permission of the device file.
- Various fixes around config file parsing:


3.7.3

Improvements
- Updated Python package requirements.
- Can now compile without MongoDB.
- Added eventlog to the list of required pkg-config packages.
- Basic FreeBSD and HP-UX support of syslog debug bundle generator
  by improving POSIX shell compatibility.
- Keep the program destination open between configuration reloads.
- system-source now uses keep-timestamp(no) for Linux kernel log.
  The time source used by /dev/kmsg is not updated after system
  SUSPEND/RESUME.

Fixes
- Fix a SIGSEGV when a Redis command returns an error.
- Resolve deadlock in logwriter triggered by suppress()
- Mitigate possible deadlock in patterndb
- Fixed global inheritance of pass-unix-credentials() and
  create-dirs().
- Certain compilers complained about an undefined symbol when
  setting keep-alive(yes).
- For certain use cases, afsocket would not handle procfs read
  errors due to an integer underflow.
- Enhanced Java version check and the handling of
  SyslogNgInternalLogger (used by Kafka), the FATAL loglevel and
  getLocationInformation().
- When a big amount of kernel log was produced in a very short
  time, the syslog-ng process sometimes entered into a spin and
  stop processing messages.

Revision 1.1: download - view: text, markup, annotated - select for diffs
Thu Oct 29 16:34:13 2015 UTC (9 years, 5 months ago) by fhajny
Branches: MAIN
CVS tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4
Update syslog-ng to the latest stable 3.7.2 version.
Rework and clean up the package, split off various bindings
into separate packages. Add SMF support.

Major features and improvements introduced in major releases since 3.2.

3.7
- OpenSSL is now a required dependency for syslog-ng.
- Java-destination driver ported from syslog-ng-incubator.
- Python language support is ported from syslog-ng incubator.
- New Java destination drivers
- New Parsers

3.6
- PCRE is now a required dependency of syslog-ng.
- Threaded mode is now enabled by default.

3.5
- Multi-line support
- STOMP destination
- Redis destination
- Template type hinting
- Template options honored everywhere
- Support for unit suffixes in the configuration
- The Incubator project

3.4
- New plugins: AMQP & SMTP destinations, JSON parser.
- New parsers for patterndb: HOSTNAME, EMAIL, PCRE and LLADDR.
- It is now possible to control what db-parser() sees as its input
  via it's new template() option.
- value-pairs() gained support for programmatically
  rewriting key names in bulk, via the rekey() method.
- The network() driver is introduced, unifying and extending
  tcp(), udp(), syslog(), unix-dgram() and
  unix-stream(). The old drivers are still available, but
- Support for junctions & channels were added, which improve
  the flexibility of the syslog-ng configuration language.

3.3
- multi-core/CPU scaling: the new multi-threaded architecture allows
  syslog-ng to scale into the 800k msg/sec region.
- MongoDB support: using MongoDB instead of SQL is faster and
  allows better representation of log data.
- JSON support: using the $(format-json) template function it is
  now possible to construct JSON (JavaScript Object Notation)
  output for log messages.
- A number of enhancements all over the place: SQL, patterndb.
- The default ports have changed. syslog-ng is using the standard

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>