File:  [cvs.NetBSD.org] / pkgsrc / sysutils / sformat / Makefile
Revision 1.9: download - view: text, annotated - select for diffs
Thu Feb 22 19:27:12 2007 UTC (17 years, 9 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2007Q1-base, pkgsrc-2007Q1, HEAD
Whitespace cleanup, courtesy of pkglint.
Patch provided by Sergey Svishchev in private mail.

# $NetBSD: Makefile,v 1.9 2007/02/22 19:27:12 wiz Exp $
#

DISTNAME=		sformat-3.5
PKGREVISION=		1
CATEGORIES=		sysutils
MASTER_SITES=		ftp://ftp.berlios.de/pub/sformat/

MAINTAINER=		Andreas.Hallmann@tiscali.de,pkgsrc-users@NetBSD.org
HOMEPAGE=		http://freshmeat.net/projects/sformat
COMMENT=		SCSI disk maintainance, formating, and ultimative repair tool with support for NetBSD labels

PKG_INSTALLATION_TYPES=	overwrite pkgviews

.include "../../mk/bsd.prefs.mk"

USE_TOOLS+=		gmake
TBL?=			tbl

# avoid picking up a bad ${ARCH} during the build
MAKE_ENV+=	ARCH=""
MAKE_ENV+=	MAKEPROG="gmake"
MAKE_ENV+=	COPTX=${CFLAGS:M*:Q}
MAKE_ENV+=	LDOPTX=${LDFLAGS:M*:Q}
MAKE_FLAGS+=	INS_BASE=${LOCALBASE:Q}	# won't work in MAKE_ENV!

# if we're using a gcc which is named gcc, we need to set CCOM=gcc
# in MAKE_ENV so the make infrastructure picks the right options.
.if !empty(CC:M*gcc*)
MAKE_ENV+=	CCOM="gcc"
.endif

INSTALLATION_DIRS=	bin include lib ${PKGMANDIR}/man5 ${PKGMANDIR}/man8

.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>