File:  [cvs.NetBSD.org] / pkgsrc / sysutils / sandboxctl / Makefile
Revision 1.1: download - view: text, annotated - select for diffs
Fri Feb 17 21:23:42 2017 UTC (8 years, 2 months ago) by jmmv
Branches: MAIN
CVS tags: pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, HEAD
Initial addition of sandboxctl 1.0:

sandboxctl is a tool to interact with chroot-based sandboxes.

The sandboxctl tool provides an automated mechanism to create and
interact with chroot-based sandboxes.  These sandboxes can be transient
(e.g. to run a single command within them) or long-lived (e.g. to run a
system service in a safe manner).

Sandboxes can be created using multiple mechanisms, which range from
extracting fresh distribution sets to bind-mounting the outer file
systems inside the sandbox.  The specific mechanism depends on the
features supported by the underlying operating system and the chosen
sandbox type.  Currently, sandboxctl includes support for FreeBSD,
Linux, macOS (Darwin), and NetBSD.

Each sandbox is defined via a configuration file provided by the user
and a system-specific template provided by this package.  The user
configuration is simple and semantically-rich, allowing the system
administrator to not worry about the environment-specific details.

This package is primarily targetted at supporting pkgtools/pkg_comp
but is provided as a standalone tool for flexibility.

# $NetBSD: Makefile,v 1.1 2017/02/17 21:23:42 jmmv Exp $

DISTNAME=	sandboxctl-1.0
CATEGORIES=	sysutils
MASTER_SITES=	${MASTER_SITE_GITHUB:=jmmv/}sandboxctl/releases/download/sandboxctl-1.0/

MAINTAINER=	jmmv@NetBSD.org
COMMENT=	Manages chroot-based sandboxes
LICENSE=	modified-bsd

ONLY_FOR_PLATFORM=	Darwin-*-* FreeBSD-*-* Linux-*-* NetBSD-*-*

GNU_CONFIGURE=		yes
TEST_TARGET=		check
USE_LANGUAGES=		# empty
USE_TOOLS=		pkg-config

PKG_SYSCONFSUBDIR=	sandboxctl
CONFIGURE_ARGS+=	--sysconfdir=${PKG_SYSCONFDIR}
CONFIGURE_ARGS+=	SANDBOXCTL_CONFSUBDIR=
INSTALL_MAKE_FLAGS+=	sandboxctl_confdir=${EGDIR}
EGDIR=			${PREFIX}/share/examples/sandboxctl
CONF_FILES+=		${EGDIR}/default.conf ${PKG_SYSCONFDIR}/default.conf

PKG_OPTIONS_VAR=	PKG_OPTIONS.sandboxctl
PKG_SUPPORTED_OPTIONS=	tests
PKG_SUGGESTED_OPTIONS=	tests

.include "../../mk/bsd.options.mk"

.if !empty(PKG_OPTIONS:Mtests)
.  include "../../devel/atf/buildlink3.mk"
PLIST_SUBST+=		TESTS=
.else
CONFIGURE_ARGS+=	--with-atf=no
PLIST_SUBST+=		TESTS=@comment

post-install:
	rm -rf "${PREFIX}/share/tests/sandboxctl"
.endif

BUILDLINK_API_DEPENDS.shtk+=	shtk>=1.7
.include "../../devel/shtk/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>