[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / sysutils / salt-docs

File: [cvs.NetBSD.org] / pkgsrc / sysutils / salt-docs / Makefile (download)

Revision 1.2, Sat Apr 6 03:45:25 2013 UTC (11 years ago) by rodent
Branch: MAIN
CVS Tags: pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2
Changes since 1.1: +3 -3 lines

Fixes:

 COMMENT should not be longer than 70 characters.
 COMMENT should not begin with 'A'.
 COMMENT should not begin with 'An'.
 COMMENT should not begin with 'a'.
 COMMENT should not end with a period.
 COMMENT should start with a capital letter.

pkglint warnings. Some files also got minor formatting, spelling, and style
corrections.

# $NetBSD: Makefile,v 1.2 2013/04/06 03:45:25 rodent Exp $
#

DISTNAME=	salt-0.10.5
PKGNAME=	${DISTNAME:S/-/-docs-/}
CATEGORIES=	sysutils
MASTER_SITES=	http://cloud.github.com/downloads/saltstack/salt/

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://saltstack.org/
COMMENT=	Documentation for salt
LICENSE=	apache-2.0

NO_CONFIGURE=	yes
BUILD_DIRS=	doc
BUILD_TARGET=	html

HTMLDIR=	share/doc/salt
PLIST_SRC=	${WRKDIR}/.PLIST_SRC

INSTALLATION_DIRS=	${HTMLDIR}

do-install:
	( cd ${WRKSRC}/doc/_build/html \
	  && pax -rw -pe . ${DESTDIR}${PREFIX}/${HTMLDIR} )
	( cd ${DESTDIR}${PREFIX} \
	  && ${FIND} ${HTMLDIR} -type f -print ) >>${PLIST_SRC}

# The upstream salt project does not say what version of sphinx is required.
.include "../../lang/python/pyversion.mk"
BUILD_DEPENDS+=	${PYPKGPREFIX}-sphinx-[0-9]*:../../textproc/py-sphinx

.include "../../mk/bsd.pkg.mk"